Loading ...
Sorry, an error occurred while loading the content.
 

cdrom & sata

Expand Messages
  • Sandro Dentella
    some months ago, joakim on this list suggested that in order to see the cdrom with sata I was to do: include/linux/libata.h and change the line #undef
    Message 1 of 6 , Feb 1, 2006
      some months ago, joakim on this list suggested that in order to see the
      cdrom with sata I was to do:

      include/linux/libata.h and change the line #undef ATA_ENABLE_ATAPI to
      #define ATA_ENABLE_ATAPI and compile your own kernel.


      And it worked. Now kernel 2.6.15.1 does not habe ATA_ENABLE_ATAPI, whet
      should I do to enable it?


      Thanks

      sandro
      *:-)



      --
      Sandro Dentella *:-)
      e-mail: sandro@...
      http://www.tksql.org TkSQL Home page - My GPL work
    • Sandro Dentella
      ... I forgot to say that I already tried adding: atapi_enabled=1 2 hdc=noprobe and libata.atapi_enabled=1 2 and hdc=noprobe without success *:-) -- Sandro
      Message 2 of 6 , Feb 1, 2006
        On Wed, Feb 01, 2006 at 10:35:27PM +0100, Sandro Dentella wrote:
        > some months ago, joakim on this list suggested that in order to see the
        > cdrom with sata I was to do:
        >
        > include/linux/libata.h and change the line #undef ATA_ENABLE_ATAPI to
        > #define ATA_ENABLE_ATAPI and compile your own kernel.
        >
        > And it worked. Now kernel 2.6.15.1 does not habe ATA_ENABLE_ATAPI, whet
        > should I do to enable it?

        I forgot to say that I already tried adding:

        atapi_enabled=1 2 hdc=noprobe
        and
        libata.atapi_enabled=1 2
        and
        hdc=noprobe

        without success
        *:-)

        --
        Sandro Dentella *:-)
        e-mail: sandro@...
        http://www.tksql.org TkSQL Home page - My GPL work
      • Joakim Olsson
        Hi Sandro, In 2.6.15 the ATA_ENABLE_ATAPI has been replaced by a kernel option. Just add libata.atapi_enabled=1 and you should have your cdrom back again. Best
        Message 3 of 6 , Feb 1, 2006
          Hi Sandro,

          In 2.6.15 the ATA_ENABLE_ATAPI has been replaced by a kernel option.
          Just add libata.atapi_enabled=1 and you should have your cdrom back
          again.

          Best regards,
          Joakim


          On ons, 2006-02-01 at 22:35 +0100, Sandro Dentella wrote:
          > some months ago, joakim on this list suggested that in order to see the
          > cdrom with sata I was to do:
          >
          > include/linux/libata.h and change the line #undef ATA_ENABLE_ATAPI to
          > #define ATA_ENABLE_ATAPI and compile your own kernel.
          >
          >
          > And it worked. Now kernel 2.6.15.1 does not habe ATA_ENABLE_ATAPI, whet
          > should I do to enable it?
          >
          >
          > Thanks
          >
          > sandro
          > *:-)
          >
          >
          >
        • Joakim Olsson
          Hi again Sandro, If you have already tried with libata.atapi_enabled=1 without success, then I don t know what to do. That did the trick for me. By the way,
          Message 4 of 6 , Feb 1, 2006
            Hi again Sandro,

            If you have already tried with libata.atapi_enabled=1 without success,
            then I don't know what to do. That did the trick for me.

            By the way, what does the 2 in you kernel options do?

            Best regards,
            Joakim


            Quoting Sandro Dentella <sandro@...>:

            > On Wed, Feb 01, 2006 at 10:35:27PM +0100, Sandro Dentella wrote:
            >> some months ago, joakim on this list suggested that in order to see the
            >> cdrom with sata I was to do:
            >>
            >> include/linux/libata.h and change the line #undef ATA_ENABLE_ATAPI to
            >> #define ATA_ENABLE_ATAPI and compile your own kernel.
            >>
            >> And it worked. Now kernel 2.6.15.1 does not habe ATA_ENABLE_ATAPI, whet
            >> should I do to enable it?
            >
            > I forgot to say that I already tried adding:
            >
            > atapi_enabled=1 2 hdc=noprobe
            > and
            > libata.atapi_enabled=1 2
            > and
            > hdc=noprobe
            >
            > without success
            > *:-)
            >
            > --
            > Sandro Dentella *:-)
            > e-mail: sandro@...
            > http://www.tksql.org TkSQL Home page - My GPL work
            >
            >
            > --------------------------------------------------------------
            > Please post your X config files in the group links or database
            > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
            > FAQ: http://www.whacked.net/ldl/faq
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
            >
            >



            ----------------------------------------------------------------
            This message was sent using IMP, the Internet Messaging Program.
          • Sandro Dentella
            ... Sorry I could have stripped it, it just forces runlevel 2, not related to cdrom, of course. Do you need hdc=noprobe? Nothing else should be set in the
            Message 5 of 6 , Feb 2, 2006
              On Thu, Feb 02, 2006 at 07:28:06AM +0100, Joakim Olsson wrote:
              > Hi again Sandro,
              >
              > If you have already tried with libata.atapi_enabled=1 without success,
              > then I don't know what to do. That did the trick for me.
              >
              > By the way, what does the 2 in you kernel options do?


              Sorry I could have stripped it, it just forces runlevel 2, not related to
              cdrom, of course. Do you need hdc=noprobe? Nothing else should be set in
              the kernel?

              TIA
              sandro
              *:-)

              --
              Sandro Dentella *:-)
              e-mail: sandro@...
              http://www.tksql.org TkSQL Home page - My GPL work
            • Joakim Olsson
              ... Aaah...Ok. No, I don t have hdc=noprobe and I don t recall doing anything specific in the kernel configuration. I can send you my .config when I get home
              Message 6 of 6 , Feb 2, 2006
                Quoting Sandro Dentella <sandro@...>:

                > On Thu, Feb 02, 2006 at 07:28:06AM +0100, Joakim Olsson wrote:
                >> Hi again Sandro,
                >>
                >> If you have already tried with libata.atapi_enabled=1 without success,
                >> then I don't know what to do. That did the trick for me.
                >>
                >> By the way, what does the 2 in you kernel options do?
                >
                >
                > Sorry I could have stripped it, it just forces runlevel 2, not related to
                > cdrom, of course. Do you need hdc=noprobe? Nothing else should be set in
                > the kernel?
                >

                Aaah...Ok. No, I don't have hdc=noprobe and I don't recall doing
                anything specific in the kernel configuration. I can send you my
                .config when I get home if you want it.

                Best regards,
                Joakim


                ----------------------------------------------------------------
                This message was sent using IMP, the Internet Messaging Program.
              Your message has been successfully submitted and would be delivered to recipients shortly.