Loading ...
Sorry, an error occurred while loading the content.

USB not working after resume & black screen

Expand Messages
  • p3sho
    Hello there! I m new to this group and I m very happy that I found it. I have a Dell Latitude D510 laptop running Ubuntu 5.10 Breezy Linux. I was experiencing
    Message 1 of 5 , Oct 20, 2005
    • 0 Attachment
      Hello there!
      I'm new to this group and I'm very happy that I found it. I have a
      Dell Latitude D510 laptop running Ubuntu 5.10 Breezy Linux.
      I was experiencing some problems with suspending to RAM but somehow I
      got it to work. Now I have some more issues to deal with and I was
      wondering if you could help me.

      So, when I suspend and then resume, USB devices (mouse, for example)
      are not working and I have to do manually /etc/init.d/hotplug restart.
      Do you know of a way how to do that automatically on resume or any
      other solution to the problem?

      Also, when I close my screen (close the lid) the screen turns black,
      but when I open it, it remains black and I can't get it on - pressing
      random keys does not help. Apart from that, I would like ot make my
      computer suspend on closing lid and not just turn the screen black (I
      read a lot of stuff on the net about ACPI scripts, alas non of them
      helped).


      Thank you very much in advance!

      Sincerely yours,
      Petar.

      --
      Petar Dobrev
      International University Bremen
    • Gareth
      ... In file /etc/default/acpi-support : #USE_DPMS=true # GSO: commented out, screen not switching back on with this setting (i.e. remains switched off on
      Message 2 of 5 , Oct 20, 2005
      • 0 Attachment
        --- In linux-dell-laptops@yahoogroups.com, "p3sho" <p3sho@y...> wrote:
        >
        ....
        > So, when I suspend and then resume, USB devices (mouse, for example)
        > are not working and I have to do manually /etc/init.d/hotplug restart.
        > Do you know of a way how to do that automatically on resume or any
        > other solution to the problem?
        >

        In file '/etc/default/acpi-support':

        #USE_DPMS=true # GSO: commented out, screen not switching back on
        with this setting (i.e. remains switched off on reset)

        The problem seems to be with DPMS, commenting this line out means the
        screen doesn't get switched off (though it does switch to a tty).

        One thing that could be tried is including '/etc/init.d/hotplug' in
        the acpi scripts - i.e. '/etc/acpi/resume.sh' (or something, ref.
        acpid man page).
      • Herman
        To get the screen to turn on when opening the lid, try switching TTYs: Ctrl-F6, followed by Ctrl-F7 Cheers, H.
        Message 3 of 5 , Oct 20, 2005
        • 0 Attachment
          To get the screen to turn on when opening the lid, try switching TTYs:
          Ctrl-F6, followed by Ctrl-F7

          Cheers,

          H.
        • Peter Dobrev
          Yes, but DPMS is for switching off the screen when suspending, and when I close the lid, it does not suspend. ... __________________________________ Yahoo!
          Message 4 of 5 , Oct 20, 2005
          • 0 Attachment
            Yes, but DPMS is for switching off the screen when
            suspending, and when I close the lid, it does not
            suspend.


            --- Gareth <gsowww@...> wrote:

            > --- In linux-dell-laptops@yahoogroups.com, "p3sho"
            > <p3sho@y...> wrote:
            > >
            > ....
            > > So, when I suspend and then resume, USB devices
            > (mouse, for example)
            > > are not working and I have to do manually
            > /etc/init.d/hotplug restart.
            > > Do you know of a way how to do that automatically
            > on resume or any
            > > other solution to the problem?
            > >
            >
            > In file '/etc/default/acpi-support':
            >
            > #USE_DPMS=true # GSO: commented out, screen not
            > switching back on
            > with this setting (i.e. remains switched off on
            > reset)
            >
            > The problem seems to be with DPMS, commenting this
            > line out means the
            > screen doesn't get switched off (though it does
            > switch to a tty).
            >
            > One thing that could be tried is including
            > '/etc/init.d/hotplug' in
            > the acpi scripts - i.e. '/etc/acpi/resume.sh' (or
            > something, ref.
            > acpid man page).
            >
            >
            >
            >
            >





            __________________________________
            Yahoo! Mail - PC Magazine Editors' Choice 2005
            http://mail.yahoo.com
          • Gareth
            ... The poblem seems to be switching the monitor back on after DPMS has switched it off. Re. the mouse freezing, I found that this happened when switcing into
            Message 5 of 5 , Oct 21, 2005
            • 0 Attachment
              --- In linux-dell-laptops@yahoogroups.com, Peter Dobrev <p3sho@y...>
              wrote:
              >
              > Yes, but DPMS is for switching off the screen when
              > suspending, and when I close the lid, it does not
              > suspend.
              >

              The poblem seems to be switching the monitor back on after DPMS has
              switched it off. Re. the mouse freezing, I found that this happened
              when switcing into 'sleep' state, however things worked OK if only
              using 'standby' power down as long as the DPMS line was comnmented
              out. Using standby mode on kUbuntu worked fine out of the box (no
              need to configure anything other than the standby preference for power
              down).

              How 'acpi' works! This is not straightforward to explain but here
              goes. 'acpi' is configured with files in the /etc/acpi/events each of
              which has an 'event' and 'action' entry. The event specifies the key
              that is associated with the action, which is generally a script in
              the directory higher (e.g. suspend button runs sleep.sh, which at the
              end calls resume.sh).

              Maybe the problem is (off the top of my head) that the default Ubuntu
              acpi install only has a sleep mode that uses 'S3' state which (I'm
              guessing here) the Dell C600 which I use does not support - supporting
              only S1 and S2D) - which means a new acpi script needs writing and
              event file configuring.

              Check your BIOS settings, I found I could get the Fn + Suspend key
              combination to work as long as power management was at least to some
              extent enabled in the BIOS.
            Your message has been successfully submitted and would be delivered to recipients shortly.