Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] CPU temperature

Expand Messages
  • Alexander Toresson
    ... Wrong. You need to have the acpi-cpufreq module loaded (speedstep-centrino for older 2.6 kernels) and a cpufreq-* module loaded. In my case, I have the
    Message 1 of 7 , Oct 20, 2005
    • 0 Attachment
      On 10/19/05, Haedn Thorn <lordhaedn@...> wrote:
      >
      >
      > --- roberto <robcatanuto@...> wrote:
      >
      > > hello, i need to know if the temperature of my CPU in D600 laptop is in a
      > > correct range, since i
      > > can hear the fan almost constantly up and running very fast; temp keeps at
      > > 53-56 C is it ok?
      > > does anyone holding a D600 with 2.6.8 kernel have the same working
      > > temperatures? and how can i
      > > know if my CPU gets to hot or it is ok?
      > >
      > > CPU: Intel Centrino 2.00 GHz
      > > kernel: 2.6.8
      > > OS: Debian Sarge
      >
      > My PentiumM 1.60GHz is usually in the 48-54 C range, unless I'm playing a game
      > with 3-D. When the system gets too hot, it should drop the operating frequency
      > to its minimum. I belive this is internal to the processor and should happen
      > regaurdless of your OS and configuration.
      >

      Wrong. You need to have the acpi-cpufreq module loaded
      (speedstep-centrino for older 2.6 kernels) and a cpufreq-* module
      loaded. In my case, I have the cpufreq-userspace module loaded and let
      the powernowd daemon control it in userspace, and this works great.
      This enabled me to turn it on and off whenever I want, and also set it
      to a frequency myself. Also, depending on what type of Pentium M
      you've got (banias, dothan, sonoma, 400 or 533mhz fsb) you may need to
      have a recenty kernel (2.6.11+) for it to work well.

      To check if speedstep is working, let the laptop be idle and do cat
      /proc/cpuinfo. If it returns a frequency that is significantly lower
      than the max frequency, it's working.

      Regards, Alexander Toresspm
    • Gareth
      A C600 with Ubuntu Breezy did the same, in the end I disabled speedstep in the BIOS to shut it up . Having said that I was using Kubuntu (Hoary) a while ago
      Message 2 of 7 , Oct 20, 2005
      • 0 Attachment
        A C600 with Ubuntu Breezy did the same, in the end I disabled
        speedstep in the BIOS to 'shut it up'.

        Having said that I was using Kubuntu (Hoary) a while ago which was
        configured out of the box to switch into standby - working fine
        otherwise as well.
      Your message has been successfully submitted and would be delivered to recipients shortly.