Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] My Latitude D505 shuts down immediately without reason - related to 3D acceleration ?

Expand Messages
  • Olivier Berger
    Hi. Thanks for your comments. I was suspecting it could be that, but I experienced the same crash again, but this time, when running on battery... And later, I
    Message 1 of 13 , Aug 8, 2005
    • 0 Attachment
      Hi.

      Thanks for your comments.

      I was suspecting it could be that, but I experienced the same crash
      again, but this time, when running on battery...

      And later, I tested the battery, and it didn't occur again...

      I also swapped the disk in another identical machine, and this time it
      also occurred on the second system...

      I'm then thinking now it is probably related to software/OS...

      Now, I think I may have a new idea of the cause : I think it may be
      related to the 3D support in the video card.
      Last time it happened, the screensaver was displaying a 3D
      representation of a molecule (xscreensaver-gl)...
      Maybe this has to do with the 3D support... I think I can remember
      similar problems on other systems years ago...

      So I've disabled the DRI support in the XF86Config-4 and will try and
      wait until it happens again, or not ;)

      What would you thing of this new hypothesis ?

      Best regards,

      Haedn Thorn <lordhaedn@...> writes:

      > Yes, software is a possibility, but occassionally, you may also get a variance
      > in voltage levels that can cause all kinds of unknown symptoms. Modern systems
      > have this more or less eliminated, but it is still possible for it to occur
      > (remember that the FCC mandates that consumer electronics must accept
      > interference) ... Another thing I would consider is battery age. Batteries are
      > really the weakest link in our laptops. The battery that came with my 600m said
      > it was designed for approximately 300 cycles, which, under normal usage, should
      > be about a year. And, as I'm typing this now (about a year after I got the
      > thing), my battery life is about 3 hours compared to the 4 hours I got up until
      > a month or two ago. And slightly off-topic, but still directly related, I had
      > to replace one of my BackUPS last week due to a failed battery. It had about 3
      > years on it and the battery will not longer hold any charge at all! (and that
      > was on my webserver!!!!)
      >
      > So in conclusion, if it doesn't do it again, write it off as a glitch. If it's
      > recurring, I'd suspect the battery first.
      >
      >


      --
      Olivier BERGER (OpenPGP: 1024D/B4C5F37F)
      APRIL (http://www.april.org) - Vive python (http://www.python.org)
      Pétition contre les brevets logiciels : http://petition.eurolinux.org
    • Haedn Thorn
      ... 3D definitely puts extra stress on a system. I had to build a small table with cooling fans in order to play any games for more than about 30 minutes on my
      Message 2 of 13 , Aug 8, 2005
      • 0 Attachment
        --- Olivier Berger <oberger@...> wrote:

        > I was suspecting it could be that, but I experienced the same crash
        > again, but this time, when running on battery...
        >
        > And later, I tested the battery, and it didn't occur again...
        >
        > I also swapped the disk in another identical machine, and this time it
        > also occurred on the second system...
        >
        > I'm then thinking now it is probably related to software/OS...
        >
        > Now, I think I may have a new idea of the cause : I think it may be
        > related to the 3D support in the video card.
        > Last time it happened, the screensaver was displaying a 3D
        > representation of a molecule (xscreensaver-gl)...
        > Maybe this has to do with the 3D support... I think I can remember
        > similar problems on other systems years ago...
        >
        > So I've disabled the DRI support in the XF86Config-4 and will try and
        > wait until it happens again, or not ;)
        >
        > What would you thing of this new hypothesis ?

        3D definitely puts extra stress on a system. I had to build a small table with
        cooling fans in order to play any games for more than about 30 minutes on my
        600m!! With this ATi chipset, I've had all kinds of trouble even getting the 3D
        drivers to load (it always seemed so easy with all my other systems running
        nVidia chipsets) The only way to know for sure is to try ;) Good luck with it.
      • Olivier Berger
        Hi. Just to let you know that I think I have found one possible cause of my problem: the laptop was plugged on a faulty multi-plug, in which wires were almost
        Message 3 of 13 , Aug 9, 2005
        • 0 Attachment
          Hi.

          Just to let you know that I think I have found one possible cause of
          my problem: the laptop was plugged on a faulty multi-plug, in which
          wires were almost in contact, which caused the ground wire not to be
          at 0 V.

          The laptop metalic parts in contact with me (the border of the
          keyboard, or the metalic lock of the anti-theft cable that was locked
          on the laptop) were then at 25 V from the ground...

          I noticed that the laptop shot itself down when my watch bandwrist
          (also metallic) touched the anti-theft cable's lock... so I was
          suspecting some kind of static charge causing the problem... I was
          used to feeling some light shocks when I touched the keyboard's
          borders... that happens sometimes without much harm to the machines,
          depending on the floor's carpeting, your shoes, etc. ... but this time
          it looked more serious if this caused the laptop to shut off !

          So I had the idea of testing the voltage and discovered this 25 V
          difference... and when I tested the AC adapter's output plug's
          external contact part, I found also the same 25 V.
          I decided to test the same voltage on an old adapter and found 0 V !

          So, now, I have removed the faulty multi-plug, of course, but I'm
          surprised that in that situation, the adapter didn't behave like the
          old one...
          What's surprising is that an old AC adapter did "protect" the laptop
          and its user (me) whereas the new one doesn't...

          Do you think this looks like a defective AC adapter too (although it's
          brand new) ?

          Thanks in advance.

          Best regards,

          P.S.: although I have removed the faulty plug, there is still an other
          problem : it has shot down itself again 5 minutes ago :(

          Olivier Berger <oberger@...> writes:

          > Hi.
          >
          > I'd like to get your help about the following problem for which I
          > don't know if it can be a problem related to the software or Hardware.
          >
          > I've installed a Debian system on my brand new Latitude D505 which was
          > runing fine for a week... and yesterday in the middle of a work
          > session (recompiling xfree86), without notice, it completely went off
          > really instantly, without any explanation...
          >
          > It looks just like if power had failed... but there was a battery
          > inside and I didn't notice any problem on power source shared with
          > other machines.
          >
          > I'm not sure though if it's something that could be caused by software
          > anyhow... Would you imagine something in Linux kernel that could lead
          > to such a behaviour (bad hardware support of some sort) ?
          >
          > Maybe related to acpi, cpufreqd or other things the like ?
          >
          > Any hints welcome.
          >
          > Best regards,
          >
          > FYI, I had started collecting my experience on :
          > http://www-inf.int-evry.fr/~olberger/weblog/debiansargeondelllatituded505/
          >
          > Best regards,

          --
          Olivier BERGER (OpenPGP: 1024D/B4C5F37F)
          APRIL (http://www.april.org) - Vive python (http://www.python.org)
          Pétition contre les brevets logiciels : http://petition.eurolinux.org
        • Haedn Thorn
          ... Sounds like they tried to save some money on the new design? That s pretty lame, but typical. If you had a faulty power connection for realy any amount of
          Message 4 of 13 , Aug 9, 2005
          • 0 Attachment
            --- Olivier Berger <oberger@...> wrote:

            > Just to let you know that I think I have found one possible cause of
            > my problem: the laptop was plugged on a faulty multi-plug, in which
            > wires were almost in contact, which caused the ground wire not to be
            > at 0 V.
            >
            > The laptop metalic parts in contact with me (the border of the
            > keyboard, or the metalic lock of the anti-theft cable that was locked
            > on the laptop) were then at 25 V from the ground...
            >
            > I noticed that the laptop shot itself down when my watch bandwrist
            > (also metallic) touched the anti-theft cable's lock... so I was
            > suspecting some kind of static charge causing the problem... I was
            > used to feeling some light shocks when I touched the keyboard's
            > borders... that happens sometimes without much harm to the machines,
            > depending on the floor's carpeting, your shoes, etc. ... but this time
            > it looked more serious if this caused the laptop to shut off !
            >
            > So I had the idea of testing the voltage and discovered this 25 V
            > difference... and when I tested the AC adapter's output plug's
            > external contact part, I found also the same 25 V.
            > I decided to test the same voltage on an old adapter and found 0 V !
            >
            > So, now, I have removed the faulty multi-plug, of course, but I'm
            > surprised that in that situation, the adapter didn't behave like the
            > old one...
            > What's surprising is that an old AC adapter did "protect" the laptop
            > and its user (me) whereas the new one doesn't...
            >
            > Do you think this looks like a defective AC adapter too (although it's
            > brand new) ?
            >
            > Thanks in advance.
            >
            > Best regards,
            >
            > P.S.: although I have removed the faulty plug, there is still an other
            > problem : it has shot down itself again 5 minutes ago :(

            Sounds like they tried to save some money on the new design? That's pretty
            lame, but typical. If you had a faulty power connection for realy any amount of
            time, there is a great deal of static damage which could have occured in the
            chips themselves. Static shocks which we feel can often be several thousand
            volts! The traces within computer chips are TINY and high voltages can erode
            them, casuing all sorts of problems. Of course, this is the extreme case (well,
            short of the thing not working at all) and it could still just be a
            software/timing issue.
          • Olivier Berger
            Hi. Thanks for your comments. Just to let you know that the problem happened again this morning, in the same conditions exactly (bandwrist in contact with lock
            Message 5 of 13 , Aug 10, 2005
            • 0 Attachment
              Hi.

              Thanks for your comments.

              Just to let you know that the problem happened again this morning, in
              the same conditions exactly (bandwrist in contact with lock of the
              anti-theft cable, etc.), of course without the multi-plug, but this
              time during the BIOS pre-boot checks (progress bar)... so I definitely
              can say there is a problem which is not caused by software, especially
              by Linux....although there might be other problems related to software
              too, but definitely something to do with static charges and contacts
              with the internal electric parts, a damaged component, etc.

              Dell will replace the mainboard tomorrow, and I hope this is the end
              of it... although I will probably try and cover the anti-theft cable's
              lock with some isolating material of some kind to avoir direct contact
              with the mainboard in the future...

              I may also consider changing something with the floor of my office
              since people often mention this as a cause of static electricity ?

              Best regards,

              Haedn Thorn <lordhaedn@...> writes:

              > --- Olivier Berger <oberger@...> wrote:
              >
              >> Just to let you know that I think I have found one possible cause of
              >> my problem: the laptop was plugged on a faulty multi-plug, in which
              >> wires were almost in contact, which caused the ground wire not to be
              >> at 0 V.
              >>
              >> The laptop metalic parts in contact with me (the border of the
              >> keyboard, or the metalic lock of the anti-theft cable that was locked
              >> on the laptop) were then at 25 V from the ground...
              >>
              >> I noticed that the laptop shot itself down when my watch bandwrist
              >> (also metallic) touched the anti-theft cable's lock... so I was
              >> suspecting some kind of static charge causing the problem... I was
              >> used to feeling some light shocks when I touched the keyboard's
              >> borders... that happens sometimes without much harm to the machines,
              >> depending on the floor's carpeting, your shoes, etc. ... but this time
              >> it looked more serious if this caused the laptop to shut off !
              >>
              >> So I had the idea of testing the voltage and discovered this 25 V
              >> difference... and when I tested the AC adapter's output plug's
              >> external contact part, I found also the same 25 V.
              >> I decided to test the same voltage on an old adapter and found 0 V !
              >>
              >> So, now, I have removed the faulty multi-plug, of course, but I'm
              >> surprised that in that situation, the adapter didn't behave like the
              >> old one...
              >> What's surprising is that an old AC adapter did "protect" the laptop
              >> and its user (me) whereas the new one doesn't...
              >>
              >> Do you think this looks like a defective AC adapter too (although it's
              >> brand new) ?
              >>
              >> Thanks in advance.
              >>
              >> Best regards,
              >>
              >> P.S.: although I have removed the faulty plug, there is still an other
              >> problem : it has shot down itself again 5 minutes ago :(
              >
              > Sounds like they tried to save some money on the new design? That's pretty
              > lame, but typical. If you had a faulty power connection for realy any amount of
              > time, there is a great deal of static damage which could have occured in the
              > chips themselves. Static shocks which we feel can often be several thousand
              > volts! The traces within computer chips are TINY and high voltages can erode
              > them, casuing all sorts of problems. Of course, this is the extreme case (well,
              > short of the thing not working at all) and it could still just be a
              > software/timing issue.
              >
              >

              --
              Olivier BERGER (OpenPGP: 1024D/B4C5F37F)
              APRIL (http://www.april.org) - Vive python (http://www.python.org)
              Pétition contre les brevets logiciels : http://petition.eurolinux.org
            • Haedn Thorn
              ... Replacing the mainboard will take care of almost all the components that might be damaged, so that is a very good option. Static charges can develop quite
              Message 6 of 13 , Aug 10, 2005
              • 0 Attachment
                --- Olivier Berger <oberger@...> wrote:

                > Just to let you know that the problem happened again this morning, in
                > the same conditions exactly (bandwrist in contact with lock of the
                > anti-theft cable, etc.), of course without the multi-plug, but this
                > time during the BIOS pre-boot checks (progress bar)... so I definitely
                > can say there is a problem which is not caused by software, especially
                > by Linux....although there might be other problems related to software
                > too, but definitely something to do with static charges and contacts
                > with the internal electric parts, a damaged component, etc.
                >
                > Dell will replace the mainboard tomorrow, and I hope this is the end
                > of it... although I will probably try and cover the anti-theft cable's
                > lock with some isolating material of some kind to avoir direct contact
                > with the mainboard in the future...
                >
                > I may also consider changing something with the floor of my office
                > since people often mention this as a cause of static electricity ?

                Replacing the mainboard will take care of almost all the components that might
                be damaged, so that is a very good option. Static charges can develop quite
                easily in many places. If you are having trouble in a particular location,
                there are a number of products available to help eliminate the problem. Of
                course, a good ground to your computer is at the top of the list, I believe
                you've already taken care of this? Then there are grounding pads for floors and
                desks, wrist straps, ankle straps, and a number of other devices. ... I have a
                wrist strap that I paid something like $2.00 for, but I only use that when I am
                working inside of computers.

                O, and I just had a thought. Is your metal armband one of those copper ones
                with magnets in it? I could see one of those being an issue with laptop use.
                While I'm typing this on my 600m, I have a hard drive under one wrist, and the
                battery is beneath the other.
              • Olivier Berger
                Hi. Thanks for your comments. I wonder if I shouldn t simply get naked before approaching this beast ;) No kidding : can t computers be protected from such
                Message 7 of 13 , Aug 10, 2005
                • 0 Attachment
                  Hi.

                  Thanks for your comments.

                  I wonder if I shouldn't simply get naked before approaching this beast
                  ;)

                  No kidding : can't computers be protected from such environmental
                  influences ? ... you're supposed to be able to use a laptop touching
                  it (on your lap too...) ? :)

                  Without humans, computers would work much better ;)


                  Anyway, just to keep you informed, it looks like finaly, Dell figured
                  out that replacing the motherboard wouldn't solve my issue, and have
                  passed my request to quality assurance (level 2 ?), for further
                  investigation... have to wait for one week for news from them... who
                  told me we got a next day on site service support contract ?...

                  I've got this strange intuition it will end with them providing me
                  with a different model...

                  I'll tell you anyway.

                  Best regards, and happy computing (naked remember ;)

                  Haedn Thorn <lordhaedn@...> writes:

                  > O, and I just had a thought. Is your metal armband one of those copper ones
                  > with magnets in it? I could see one of those being an issue with laptop use.
                  > While I'm typing this on my 600m, I have a hard drive under one wrist, and the
                  > battery is beneath the other.
                  >

                  --
                  Olivier BERGER (OpenPGP: 1024D/B4C5F37F)
                  APRIL (http://www.april.org) - Vive python (http://www.python.org)
                  Pétition contre les brevets logiciels : http://petition.eurolinux.org
                • Olivier Berger
                  Hi. Just a small followup, to tell you that Dell suggests that I lock my anti-theft cable on the other side of the beast to avoid the poweroff issue. Nice
                  Message 8 of 13 , Aug 23, 2005
                  • 0 Attachment
                    Hi.

                    Just a small followup, to tell you that Dell suggests that I lock my
                    anti-theft cable on the other side of the beast to avoid the poweroff
                    issue.

                    Nice workaround, but no definitive solution.

                    This seems to be a known problem... but I'm not sure if I can be
                    satisfied with such an answer.

                    What would you think ?

                    Best regards,

                    Olivier Berger <oberger@...> writes:

                    > Anyway, just to keep you informed, it looks like finaly, Dell figured
                    > out that replacing the motherboard wouldn't solve my issue, and have
                    > passed my request to quality assurance (level 2 ?), for further
                    > investigation... have to wait for one week for news from them... who
                    > told me we got a next day on site service support contract ?...
                    >
                    > I've got this strange intuition it will end with them providing me
                    > with a different model...
                    >
                    > I'll tell you anyway.
                    >

                    --
                    Olivier BERGER (OpenPGP: 1024D/B4C5F37F)
                    APRIL (http://www.april.org) - Vive python (http://www.python.org)
                    Pétition contre les brevets logiciels : http://petition.eurolinux.org
                  • Herman
                    ... Well, consider that anti-theft cables are quite useless anyway... Cheers, H.
                    Message 9 of 13 , Aug 23, 2005
                    • 0 Attachment
                      Olivier Berger wrote:
                      > Hi.
                      >
                      > Just a small followup, to tell you that Dell suggests that I lock my
                      > anti-theft cable on the other side of the beast to avoid the poweroff
                      > issue.

                      Well, consider that anti-theft cables are quite useless anyway...

                      Cheers,

                      H.
                    • Stephen Lau
                      ... Not true... I had my laptop locked up at a conference once during a lunch break, and someone came in and stole all the laptops that weren t locked. The 3
                      Message 10 of 13 , Aug 23, 2005
                      • 0 Attachment
                        Herman wrote:

                        >Olivier Berger wrote:
                        >
                        >
                        >>Hi.
                        >>
                        >>Just a small followup, to tell you that Dell suggests that I lock my
                        >>anti-theft cable on the other side of the beast to avoid the poweroff
                        >>issue.
                        >>
                        >>
                        >
                        >Well, consider that anti-theft cables are quite useless anyway...
                        >
                        >
                        >
                        Not true... I had my laptop locked up at a conference once during a
                        lunch break, and someone came in and stole all the laptops that weren't
                        locked. The 3 of us that had our laptops locked were okay.

                        Yes, someone who is determined to can probably break through the lock
                        with a bit of effort. But it's like that old saying:
                        (I'm paraphrasing this since I don't know where I heard it from originally)
                        Two men are trying to escape a tiger in a jungle. One of them bends
                        down to tie his shoelaces, and the other guy says "what are you doing?
                        we have no hope of outrunning the tiger." The other guy says, "i don't
                        need to outrun the tiger. i just need to outrun you."

                        cheers,
                        steve

                        (if anyone knows where that quote comes from, i'd like to hear it... ) :)
                      Your message has been successfully submitted and would be delivered to recipients shortly.