Loading ...
Sorry, an error occurred while loading the content.

Re: Inspiron 9300 - Kernel panic problem.

Expand Messages
  • qsidude
    Well, I had the same problem. And after days of work i figured it out. If you see the kernel messages, then you will notice that the hdd is detected as a scsi
    Message 1 of 3 , Jul 26, 2005
    • 0 Attachment
      Well, I had the same problem. And after days of work i figured it out.

      If you see the kernel messages, then you will notice that the hdd is
      detected as a scsi device, where as the newer kernel detects it as
      hda.

      Now all you need to do is to enable the following options while config
      uring your kernel. (i dont have the config file open right now,

      so i might miss out some stuff )

      1. Enable SATA in SCSI.
      2. Select the ICH SATA drivers.
      3. Select the RAID option in SCSI.
      4. Do not disable any Raid options while configuration.
      5. Enable MSDOS partition support. (IMP, if using extended partitions)

      Once you are done, you can boot your kernel with the parameters taken
      from the preinstalled one (e.g root=/dev/sda5 blah blah).

      Despite of doing all this and the kernel detecting the FS correctly on
      the root, i still got a "warning: unable to open initial console".

      No idea, why this pops up, but you can solve this by creating a initrd
      for your kernel.

      use the command line option

      mkinitrd /boot/<imgfilename>.img <kernelversion>

      e.g: mkinitrd /boot/initrd-2.6.12.3.img 2.6.12.3

      Edit your grub or lilo conf file app. and you are should be able to
      boot.

      Regards
      Bhaskar Kishore



      --- In linux-dell-laptops@yahoogroups.com, "willubro" <willubro@y...>
      wrote:
      > Hello I have an Inspiron 9300 with 60GB TOSHIBA MK6026GAX. With kernel
      > 2.4.27 it boots but PCI Express doesn't function . With 2.6.11.9 linux
      > does kernel panic. This is the final boot message:
      >
      > VFS: Cannot open root device "hda5" or unknown-block(0,0)
      > Please append a correct "root=" boot option
      > Kernel panic - not syncing: VFS: Unable to mount root fs on
      > unknown-block(0,0)
      >
      > I suppose that it doesn't found hard disk. Indeed I had same problem
      > when installing 2.6 kernel(so I installed 2.4).
      >
      > Please help me.
      > Thanks
      > Willy
    Your message has been successfully submitted and would be delivered to recipients shortly.