Loading ...
Sorry, an error occurred while loading the content.
 

My Experiences with a 9300

Expand Messages
  • Vaibhav Vaidya
    Experiences with Scientific Linux 4.0 on a Dell Inspiron 9300 (2GHz(2MB cache), 512MB dual channel DDR, 7500RPM SATA hard drive, 24x CDRW-DVDrom SATA drive,
    Message 1 of 1 , Jul 25 7:08 PM
      Experiences with Scientific Linux 4.0 on a Dell
      Inspiron 9300
      (2GHz(2MB cache), 512MB dual channel DDR, 7500RPM SATA
      hard drive, 24x CDRW-DVDrom SATA drive, WUXGA
      (1920*1200) LCD, default Win XP, no Bluetooth, Intel
      pro wireless 2915 A/B/G wireless card, standard
      battery (lasts 3 hours without extensive use))

      This is for people trying to get their 9300s to work
      with SL 40. Hopefully the solutions and work arounds
      presented will save some of you a lot of time, and
      hopefully the problems presented here will invite
      solutions from the experts on this list which will act
      to complete the procedure to get SL 40 working on a
      Dell 9300.

      ********** Installation
      * The first 'what's going on in there' moment I had
      was right after I started the SL 40 install. As soon
      as it tried to start the graphical install, the screen
      sort of crazed over.... nothing appeared for quite a
      while so I rebooted. After a couple of minutes playing
      around, I found that the installer recognised my ATI
      Radeon Mobility X300 (or is it M300) immediately, but
      had issues with the 'Expand' function of the LCD
      screen. In the BIOS, the LCD is configured to expand
      the display to full screen even if it is being driven
      at a lower resolution. SWITCH OFF THIS OPTION and
      graphical install goes thru.

      * I did an 'everything' install, which ran smoothly (2
      linux partitions, 2 windows vfat partitions) except at
      the very end when it gave an error about
      rh2install.img not being a directory or something and
      crashed... this happened twice, before it ran the
      post-install config.
      I found that since I created vfat partitions and
      mounted them (or some such reason) it created the
      install image in one of the vfat partitions... the
      next time I ran the install I didnt mount the vfat
      partitions, and the FULL install ran through... my
      sound card was detected, the display panel had to be
      manually selected to be a 1920*1200 Generic LCD, the
      wireless driver was installed (more on this later) and
      SL booted without major problems

      ************* Repositories
      * These can simplify life!!! They are under
      Community-> Repositories on the SL website. ATRPMS and
      DAG. Use yum if possible, up2date can also be made to
      work for most things.

      * SL 40 already has a HUGE amount of updates
      available. First do all the updates from the default
      up2date channels, before adding atrpms and dag. First
      of all, do the kernel update so that new packages you
      install do well.

      * Up2date stops doing anything sometimes, you can
      always close it and restart, it takes up from where it
      left off last.

      * when using up2date: DONT SELECT ALL UPDATES on
      channels other than the SL-base and the SL-errata
      channels. Updates on atrpms and dag are best selected
      one at a time, most times you might have to manually
      resolve dependancies. I havent tried yum, but
      supposedly it is supported better on all these
      channels.

      * the rpm gpg keys for atrpms and dag need to be
      downloaded as on their website. Also, interestingly, I
      had to download the SL GPG keys also, from the SL
      website (you have to snoop around the iso download
      site for them). You should do this before you start
      installing anything, as it will make installation much
      easier.

      ************** Wifi
      one problem was that the ipw2200 driver (which is
      available on the atrpms repository and also on the
      sourceforge project page) was installed, but my
      wireless card was not active.

      * I discovered that the firmware was not installed in
      /etc/firmware and /lib/firmware. Since the firmware
      version needs to match the driver version, I
      downloaded both from the sourceforge site and
      installed the new driver and the new firmware (both in
      /etc/firmware and in /lib/firmware).
      Before I could do that however, I had to download the
      ieee crypto libraries (available on atrpms or dag
      repositories)

      You can check whether the driver is installed by doing

      lsmod | grep ipw
      and a bunch of entries showing the ieee crypto modules
      and the ipw itself should show up. You can check if
      the firmware is being accessed by doing
      dmesg | grep ipw
      and it should show what the ipw2200 driver did on boot
      up.

      * I discovered a BIOS setting which allows the
      wireless card to be ON by default, this can be
      important for boot-up configuration of the card in
      linux. Thus you need to go to BIOS and set it up to be
      ON by default. Also make sure that the ON/OFF setting
      is Fn+F2 and application. This ensures that you can
      switch the card on and off with the function key.

      * The Wifi light does not work, i.e. it does not
      indicate whether wireless is on or off. the Fn+F2 key
      DOES WORK, though it shows NO INDICATION in SL (in
      kwifimanager etc).

      * Kwifimanager: The kwifimanager wireless kill on/off
      switch doesnt work. In fact, the kwifi version that
      comes with SL40 is the BUGGY version which has
      problems _saving_ the wireless configuration. I
      downloaded wireless assistant and wireless monitor
      from sourceforge, which allowed me to change
      connections without typing wep keys everytime, but
      still had to change ifcfg-eth1 to enforce default
      settings.

      * You might need to create a
      /etc/sysconfig/network-scripts/ifcfg-eth1 based on
      ifcfg-eth0, to make sure your wireless network is
      enabled and always attaches to your network on bootup.
      In this file, put in configuration for your network
      including security key etc (google ifcfg). otherwise,
      by default the card sometimes connects to the best
      available network, unsecured.

      * A useful command while doing the above settings
      changes is
      service network restart
      especially for the ifcfg changes

      * A useful way of setting WEP keys is to start
      Accessories->KHex Edit, and type in a 13 character
      ascii phrase in a new file and see it's hex equivalent
      which becomes your new WEP key.

      ************ Display
      * The 1920*1200 selection for resolution and display
      type should be done in post-install config, however it
      can also be done through System Settings -> Display

      * The available resolutions in Preferences -> Screen
      Resolution do not include wide-screen formats.
      However, the options shown are simply the list of
      options given in /etc/X11/xorg.conf (Subsection
      "Display") You can edit this file to add ANY
      compatible configuration that youre comfortable with.
      Remember that the aspect ratio is 1.6:1, so you can
      add configs like "1920x1200" and "1600x1000" and
      they'll show up in the Screen Resolution preferences
      the next time you start X. one precaution here: put
      the resolutions in correct order: e.g. 1920x1200
      should come first, 1600x1000 should come after
      1600x1024 etc... I think this has an impact on whether
      the high resolutions work... and it doesnt hurt to be
      a little organised!!!

      ************ Input Devices
      * Its useful to edit the xorg.conf file and set the
      XKbModel to "Inspiron" (google xkbmodel inspiron).
      however, this does not enable functions like CD drive
      eject, volume control etc. the Media buttons on the
      laptop dont work either.

      * My USB mini mouse was recognised instantly. The
      touch pad on the laptop works in compatibility mode,
      scroll functions and advanced functions dont work. Try
      installing the synaptic patch found at one of the
      atrpms/dag repositories: I havent had success yet due
      to dependencies (apt, which depends on rpmlib, which
      refuses to upgrade)

      * man xev and xmodmap to program any shortcuts you
      want. You can also make the media buttons (The ones on
      the front of the laptop base) using these two. But the
      Fn+F8, F10, Pageup/dn etc are not recognised as
      keystrokes in my experience, even after you set
      xkbmodel to inspiron...

      *********** CD/DVD
      * My system uses SATA drives, possibly because I went
      for a 7500RPM hard drive. I'm not sure if 5400 drives
      are also SATA. You should check this through System
      Tools -> hardware browser

      * If your hard drive is sata, so is your DVD, and
      linux currently doesnt officially support cd/dvd SATA
      drives, although it is expected in the future (google
      SATA linux, hdparm SATA). You can download a patch for
      it, but you need to recompile the kernel so it's not
      everybody's piece of cake!!

      * DVD playback is choppy (I recommend VLC player for
      dvd, or xmms-ogle plugin, the latter has a very smooth
      install process while the former has loads of
      features). This is because of the fact that SATA
      drives are not supported, which precludes use of DMA
      on the drive (google hdparm sata). However, since the
      system is fast, there's a workaround :)
      you can achieve acceptable playback by setting the
      read-ahead buffers to zero
      hdparm -a0 /dev/hdc
      My sata drive was mounted as /dev/hdc, it should have
      been /dev/sdb or something if linux supported sata.
      Note that using hdparm on /media/dvd or such wont
      work, you have to check where these point, which
      should ultimately lead you to an entry in the /dev
      sysytem.
      when you do this, run DVD exclusively (dont multitask)
      and your playback should be ok.

      *********** Misc issues
      * HALDAEMON: If you set ifcfg-eth0 to not detect your
      ethernet on boot up (because adds half a minute to
      boot time on it's own if your cable is not plugged in)
      then haldaemon crashes on ALTERNATE boots, in my
      experience, locking up the system entirely so you have
      to hold the power button to restart.

      * Suspend/Hibernate: You can switch to KDE, go to
      Control Center and look for power management to enable
      suspend/resume, hibernate etc... but in my experience
      the computer goes into suspend and never wakes up...
      you have to push power whence it boots from scratch.
      If you leave your laptop on battery long enough, it
      will simply shutdown when battery runs out and NOT
      RESPOND TO THE POWER BUTTON UNTIL YOU CONNECT THE
      POWER ADAPTER.

      * Sound card: It is recognised, but sometimes not
      started on X startup... you might have to go to System
      Settings -> sound card detection, and play the test
      sound to activate it in the first place. EVEN AFTER
      THIS, you need to open up volume controls and set
      different volumes to non-zero values. Especially if
      you're plugging in external speakers, you need to
      un-mute headphones etc etc

      * Windows XP dual boot: It works!!! Though there might
      be some contention on this issue, I suggest using the
      linux partitioner to repartition your drive, then
      reinstalling winxp and then installing SL 40 (read the
      point on Win Xp from Dell)

      * In case you install Win XP after SL 40, you might
      need to reinstall the boot loader. boot through the
      SL40 install disc 1, go to linux rescue, and do the
      following:
      chroot /mnt/sysimage - to use your SL 40
      installation settings
      grub-install /dev/sda - sda was my hard drive
      exit
      before you do this, google grub-install to ensure
      youre doing the right thing. In case you havent
      configured grub to boot other OS, you can edit
      grub.conf to add the WinXP partition

      * Windows XP from DELL: These days DELL doesnt give OS
      CDs with the laptop by default. Instead, they make a
      partition on the hard drive which has all the restore
      data. There are 2 options:
      1> call dell and tell them to send the CDs free of
      charge, make sure they get your system SPECs correctly
      and make sure they enumerate ALL the cds you need:
      winxp install CD, drivers and tools CD and application
      CD in the least, if not mc affee, corel wordperfect,
      aol etc etc
      2> preserve the restore partition on your drive when
      you repartition it to add linux partitions. If you do
      this you can use some bios utilities to re-install all
      the apps, drivers and everything your dell came pre
      installed with on the partition of your choice.
      Ideally, you should do BOTH of the above things.

      * Re partitioning: I recommend at least a win xp
      install and apps partition, a win xp data partition, a
      linux install partition and a swap partition. Also
      recommended are a linux data partition and a linux
      boot partition. Make sure you have the 'primary' and
      'extended' partition settings right: all OS installs
      should be in primary partitions, linux allows upto 4
      primary partitions, install partitions could come
      first in the drive before data. e.g. /dev/sda1 linux,
      sda2 winxp install, sda3 winxp data, sda4 extended
      with linux data & swap. I donot know if the boot
      partition needs to be primary, but this is likely. You
      also need to account for the default DELL restore
      partition (I dont have it anymore though)

      * WinXP might need the driver CD to get all devices
      working

      --Vaibhav

      __________________________________________________
      Do You Yahoo!?
      Tired of spam? Yahoo! Mail has the best spam protection around
      http://mail.yahoo.com
    Your message has been successfully submitted and would be delivered to recipients shortly.