Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] wireless on i9300

Expand Messages
  • Joakim Olsson
    Hi, Just jumping into the discussion without all the background info but have ju placed the latest ipw2200 firmware in the correct place?
    Message 1 of 13 , Jul 4, 2005
    • 0 Attachment
      Hi,

      Just jumping into the discussion without all the background info but
      have ju placed the latest ipw2200 firmware in the correct place?
      (/usr/lib/hotplug/firmware on my Debian-laptop)

      Best regards,
      Joakim


      Walter Cazzola wrote:

      >On Fri, 1 Jul 2005, Haedn Thorn wrote:
      >
      >
      >
      >>>I have already checked, I have just three options: always off, hw on/off
      >>>and sw on/off, at the moment is on the hw on/off and starts as off
      >>>(thence I cannot turn it on :-(()
      >>>
      >>>
      >
      >
      >
      >>Check out rfswitch.sf.net ... I haven't tried it with my ipw2200 since mine
      >>defaults to on, but I think it could get you going.
      >>
      >>
      >
      >uhm, I didn't try it but it looks they do not supports dell laptops, BTW,
      >I'll keep it in mind and if anything else work I'll try it.
      >
      >thank you for the link.
      >Walter
      >
      >
      >
    • Walter Cazzola
      ... well, I don t know if it is the last release but I have istalled the rpm ipw2200-firmware-2.2-3plf and the firmware is exactly in the place you say. I
      Message 2 of 13 , Jul 4, 2005
      • 0 Attachment
        On Mon, 4 Jul 2005, Joakim Olsson wrote:

        > Just jumping into the discussion without all the background info but
        > have ju placed the latest ipw2200 firmware in the correct place?
        > (/usr/lib/hotplug/firmware on my Debian-laptop)

        well, I don't know if it is the last release but I have istalled the rpm

        ipw2200-firmware-2.2-3plf

        and the firmware is exactly in the place you say. I cannot check if it
        is the last release because the version number changes from distribution
        to distribution.

        Thank you for the suggestion.

        Walter

        --
        Walter Cazzola, PhD - Assistant Professor, DICo, University of Milano
        E-mail cazzola@... Ph.: +39 010 353 6637 Fax: +39 010 353 6699
        · · · --------------------------- · · · --------------------------- · · ·
        ... recursive: adjective, see recursive ...
        · · · --------------------------- · · · --------------------------- · · ·
      • Herman
        ... I suggest that you go to the Intel project site and get the latest driver and firmware there. http://ipw2200.sourceforge.net/ Cheers, -- -- Herman
        Message 3 of 13 , Jul 4, 2005
        • 0 Attachment
          Walter Cazzola wrote:
          > On Mon, 4 Jul 2005, Joakim Olsson wrote:
          >
          >
          >>Just jumping into the discussion without all the background info but
          >>have ju placed the latest ipw2200 firmware in the correct place?
          >>(/usr/lib/hotplug/firmware on my Debian-laptop)
          >
          >
          > well, I don't know if it is the last release but I have istalled the rpm
          >
          > ipw2200-firmware-2.2-3plf
          >
          > and the firmware is exactly in the place you say. I cannot check if it
          > is the last release because the version number changes from distribution
          > to distribution.
          >
          > Thank you for the suggestion.
          >
          > Walter
          >

          I suggest that you go to the Intel project site and get the latest
          driver and firmware there.
          http://ipw2200.sourceforge.net/

          Cheers,
          --
          --
          Herman Oosthuysen, B.Eng(E), MIEEE
          #207, 908 - 17th Ave SW
          Calgary, AB, T2T 0A3, Canada
          Phone: 1.403.228-4181
          http://www.AerospaceSoftware.com
        • Walter Cazzola
          ... I m downloading it, there is a way to know the version of the currently installed firmware? BTW I got some success in installing kwifimanager now I m able
          Message 4 of 13 , Jul 4, 2005
          • 0 Attachment
            On Mon, 4 Jul 2005, Herman wrote:

            > I suggest that you go to the Intel project site and get the latest
            > driver and firmware there.
            > http://ipw2200.sourceforge.net/

            I'm downloading it, there is a way to know the version of the currently
            installed firmware?

            BTW I got some success in installing kwifimanager now I'm able to
            connecting to the wifi network:

            eth2 Scan completed :
            Cell 01 - Address: 00:C0:49:DA:9E:D5
            ESSID:"educwifi"
            Protocol:IEEE 802.11bg
            Mode:Master
            Channel:11
            Encryption key:off
            Bit Rate:54 Mb/s
            Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 22 24 36 48 54
            Signal level=-76 dBm
            Extra: Last beacon: 40ms ago

            but the signal is too low to experiment the navigation, I look for
            another AP and try again but I'm trusting that now it is working.

            thanks to all the help

            Walter

            --
            Walter Cazzola, PhD - Assistant Professor, DICo, University of Milano
            E-mail cazzola@... Ph.: +39 010 353 6637 Fax: +39 010 353 6699
            · · · --------------------------- · · · --------------------------- · · ·
            ... recursive: adjective, see recursive ...
            · · · --------------------------- · · · --------------------------- · · ·
          • ken
            ... Sorry, I ve been away on vacation. Yeah, you shouldn t have eth2 configured for an IPv6 address. Check the configuration file. -- A lot of us are working
            Message 5 of 13 , Jul 9, 2005
            • 0 Attachment
              Walter Cazzola wrote:

              >On Fri, 1 Jul 2005, ken wrote:
              >
              >[BIOS settings]
              >
              >
              >
              >>>I have already checked, I have just three options: always off, hw on/off
              >>>and sw on/off, at the moment is on the hw on/off and starts as off
              >>>(thence I cannot turn it on :-(()
              >>>
              >>>
              >
              >
              >
              >>Well, then that's the basic problem. If you can't turn the radio on,
              >>you're not going to be able to use the wireless!
              >>
              >>
              >
              >right, in fact I would like to turn it on :-(((
              >
              >
              >
              >>Maybe if you set the BIOS to "sw on/off", you could find a way to turn
              >>it on with some software... perhaps even FN-F2...?
              >>
              >>
              >
              >well, from what I read (but it could be wrong) the "hw on/off" option
              >should enable me to turn on/off the radio from linux, because it is an
              >HW switch as the CRT/LCD switch not interpreted by the OS.
              >
              >
              >
              >>(Asking a second time....) What is the output from "cat
              >>/proc/net/wireless"?
              >>
              >>
              >
              ># cat /proc/net/wireless
              >Inter-| sta-| Quality | Discarded packets | Missed | WE
              > face | tus | link level noise | nwid crypt frag retry misc | beacon | 17
              > eth2: 0000 0. 0. 0. 0 0 0 0 0 0
              >
              >
              >
              >
              >>>iwconfig says me that I have only eth2 and I'm scanning it without
              >>>results :-(((
              >>>
              >>>
              >
              >
              >
              >>What does "ifconfig" tell you?
              >>
              >>
              >
              >
              ># ifconfig eth2
              >eth2 Link encap:Ethernet HWaddr 00:00:00:00:00:00
              > inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
              > UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
              > RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              > TX packets:0 errors:0 dropped:0 overruns:0 carrier:1
              > collisions:0 txqueuelen:1000
              > RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
              > Interrupt:17 Base address:0xe000 Memory:dcffd000-dcffdfff
              >
              >uhm, just now, I have noted the "inet6 address" I don't think it is the
              >problem but I don't use IPv6, really strange.
              >
              >
              >
              >>>I think that I have to find the way to us the FN-F2 key to turn on the
              >>>radio. Any other idea?
              >>>
              >>>
              >
              >
              >
              >>Play around with configuring FN-F2 later... after you have the wireless
              >>working properly.
              >>
              >>
              >
              >Ok, I agree with you, what do you think from the date above, is it well
              >configurated?
              >
              >thank you
              >Walter
              >
              >

              Sorry, I've been away on vacation.

              Yeah, you shouldn't have eth2 configured for an IPv6 address. Check the
              configuration file.

              --
              A lot of us are working harder than we want, at things we don't like to
              do. Why? ...In order to afford the sort of existence we don't care to live.
              -- Bradford Angier
            Your message has been successfully submitted and would be delivered to recipients shortly.