Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] Inspiron 1150 with WLAN 1350 Mini-PCI (BCM4306) working. Knoppix 3.7

Expand Messages
  • Herman
    Yup - same damn problem over here. The way to fix it is to write a little script and store it and the .inf and .sys files on the USB dongle, then run it after
    Message 1 of 9 , Jul 1, 2005
    • 0 Attachment
      Yup - same damn problem over here.

      The way to fix it is to write a little script and store it and the .inf
      and .sys files on the USB dongle, then run it after startup.

      Something like this should get you going, file wup:

      #! /bin/bash
      /wherever/ndiswrapper -i /mnt/wherever/driver.inf
      /wherever/iwconfig wlan0 essid=whatever mode=managed
      /wherever/ifconfig wlan0 up
      /wherever/dhclient wlan0

      Read the man pages for details, but the above parameters are all you
      need as far as I know.

      'Hope this helps!

      Cheers,

      Herman

      bruce_marsh wrote:
      > I am writing this message on my Dell Inspiron 1150 with the Dell
      > WLAN 1350 Mini-PCI Card.
      >
      > I'm running Knoppix 3.7 booting from the CD.
      >
      > My only problem is that I don't know how to make these changes
      > permanent.
      >
      > Here's how I got the wireless card working:
      >
      > First, download R81433.exe from ftp://ftp.dell.com/network while
      > running Windows XP. Then run the program, and it will self-extract
      > into c:\Dell\drivers\81433
      >
      > Boot to the Knoppix CD, and type:
      >
      > knoppix myconfig=scan home=scan
      >
      > for the boot option.
      >
      > (If this is your first time running Knoppix you can just type:
      > knoppix for the boot option).
      >
      > Click the knoppix menu (the penguin at the bottom left of the
      > screen). Go to Network/Internet and then click on ndiswrapper
      > configuration. Click OK.
      >
      > In the Selection: text box, type
      >
      > /mnt/hdc2/DELL/drivers/R81433/AR/bcmwl5a.inf
      >
      > and click OK
      >
      > Next, click the knoppix menu, go to Network/Internet, and click
      > Wavelan configuration.
      >
      > Enter your ESSID when asked.
      >
      > If your wireless network is protected, answer the rest of the
      > questions as required. Otherwise just leave the rest of the boxes
      > blank.
      >
      > Now, click the knoppix menu, and click Root Shell
      >
      > The following is for a laptop with a static IP address of
      > 192.168.1.25 and a default gateway of 192.168.1.1:
      >
      > Type the following lines in the root shell:
      >
      > ifconfig wlan0 192.168.1.25 netmask 255.255.255.0 up
      >
      > route add 192.168.1.25 wlan0
      >
      > route add default gw 192.168.1.1 wlan0
      >
      > route add -host 127.0.0.1 lo
      >
      > kwrite
      >
      > That last line opens the kwrite editor.
      >
      > Click File, Open, and in the location text box type /etc/resolv.conf
      >
      > add a line to the bottom of the file:
      >
      > nameserver yourDNSserversIPaddress
      >
      > for example:
      >
      > nameserver 68.87.64.196
      >
      > would be the line to add for Comcast's DNS server.
      >
      > Save the file, and then try a web browser.
      >
      > Now, the only problem is that I don't know to make these settings
      > permanent. I've tried doing the Save Knoppix Configuration, but the
      > settings are gone each time I restart. (It does retain my data
      > files and bookmarks, though) I assume that the problem is that the
      > files that I'm changing are being overwritten by knoppix each time I
      > restart.
      >
      > I don't know enough about Linux and Knoppix to know how to fix this.
      >
      > Any ideas?
      >
      >
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
      > FAQ: http://www.whacked.net/ldl/faq
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
      >


      --
      --
      Herman Oosthuysen, B.Eng(E), MIEEE
      #207, 908 - 17th Ave SW
      Calgary, AB, T2T 0A3, Canada
      Phone: 1.403.228-4181
      http://www.AerospaceSoftware.com
    • Herman
      Herman wrote: I created a little wup script and got this going: #! /bin/bash ndiswrapper -i bcmwl5.inf modprobe ndiswrapper ndiswrapper -m iwconfig wlan0 mode
      Message 2 of 9 , Jul 1, 2005
      • 0 Attachment
        Herman wrote:

        I created a little wup script and got this going:
        #! /bin/bash
        ndiswrapper -i bcmwl5.inf
        modprobe ndiswrapper
        ndiswrapper -m
        iwconfig wlan0 mode managed essid whatever
        ifconfig wlan0 up


        Now the remaining problem is getting DHCP to work. Knoppix ships with
        pump, and this command is supposed to get an IP address:
        pump -i wlan0

        Except that it doesn't work for me.

        Does anyone know how to get this sad excuse for a DHCP client to do
        something?

        Cheers,

        H.
      • Herman
        Herman wrote: I created a little wup script and got this going: #! /bin/bash ndiswrapper -i bcmwl5a.inf modprobe ndiswrapper ndiswrapper -m iwconfig wlan0 mode
        Message 3 of 9 , Jul 1, 2005
        • 0 Attachment
          Herman wrote:

          I created a little wup script and got this going:
          #! /bin/bash
          ndiswrapper -i bcmwl5a.inf
          modprobe ndiswrapper
          ndiswrapper -m
          iwconfig wlan0 mode managed essid whateverssid key deadd00d12
          ifconfig wlan0 up
          pump -i wlan0

          It sure helps if the essid and key is specified right...

          Save the wup script, bcmwl5a.inf and bcmwl5.sys on /mnt/uba1 and make
          wup executable.

          You can make various scripts depending on which WAP you have to connect
          to, home, office, whatever.

          Cheers

          H.
        • bruce_marsh
          Thanks for the help! -Bruce ... make ... connect
          Message 4 of 9 , Jul 1, 2005
          • 0 Attachment
            Thanks for the help!

            -Bruce

            --- In linux-dell-laptops@yahoogroups.com, Herman <herman@a...>
            wrote:
            > Herman wrote:
            >
            > I created a little wup script and got this going:
            > #! /bin/bash
            > ndiswrapper -i bcmwl5a.inf
            > modprobe ndiswrapper
            > ndiswrapper -m
            > iwconfig wlan0 mode managed essid whateverssid key deadd00d12
            > ifconfig wlan0 up
            > pump -i wlan0
            >
            > It sure helps if the essid and key is specified right...
            >
            > Save the wup script, bcmwl5a.inf and bcmwl5.sys on /mnt/uba1 and
            make
            > wup executable.
            >
            > You can make various scripts depending on which WAP you have to
            connect
            > to, home, office, whatever.
            >
            > Cheers
            >
            > H.
          • Michelle L. Gill
            The following may not apply to running linux from a boot disk, but I am able to get my BCM4306 card to work on a Suse 9.3 install (not boot from CD) without
            Message 5 of 9 , Jul 3, 2005
            • 0 Attachment
              The following may not apply to running linux from a boot disk, but I
              am able to get my BCM4306 card to work on a Suse 9.3 install (not
              boot from CD) without running any external scripts. If you end up
              installing Knoppix, I bet my procedure would work well for you. I
              have posted about it before:
              http://groups.yahoo.com/group/linux-dell-laptops/message/26859

              You need to set a flag in the /etc/sysconfig/kernel config file so
              that ndiswrapper is loaded on boot. Knoppix may have the files in a
              slightly different place, but the settings should be easy to fix
              once you find the file.

              Finally, and this was tricky to find, you need to add the following
              line to your /etc/sysconfig/network/ifcfg-wlan0 (of whatever Knoppix
              calls it) file:
              DHCLIENT_PRIMARY_DEVICE='yes'
              There is a problem with DHCP when it tries to resolve multiple
              network interfaces (like on a laptop when you have wireless and
              ethernet cards). You can also set your network ID and password in
              this file. I keep copies of the file for each wireless network I
              use. All of this is described in more detail--just follow the link
              above.


              --- In linux-dell-laptops@yahoogroups.com, "bruce_marsh"
              <bruce_marsh@y...> wrote:
              > Thanks for the help!
              >
              > -Bruce
              >
              > --- In linux-dell-laptops@yahoogroups.com, Herman <herman@a...>
              > wrote:
              > > Herman wrote:
              > >
              > > I created a little wup script and got this going:
              > > #! /bin/bash
              > > ndiswrapper -i bcmwl5a.inf
              > > modprobe ndiswrapper
              > > ndiswrapper -m
              > > iwconfig wlan0 mode managed essid whateverssid key deadd00d12
              > > ifconfig wlan0 up
              > > pump -i wlan0
              > >
              > > It sure helps if the essid and key is specified right...
              > >
              > > Save the wup script, bcmwl5a.inf and bcmwl5.sys on /mnt/uba1 and

              > make
              > > wup executable.
              > >
              > > You can make various scripts depending on which WAP you have to
              > connect
              > > to, home, office, whatever.
              > >
              > > Cheers
              > >
              > > H.
            • Michelle L. Gill
              One more thing, the DHCP line that you add to ifcfg-wlan0 should take care of setting the default gateway and obtainin an IP, if you have DHCP configured. I
              Message 6 of 9 , Jul 3, 2005
              • 0 Attachment
                One more thing, the DHCP line that you add to ifcfg-wlan0 should
                take care of setting the default gateway and obtainin an IP, if you
                have DHCP configured. I bet you've had to configure them from a
                command line in the past because this line of text was missing.

                --- In linux-dell-laptops@yahoogroups.com, "Michelle L. Gill"
                <michelle.gill@y...> wrote:
                > The following may not apply to running linux from a boot disk, but
                I
                > am able to get my BCM4306 card to work on a Suse 9.3 install (not
                > boot from CD) without running any external scripts. If you end up
                > installing Knoppix, I bet my procedure would work well for you. I
                > have posted about it before:
                > http://groups.yahoo.com/group/linux-dell-laptops/message/26859
                >
                > You need to set a flag in the /etc/sysconfig/kernel config file so
                > that ndiswrapper is loaded on boot. Knoppix may have the files in
                a
                > slightly different place, but the settings should be easy to fix
                > once you find the file.
                >
                > Finally, and this was tricky to find, you need to add the
                following
                > line to your /etc/sysconfig/network/ifcfg-wlan0 (of whatever
                Knoppix
                > calls it) file:
                > DHCLIENT_PRIMARY_DEVICE='yes'
                > There is a problem with DHCP when it tries to resolve multiple
                > network interfaces (like on a laptop when you have wireless and
                > ethernet cards). You can also set your network ID and password in
                > this file. I keep copies of the file for each wireless network I
                > use. All of this is described in more detail--just follow the
                link
                > above.
                >
                >
                > --- In linux-dell-laptops@yahoogroups.com, "bruce_marsh"
                > <bruce_marsh@y...> wrote:
                > > Thanks for the help!
                > >
                > > -Bruce
                > >
                > > --- In linux-dell-laptops@yahoogroups.com, Herman <herman@a...>
                > > wrote:
                > > > Herman wrote:
                > > >
                > > > I created a little wup script and got this going:
                > > > #! /bin/bash
                > > > ndiswrapper -i bcmwl5a.inf
                > > > modprobe ndiswrapper
                > > > ndiswrapper -m
                > > > iwconfig wlan0 mode managed essid whateverssid key deadd00d12
                > > > ifconfig wlan0 up
                > > > pump -i wlan0
                > > >
                > > > It sure helps if the essid and key is specified right...
                > > >
                > > > Save the wup script, bcmwl5a.inf and bcmwl5.sys on /mnt/uba1
                and
                >
                > > make
                > > > wup executable.
                > > >
                > > > You can make various scripts depending on which WAP you have
                to
                > > connect
                > > > to, home, office, whatever.
                > > >
                > > > Cheers
                > > >
                > > > H.
              • Herman
                ... If the DHCP server is configured correctly, then it will send all the info to the client, including the default GW. So, if you don t receive all the
                Message 7 of 9 , Jul 3, 2005
                • 0 Attachment
                  Michelle L. Gill wrote:
                  > One more thing, the DHCP line that you add to ifcfg-wlan0 should
                  > take care of setting the default gateway and obtainin an IP, if you
                  > have DHCP configured. I bet you've had to configure them from a
                  > command line in the past because this line of text was missing.

                  If the DHCP server is configured correctly, then it will send all the
                  info to the client, including the default GW. So, if you don't receive
                  all the network info, then check the server.

                  Cheers,

                  H.
                • Herman
                  ... Cool. I basically use Knoppix as a test and debug CD, not as a permanent hard disk installation. Getting the WiFi adaptor to work was more of a mental
                  Message 8 of 9 , Jul 3, 2005
                  • 0 Attachment
                    Michelle L. Gill wrote:
                    > The following may not apply to running linux from a boot disk, but I
                    > am able to get my BCM4306 card to work on a Suse 9.3 install (not
                    > boot from CD) without running any external scripts. If you end up
                    > installing Knoppix, I bet my procedure would work well for you. I
                    > have posted about it before:
                    > http://groups.yahoo.com/group/linux-dell-laptops/message/26859
                    >
                    > You need to set a flag in the /etc/sysconfig/kernel config file so
                    > that ndiswrapper is loaded on boot. Knoppix may have the files in a
                    > slightly different place, but the settings should be easy to fix
                    > once you find the file.
                    >
                    > Finally, and this was tricky to find, you need to add the following
                    > line to your /etc/sysconfig/network/ifcfg-wlan0 (of whatever Knoppix
                    > calls it) file:
                    > DHCLIENT_PRIMARY_DEVICE='yes'
                    > There is a problem with DHCP when it tries to resolve multiple
                    > network interfaces (like on a laptop when you have wireless and
                    > ethernet cards). You can also set your network ID and password in
                    > this file. I keep copies of the file for each wireless network I
                    > use. All of this is described in more detail--just follow the link
                    > above.
                    >

                    Cool. I basically use Knoppix as a test and debug CD, not as a
                    permanent hard disk installation. Getting the WiFi adaptor to work was
                    more of a mental exercise than a practical thing, to see how much effort
                    it would take to get a WiFi thing to work on a machine.

                    Cheers,

                    Herman
                  Your message has been successfully submitted and would be delivered to recipients shortly.