Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] how can i shift redhat linux 9 from text mode to graphical mode?

Expand Messages
  • Chris Fox
    ... Hash: SHA1 ... you mean how can you start the GUI? Type startx at a prompt. You don t have to be root (and in fact you should not log into the GUI as
    Message 1 of 13 , Apr 5, 2005
    • 0 Attachment
      -----BEGIN PGP SIGNED MESSAGE-----
      Hash: SHA1

      vitalmarks wrote:

      |
      | how can i shift redhat linux 9 from text mode to graphical mode?

      you mean how can you start the GUI? Type

      startx

      at a prompt. You don't have to be root (and in fact you should not log
      into the GUI as root)

      How can you tell it to boot into the GUI? Set the default runlevel to 5
      -----BEGIN PGP SIGNATURE-----
      Version: GnuPG v1.4.0 (MingW32)
      Comment: Gentlemen don't read each others' mail -- Henry Stimson
      Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

      iD8DBQFCUuzG9jaRInQzvmsRAr19AJwMBskUhe4HRfvH0VRe8USfYwfw3wCfcqa4
      /y5UGPOzbB2KMurlZO5ylYU=
      =/6PK
      -----END PGP SIGNATURE-----
    • Douglas S. Oliver
      Well, assuming you have your monitor and graphics card set up correctly, just enter startx without the quotes. If things lock up, use cntrl/alt/bkspc to
      Message 2 of 13 , Apr 5, 2005
      • 0 Attachment
        Well, assuming you have your monitor and graphics card set up correctly,
        just enter "startx" without the quotes. If things lock up, use
        cntrl/alt/bkspc to leave the GUI. You also might be able to get out by
        switching to a text console with ctrl/alt F1 or F2.

        vitalmarks wrote:

        >how can i shift redhat linux 9 from text mode to graphical mode?
        >
        >
        >
        >
        >
        >--------------------------------------------------------------
        >Please post your X config files in the group links or database
        >To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        >FAQ: http://www.whacked.net/ldl/faq
        >Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
        >
        >
        >
        >
      • theuteck@gmail.com
        If you all ready have X running you can use Ctrl+Alt+F7 to go back to the running X session. Ctrl+Alt+F1 through F6 will bring you to text logins. And yes you
        Message 3 of 13 , Apr 5, 2005
        • 0 Attachment
          If you all ready have X running you can use Ctrl+Alt+F7 to go back to
          the running X session. Ctrl+Alt+F1 through F6 will bring you to text
          logins.

          And yes you can run X on F8 -F12, but I don't remember how at the moment.


          On Tue, 05 Apr 2005 13:58:50 -0700, "Douglas S. Oliver"
          <dsoliver@...> wrote:
          >
          > Well, assuming you have your monitor and graphics card set up correctly,
          > just enter "startx" without the quotes. If things lock up, use
          > cntrl/alt/bkspc to leave the GUI. You also might be able to get out by
          > switching to a text console with ctrl/alt F1 or F2.
          >
          > vitalmarks wrote:
          >
          > >how can i shift redhat linux 9 from text mode to graphical mode?
          > >
          > >
          > >
          > >
          > >
          > >--------------------------------------------------------------
          > >Please post your X config files in the group links or database
          > >To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
          > >FAQ: http://www.whacked.net/ldl/faq
          > >Yahoo! Groups Links
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          > >
          >
          >
          > --------------------------------------------------------------
          > Please post your X config files in the group links or database
          > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
          > FAQ: http://www.whacked.net/ldl/faq
          > Yahoo! Groups Links
          >
          >
          >
          >
          >
          >
          >
          >

          --
          no .sig found
          Please restart your browser.
        • ken
          ... Type startx . -- A lot of us are working harder than we want, at things we don t like to do. Why? ...In order to afford the sort of existence we don t
          Message 4 of 13 , Apr 5, 2005
          • 0 Attachment
            vitalmarks wrote:

            >how can i shift redhat linux 9 from text mode to graphical mode?
            >
            >

            Type "startx".


            --
            A lot of us are working harder than we want, at things we don't like to
            do. Why? ...In order to afford the sort of existence we don't care to live.
            -- Bradford Angier
          • Alexandre Tessier
            ... As said in other posts : startx. If you want to have X11 launch at the end of the boot process, edit /etc/inittab and replace the line like
            Message 5 of 13 , Apr 6, 2005
            • 0 Attachment
              vitalmarks wrote:
              >
              > how can i shift redhat linux 9 from text mode to graphical mode?

              As said in other posts : startx.
              If you want to have X11 launch at the end of the boot process, edit
              /etc/inittab and replace the line like
              id:3:initdefault:
              by
              id:5:initdefault:

              In a lot of distros, the default install provides several consoles. As
              said in a previous post you can switch from one to another by using
              <ctrl><alt><F*>. Generally, consoles from F1 to F6 are text consoles and
              consoles from F7 to F12 are X consoles.
              If you have an instance of X running on display :0 on console F7, you
              can launch another instance of X on display :1 on console F8, enter the
              command:
              startx -- :1
              now, with <ctrl><alt><F7> you have the first display :0 and with
              <ctrl><alt><F8> the second display :1.

              Alex.

              >
              >
              >
              >
              >
              > --------------------------------------------------------------
              > Please post your X config files in the group links or database
              > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
              > FAQ: http://www.whacked.net/ldl/faq
              > Yahoo! Groups Links
              >
              >
              >
              >
              >
              >
              >
              >
              >
            • ken
              ... I tried the above, but can t figure out how to get to the console from which to run the above command. I can do to get to a login
              Message 6 of 13 , Apr 6, 2005
              • 0 Attachment
                Alexandre Tessier wrote:

                > [....]
                >
                >In a lot of distros, the default install provides several consoles. As
                >said in a previous post you can switch from one to another by using
                ><ctrl><alt><F*>. Generally, consoles from F1 to F6 are text consoles and
                >consoles from F7 to F12 are X consoles.
                >If you have an instance of X running on display :0 on console F7, you
                >can launch another instance of X on display :1 on console F8, enter the
                >command:
                >startx -- :1
                >
                >

                I tried the above, but can't figure out how to get to the <F8> console
                from which to run the above command.

                I can do <Ctrl><Alt><F1> to get to a login prompt, but <Ctrl><Alt><F8>
                just gives me a blank (black) screen with a blinking cursor in the
                upper-left corner.

                I tried running "startx -- :1" from the <F2> console (after logging in),
                but it failed with the message (something like) "Waiting for X session
                to end."


                Thanks for any assistance,
                ken


                --

                A lot of us are working harder than we want, at things we don't like to
                do. Why? ...In order to afford the sort of existence we don't care to live.
                -- Bradford Angier
              • Alexandre Tessier
                ... That s normal. No X11 session is affected to the virtual console 8. ... That s not normal! I don t understand why it does not work. The command startx --
                Message 7 of 13 , Apr 6, 2005
                • 0 Attachment
                  ken wrote:
                  > Alexandre Tessier wrote:
                  >
                  >
                  >>[....]
                  >>
                  >>In a lot of distros, the default install provides several consoles. As
                  >>said in a previous post you can switch from one to another by using
                  >><ctrl><alt><F*>. Generally, consoles from F1 to F6 are text consoles and
                  >>consoles from F7 to F12 are X consoles.
                  >>If you have an instance of X running on display :0 on console F7, you
                  >>can launch another instance of X on display :1 on console F8, enter the
                  >>command:
                  >>startx -- :1
                  >>
                  >>
                  >
                  >
                  > I tried the above, but can't figure out how to get to the <F8> console
                  > from which to run the above command.
                  >
                  > I can do <Ctrl><Alt><F1> to get to a login prompt, but <Ctrl><Alt><F8>
                  > just gives me a blank (black) screen with a blinking cursor in the
                  > upper-left corner.

                  That's normal. No X11 session is affected to the virtual console 8.

                  >
                  > I tried running "startx -- :1" from the <F2> console (after logging in),
                  > but it failed with the message (something like) "Waiting for X session
                  > to end."

                  That's not normal! I don't understand why it does not work.
                  The command "startx -- :1" in a xterm (or in a text mode console) should
                  launch X11 in the first free X console (vt8 if you have already X11
                  running in vt7).
                  What distro are you using?
                  Do you have a particular X init file (.xsession, .xinitrc, .xserverrc,
                  ...) in your home dir?
                  Can you tell me the exact message of Xorg (or XFree)?

                  Alex.

                  >
                  >
                  > Thanks for any assistance,
                  > ken
                  >
                  >
                • ken
                  ... Yeah. Running from an xterm in my already-running X, I can cut-n-paste: $ startx -- :1 Using authority file /home/ken/.Xauthority Writing authority file
                  Message 8 of 13 , Apr 6, 2005
                  • 0 Attachment
                    Alexandre Tessier wrote:

                    >ken wrote:
                    >
                    >
                    >>Alexandre Tessier wrote:
                    >>
                    >>
                    >>
                    >>
                    >>>[....]
                    >>>
                    >>>In a lot of distros, the default install provides several consoles. As
                    >>>said in a previous post you can switch from one to another by using
                    >>><ctrl><alt><F*>. Generally, consoles from F1 to F6 are text consoles and
                    >>>consoles from F7 to F12 are X consoles.
                    >>>If you have an instance of X running on display :0 on console F7, you
                    >>>can launch another instance of X on display :1 on console F8, enter the
                    >>>command:
                    >>>startx -- :1
                    >>>
                    >>>
                    >>>
                    >>>
                    >>[....]
                    >>
                    >
                    >
                    >>I tried running "startx -- :1" from the <F2> console (after logging in),
                    >>but it failed with the message (something like) "Waiting for X session
                    >>to end."
                    >>
                    >>
                    > <>
                    > That's not normal! I don't understand why it does not work.
                    > The command "startx -- :1" in a xterm (or in a text mode console) should
                    > launch X11 in the first free X console (vt8 if you have already X11
                    > running in vt7).
                    > What distro are you using?
                    > Do you have a particular X init file (.xsession, .xinitrc, .xserverrc,
                    > ...) in your home dir?
                    > Can you tell me the exact message of Xorg (or XFree)?


                    Yeah. Running from an xterm in my already-running X, I can cut-n-paste:

                    $ startx -- :1
                    Using authority file /home/ken/.Xauthority
                    Writing authority file /home/ken/.Xauthority
                    Using authority file /home/ken/.Xauthority
                    Writing authority file /home/ken/.Xauthority


                    XFree86 Version 4.3.0 (Custom Build: 4.3.0-2.90.55)
                    Release Date: 15 August 2003
                    X Protocol Version 11, Revision 0, Release 6.6
                    Build Operating System: Linux 2.4.20-8 i686 [ELF]
                    Build Date: 31 March 2004
                    Build Host: heidegger

                    Before reporting any problems, please make sure you are using
                    the most
                    recent XFree86 packages available from Red Hat by checking for
                    updates
                    at http://rhn.redhat.com/errata or by using the Red Hat Network
                    up2date
                    tool. If you still encounter problems, please file bug reports
                    in the
                    XFree86.org bugzilla at http://bugs.xfree86.org and/or Red Hat
                    bugzilla at http://bugzilla.redhat.com

                    Module Loader present
                    OS Kernel: Linux version 2.4.20-8 (bhcompile@...)
                    (gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Thu Mar 13
                    17:18:24 EST 2003
                    Markers: (--) probed, (**) from config file, (==) default setting,
                    (++) from command line, (!!) notice, (II) informational,
                    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
                    (==) Log file: "/var/log/XFree86.1.log", Time: Wed Apr 6 12:35:15 2005
                    (==) Using config file: "/etc/X11/XF86Config"
                    (EE) MGA(0): [drm] DRIScreenInit failed. Disabling DRI.

                    waiting for X server to shut down

                    ================================================

                    Looking through var/log/XFree86.1.log (a very large file), I found this
                    (see "failure" about 20 lines into it):

                    ...
                    (==) MGA(0): Write-combining range (0xe4000000,0x2000000)
                    (II) MGA(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
                    (--) MGA(0): 16 DWORD fifo
                    (==) MGA(0): Default visual is TrueColor
                    (II) MGA(0): [drm] bpp: 32 depth: 24
                    (II) MGA(0): [drm] Sarea 2200+664: 2864
                    drmOpenDevice: minor is 0
                    drmOpenDevice: node name is /dev/dri/card0
                    drmOpenDevice: open result is 7, (OK)
                    drmOpenDevice: minor is 0
                    drmOpenDevice: node name is /dev/dri/card0
                    drmOpenDevice: open result is 7, (OK)
                    drmOpenDevice: minor is 0
                    drmOpenDevice: node name is /dev/dri/card0
                    drmOpenDevice: open result is 7, (OK)
                    drmGetBusid returned 'PCI:1:5:0'
                    drmOpenDevice: minor is 1
                    drmOpenDevice: node name is /dev/dri/card1
                    drmOpenDevice: open result is -1, (No such device)
                    drmOpenDevice: open result is -1, (No such device)
                    drmOpenDevice: Open failed
                    drmOpenDevice: minor is 2
                    drmOpenDevice: node name is /dev/dri/card2
                    ...

                    ================================================

                    This suggests to me that the "startx -- :1" is telling my system to look
                    for the second video card-- which I don't have. Perhaps I want to do
                    "startx -- :0.1"??? (But I want to ship off this email before trying
                    it... I might crash X and lose this entire email.


                    Thanks for your help. I've been curious about this for some time.

                    ken

                    --
                    A lot of us are working harder than we want, at things we don't like to
                    do. Why? ...In order to afford the sort of existence we don't care to live.
                    -- Bradford Angier
                  • ken
                    startx -- :0.1 didn t work either. It gave me this: $ startx -- :0.1 _XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
                    Message 9 of 13 , Apr 6, 2005
                    • 0 Attachment
                      "startx -- :0.1" didn't work either. It gave me this:

                      $ startx -- :0.1
                      _XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
                      _XSERVTransMakeAllCOTSServerListeners: server already running


                      Fatal server error:
                      Cannot establish any listening sockets - Make sure an X server isn't
                      already running


                      If you encounter a server crash, please report the problem by filing a bug
                      report in the XFree86.org bugzilla at http://bugs.xfree86.org and/or Red Hat
                      bugzilla at http://bugzilla.redhat.com/bugzilla. When filing your
                      report, it
                      is very important that you explain your problem in as much detail as
                      possible,
                      and include a complete description on how to reproduce the problem. After
                      submitting the bug report, attach the following files as uncompressed
                      individual file attachments using the bugzilla file attachment feature:
                      - X server log file: /var/log/XFree86.0.1.log
                      - Kernel log file: /var/log/messages


                      It hung there, but ^C gave me the CLI back.

                      --
                      A lot of us are working harder than we want, at things we don't like to
                      do. Why? ...In order to afford the sort of existence we don't care to live.
                      -- Bradford Angier
                    • Alexandre Tessier
                      ... Can you try with another user (for example root or another one). Alex.
                      Message 10 of 13 , Apr 6, 2005
                      • 0 Attachment
                        ken wrote:
                        > Yeah. Running from an xterm in my already-running X, I can cut-n-paste:

                        Can you try with another user (for example root or another one).

                        Alex.
                      • ken
                        ... Sure. Here s another user I created just for the occasion. Though it still fails, the output is a little different: $ startx -- :1 xauth: timeout in
                        Message 11 of 13 , Apr 6, 2005
                        • 0 Attachment
                          Alexandre Tessier wrote:

                          >ken wrote:
                          >
                          >
                          >>Yeah. Running from an xterm in my already-running X, I can cut-n-paste:
                          >>
                          >>
                          >
                          >Can you try with another user (for example root or another one).
                          >
                          >Alex.
                          >
                          >
                          Sure. Here's another user I created just for the occasion. Though it
                          still fails, the output is a little different:



                          $ startx -- :1
                          xauth: timeout in locking authority file /root/.xauthcmOVC0
                          xauth: timeout in locking authority file /root/.xauthcmOVC0
                          xauth: timeout in locking authority file /root/.xauthcmOVC0
                          xauth: timeout in locking authority file /root/.xauthcmOVC0


                          Fatal server error:
                          PAM authentication failed, cannot start X server.
                          Perhaps you do not have console ownership?


                          If you encounter a server crash, please report the problem by filing a bug
                          report in the XFree86.org bugzilla at http://bugs.xfree86.org and/or Red Hat
                          bugzilla at http://bugzilla.redhat.com/bugzilla. When filing your
                          report, it
                          is very important that you explain your problem in as much detail as
                          possible,
                          and include a complete description on how to reproduce the problem. After
                          submitting the bug report, attach the following files as uncompressed
                          individual file attachments using the bugzilla file attachment feature:
                          - Kernel log file: /var/log/messages


                          giving up.
                          xinit: No such file or directory (errno 2): unable to connect to X server
                          xinit: No such process (errno 3): Server error.
                          xauth: timeout in locking authority file /root/.xauthcmOVC0
                          Couldnt get a file descriptor referring to the console



                          --
                          A lot of us are working harder than we want, at things we don't like to
                          do. Why? ...In order to afford the sort of existence we don't care to live.
                          -- Bradford Angier
                        • Douglas S. Oliver
                          Good point. When I was studying with RH for my RHCE, I think the exercise had the student su to a diffrent account before starting a new concurrent X session.
                          Message 12 of 13 , Apr 7, 2005
                          • 0 Attachment
                            Good point. When I was studying with RH for my RHCE, I think the exercise had the student su to a diffrent account before starting a new concurrent X session. I paid for but didn't take my RHCE exam. I haven't thought about this stuff in a couple of years. -- douglas

                            -----Original Message-----
                            From: Alexandre Tessier <Alexandre.Tessier@...-orleans.fr>
                            Sent: Apr 6, 2005 12:48 PM
                            To: linux-dell-laptops@yahoogroups.com
                            Subject: Re: [linux-dell-laptops] how can i shift redhat linux 9 from text mode to graphical mode?


                            ken wrote:
                            > Yeah. Running from an xterm in my already-running X, I can cut-n-paste:

                            Can you try with another user (for example root or another one).

                            Alex.


                            --------------------------------------------------------------
                            Please post your X config files in the group links or database
                            To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                            FAQ: http://www.whacked.net/ldl/faq
                            Yahoo! Groups Links
                          Your message has been successfully submitted and would be delivered to recipients shortly.