Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] Re: unable to get ipw2100 up

Expand Messages
  • user user
    I may be wrong, but shouldn t your wireless card be detected as ath0 instead of eth1? Somewhere in your /etc directory there will be a file where you can
    Message 1 of 15 , Apr 2, 2005
    • 0 Attachment
      I may be wrong, but shouldn't your wireless card be detected as
      "ath0" instead of eth1? Somewhere in your /etc directory there will
      be a file where you can add the settings for you Wireless network
      card. For me they are in "/etc/network/interfaces". You should have
      a file that may be named interfaces or may named something else.
      Regardless the contents of the file looks like this:

      Tardis:/etc/network # cat interfaces

      # This file describes the network interfaces available on your system
      # and how to activate them. For more information, see interfaces(5).

      # The loopback network interface
      auto lo
      iface lo inet loopback

      # The Ethernet Adapter
      iface eth0 inet dhcp
      name Ethernet LAN card

      # The Wireless Adapter
      iface ath0 inet dhcp
      name Wireless LAN card
      wireless_essid Cloud
      wireless key "dont you wish"

      auto eth0

      auto ath0

      Add you wireless card info to this file and don't forget the "auto
      ath0" as I think this will automatically initialize DHCP.





      --- Alwin Gupta <alwingupta@...> wrote:

      >
      > Thanks for the info..
      >
      > I have now 1.1.0 installed but still not able to use the wireless
      > card. I am able to associate with the access point but cant ping
      > it.
      >
      > I am pasting the output of the iwconfig:
      >
      > [root@inspiron root]# iwconfig eth1
      > eth1 IEEE 802.11b ESSID:"123" Nickname:"ipw2100"
      > Mode:Managed Frequency:2.412 GHz Access Point:
      > 00:60:B3:19:8E:1E
      > Bit Rate=1 Mb/s Tx-Power:off
      > Retry:on RTS thr:off Fragment thr:off
      > Encryption key:off
      > Power Management:off
      > Link Quality=14/100 Signal level=-78 dBm
      > Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
      > Tx excessive retries:8 Invalid misc:0 Missed beacon:0
      >
      >
      > the Tx-power is off here. If i try to set the txpower I get the
      > following message:
      >
      > [root@inspiron root]# iwconfig eth1 txpower on
      > Error for wireless request "Set Tx Power" (8B26) :
      > SET failed on device eth1 ; Invalid argument.
      >
      > Please help what else I should try...
      >
      > Also, my card is "Intel pro/wireless 2100 3A mini PCI adapter" is
      > 3A
      > supported? or this is the problem because of which I am not able to
      > use wifi.
      >
      > any help would be greatly appreciated.
      >
      > Thanks,
      > Alwin
      >
      >
      > --- In linux-dell-laptops@yahoogroups.com, <theuteck@g...> wrote:
      > > They are up to driver version 1.1.0, perhaps trying that?
      > > http://ipw2100.sourceforge.net/
      > >
      > >
      > > On Wed, 30 Mar 2005 17:33:07 -0000, Alwin Gupta <alwin@c...>
      > wrote:
      > > >
      > > >
      > > > Hi,
      > > >
      > > > I have a Dell inpiron 510m laptop running Fedora Core 2 with
      > 2.6.8
      > > > kernel and really trying hard to setup the wireless card, done
      > a lot
      > > > of things starting from compiling kernel with wireless support,
      > > > installing firmware etc.
      > > >
      > > > I have built the wireless 2100 driver in kernel source and
      > could see
      > > > the wireless indicator turn green on doing 'modporbe ipw2100'
      > but when
      > > > I try to bring up the interface it gives the following error:
      > > >
      > > > [root@inspiron ipw2100]# ifup eth1
      > > > Error for wireless request "Set Frequency" (8B04) :
      > > > SET failed on device eth1 ; Operation not supported.
      > > >
      > > >
      > > > Does ne body have ne idea how to resolve this issue. Thanks in
      > advance
      > > > for all the help.
      > > >
      > > > -Alwin.
      > > >
      > > > PS: I am using ipw2100 (ver 1.0.2) with firmware (v1.3).
      > > >
      > > >
      > > >
      > > >
      > > >
      > > > --------------------------------------------------------------
      > > > Please post your X config files in the group links or database
      > > > To unsubscribe, email:
      > linux-dell-laptops-unsubscribe@yahoogroups.com
      > > > FAQ: http://www.whacked.net/ldl/faq
      > > > Yahoo! Groups Links
      > > >
      > > >
      > > >
      > > >
      > > >
      > > >
      > > >
      > > >
      > >
      > > --
      > > no .sig found
      > > Please restart your browser.
      >
      >
      >
      >




      __________________________________
      Do you Yahoo!?
      Yahoo! Mail - Find what you need with new enhanced search.
      http://info.mail.yahoo.com/mail_250
    • pdast1
      Hi, no the ath name comes from the atheros chipset used in some a/b/g chipsets. The driver that uses that naming convention is the madwifi driver by Sam
      Message 2 of 15 , Apr 2, 2005
      • 0 Attachment
        Hi,
        no the "ath" name comes from the atheros chipset used in some a/b/g
        chipsets. The driver that uses that naming convention is the madwifi
        driver by Sam Leffler.

        Cheers,
        P

        --- In linux-dell-laptops@yahoogroups.com, user user <flows_2000@y...>
        wrote:
        > I may be wrong, but shouldn't your wireless card be detected as
        > "ath0" instead of eth1? Somewhere in your /etc directory there will
        > be a file where you can add the settings for you Wireless network
        > card. For me they are in "/etc/network/interfaces". You should have
        > a file that may be named interfaces or may named something else.
        > Regardless the contents of the file looks like this:
        >
        > Tardis:/etc/network # cat interfaces
        >
        > # This file describes the network interfaces available on your system
        > # and how to activate them. For more information, see interfaces(5).
        >
        > # The loopback network interface
        > auto lo
        > iface lo inet loopback
        >
        > # The Ethernet Adapter
        > iface eth0 inet dhcp
        > name Ethernet LAN card
        >
        > # The Wireless Adapter
        > iface ath0 inet dhcp
        > name Wireless LAN card
        > wireless_essid Cloud
        > wireless key "dont you wish"
        >
        > auto eth0
        >
        > auto ath0
        >
        > Add you wireless card info to this file and don't forget the "auto
        > ath0" as I think this will automatically initialize DHCP.
        >
        >
        >
        >
        >
        > --- Alwin Gupta <alwingupta@y...> wrote:
        >
        > >
        > > Thanks for the info..
        > >
        > > I have now 1.1.0 installed but still not able to use the wireless
        > > card. I am able to associate with the access point but cant ping
        > > it.
        > >
        > > I am pasting the output of the iwconfig:
        > >
        > > [root@inspiron root]# iwconfig eth1
        > > eth1 IEEE 802.11b ESSID:"123" Nickname:"ipw2100"
        > > Mode:Managed Frequency:2.412 GHz Access Point:
        > > 00:60:B3:19:8E:1E
        > > Bit Rate=1 Mb/s Tx-Power:off
        > > Retry:on RTS thr:off Fragment thr:off
        > > Encryption key:off
        > > Power Management:off
        > > Link Quality=14/100 Signal level=-78 dBm
        > > Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
        > > Tx excessive retries:8 Invalid misc:0 Missed beacon:0
        > >
        > >
        > > the Tx-power is off here. If i try to set the txpower I get the
        > > following message:
        > >
        > > [root@inspiron root]# iwconfig eth1 txpower on
        > > Error for wireless request "Set Tx Power" (8B26) :
        > > SET failed on device eth1 ; Invalid argument.
        > >
        > > Please help what else I should try...
        > >
        > > Also, my card is "Intel pro/wireless 2100 3A mini PCI adapter" is
        > > 3A
        > > supported? or this is the problem because of which I am not able to
        > > use wifi.
        > >
        > > any help would be greatly appreciated.
        > >
        > > Thanks,
        > > Alwin
        > >
        > >
        > > --- In linux-dell-laptops@yahoogroups.com, <theuteck@g...> wrote:
        > > > They are up to driver version 1.1.0, perhaps trying that?
        > > > http://ipw2100.sourceforge.net/
        > > >
        > > >
        > > > On Wed, 30 Mar 2005 17:33:07 -0000, Alwin Gupta <alwin@c...>
        > > wrote:
        > > > >
        > > > >
        > > > > Hi,
        > > > >
        > > > > I have a Dell inpiron 510m laptop running Fedora Core 2 with
        > > 2.6.8
        > > > > kernel and really trying hard to setup the wireless card, done
        > > a lot
        > > > > of things starting from compiling kernel with wireless support,
        > > > > installing firmware etc.
        > > > >
        > > > > I have built the wireless 2100 driver in kernel source and
        > > could see
        > > > > the wireless indicator turn green on doing 'modporbe ipw2100'
        > > but when
        > > > > I try to bring up the interface it gives the following error:
        > > > >
        > > > > [root@inspiron ipw2100]# ifup eth1
        > > > > Error for wireless request "Set Frequency" (8B04) :
        > > > > SET failed on device eth1 ; Operation not supported.
        > > > >
        > > > >
        > > > > Does ne body have ne idea how to resolve this issue. Thanks in
        > > advance
        > > > > for all the help.
        > > > >
        > > > > -Alwin.
        > > > >
        > > > > PS: I am using ipw2100 (ver 1.0.2) with firmware (v1.3).
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > > --------------------------------------------------------------
        > > > > Please post your X config files in the group links or database
        > > > > To unsubscribe, email:
        > > linux-dell-laptops-unsubscribe@yahoogroups.com
        > > > > FAQ: http://www.whacked.net/ldl/faq
        > > > > Yahoo! Groups Links
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > >
        > > > --
        > > > no .sig found
        > > > Please restart your browser.
        > >
        > >
        > >
        > >
        >
        >
        >
        >
        > __________________________________
        > Do you Yahoo!?
        > Yahoo! Mail - Find what you need with new enhanced search.
        > http://info.mail.yahoo.com/mail_250
      • pdast1
        Hi Alwin, don t know if this will help, but I have the 2200 driver and once had a strange problem that I ve had trouble reproducing. My problematic set up is
        Message 3 of 15 , Apr 2, 2005
        • 0 Attachment
          Hi Alwin,
          don't know if this will help, but I have the 2200 driver and once had
          a strange problem that I've had trouble reproducing. My problematic
          set up is an internal 2200 trying to associate with a linksys wap54g,
          no broadcast ssid. On client I forced the ssid in config, and have no
          wpa or wep, using a static IP. Every once in a while, I have problems
          where it associates with the AP, but I can't seem to ping anything.
          What I've noticed though, is that the machine being pinged receives
          the echo requests and responds, but the wireless card ignores them.
          If I let it ping for 5+mins I'll start seeing some replys, but mostly
          they're "dup"'s. I've discovered that when in that state, if I force
          the mode from "auto" to Ad-Hoc, then back to auto, it will correct
          itself and all is well.

          Cheers,
          P

          --- In linux-dell-laptops@yahoogroups.com, "Alwin Gupta"
          <alwingupta@y...> wrote:
          >
          > Thanks for the info..
          >
          > I have now 1.1.0 installed but still not able to use the wireless
          > card. I am able to associate with the access point but cant ping it.
          >
          > I am pasting the output of the iwconfig:
          >
          > [root@inspiron root]# iwconfig eth1
          > eth1 IEEE 802.11b ESSID:"123" Nickname:"ipw2100"
          > Mode:Managed Frequency:2.412 GHz Access Point:
          > 00:60:B3:19:8E:1E
          > Bit Rate=1 Mb/s Tx-Power:off
          > Retry:on RTS thr:off Fragment thr:off
          > Encryption key:off
          > Power Management:off
          > Link Quality=14/100 Signal level=-78 dBm
          > Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          > Tx excessive retries:8 Invalid misc:0 Missed beacon:0
          >
          >
          > the Tx-power is off here. If i try to set the txpower I get the
          > following message:
          >
          > [root@inspiron root]# iwconfig eth1 txpower on
          > Error for wireless request "Set Tx Power" (8B26) :
          > SET failed on device eth1 ; Invalid argument.
          >
          > Please help what else I should try...
          >
          > Also, my card is "Intel pro/wireless 2100 3A mini PCI adapter" is 3A
          > supported? or this is the problem because of which I am not able to
          > use wifi.
          >
          > any help would be greatly appreciated.
          >
          > Thanks,
          > Alwin
          >
          >
          > --- In linux-dell-laptops@yahoogroups.com, <theuteck@g...> wrote:
          > > They are up to driver version 1.1.0, perhaps trying that?
          > > http://ipw2100.sourceforge.net/
          > >
          > >
          > > On Wed, 30 Mar 2005 17:33:07 -0000, Alwin Gupta <alwin@c...> wrote:
          > > >
          > > >
          > > > Hi,
          > > >
          > > > I have a Dell inpiron 510m laptop running Fedora Core 2 with 2.6.8
          > > > kernel and really trying hard to setup the wireless card, done a lot
          > > > of things starting from compiling kernel with wireless support,
          > > > installing firmware etc.
          > > >
          > > > I have built the wireless 2100 driver in kernel source and could see
          > > > the wireless indicator turn green on doing 'modporbe ipw2100'
          but when
          > > > I try to bring up the interface it gives the following error:
          > > >
          > > > [root@inspiron ipw2100]# ifup eth1
          > > > Error for wireless request "Set Frequency" (8B04) :
          > > > SET failed on device eth1 ; Operation not supported.
          > > >
          > > >
          > > > Does ne body have ne idea how to resolve this issue. Thanks in
          advance
          > > > for all the help.
          > > >
          > > > -Alwin.
          > > >
          > > > PS: I am using ipw2100 (ver 1.0.2) with firmware (v1.3).
          > > >
          > > >
          > > >
          > > >
          > > >
          > > > --------------------------------------------------------------
          > > > Please post your X config files in the group links or database
          > > > To unsubscribe, email:
          linux-dell-laptops-unsubscribe@yahoogroups.com
          > > > FAQ: http://www.whacked.net/ldl/faq
          > > > Yahoo! Groups Links
          > > >
          > > >
          > > >
          > > >
          > > >
          > > >
          > > >
          > > >
          > >
          > > --
          > > no .sig found
          > > Please restart your browser.
        • Alwin Gupta
          Hi P, Thanks for your reply. I tried what you said but it didn t worked out for me. I have checked Intel site they say they do not plan to support 2100A on
          Message 4 of 15 , Apr 3, 2005
          • 0 Attachment
            Hi P,

            Thanks for your reply. I tried what you said but it
            didn't worked out for me.

            I have checked Intel site they say they do not plan to
            support 2100A on linux. Now, I am throughly confused
            whether my card is 2100A??

            BTW, whats the difference between "2100A" and "2100
            3A"?

            On windows it shows "Intel Wireless PRO 2100 3A mini
            PCI". After installing ipw2100 linux identifies it as
            "2100 3B". I suspect if this is the issue which is
            causing the problem.

            Once again thanks for the help!

            -Alwin

            --- pdast1 <parmor@...> wrote:

            >
            > Hi Alwin,
            > don't know if this will help, but I have the 2200
            > driver and once had
            > a strange problem that I've had trouble reproducing.
            > My problematic
            > set up is an internal 2200 trying to associate with
            > a linksys wap54g,
            > no broadcast ssid. On client I forced the ssid in
            > config, and have no
            > wpa or wep, using a static IP. Every once in a
            > while, I have problems
            > where it associates with the AP, but I can't seem to
            > ping anything.
            > What I've noticed though, is that the machine being
            > pinged receives
            > the echo requests and responds, but the wireless
            > card ignores them.
            > If I let it ping for 5+mins I'll start seeing some
            > replys, but mostly
            > they're "dup"'s. I've discovered that when in that
            > state, if I force
            > the mode from "auto" to Ad-Hoc, then back to auto,
            > it will correct
            > itself and all is well.
            >
            > Cheers,
            > P
            >
            > --- In linux-dell-laptops@yahoogroups.com, "Alwin
            > Gupta"
            > <alwingupta@y...> wrote:
            > >
            > > Thanks for the info..
            > >
            > > I have now 1.1.0 installed but still not able to
            > use the wireless
            > > card. I am able to associate with the access point
            > but cant ping it.
            > >
            > > I am pasting the output of the iwconfig:
            > >
            > > [root@inspiron root]# iwconfig eth1
            > > eth1 IEEE 802.11b ESSID:"123"
            > Nickname:"ipw2100"
            > > Mode:Managed Frequency:2.412 GHz
            > Access Point:
            > > 00:60:B3:19:8E:1E
            > > Bit Rate=1 Mb/s Tx-Power:off
            > > Retry:on RTS thr:off Fragment
            > thr:off
            > > Encryption key:off
            > > Power Management:off
            > > Link Quality=14/100 Signal level=-78
            > dBm
            > > Rx invalid nwid:0 Rx invalid crypt:0
            > Rx invalid frag:0
            > > Tx excessive retries:8 Invalid misc:0
            > Missed beacon:0
            > >
            > >
            > > the Tx-power is off here. If i try to set the
            > txpower I get the
            > > following message:
            > >
            > > [root@inspiron root]# iwconfig eth1 txpower on
            > > Error for wireless request "Set Tx Power" (8B26) :
            > > SET failed on device eth1 ; Invalid argument.
            > >
            > > Please help what else I should try...
            > >
            > > Also, my card is "Intel pro/wireless 2100 3A mini
            > PCI adapter" is 3A
            > > supported? or this is the problem because of which
            > I am not able to
            > > use wifi.
            > >
            > > any help would be greatly appreciated.
            > >
            > > Thanks,
            > > Alwin
            > >
            > >
            > > --- In linux-dell-laptops@yahoogroups.com,
            > <theuteck@g...> wrote:
            > > > They are up to driver version 1.1.0, perhaps
            > trying that?
            > > > http://ipw2100.sourceforge.net/
            > > >
            > > >
            > > > On Wed, 30 Mar 2005 17:33:07 -0000, Alwin Gupta
            > <alwin@c...> wrote:
            > > > >
            > > > >
            > > > > Hi,
            > > > >
            > > > > I have a Dell inpiron 510m laptop running
            > Fedora Core 2 with 2.6.8
            > > > > kernel and really trying hard to setup the
            > wireless card, done a lot
            > > > > of things starting from compiling kernel with
            > wireless support,
            > > > > installing firmware etc.
            > > > >
            > > > > I have built the wireless 2100 driver in
            > kernel source and could see
            > > > > the wireless indicator turn green on doing
            > 'modporbe ipw2100'
            > but when
            > > > > I try to bring up the interface it gives the
            > following error:
            > > > >
            > > > > [root@inspiron ipw2100]# ifup eth1
            > > > > Error for wireless request "Set Frequency"
            > (8B04) :
            > > > > SET failed on device eth1 ; Operation not
            > supported.
            > > > >
            > > > >
            > > > > Does ne body have ne idea how to resolve this
            > issue. Thanks in
            > advance
            > > > > for all the help.
            > > > >
            > > > > -Alwin.
            > > > >
            > > > > PS: I am using ipw2100 (ver 1.0.2) with
            > firmware (v1.3).
            > > > >
            > > > >
            > > > >
            > > > >
            > > > >
            > > > >
            >
            --------------------------------------------------------------
            > > > > Please post your X config files in the group
            > links or database
            > > > > To unsubscribe, email:
            > linux-dell-laptops-unsubscribe@yahoogroups.com
            > > > > FAQ: http://www.whacked.net/ldl/faq
            > > > > Yahoo! Groups Links
            > > > >
            > > > >
            > > > >
            > > > >
            > > > >
            > > > >
            > > > >
            > > > >
            > > >
            > > > --
            > > > no .sig found
            > > > Please restart your browser.
            >
            >
            >
            >



            __________________________________
            Yahoo! Messenger
            Show us what our next emoticon should look like. Join the fun.
            http://www.advision.webevents.yahoo.com/emoticontest
          • theuteck@gmail.com
            I saw a post that said this model laptop and nic have an IRQ conflict. (http://ubuntuforums.org/archive/index.php/t-2586.html) He fixed by adding;
            Message 5 of 15 , Apr 3, 2005
            • 0 Attachment
              I saw a post that said this model laptop and nic have an IRQ conflict.
              (http://ubuntuforums.org/archive/index.php/t-2586.html)
              He fixed by adding; acpi_irq_isa=7 to the /boot/grub/menu.list kernel
              boot lines.
              So this line; kernel /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro
              would like; kernel /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4
              ro acpi_irq_isa=7


              On Sun, 3 Apr 2005 00:54:29 -0800 (PST), Alwin Gupta
              <alwingupta@...> wrote:
              >
              > Hi P,
              >
              > Thanks for your reply. I tried what you said but it
              > didn't worked out for me.
              >
              > I have checked Intel site they say they do not plan to
              > support 2100A on linux. Now, I am throughly confused
              > whether my card is 2100A??
              >
              > BTW, whats the difference between "2100A" and "2100
              > 3A"?
              >
              > On windows it shows "Intel Wireless PRO 2100 3A mini
              > PCI". After installing ipw2100 linux identifies it as
              > "2100 3B". I suspect if this is the issue which is
              > causing the problem.
              >
              > Once again thanks for the help!
              >
              > -Alwin
              >
              > --- pdast1 <parmor@...> wrote:
              >
              > >
              > > Hi Alwin,
              > > don't know if this will help, but I have the 2200
              > > driver and once had
              > > a strange problem that I've had trouble reproducing.
              > > My problematic
              > > set up is an internal 2200 trying to associate with
              > > a linksys wap54g,
              > > no broadcast ssid. On client I forced the ssid in
              > > config, and have no
              > > wpa or wep, using a static IP. Every once in a
              > > while, I have problems
              > > where it associates with the AP, but I can't seem to
              > > ping anything.
              > > What I've noticed though, is that the machine being
              > > pinged receives
              > > the echo requests and responds, but the wireless
              > > card ignores them.
              > > If I let it ping for 5+mins I'll start seeing some
              > > replys, but mostly
              > > they're "dup"'s. I've discovered that when in that
              > > state, if I force
              > > the mode from "auto" to Ad-Hoc, then back to auto,
              > > it will correct
              > > itself and all is well.
              > >
              > > Cheers,
              > > P
              > >
              > > --- In linux-dell-laptops@yahoogroups.com, "Alwin
              > > Gupta"
              > > <alwingupta@y...> wrote:
              > > >
              > > > Thanks for the info..
              > > >
              > > > I have now 1.1.0 installed but still not able to
              > > use the wireless
              > > > card. I am able to associate with the access point
              > > but cant ping it.
              > > >
              > > > I am pasting the output of the iwconfig:
              > > >
              > > > [root@inspiron root]# iwconfig eth1
              > > > eth1 IEEE 802.11b ESSID:"123"
              > > Nickname:"ipw2100"
              > > > Mode:Managed Frequency:2.412 GHz
              > > Access Point:
              > > > 00:60:B3:19:8E:1E
              > > > Bit Rate=1 Mb/s Tx-Power:off
              > > > Retry:on RTS thr:off Fragment
              > > thr:off
              > > > Encryption key:off
              > > > Power Management:off
              > > > Link Quality=14/100 Signal level=-78
              > > dBm
              > > > Rx invalid nwid:0 Rx invalid crypt:0
              > > Rx invalid frag:0
              > > > Tx excessive retries:8 Invalid misc:0
              > > Missed beacon:0
              > > >
              > > >
              > > > the Tx-power is off here. If i try to set the
              > > txpower I get the
              > > > following message:
              > > >
              > > > [root@inspiron root]# iwconfig eth1 txpower on
              > > > Error for wireless request "Set Tx Power" (8B26) :
              > > > SET failed on device eth1 ; Invalid argument.
              > > >
              > > > Please help what else I should try...
              > > >
              > > > Also, my card is "Intel pro/wireless 2100 3A mini
              > > PCI adapter" is 3A
              > > > supported? or this is the problem because of which
              > > I am not able to
              > > > use wifi.
              > > >
              > > > any help would be greatly appreciated.
              > > >
              > > > Thanks,
              > > > Alwin
              > > >
              > > >
              > > > --- In linux-dell-laptops@yahoogroups.com,
              > > <theuteck@g...> wrote:
              > > > > They are up to driver version 1.1.0, perhaps
              > > trying that?
              > > > > http://ipw2100.sourceforge.net/
              > > > >
              > > > >
              > > > > On Wed, 30 Mar 2005 17:33:07 -0000, Alwin Gupta
              > > <alwin@c...> wrote:
              > > > > >
              > > > > >
              > > > > > Hi,
              > > > > >
              > > > > > I have a Dell inpiron 510m laptop running
              > > Fedora Core 2 with 2.6.8
              > > > > > kernel and really trying hard to setup the
              > > wireless card, done a lot
              > > > > > of things starting from compiling kernel with
              > > wireless support,
              > > > > > installing firmware etc.
              > > > > >
              > > > > > I have built the wireless 2100 driver in
              > > kernel source and could see
              > > > > > the wireless indicator turn green on doing
              > > 'modporbe ipw2100'
              > > but when
              > > > > > I try to bring up the interface it gives the
              > > following error:
              > > > > >
              > > > > > [root@inspiron ipw2100]# ifup eth1
              > > > > > Error for wireless request "Set Frequency"
              > > (8B04) :
              > > > > > SET failed on device eth1 ; Operation not
              > > supported.
              > > > > >
              > > > > >
              > > > > > Does ne body have ne idea how to resolve this
              > > issue. Thanks in
              > > advance
              > > > > > for all the help.
              > > > > >
              > > > > > -Alwin.
              > > > > >
              > > > > > PS: I am using ipw2100 (ver 1.0.2) with
              > > firmware (v1.3).
              > > > > >
              > > > > >
              > > > > >
              > > > > >
              > > > > >
              > > > > >
              > >
              > --------------------------------------------------------------
              > > > > > Please post your X config files in the group
              > > links or database
              > > > > > To unsubscribe, email:
              > > linux-dell-laptops-unsubscribe@yahoogroups.com
              > > > > > FAQ: http://www.whacked.net/ldl/faq
              > > > > > Yahoo! Groups Links
              > > > > >
              > > > > >
              > > > > >
              > > > > >
              > > > > >
              > > > > >
              > > > > >
              > > > > >
              > > > >
              > > > > --
              > > > > no .sig found
              > > > > Please restart your browser.
              > >
              > >
              > >
              > >
              >
              >
              >
              > __________________________________
              > Yahoo! Messenger
              > Show us what our next emoticon should look like. Join the fun.
              > http://www.advision.webevents.yahoo.com/emoticontest
              >
              >
              > --------------------------------------------------------------
              > Please post your X config files in the group links or database
              > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
              > FAQ: http://www.whacked.net/ldl/faq
              > Yahoo! Groups Links
              >
              >
              >
              >
              >
              >
              >
              >

              --
              no .sig found
              Please restart your browser.
            • Alwin Gupta
              Thanks for the info. I ll try this tonight and let you know. -Alwin ... (http://ubuntuforums.org/archive/index.php/t-2586.html) ... === message truncated ===
              Message 6 of 15 , Apr 3, 2005
              • 0 Attachment
                Thanks for the info. I'll try this tonight and let you
                know.

                -Alwin


                --- theuteck@... wrote:

                > I saw a post that said this model laptop and nic
                > have an IRQ conflict.
                >
                >
                (http://ubuntuforums.org/archive/index.php/t-2586.html)
                > He fixed by adding; acpi_irq_isa=7 to the
                > /boot/grub/menu.list kernel
                > boot lines.
                > So this line; kernel
                > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro
                > would like; kernel
                > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4
                > ro acpi_irq_isa=7
                >
                >
                > On Sun, 3 Apr 2005 00:54:29 -0800 (PST), Alwin Gupta
                > <alwingupta@...> wrote:
                > >
                > > Hi P,
                > >
                > > Thanks for your reply. I tried what you said but
                > it
                > > didn't worked out for me.
                > >
                > > I have checked Intel site they say they do not
                > plan to
                > > support 2100A on linux. Now, I am throughly
                > confused
                > > whether my card is 2100A??
                > >
                > > BTW, whats the difference between "2100A" and
                > "2100
                > > 3A"?
                > >
                > > On windows it shows "Intel Wireless PRO 2100 3A
                > mini
                > > PCI". After installing ipw2100 linux identifies it
                > as
                > > "2100 3B". I suspect if this is the issue which is
                > > causing the problem.
                > >
                > > Once again thanks for the help!
                > >
                > > -Alwin
                > >
                > > --- pdast1 <parmor@...> wrote:
                > >
                > > >
                > > > Hi Alwin,
                > > > don't know if this will help, but I have the
                > 2200
                > > > driver and once had
                > > > a strange problem that I've had trouble
                > reproducing.
                > > > My problematic
                > > > set up is an internal 2200 trying to associate
                > with
                > > > a linksys wap54g,
                > > > no broadcast ssid. On client I forced the ssid
                > in
                > > > config, and have no
                > > > wpa or wep, using a static IP. Every once in a
                > > > while, I have problems
                > > > where it associates with the AP, but I can't
                > seem to
                > > > ping anything.
                > > > What I've noticed though, is that the machine
                > being
                > > > pinged receives
                > > > the echo requests and responds, but the wireless
                > > > card ignores them.
                > > > If I let it ping for 5+mins I'll start seeing
                > some
                > > > replys, but mostly
                > > > they're "dup"'s. I've discovered that when in
                > that
                > > > state, if I force
                > > > the mode from "auto" to Ad-Hoc, then back to
                > auto,
                > > > it will correct
                > > > itself and all is well.
                > > >
                > > > Cheers,
                > > > P
                > > >
                > > > --- In linux-dell-laptops@yahoogroups.com,
                > "Alwin
                > > > Gupta"
                > > > <alwingupta@y...> wrote:
                > > > >
                > > > > Thanks for the info..
                > > > >
                > > > > I have now 1.1.0 installed but still not able
                > to
                > > > use the wireless
                > > > > card. I am able to associate with the access
                > point
                > > > but cant ping it.
                > > > >
                > > > > I am pasting the output of the iwconfig:
                > > > >
                > > > > [root@inspiron root]# iwconfig eth1
                > > > > eth1 IEEE 802.11b ESSID:"123"
                > > > Nickname:"ipw2100"
                > > > > Mode:Managed Frequency:2.412 GHz
                > > > Access Point:
                > > > > 00:60:B3:19:8E:1E
                > > > > Bit Rate=1 Mb/s Tx-Power:off
                > > > > Retry:on RTS thr:off Fragment
                > > > thr:off
                > > > > Encryption key:off
                > > > > Power Management:off
                > > > > Link Quality=14/100 Signal
                > level=-78
                > > > dBm
                > > > > Rx invalid nwid:0 Rx invalid
                > crypt:0
                > > > Rx invalid frag:0
                > > > > Tx excessive retries:8 Invalid
                > misc:0
                > > > Missed beacon:0
                > > > >
                > > > >
                > > > > the Tx-power is off here. If i try to set the
                > > > txpower I get the
                > > > > following message:
                > > > >
                > > > > [root@inspiron root]# iwconfig eth1 txpower on
                > > > > Error for wireless request "Set Tx Power"
                > (8B26) :
                > > > > SET failed on device eth1 ; Invalid
                > argument.
                > > > >
                > > > > Please help what else I should try...
                > > > >
                > > > > Also, my card is "Intel pro/wireless 2100 3A
                > mini
                > > > PCI adapter" is 3A
                > > > > supported? or this is the problem because of
                > which
                > > > I am not able to
                > > > > use wifi.
                > > > >
                > > > > any help would be greatly appreciated.
                > > > >
                > > > > Thanks,
                > > > > Alwin
                > > > >
                > > > >
                > > > > --- In linux-dell-laptops@yahoogroups.com,
                > > > <theuteck@g...> wrote:
                > > > > > They are up to driver version 1.1.0, perhaps
                > > > trying that?
                > > > > > http://ipw2100.sourceforge.net/
                > > > > >
                > > > > >
                > > > > > On Wed, 30 Mar 2005 17:33:07 -0000, Alwin
                > Gupta
                > > > <alwin@c...> wrote:
                > > > > > >
                > > > > > >
                > > > > > > Hi,
                > > > > > >
                > > > > > > I have a Dell inpiron 510m laptop running
                > > > Fedora Core 2 with 2.6.8
                > > > > > > kernel and really trying hard to setup the
                > > > wireless card, done a lot
                > > > > > > of things starting from compiling kernel
                > with
                > > > wireless support,
                > > > > > > installing firmware etc.
                > > > > > >
                > > > > > > I have built the wireless 2100 driver in
                > > > kernel source and could see
                > > > > > > the wireless indicator turn green on doing
                > > > 'modporbe ipw2100'
                > > > but when
                > > > > > > I try to bring up the interface it gives
                > the
                > > > following error:
                > > > > > >
                > > > > > > [root@inspiron ipw2100]# ifup eth1
                > > > > > > Error for wireless request "Set Frequency"
                > > > (8B04) :
                > > > > > > SET failed on device eth1 ; Operation
                > not
                > > > supported.
                > > > > > >
                > > > > > >
                > > > > > > Does ne body have ne idea how to resolve
                > this
                > > > issue. Thanks in
                > > > advance
                > > > > > > for all the help.
                > > > > > >
                > > > > > > -Alwin.
                > > > > > >
                > > > > > > PS: I am using ipw2100 (ver 1.0.2) with
                > > > firmware (v1.3).
                > > > > > >
                > > > > > >
                > > > > > >
                >
                === message truncated ===




                __________________________________
                Yahoo! Messenger
                Show us what our next emoticon should look like. Join the fun.
                http://www.advision.webevents.yahoo.com/emoticontest
              • theuteck@gmail.com
                Looks like gmail decided to do some word wrapping, that last one should be 1 line. On Sun, 3 Apr 2005 20:44:14 -0700 (PDT), Alwin Gupta ... -- no .sig found
                Message 7 of 15 , Apr 4, 2005
                • 0 Attachment
                  Looks like gmail decided to do some word wrapping, that last one
                  should be 1 line.


                  On Sun, 3 Apr 2005 20:44:14 -0700 (PDT), Alwin Gupta
                  <alwingupta@...> wrote:
                  >
                  > Thanks for the info. I'll try this tonight and let you
                  > know.
                  >
                  > -Alwin
                  >
                  >
                  > --- theuteck@... wrote:
                  >
                  > > I saw a post that said this model laptop and nic
                  > > have an IRQ conflict.
                  > >
                  > >
                  > (http://ubuntuforums.org/archive/index.php/t-2586.html)
                  > > He fixed by adding; acpi_irq_isa=7 to the
                  > > /boot/grub/menu.list kernel
                  > > boot lines.
                  > > So this line; kernel
                  > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro
                  > > would like; kernel
                  > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4
                  > > ro acpi_irq_isa=7
                  > >
                  > >
                  > > On Sun, 3 Apr 2005 00:54:29 -0800 (PST), Alwin Gupta
                  > > <alwingupta@...> wrote:
                  > > >
                  > > > Hi P,
                  > > >
                  > > > Thanks for your reply. I tried what you said but
                  > > it
                  > > > didn't worked out for me.
                  > > >
                  > > > I have checked Intel site they say they do not
                  > > plan to
                  > > > support 2100A on linux. Now, I am throughly
                  > > confused
                  > > > whether my card is 2100A??
                  > > >
                  > > > BTW, whats the difference between "2100A" and
                  > > "2100
                  > > > 3A"?
                  > > >
                  > > > On windows it shows "Intel Wireless PRO 2100 3A
                  > > mini
                  > > > PCI". After installing ipw2100 linux identifies it
                  > > as
                  > > > "2100 3B". I suspect if this is the issue which is
                  > > > causing the problem.
                  > > >
                  > > > Once again thanks for the help!
                  > > >
                  > > > -Alwin
                  > > >
                  > > > --- pdast1 <parmor@...> wrote:
                  > > >
                  > > > >
                  > > > > Hi Alwin,
                  > > > > don't know if this will help, but I have the
                  > > 2200
                  > > > > driver and once had
                  > > > > a strange problem that I've had trouble
                  > > reproducing.
                  > > > > My problematic
                  > > > > set up is an internal 2200 trying to associate
                  > > with
                  > > > > a linksys wap54g,
                  > > > > no broadcast ssid. On client I forced the ssid
                  > > in
                  > > > > config, and have no
                  > > > > wpa or wep, using a static IP. Every once in a
                  > > > > while, I have problems
                  > > > > where it associates with the AP, but I can't
                  > > seem to
                  > > > > ping anything.
                  > > > > What I've noticed though, is that the machine
                  > > being
                  > > > > pinged receives
                  > > > > the echo requests and responds, but the wireless
                  > > > > card ignores them.
                  > > > > If I let it ping for 5+mins I'll start seeing
                  > > some
                  > > > > replys, but mostly
                  > > > > they're "dup"'s. I've discovered that when in
                  > > that
                  > > > > state, if I force
                  > > > > the mode from "auto" to Ad-Hoc, then back to
                  > > auto,
                  > > > > it will correct
                  > > > > itself and all is well.
                  > > > >
                  > > > > Cheers,
                  > > > > P
                  > > > >
                  > > > > --- In linux-dell-laptops@yahoogroups.com,
                  > > "Alwin
                  > > > > Gupta"
                  > > > > <alwingupta@y...> wrote:
                  > > > > >
                  > > > > > Thanks for the info..
                  > > > > >
                  > > > > > I have now 1.1.0 installed but still not able
                  > > to
                  > > > > use the wireless
                  > > > > > card. I am able to associate with the access
                  > > point
                  > > > > but cant ping it.
                  > > > > >
                  > > > > > I am pasting the output of the iwconfig:
                  > > > > >
                  > > > > > [root@inspiron root]# iwconfig eth1
                  > > > > > eth1 IEEE 802.11b ESSID:"123"
                  > > > > Nickname:"ipw2100"
                  > > > > > Mode:Managed Frequency:2.412 GHz
                  > > > > Access Point:
                  > > > > > 00:60:B3:19:8E:1E
                  > > > > > Bit Rate=1 Mb/s Tx-Power:off
                  > > > > > Retry:on RTS thr:off Fragment
                  > > > > thr:off
                  > > > > > Encryption key:off
                  > > > > > Power Management:off
                  > > > > > Link Quality=14/100 Signal
                  > > level=-78
                  > > > > dBm
                  > > > > > Rx invalid nwid:0 Rx invalid
                  > > crypt:0
                  > > > > Rx invalid frag:0
                  > > > > > Tx excessive retries:8 Invalid
                  > > misc:0
                  > > > > Missed beacon:0
                  > > > > >
                  > > > > >
                  > > > > > the Tx-power is off here. If i try to set the
                  > > > > txpower I get the
                  > > > > > following message:
                  > > > > >
                  > > > > > [root@inspiron root]# iwconfig eth1 txpower on
                  > > > > > Error for wireless request "Set Tx Power"
                  > > (8B26) :
                  > > > > > SET failed on device eth1 ; Invalid
                  > > argument.
                  > > > > >
                  > > > > > Please help what else I should try...
                  > > > > >
                  > > > > > Also, my card is "Intel pro/wireless 2100 3A
                  > > mini
                  > > > > PCI adapter" is 3A
                  > > > > > supported? or this is the problem because of
                  > > which
                  > > > > I am not able to
                  > > > > > use wifi.
                  > > > > >
                  > > > > > any help would be greatly appreciated.
                  > > > > >
                  > > > > > Thanks,
                  > > > > > Alwin
                  > > > > >
                  > > > > >
                  > > > > > --- In linux-dell-laptops@yahoogroups.com,
                  > > > > <theuteck@g...> wrote:
                  > > > > > > They are up to driver version 1.1.0, perhaps
                  > > > > trying that?
                  > > > > > > http://ipw2100.sourceforge.net/
                  > > > > > >
                  > > > > > >
                  > > > > > > On Wed, 30 Mar 2005 17:33:07 -0000, Alwin
                  > > Gupta
                  > > > > <alwin@c...> wrote:
                  > > > > > > >
                  > > > > > > >
                  > > > > > > > Hi,
                  > > > > > > >
                  > > > > > > > I have a Dell inpiron 510m laptop running
                  > > > > Fedora Core 2 with 2.6.8
                  > > > > > > > kernel and really trying hard to setup the
                  > > > > wireless card, done a lot
                  > > > > > > > of things starting from compiling kernel
                  > > with
                  > > > > wireless support,
                  > > > > > > > installing firmware etc.
                  > > > > > > >
                  > > > > > > > I have built the wireless 2100 driver in
                  > > > > kernel source and could see
                  > > > > > > > the wireless indicator turn green on doing
                  > > > > 'modporbe ipw2100'
                  > > > > but when
                  > > > > > > > I try to bring up the interface it gives
                  > > the
                  > > > > following error:
                  > > > > > > >
                  > > > > > > > [root@inspiron ipw2100]# ifup eth1
                  > > > > > > > Error for wireless request "Set Frequency"
                  > > > > (8B04) :
                  > > > > > > > SET failed on device eth1 ; Operation
                  > > not
                  > > > > supported.
                  > > > > > > >
                  > > > > > > >
                  > > > > > > > Does ne body have ne idea how to resolve
                  > > this
                  > > > > issue. Thanks in
                  > > > > advance
                  > > > > > > > for all the help.
                  > > > > > > >
                  > > > > > > > -Alwin.
                  > > > > > > >
                  > > > > > > > PS: I am using ipw2100 (ver 1.0.2) with
                  > > > > firmware (v1.3).
                  > > > > > > >
                  > > > > > > >
                  > > > > > > >
                  > >
                  > === message truncated ===
                  >
                  >
                  >
                  >
                  > __________________________________
                  > Yahoo! Messenger
                  > Show us what our next emoticon should look like. Join the fun.
                  > http://www.advision.webevents.yahoo.com/emoticontest
                  >
                  >
                  > --------------------------------------------------------------
                  > Please post your X config files in the group links or database
                  > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                  > FAQ: http://www.whacked.net/ldl/faq
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >

                  --
                  no .sig found
                  Please restart your browser.
                • Marvin R. Pierce
                  I had the same problem and switched to ipw2200. Also, make sure you are using the correct eth-x to id the connection. I found that on my Dell9300, it was id as
                  Message 8 of 15 , Apr 4, 2005
                  • 0 Attachment
                    I had the same problem and switched to ipw2200.
                    Also, make sure you are using the correct eth-x to id the connection.
                    I found that on my Dell9300, it was id as eth2 and not wlan0.

                    -----Original Message-----
                    From: theuteck@... [mailto:theuteck@...]
                    Sent: Tuesday, 5 April 2005 7:27 AM
                    To: linux-dell-laptops@yahoogroups.com
                    Subject: [linux-dell-laptops] Re: unable to get ipw2100 up


                    Looks like gmail decided to do some word wrapping, that last one should be 1
                    line.


                    On Sun, 3 Apr 2005 20:44:14 -0700 (PDT), Alwin Gupta <alwingupta@...>
                    wrote:
                    >
                    > Thanks for the info. I'll try this tonight and let you know.
                    >
                    > -Alwin
                    >
                    >
                    > --- theuteck@... wrote:
                    >
                    > > I saw a post that said this model laptop and nic have an IRQ
                    > > conflict.
                    > >
                    > >
                    > (http://ubuntuforums.org/archive/index.php/t-2586.html)
                    > > He fixed by adding; acpi_irq_isa=7 to the /boot/grub/menu.list
                    > > kernel boot lines.
                    > > So this line; kernel
                    > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro
                    > > would like; kernel
                    > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro acpi_irq_isa=7
                    > >
                    > >
                    > > On Sun, 3 Apr 2005 00:54:29 -0800 (PST), Alwin Gupta
                    > > <alwingupta@...> wrote:
                    > > >
                    > > > Hi P,
                    > > >
                    > > > Thanks for your reply. I tried what you said but
                    > > it
                    > > > didn't worked out for me.
                    > > >
                    > > > I have checked Intel site they say they do not
                    > > plan to
                    > > > support 2100A on linux. Now, I am throughly
                    > > confused
                    > > > whether my card is 2100A??
                    > > >
                    > > > BTW, whats the difference between "2100A" and
                    > > "2100
                    > > > 3A"?
                    > > >
                    > > > On windows it shows "Intel Wireless PRO 2100 3A
                    > > mini
                    > > > PCI". After installing ipw2100 linux identifies it
                    > > as
                    > > > "2100 3B". I suspect if this is the issue which is causing the
                    > > > problem.
                    > > >
                    > > > Once again thanks for the help!
                    > > >
                    > > > -Alwin
                    > > >
                    > > > --- pdast1 <parmor@...> wrote:
                    > > >
                    > > > >
                    > > > > Hi Alwin,
                    > > > > don't know if this will help, but I have the
                    > > 2200
                    > > > > driver and once had
                    > > > > a strange problem that I've had trouble
                    > > reproducing.
                    > > > > My problematic
                    > > > > set up is an internal 2200 trying to associate
                    > > with
                    > > > > a linksys wap54g,
                    > > > > no broadcast ssid. On client I forced the ssid
                    > > in
                    > > > > config, and have no
                    > > > > wpa or wep, using a static IP. Every once in a while, I have
                    > > > > problems where it associates with the AP, but I can't
                    > > seem to
                    > > > > ping anything.
                    > > > > What I've noticed though, is that the machine
                    > > being
                    > > > > pinged receives
                    > > > > the echo requests and responds, but the wireless card ignores
                    > > > > them.
                    > > > > If I let it ping for 5+mins I'll start seeing
                    > > some
                    > > > > replys, but mostly
                    > > > > they're "dup"'s. I've discovered that when in
                    > > that
                    > > > > state, if I force
                    > > > > the mode from "auto" to Ad-Hoc, then back to
                    > > auto,
                    > > > > it will correct
                    > > > > itself and all is well.
                    > > > >
                    > > > > Cheers,
                    > > > > P
                    > > > >
                    > > > > --- In linux-dell-laptops@yahoogroups.com,
                    > > "Alwin
                    > > > > Gupta"
                    > > > > <alwingupta@y...> wrote:
                    > > > > >
                    > > > > > Thanks for the info..
                    > > > > >
                    > > > > > I have now 1.1.0 installed but still not able
                    > > to
                    > > > > use the wireless
                    > > > > > card. I am able to associate with the access
                    > > point
                    > > > > but cant ping it.
                    > > > > >
                    > > > > > I am pasting the output of the iwconfig:
                    > > > > >
                    > > > > > [root@inspiron root]# iwconfig eth1
                    > > > > > eth1 IEEE 802.11b ESSID:"123"
                    > > > > Nickname:"ipw2100"
                    > > > > > Mode:Managed Frequency:2.412 GHz
                    > > > > Access Point:
                    > > > > > 00:60:B3:19:8E:1E
                    > > > > > Bit Rate=1 Mb/s Tx-Power:off
                    > > > > > Retry:on RTS thr:off Fragment
                    > > > > thr:off
                    > > > > > Encryption key:off
                    > > > > > Power Management:off
                    > > > > > Link Quality=14/100 Signal
                    > > level=-78
                    > > > > dBm
                    > > > > > Rx invalid nwid:0 Rx invalid
                    > > crypt:0
                    > > > > Rx invalid frag:0
                    > > > > > Tx excessive retries:8 Invalid
                    > > misc:0
                    > > > > Missed beacon:0
                    > > > > >
                    > > > > >
                    > > > > > the Tx-power is off here. If i try to set the
                    > > > > txpower I get the
                    > > > > > following message:
                    > > > > >
                    > > > > > [root@inspiron root]# iwconfig eth1 txpower on Error for
                    > > > > > wireless request "Set Tx Power"
                    > > (8B26) :
                    > > > > > SET failed on device eth1 ; Invalid
                    > > argument.
                    > > > > >
                    > > > > > Please help what else I should try...
                    > > > > >
                    > > > > > Also, my card is "Intel pro/wireless 2100 3A
                    > > mini
                    > > > > PCI adapter" is 3A
                    > > > > > supported? or this is the problem because of
                    > > which
                    > > > > I am not able to
                    > > > > > use wifi.
                    > > > > >
                    > > > > > any help would be greatly appreciated.
                    > > > > >
                    > > > > > Thanks,
                    > > > > > Alwin
                    > > > > >
                    > > > > >
                    > > > > > --- In linux-dell-laptops@yahoogroups.com,
                    > > > > <theuteck@g...> wrote:
                    > > > > > > They are up to driver version 1.1.0, perhaps
                    > > > > trying that?
                    > > > > > > http://ipw2100.sourceforge.net/
                    > > > > > >
                    > > > > > >
                    > > > > > > On Wed, 30 Mar 2005 17:33:07 -0000, Alwin
                    > > Gupta
                    > > > > <alwin@c...> wrote:
                    > > > > > > >
                    > > > > > > >
                    > > > > > > > Hi,
                    > > > > > > >
                    > > > > > > > I have a Dell inpiron 510m laptop running
                    > > > > Fedora Core 2 with 2.6.8
                    > > > > > > > kernel and really trying hard to setup the
                    > > > > wireless card, done a lot
                    > > > > > > > of things starting from compiling kernel
                    > > with
                    > > > > wireless support,
                    > > > > > > > installing firmware etc.
                    > > > > > > >
                    > > > > > > > I have built the wireless 2100 driver in
                    > > > > kernel source and could see
                    > > > > > > > the wireless indicator turn green on doing
                    > > > > 'modporbe ipw2100'
                    > > > > but when
                    > > > > > > > I try to bring up the interface it gives
                    > > the
                    > > > > following error:
                    > > > > > > >
                    > > > > > > > [root@inspiron ipw2100]# ifup eth1 Error for wireless
                    > > > > > > > request "Set Frequency"
                    > > > > (8B04) :
                    > > > > > > > SET failed on device eth1 ; Operation
                    > > not
                    > > > > supported.
                    > > > > > > >
                    > > > > > > >
                    > > > > > > > Does ne body have ne idea how to resolve
                    > > this
                    > > > > issue. Thanks in
                    > > > > advance
                    > > > > > > > for all the help.
                    > > > > > > >
                    > > > > > > > -Alwin.
                    > > > > > > >
                    > > > > > > > PS: I am using ipw2100 (ver 1.0.2) with
                    > > > > firmware (v1.3).
                    > > > > > > >
                    > > > > > > >
                    > > > > > > >
                    > >
                    > === message truncated ===
                    >
                    >
                    >
                    >
                    > __________________________________
                    > Yahoo! Messenger
                    > Show us what our next emoticon should look like. Join the fun.
                    > http://www.advision.webevents.yahoo.com/emoticontest
                    >
                    >
                    > --------------------------------------------------------------
                    > Please post your X config files in the group links or database To
                    > unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                    > FAQ: http://www.whacked.net/ldl/faq
                    > Yahoo! Groups Links
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    >

                    --
                    no .sig found
                    Please restart your browser.


                    --------------------------------------------------------------
                    Please post your X config files in the group links or database
                    To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                    FAQ: http://www.whacked.net/ldl/faq
                    Yahoo! Groups Links
                  • Alwin Gupta
                    It seems there is some problem with the wireless card itself, its not even working in Windows! In windows also the problem is same, it could detect and
                    Message 9 of 15 , Apr 5, 2005
                    • 0 Attachment
                      It seems there is some problem with the wireless card itself, its not even
                      working in Windows!

                      In windows also the problem is same, it could detect and associate itself with
                      the network but can't ping the gateway. Interestingly during the ping it
                      sometimes also says "hardware error" along with "Request timed out". I mailed
                      to Dell regarding this as my notebook is still under the Complete Cover and
                      other things Dell offer.

                      I dont know what the Dell technical support people are trying to do, they have
                      asked me to do all kind of wierd stuff from flashing my BIOS .. reinstallation
                      of the OS. Although, I have flashed the BIOS with the latest available on the
                      Dell site for my laptop model. But, it didn't helped, as I was expecting! I
                      rarely boot into WinXP and previously the same card used to work smoothly in
                      WinXP.

                      I am sure that this is related to some hardware problem. I'll ask Dell to
                      replace the wireless card. In linux I could see the output of the iwconfig, it
                      shows the 'tx-power off' which I cant turn on or set to some value, it seems
                      that the transmission circuit has gone.

                      -Alwin


                      --- "Marvin R. Pierce" <mpierce@...> wrote:

                      > I had the same problem and switched to ipw2200.
                      > Also, make sure you are using the correct eth-x to id the connection.
                      > I found that on my Dell9300, it was id as eth2 and not wlan0.
                      >
                      > -----Original Message-----
                      > From: theuteck@... [mailto:theuteck@...]
                      > Sent: Tuesday, 5 April 2005 7:27 AM
                      > To: linux-dell-laptops@yahoogroups.com
                      > Subject: [linux-dell-laptops] Re: unable to get ipw2100 up
                      >
                      >
                      > Looks like gmail decided to do some word wrapping, that last one should be 1
                      > line.
                      >
                      >
                      > On Sun, 3 Apr 2005 20:44:14 -0700 (PDT), Alwin Gupta <alwingupta@...>
                      > wrote:
                      > >
                      > > Thanks for the info. I'll try this tonight and let you know.
                      > >
                      > > -Alwin
                      > >
                      > >
                      > > --- theuteck@... wrote:
                      > >
                      > > > I saw a post that said this model laptop and nic have an IRQ
                      > > > conflict.
                      > > >
                      > > >
                      > > (http://ubuntuforums.org/archive/index.php/t-2586.html)
                      > > > He fixed by adding; acpi_irq_isa=7 to the /boot/grub/menu.list
                      > > > kernel boot lines.
                      > > > So this line; kernel
                      > > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro
                      > > > would like; kernel
                      > > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro acpi_irq_isa=7
                      > > >
                      > > >
                      > > > On Sun, 3 Apr 2005 00:54:29 -0800 (PST), Alwin Gupta
                      > > > <alwingupta@...> wrote:
                      > > > >
                      > > > > Hi P,
                      > > > >
                      > > > > Thanks for your reply. I tried what you said but
                      > > > it
                      > > > > didn't worked out for me.
                      > > > >
                      > > > > I have checked Intel site they say they do not
                      > > > plan to
                      > > > > support 2100A on linux. Now, I am throughly
                      > > > confused
                      > > > > whether my card is 2100A??
                      > > > >
                      > > > > BTW, whats the difference between "2100A" and
                      > > > "2100
                      > > > > 3A"?
                      > > > >
                      > > > > On windows it shows "Intel Wireless PRO 2100 3A
                      > > > mini
                      > > > > PCI". After installing ipw2100 linux identifies it
                      > > > as
                      > > > > "2100 3B". I suspect if this is the issue which is causing the
                      > > > > problem.
                      > > > >
                      > > > > Once again thanks for the help!
                      > > > >
                      > > > > -Alwin
                      > > > >
                      > > > > --- pdast1 <parmor@...> wrote:
                      > > > >
                      > > > > >
                      > > > > > Hi Alwin,
                      > > > > > don't know if this will help, but I have the
                      > > > 2200
                      > > > > > driver and once had
                      > > > > > a strange problem that I've had trouble
                      > > > reproducing.
                      > > > > > My problematic
                      > > > > > set up is an internal 2200 trying to associate
                      > > > with
                      > > > > > a linksys wap54g,
                      > > > > > no broadcast ssid. On client I forced the ssid
                      > > > in
                      > > > > > config, and have no
                      > > > > > wpa or wep, using a static IP. Every once in a while, I have
                      > > > > > problems where it associates with the AP, but I can't
                      > > > seem to
                      > > > > > ping anything.
                      > > > > > What I've noticed though, is that the machine
                      > > > being
                      > > > > > pinged receives
                      > > > > > the echo requests and responds, but the wireless card ignores
                      > > > > > them.
                      > > > > > If I let it ping for 5+mins I'll start seeing
                      > > > some
                      > > > > > replys, but mostly
                      > > > > > they're "dup"'s. I've discovered that when in
                      > > > that
                      > > > > > state, if I force
                      > > > > > the mode from "auto" to Ad-Hoc, then back to
                      > > > auto,
                      > > > > > it will correct
                      > > > > > itself and all is well.
                      > > > > >
                      > > > > > Cheers,
                      > > > > > P
                      > > > > >
                      > > > > > --- In linux-dell-laptops@yahoogroups.com,
                      > > > "Alwin
                      > > > > > Gupta"
                      > > > > > <alwingupta@y...> wrote:
                      > > > > > >
                      > > > > > > Thanks for the info..
                      > > > > > >
                      > > > > > > I have now 1.1.0 installed but still not able
                      > > > to
                      > > > > > use the wireless
                      > > > > > > card. I am able to associate with the access
                      > > > point
                      > > > > > but cant ping it.
                      > > > > > >
                      > > > > > > I am pasting the output of the iwconfig:
                      > > > > > >
                      > > > > > > [root@inspiron root]# iwconfig eth1
                      > > > > > > eth1 IEEE 802.11b ESSID:"123"
                      > > > > > Nickname:"ipw2100"
                      > > > > > > Mode:Managed Frequency:2.412 GHz
                      > > > > > Access Point:
                      > > > > > > 00:60:B3:19:8E:1E
                      > > > > > > Bit Rate=1 Mb/s Tx-Power:off
                      > > > > > > Retry:on RTS thr:off Fragment
                      > > > > > thr:off
                      > > > > > > Encryption key:off
                      > > > > > > Power Management:off
                      > > > > > > Link Quality=14/100 Signal
                      > > > level=-78
                      > > > > > dBm
                      > > > > > > Rx invalid nwid:0 Rx invalid
                      > > > crypt:0
                      > > > > > Rx invalid frag:0
                      > > > > > > Tx excessive retries:8 Invalid
                      > > > misc:0
                      > > > > > Missed beacon:0
                      > > > > > >
                      > > > > > >
                      > > > > > > the Tx-power is off here. If i try to set the
                      > > > > > txpower I get the
                      > > > > > > following message:
                      > > > > > >
                      > > > > > > [root@inspiron root]# iwconfig eth1 txpower on Error for
                      > > > > > > wireless request "Set Tx Power"
                      > > > (8B26) :
                      > > > > > > SET failed on device eth1 ; Invalid
                      > > > argument.
                      > > > > > >
                      > > > > > > Please help what else I should try...
                      > > > > > >
                      > > > > > > Also, my card is "Intel pro/wireless 2100 3A
                      > > > mini
                      > > > > > PCI adapter" is 3A
                      > > > > > > supported? or this is the problem because of
                      > > > which
                      > > > > > I am not able to
                      > > > > > > use wifi.
                      > > > > > >
                      > > > > > > any help would be greatly appreciated.
                      > > > > > >
                      > > > > > > Thanks,
                      > > > > > > Alwin
                      > > > > > >
                      > > > > > >
                      > > > > > > --- In linux-dell-laptops@yahoogroups.com,
                      > > > > > <theuteck@g...> wrote:
                      > > > > > > > They are up to driver version 1.1.0, perhaps
                      > > > > > trying that?
                      > > > > > > > http://ipw2100.sourceforge.net/
                      > > > > > > >
                      > > > > > > >
                      > > > > > > > On Wed, 30 Mar 2005 17:33:07 -0000, Alwin
                      > > > Gupta
                      > > > > > <alwin@c...> wrote:
                      > > > > > > > >
                      > > > > > > > >
                      > > > > > > > > Hi,
                      > > > > > > > >
                      > > > > > > > > I have a Dell inpiron 510m laptop running
                      > > > > > Fedora Core 2 with 2.6.8
                      > > > > > > > > kernel and really trying hard to setup the
                      > > > > > wireless card, done a lot
                      > > > > > > > > of things starting from compiling kernel
                      > > > with
                      > > > > > wireless support,
                      > > > > > > > > installing firmware etc.
                      > > > > > > > >
                      > > > > > > > > I have built the wireless 2100 driver in
                      > > > > > kernel source and could see
                      > > > > > > > > the wireless indicator turn green on doing
                      > > > > > 'modporbe ipw2100'
                      > > > > > but when
                      > > > > > > > > I try to bring up the interface it gives
                      > > > the
                      >
                      === message truncated ===




                      __________________________________
                      Do you Yahoo!?
                      Yahoo! Mail - Helps protect you from nasty viruses.
                      http://promotions.yahoo.com/new_mail
                    • Paul Gratz
                      I have an ipw2200 (basically the same card as the ipw2100 with 802.11b) in my 8500 and I ve found that in mine the tx-power stuff is controlled by the Fn-F2
                      Message 10 of 15 , Apr 5, 2005
                      • 0 Attachment
                        I have an ipw2200 (basically the same card as the ipw2100 with 802.11b)
                        in my 8500 and I've found that in mine the tx-power stuff is controlled
                        by the Fn-F2 key combo. If I hit that when its up it will turn off the
                        transmitter (and of course the net wont work then), if I hit it again it
                        turns it back on. It sounds rather obvious but have you tried this?
                        Paul


                        On Tue, 2005-04-05 at 10:57 -0700, Alwin Gupta wrote:
                        > It seems there is some problem with the wireless card itself, its not even
                        > working in Windows!
                        >
                        > In windows also the problem is same, it could detect and associate itself with
                        > the network but can't ping the gateway. Interestingly during the ping it
                        > sometimes also says "hardware error" along with "Request timed out". I mailed
                        > to Dell regarding this as my notebook is still under the Complete Cover and
                        > other things Dell offer.
                        >
                        > I dont know what the Dell technical support people are trying to do, they have
                        > asked me to do all kind of wierd stuff from flashing my BIOS .. reinstallation
                        > of the OS. Although, I have flashed the BIOS with the latest available on the
                        > Dell site for my laptop model. But, it didn't helped, as I was expecting! I
                        > rarely boot into WinXP and previously the same card used to work smoothly in
                        > WinXP.
                        >
                        > I am sure that this is related to some hardware problem. I'll ask Dell to
                        > replace the wireless card. In linux I could see the output of the iwconfig, it
                        > shows the 'tx-power off' which I cant turn on or set to some value, it seems
                        > that the transmission circuit has gone.
                        >
                        > -Alwin
                        >
                        >
                        > --- "Marvin R. Pierce" <mpierce@...> wrote:
                        >
                        > > I had the same problem and switched to ipw2200.
                        > > Also, make sure you are using the correct eth-x to id the connection.
                        > > I found that on my Dell9300, it was id as eth2 and not wlan0.
                        > >
                        > > -----Original Message-----
                        > > From: theuteck@... [mailto:theuteck@...]
                        > > Sent: Tuesday, 5 April 2005 7:27 AM
                        > > To: linux-dell-laptops@yahoogroups.com
                        > > Subject: [linux-dell-laptops] Re: unable to get ipw2100 up
                        > >
                        > >
                        > > Looks like gmail decided to do some word wrapping, that last one should be 1
                        > > line.
                        > >
                        > >
                        > > On Sun, 3 Apr 2005 20:44:14 -0700 (PDT), Alwin Gupta <alwingupta@...>
                        > > wrote:
                        > > >
                        > > > Thanks for the info. I'll try this tonight and let you know.
                        > > >
                        > > > -Alwin
                        > > >
                        > > >
                        > > > --- theuteck@... wrote:
                        > > >
                        > > > > I saw a post that said this model laptop and nic have an IRQ
                        > > > > conflict.
                        > > > >
                        > > > >
                        > > > (http://ubuntuforums.org/archive/index.php/t-2586.html)
                        > > > > He fixed by adding; acpi_irq_isa=7 to the /boot/grub/menu.list
                        > > > > kernel boot lines.
                        > > > > So this line; kernel
                        > > > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro
                        > > > > would like; kernel
                        > > > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro acpi_irq_isa=7
                        > > > >
                        > > > >
                        > > > > On Sun, 3 Apr 2005 00:54:29 -0800 (PST), Alwin Gupta
                        > > > > <alwingupta@...> wrote:
                        > > > > >
                        > > > > > Hi P,
                        > > > > >
                        > > > > > Thanks for your reply. I tried what you said but
                        > > > > it
                        > > > > > didn't worked out for me.
                        > > > > >
                        > > > > > I have checked Intel site they say they do not
                        > > > > plan to
                        > > > > > support 2100A on linux. Now, I am throughly
                        > > > > confused
                        > > > > > whether my card is 2100A??
                        > > > > >
                        > > > > > BTW, whats the difference between "2100A" and
                        > > > > "2100
                        > > > > > 3A"?
                        > > > > >
                        > > > > > On windows it shows "Intel Wireless PRO 2100 3A
                        > > > > mini
                        > > > > > PCI". After installing ipw2100 linux identifies it
                        > > > > as
                        > > > > > "2100 3B". I suspect if this is the issue which is causing the
                        > > > > > problem.
                        > > > > >
                        > > > > > Once again thanks for the help!
                        > > > > >
                        > > > > > -Alwin
                        > > > > >
                        > > > > > --- pdast1 <parmor@...> wrote:
                        > > > > >
                        > > > > > >
                        > > > > > > Hi Alwin,
                        > > > > > > don't know if this will help, but I have the
                        > > > > 2200
                        > > > > > > driver and once had
                        > > > > > > a strange problem that I've had trouble
                        > > > > reproducing.
                        > > > > > > My problematic
                        > > > > > > set up is an internal 2200 trying to associate
                        > > > > with
                        > > > > > > a linksys wap54g,
                        > > > > > > no broadcast ssid. On client I forced the ssid
                        > > > > in
                        > > > > > > config, and have no
                        > > > > > > wpa or wep, using a static IP. Every once in a while, I have
                        > > > > > > problems where it associates with the AP, but I can't
                        > > > > seem to
                        > > > > > > ping anything.
                        > > > > > > What I've noticed though, is that the machine
                        > > > > being
                        > > > > > > pinged receives
                        > > > > > > the echo requests and responds, but the wireless card ignores
                        > > > > > > them.
                        > > > > > > If I let it ping for 5+mins I'll start seeing
                        > > > > some
                        > > > > > > replys, but mostly
                        > > > > > > they're "dup"'s. I've discovered that when in
                        > > > > that
                        > > > > > > state, if I force
                        > > > > > > the mode from "auto" to Ad-Hoc, then back to
                        > > > > auto,
                        > > > > > > it will correct
                        > > > > > > itself and all is well.
                        > > > > > >
                        > > > > > > Cheers,
                        > > > > > > P
                        > > > > > >
                        > > > > > > --- In linux-dell-laptops@yahoogroups.com,
                        > > > > "Alwin
                        > > > > > > Gupta"
                        > > > > > > <alwingupta@y...> wrote:
                        > > > > > > >
                        > > > > > > > Thanks for the info..
                        > > > > > > >
                        > > > > > > > I have now 1.1.0 installed but still not able
                        > > > > to
                        > > > > > > use the wireless
                        > > > > > > > card. I am able to associate with the access
                        > > > > point
                        > > > > > > but cant ping it.
                        > > > > > > >
                        > > > > > > > I am pasting the output of the iwconfig:
                        > > > > > > >
                        > > > > > > > [root@inspiron root]# iwconfig eth1
                        > > > > > > > eth1 IEEE 802.11b ESSID:"123"
                        > > > > > > Nickname:"ipw2100"
                        > > > > > > > Mode:Managed Frequency:2.412 GHz
                        > > > > > > Access Point:
                        > > > > > > > 00:60:B3:19:8E:1E
                        > > > > > > > Bit Rate=1 Mb/s Tx-Power:off
                        > > > > > > > Retry:on RTS thr:off Fragment
                        > > > > > > thr:off
                        > > > > > > > Encryption key:off
                        > > > > > > > Power Management:off
                        > > > > > > > Link Quality=14/100 Signal
                        > > > > level=-78
                        > > > > > > dBm
                        > > > > > > > Rx invalid nwid:0 Rx invalid
                        > > > > crypt:0
                        > > > > > > Rx invalid frag:0
                        > > > > > > > Tx excessive retries:8 Invalid
                        > > > > misc:0
                        > > > > > > Missed beacon:0
                        > > > > > > >
                        > > > > > > >
                        > > > > > > > the Tx-power is off here. If i try to set the
                        > > > > > > txpower I get the
                        > > > > > > > following message:
                        > > > > > > >
                        > > > > > > > [root@inspiron root]# iwconfig eth1 txpower on Error for
                        > > > > > > > wireless request "Set Tx Power"
                        > > > > (8B26) :
                        > > > > > > > SET failed on device eth1 ; Invalid
                        > > > > argument.
                        > > > > > > >
                        > > > > > > > Please help what else I should try...
                        > > > > > > >
                        > > > > > > > Also, my card is "Intel pro/wireless 2100 3A
                        > > > > mini
                        > > > > > > PCI adapter" is 3A
                        > > > > > > > supported? or this is the problem because of
                        > > > > which
                        > > > > > > I am not able to
                        > > > > > > > use wifi.
                        > > > > > > >
                        > > > > > > > any help would be greatly appreciated.
                        > > > > > > >
                        > > > > > > > Thanks,
                        > > > > > > > Alwin
                        > > > > > > >
                        > > > > > > >
                        > > > > > > > --- In linux-dell-laptops@yahoogroups.com,
                        > > > > > > <theuteck@g...> wrote:
                        > > > > > > > > They are up to driver version 1.1.0, perhaps
                        > > > > > > trying that?
                        > > > > > > > > http://ipw2100.sourceforge.net/
                        > > > > > > > >
                        > > > > > > > >
                        > > > > > > > > On Wed, 30 Mar 2005 17:33:07 -0000, Alwin
                        > > > > Gupta
                        > > > > > > <alwin@c...> wrote:
                        > > > > > > > > >
                        > > > > > > > > >
                        > > > > > > > > > Hi,
                        > > > > > > > > >
                        > > > > > > > > > I have a Dell inpiron 510m laptop running
                        > > > > > > Fedora Core 2 with 2.6.8
                        > > > > > > > > > kernel and really trying hard to setup the
                        > > > > > > wireless card, done a lot
                        > > > > > > > > > of things starting from compiling kernel
                        > > > > with
                        > > > > > > wireless support,
                        > > > > > > > > > installing firmware etc.
                        > > > > > > > > >
                        > > > > > > > > > I have built the wireless 2100 driver in
                        > > > > > > kernel source and could see
                        > > > > > > > > > the wireless indicator turn green on doing
                        > > > > > > 'modporbe ipw2100'
                        > > > > > > but when
                        > > > > > > > > > I try to bring up the interface it gives
                        > > > > the
                        > >
                        > === message truncated ===
                        >
                        >
                        >
                        >
                        > __________________________________
                        > Do you Yahoo!?
                        > Yahoo! Mail - Helps protect you from nasty viruses.
                        > http://promotions.yahoo.com/new_mail
                        >
                        >
                        > --------------------------------------------------------------
                        > Please post your X config files in the group links or database
                        > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                        > FAQ: http://www.whacked.net/ldl/faq
                        > Yahoo! Groups Links
                        >
                        >
                        >
                        >
                        >
                        >
                        >
                        --
                        Paul Gratz <pgratz@...>
                      • Alwin Gupta
                        Hi Paul, That s a good point I didn t tried it before. Now I am pretty sure that this is an issue with the transmitter only. This is what dmesg has to say:
                        Message 11 of 15 , Apr 5, 2005
                        • 0 Attachment
                          Hi Paul,

                          That's a good point I didn't tried it before. Now I am pretty sure that this
                          is an issue with the transmitter only. This is what dmesg has to say:


                          ieee80211_crypt: registered algorithm 'NULL'
                          ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, 1.1.0
                          ipw2100: Copyright(c) 2003-2004 Intel Corporation
                          ACPI: PCI interrupt 0000:01:03.0[A] -> GSI 7 (level, low) -> IRQ 7
                          ipw2100: Detected Intel PRO/Wireless 2100 Network Connection
                          ip_tables: (C) 2000-2002 Netfilter core team
                          ip_tables: (C) 2000-2002 Netfilter core team
                          ip_tables: (C) 2000-2002 Netfilter core team
                          atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
                          atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
                          eth1: Radio is disabled by RF switch.
                          atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
                          atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
                          atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
                          atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
                          eth1: Radio is disabled by RF switch.
                          atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
                          atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
                          atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
                          atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
                          eth1: Radio is disabled by RF switch.


                          Note that for every alternate key combination of <fn + f2>, there is a message
                          for disabled RF switch but the enable message are not there. So, this is the
                          whole story!

                          You can do the same on your machine and see the output of dmesg and I am sure
                          you would see the enabled RF messages also.

                          BTW, thanks for the clue..

                          -Alwin
                          --- Paul Gratz <pgratz@...> wrote:

                          > I have an ipw2200 (basically the same card as the ipw2100 with 802.11b)
                          > in my 8500 and I've found that in mine the tx-power stuff is controlled
                          > by the Fn-F2 key combo. If I hit that when its up it will turn off the
                          > transmitter (and of course the net wont work then), if I hit it again it
                          > turns it back on. It sounds rather obvious but have you tried this?
                          > Paul
                          >
                          >
                          > On Tue, 2005-04-05 at 10:57 -0700, Alwin Gupta wrote:
                          > > It seems there is some problem with the wireless card itself, its not even
                          > > working in Windows!
                          > >
                          > > In windows also the problem is same, it could detect and associate itself
                          > with
                          > > the network but can't ping the gateway. Interestingly during the ping it
                          > > sometimes also says "hardware error" along with "Request timed out". I
                          > mailed
                          > > to Dell regarding this as my notebook is still under the Complete Cover
                          > and
                          > > other things Dell offer.
                          > >
                          > > I dont know what the Dell technical support people are trying to do, they
                          > have
                          > > asked me to do all kind of wierd stuff from flashing my BIOS ..
                          > reinstallation
                          > > of the OS. Although, I have flashed the BIOS with the latest available on
                          > the
                          > > Dell site for my laptop model. But, it didn't helped, as I was expecting!
                          > I
                          > > rarely boot into WinXP and previously the same card used to work smoothly
                          > in
                          > > WinXP.
                          > >
                          > > I am sure that this is related to some hardware problem. I'll ask Dell to
                          > > replace the wireless card. In linux I could see the output of the
                          > iwconfig, it
                          > > shows the 'tx-power off' which I cant turn on or set to some value, it
                          > seems
                          > > that the transmission circuit has gone.
                          > >
                          > > -Alwin
                          > >
                          > >
                          > > --- "Marvin R. Pierce" <mpierce@...> wrote:
                          > >
                          > > > I had the same problem and switched to ipw2200.
                          > > > Also, make sure you are using the correct eth-x to id the connection.
                          > > > I found that on my Dell9300, it was id as eth2 and not wlan0.
                          > > >
                          > > > -----Original Message-----
                          > > > From: theuteck@... [mailto:theuteck@...]
                          > > > Sent: Tuesday, 5 April 2005 7:27 AM
                          > > > To: linux-dell-laptops@yahoogroups.com
                          > > > Subject: [linux-dell-laptops] Re: unable to get ipw2100 up
                          > > >
                          > > >
                          > > > Looks like gmail decided to do some word wrapping, that last one should
                          > be 1
                          > > > line.
                          > > >
                          > > >
                          > > > On Sun, 3 Apr 2005 20:44:14 -0700 (PDT), Alwin Gupta
                          > <alwingupta@...>
                          > > > wrote:
                          > > > >
                          > > > > Thanks for the info. I'll try this tonight and let you know.
                          > > > >
                          > > > > -Alwin
                          > > > >
                          > > > >
                          > > > > --- theuteck@... wrote:
                          > > > >
                          > > > > > I saw a post that said this model laptop and nic have an IRQ
                          > > > > > conflict.
                          > > > > >
                          > > > > >
                          > > > > (http://ubuntuforums.org/archive/index.php/t-2586.html)
                          > > > > > He fixed by adding; acpi_irq_isa=7 to the /boot/grub/menu.list
                          > > > > > kernel boot lines.
                          > > > > > So this line; kernel
                          > > > > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro
                          > > > > > would like; kernel
                          > > > > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro acpi_irq_isa=7
                          > > > > >
                          > > > > >
                          > > > > > On Sun, 3 Apr 2005 00:54:29 -0800 (PST), Alwin Gupta
                          > > > > > <alwingupta@...> wrote:
                          > > > > > >
                          > > > > > > Hi P,
                          > > > > > >
                          > > > > > > Thanks for your reply. I tried what you said but
                          > > > > > it
                          > > > > > > didn't worked out for me.
                          > > > > > >
                          > > > > > > I have checked Intel site they say they do not
                          > > > > > plan to
                          > > > > > > support 2100A on linux. Now, I am throughly
                          > > > > > confused
                          > > > > > > whether my card is 2100A??
                          > > > > > >
                          > > > > > > BTW, whats the difference between "2100A" and
                          > > > > > "2100
                          > > > > > > 3A"?
                          > > > > > >
                          > > > > > > On windows it shows "Intel Wireless PRO 2100 3A
                          > > > > > mini
                          > > > > > > PCI". After installing ipw2100 linux identifies it
                          > > > > > as
                          > > > > > > "2100 3B". I suspect if this is the issue which is causing the
                          > > > > > > problem.
                          > > > > > >
                          > > > > > > Once again thanks for the help!
                          > > > > > >
                          > > > > > > -Alwin
                          > > > > > >
                          > > > > > > --- pdast1 <parmor@...> wrote:
                          > > > > > >
                          > > > > > > >
                          > > > > > > > Hi Alwin,
                          > > > > > > > don't know if this will help, but I have the
                          > > > > > 2200
                          > > > > > > > driver and once had
                          > > > > > > > a strange problem that I've had trouble
                          > > > > > reproducing.
                          > > > > > > > My problematic
                          > > > > > > > set up is an internal 2200 trying to associate
                          > > > > > with
                          > > > > > > > a linksys wap54g,
                          > > > > > > > no broadcast ssid. On client I forced the ssid
                          > > > > > in
                          > > > > > > > config, and have no
                          > > > > > > > wpa or wep, using a static IP. Every once in a while, I have
                          > > > > > > > problems where it associates with the AP, but I can't
                          > > > > > seem to
                          > > > > > > > ping anything.
                          > > > > > > > What I've noticed though, is that the machine
                          > > > > > being
                          > > > > > > > pinged receives
                          > > > > > > > the echo requests and responds, but the wireless card ignores
                          > > > > > > > them.
                          > > > > > > > If I let it ping for 5+mins I'll start seeing
                          > > > > > some
                          > > > > > > > replys, but mostly
                          > > > > > > > they're "dup"'s. I've discovered that when in
                          > > > > > that
                          > > > > > > > state, if I force
                          > > > > > > > the mode from "auto" to Ad-Hoc, then back to
                          > > > > > auto,
                          > > > > > > > it will correct
                          > > > > > > > itself and all is well.
                          > > > > > > >
                          > > > > > > > Cheers,
                          > > > > > > > P
                          > > > > > > >
                          > > > > > > > --- In linux-dell-laptops@yahoogroups.com,
                          > > > > > "Alwin
                          > > > > > > > Gupta"
                          > > > > > > > <alwingupta@y...> wrote:
                          > > > > > > > >
                          > > > > > > > > Thanks for the info..
                          > > > > > > > >
                          > > > > > > > > I have now 1.1.0 installed but still not able
                          > > > > > to
                          > > > > > > > use the wireless
                          > > > > > > > > card. I am able to associate with the access
                          > > > > > point
                          > > > > > > > but cant ping it.
                          > > > > > > > >
                          > > > > > > > > I am pasting the output of the iwconfig:
                          > > > > > > > >
                          > > > > > > > > [root@inspiron root]# iwconfig eth1
                          > > > > > > > > eth1 IEEE 802.11b ESSID:"123"
                          > > > > > > > Nickname:"ipw2100"
                          > > > > > > > > Mode:Managed Frequency:2.412 GHz
                          > > > > > > > Access Point:
                          > > > > > > > > 00:60:B3:19:8E:1E
                          > > > > > > > > Bit Rate=1 Mb/s Tx-Power:off
                          > > > > > > > > Retry:on RTS thr:off Fragment
                          > > > > > > > thr:off
                          > > > > > > > > Encryption key:off
                          > > > > > > > > Power Management:off
                          > > > > > > > > Link Quality=14/100 Signal
                          > > > > > level=-78
                          > > > > > > > dBm
                          > > > > > > > > Rx invalid nwid:0 Rx invalid
                          > > > > > crypt:0
                          > > > > > > > Rx invalid frag:0
                          > > > > > > > > Tx excessive retries:8 Invalid
                          > > > > > misc:0
                          > > > > > > > Missed beacon:0
                          > > > > > > > >
                          > > > > > > > >
                          > > > > > > > > the Tx-power is off here. If i try to set the
                          > > > > > > > txpower I get the
                          > > > > > > > > following message:
                          > > > > > > > >
                          > > > > > > > > [root@inspiron root]# iwconfig eth1 txpower on Error for
                          > > > > > > > > wireless request "Set Tx Power"
                          > > > > > (8B26) :
                          > > > > > > > > SET failed on device eth1 ; Invalid
                          > > > > > argument.
                          >
                          === message truncated ===




                          __________________________________
                          Do you Yahoo!?
                          Make Yahoo! your home page
                          http://www.yahoo.com/r/hs
                        • Paul Gratz
                          BTW one more note on this stuff. In mine you can see a bunch of info on the ipw driver in the: /sys/bus/pci/drivers/ipw2100/(device number)/ directory. In
                          Message 12 of 15 , Apr 5, 2005
                          • 0 Attachment
                            BTW one more note on this stuff. In mine you can see a bunch of info on
                            the ipw driver in the:
                            /sys/bus/pci/drivers/ipw2100/(device number)/
                            directory. In there there is a file called "rf_kill" that can be read
                            to tell you the status of the rf kill switch (either 0 or 1, 0 means
                            that rf_kill is not on so the transmitter is).

                            More info on that driver can be found on its webpage:
                            http://ipw2100.sourceforge.net/
                            or
                            http://ipw2200.sourceforge.net/
                            for mine.
                            Paul


                            On Tue, 2005-04-05 at 11:36 -0700, Alwin Gupta wrote:
                            > Hi Paul,
                            >
                            > That's a good point I didn't tried it before. Now I am pretty sure that this
                            > is an issue with the transmitter only. This is what dmesg has to say:
                            >
                            >
                            > ieee80211_crypt: registered algorithm 'NULL'
                            > ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, 1.1.0
                            > ipw2100: Copyright(c) 2003-2004 Intel Corporation
                            > ACPI: PCI interrupt 0000:01:03.0[A] -> GSI 7 (level, low) -> IRQ 7
                            > ipw2100: Detected Intel PRO/Wireless 2100 Network Connection
                            > ip_tables: (C) 2000-2002 Netfilter core team
                            > ip_tables: (C) 2000-2002 Netfilter core team
                            > ip_tables: (C) 2000-2002 Netfilter core team
                            > atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
                            > atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
                            > eth1: Radio is disabled by RF switch.
                            > atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
                            > atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
                            > atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
                            > atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
                            > eth1: Radio is disabled by RF switch.
                            > atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
                            > atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
                            > atkbd.c: Unknown key pressed (translated set 2, code 0x88 on isa0060/serio0).
                            > atkbd.c: Use 'setkeycodes e008 <keycode>' to make it known.
                            > eth1: Radio is disabled by RF switch.
                            >
                            >
                            > Note that for every alternate key combination of <fn + f2>, there is a message
                            > for disabled RF switch but the enable message are not there. So, this is the
                            > whole story!
                            >
                            > You can do the same on your machine and see the output of dmesg and I am sure
                            > you would see the enabled RF messages also.
                            >
                            > BTW, thanks for the clue..
                            >
                            > -Alwin
                            > --- Paul Gratz <pgratz@...> wrote:
                            >
                            > > I have an ipw2200 (basically the same card as the ipw2100 with 802.11b)
                            > > in my 8500 and I've found that in mine the tx-power stuff is controlled
                            > > by the Fn-F2 key combo. If I hit that when its up it will turn off the
                            > > transmitter (and of course the net wont work then), if I hit it again it
                            > > turns it back on. It sounds rather obvious but have you tried this?
                            > > Paul
                            > >
                            > >
                            > > On Tue, 2005-04-05 at 10:57 -0700, Alwin Gupta wrote:
                            > > > It seems there is some problem with the wireless card itself, its not even
                            > > > working in Windows!
                            > > >
                            > > > In windows also the problem is same, it could detect and associate itself
                            > > with
                            > > > the network but can't ping the gateway. Interestingly during the ping it
                            > > > sometimes also says "hardware error" along with "Request timed out". I
                            > > mailed
                            > > > to Dell regarding this as my notebook is still under the Complete Cover
                            > > and
                            > > > other things Dell offer.
                            > > >
                            > > > I dont know what the Dell technical support people are trying to do, they
                            > > have
                            > > > asked me to do all kind of wierd stuff from flashing my BIOS ..
                            > > reinstallation
                            > > > of the OS. Although, I have flashed the BIOS with the latest available on
                            > > the
                            > > > Dell site for my laptop model. But, it didn't helped, as I was expecting!
                            > > I
                            > > > rarely boot into WinXP and previously the same card used to work smoothly
                            > > in
                            > > > WinXP.
                            > > >
                            > > > I am sure that this is related to some hardware problem. I'll ask Dell to
                            > > > replace the wireless card. In linux I could see the output of the
                            > > iwconfig, it
                            > > > shows the 'tx-power off' which I cant turn on or set to some value, it
                            > > seems
                            > > > that the transmission circuit has gone.
                            > > >
                            > > > -Alwin
                            > > >
                            > > >
                            > > > --- "Marvin R. Pierce" <mpierce@...> wrote:
                            > > >
                            > > > > I had the same problem and switched to ipw2200.
                            > > > > Also, make sure you are using the correct eth-x to id the connection.
                            > > > > I found that on my Dell9300, it was id as eth2 and not wlan0.
                            > > > >
                            > > > > -----Original Message-----
                            > > > > From: theuteck@... [mailto:theuteck@...]
                            > > > > Sent: Tuesday, 5 April 2005 7:27 AM
                            > > > > To: linux-dell-laptops@yahoogroups.com
                            > > > > Subject: [linux-dell-laptops] Re: unable to get ipw2100 up
                            > > > >
                            > > > >
                            > > > > Looks like gmail decided to do some word wrapping, that last one should
                            > > be 1
                            > > > > line.
                            > > > >
                            > > > >
                            > > > > On Sun, 3 Apr 2005 20:44:14 -0700 (PDT), Alwin Gupta
                            > > <alwingupta@...>
                            > > > > wrote:
                            > > > > >
                            > > > > > Thanks for the info. I'll try this tonight and let you know.
                            > > > > >
                            > > > > > -Alwin
                            > > > > >
                            > > > > >
                            > > > > > --- theuteck@... wrote:
                            > > > > >
                            > > > > > > I saw a post that said this model laptop and nic have an IRQ
                            > > > > > > conflict.
                            > > > > > >
                            > > > > > >
                            > > > > > (http://ubuntuforums.org/archive/index.php/t-2586.html)
                            > > > > > > He fixed by adding; acpi_irq_isa=7 to the /boot/grub/menu.list
                            > > > > > > kernel boot lines.
                            > > > > > > So this line; kernel
                            > > > > > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro
                            > > > > > > would like; kernel
                            > > > > > > /boot/vmlinuz-2.6.11-ln.std root=/dev/hda4 ro acpi_irq_isa=7
                            > > > > > >
                            > > > > > >
                            > > > > > > On Sun, 3 Apr 2005 00:54:29 -0800 (PST), Alwin Gupta
                            > > > > > > <alwingupta@...> wrote:
                            > > > > > > >
                            > > > > > > > Hi P,
                            > > > > > > >
                            > > > > > > > Thanks for your reply. I tried what you said but
                            > > > > > > it
                            > > > > > > > didn't worked out for me.
                            > > > > > > >
                            > > > > > > > I have checked Intel site they say they do not
                            > > > > > > plan to
                            > > > > > > > support 2100A on linux. Now, I am throughly
                            > > > > > > confused
                            > > > > > > > whether my card is 2100A??
                            > > > > > > >
                            > > > > > > > BTW, whats the difference between "2100A" and
                            > > > > > > "2100
                            > > > > > > > 3A"?
                            > > > > > > >
                            > > > > > > > On windows it shows "Intel Wireless PRO 2100 3A
                            > > > > > > mini
                            > > > > > > > PCI". After installing ipw2100 linux identifies it
                            > > > > > > as
                            > > > > > > > "2100 3B". I suspect if this is the issue which is causing the
                            > > > > > > > problem.
                            > > > > > > >
                            > > > > > > > Once again thanks for the help!
                            > > > > > > >
                            > > > > > > > -Alwin
                            > > > > > > >
                            > > > > > > > --- pdast1 <parmor@...> wrote:
                            > > > > > > >
                            > > > > > > > >
                            > > > > > > > > Hi Alwin,
                            > > > > > > > > don't know if this will help, but I have the
                            > > > > > > 2200
                            > > > > > > > > driver and once had
                            > > > > > > > > a strange problem that I've had trouble
                            > > > > > > reproducing.
                            > > > > > > > > My problematic
                            > > > > > > > > set up is an internal 2200 trying to associate
                            > > > > > > with
                            > > > > > > > > a linksys wap54g,
                            > > > > > > > > no broadcast ssid. On client I forced the ssid
                            > > > > > > in
                            > > > > > > > > config, and have no
                            > > > > > > > > wpa or wep, using a static IP. Every once in a while, I have
                            > > > > > > > > problems where it associates with the AP, but I can't
                            > > > > > > seem to
                            > > > > > > > > ping anything.
                            > > > > > > > > What I've noticed though, is that the machine
                            > > > > > > being
                            > > > > > > > > pinged receives
                            > > > > > > > > the echo requests and responds, but the wireless card ignores
                            > > > > > > > > them.
                            > > > > > > > > If I let it ping for 5+mins I'll start seeing
                            > > > > > > some
                            > > > > > > > > replys, but mostly
                            > > > > > > > > they're "dup"'s. I've discovered that when in
                            > > > > > > that
                            > > > > > > > > state, if I force
                            > > > > > > > > the mode from "auto" to Ad-Hoc, then back to
                            > > > > > > auto,
                            > > > > > > > > it will correct
                            > > > > > > > > itself and all is well.
                            > > > > > > > >
                            > > > > > > > > Cheers,
                            > > > > > > > > P
                            > > > > > > > >
                            > > > > > > > > --- In linux-dell-laptops@yahoogroups.com,
                            > > > > > > "Alwin
                            > > > > > > > > Gupta"
                            > > > > > > > > <alwingupta@y...> wrote:
                            > > > > > > > > >
                            > > > > > > > > > Thanks for the info..
                            > > > > > > > > >
                            > > > > > > > > > I have now 1.1.0 installed but still not able
                            > > > > > > to
                            > > > > > > > > use the wireless
                            > > > > > > > > > card. I am able to associate with the access
                            > > > > > > point
                            > > > > > > > > but cant ping it.
                            > > > > > > > > >
                            > > > > > > > > > I am pasting the output of the iwconfig:
                            > > > > > > > > >
                            > > > > > > > > > [root@inspiron root]# iwconfig eth1
                            > > > > > > > > > eth1 IEEE 802.11b ESSID:"123"
                            > > > > > > > > Nickname:"ipw2100"
                            > > > > > > > > > Mode:Managed Frequency:2.412 GHz
                            > > > > > > > > Access Point:
                            > > > > > > > > > 00:60:B3:19:8E:1E
                            > > > > > > > > > Bit Rate=1 Mb/s Tx-Power:off
                            > > > > > > > > > Retry:on RTS thr:off Fragment
                            > > > > > > > > thr:off
                            > > > > > > > > > Encryption key:off
                            > > > > > > > > > Power Management:off
                            > > > > > > > > > Link Quality=14/100 Signal
                            > > > > > > level=-78
                            > > > > > > > > dBm
                            > > > > > > > > > Rx invalid nwid:0 Rx invalid
                            > > > > > > crypt:0
                            > > > > > > > > Rx invalid frag:0
                            > > > > > > > > > Tx excessive retries:8 Invalid
                            > > > > > > misc:0
                            > > > > > > > > Missed beacon:0
                            > > > > > > > > >
                            > > > > > > > > >
                            > > > > > > > > > the Tx-power is off here. If i try to set the
                            > > > > > > > > txpower I get the
                            > > > > > > > > > following message:
                            > > > > > > > > >
                            > > > > > > > > > [root@inspiron root]# iwconfig eth1 txpower on Error for
                            > > > > > > > > > wireless request "Set Tx Power"
                            > > > > > > (8B26) :
                            > > > > > > > > > SET failed on device eth1 ; Invalid
                            > > > > > > argument.
                            > >
                            > === message truncated ===
                            >
                            >
                            >
                            >
                            > __________________________________
                            > Do you Yahoo!?
                            > Make Yahoo! your home page
                            > http://www.yahoo.com/r/hs
                            >
                            >
                            > --------------------------------------------------------------
                            > Please post your X config files in the group links or database
                            > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                            > FAQ: http://www.whacked.net/ldl/faq
                            > Yahoo! Groups Links
                            >
                            >
                            >
                            >
                            >
                            >
                            >
                            --
                            Paul Gratz <pgratz@...>
                          Your message has been successfully submitted and would be delivered to recipients shortly.