Loading ...
Sorry, an error occurred while loading the content.
 

Re: [linux-dell-laptops] ndiswrapper netgear wg511 v2: unknown symbol in dmesg

Expand Messages
  • Alexandre Tessier
    I answer to my own post. I have upgraded to ndiswrapper 1.0 today and now it works. The proof: I send this e-mail wireless ;-) Alex.
    Message 1 of 2 , Jan 29, 2005
      I answer to my own post.

      I have upgraded to ndiswrapper 1.0 today and now it works.
      The proof: I send this e-mail wireless ;-)

      Alex.

      Alexandre Tessier wrote:
      > Hi,
      >
      > I have a Dell Latitude C840 laptop with Mandrake 10.1 and a WG511v2
      > cardbus card. (I've tried a netgear WG511 cardbus card without problem
      > with the prism54 module and I decided to buy one, but I've received a
      > netgear WG511v2 which is not supported by the prism54 module)
      >
      > I'm new to ndiswrapper.
      > I've tried the mdk10.1 ndiswrapper rpm: ndiswrapper-0.9-1mdk.i586.rpm,
      > next I've tried the ndiswrapper-1.0rc4.tar.gz source package from
      > sourceforge.
      > In both cases:
      >
      > I can install the .inf driver
      > # ndiswrapper -i /PathOnNetgearCdromTo/Driver/WindowsXP/WG511v2.INF
      >
      > I can check it
      > # ndiswrapper -l
      > Installed ndis drivers:
      > wg511v2 driver present, hardware present
      >
      > I can modprobe ndiswrapper without error
      > # modprobe ndiswrapper
      >
      > The module is loaded
      > # lsmod | grep ndiswrapper
      > ndiswrapper 119028 0
      > usbcore 103172 7 ndiswrapper,usbmouse,usbhid,usblp,uhci-hcd
      >
      > but at the end of dmesg with v0.8
      > # dmesg
      > [...]
      > ndiswrapper version 0.8 loaded
      > Unknown symbol: ntoskrnl.exe:ObfDereferenceObject
      > Unknown symbol: ntoskrnl.exe:toupper
      > Unable to prepare driver
      >
      > and with v1.0rc4
      > # dmesg
      > [...]
      > ndiswrapper version 1.0rc4 loaded (preempt=no,smp=no)
      > ndiswrapper (import:228): unknown symbol: ntoskrnl.exe:ObfDereferenceObject
      > ndiswrapper (load_sys_files:450): unable to prepare driver 'wg511v2'
      > ndiswrapper (ndiswrapper_load_driver:98): loadndiswrapper failed
      > (65280); check system log for messages from 'loadndisdriver'
      >
      > The same messages are at the end of /var/log/messages and /var/log/syslog
      >
      > I have searched the archive of the ndiswrapper mailing list and found
      > other posts on the same problem but I did not find any answer.
      >
      > Any help will be welcome!
      >
      > Alex.
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
      > FAQ: http://www.whacked.net/ldl/faq
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.