Loading ...
Sorry, an error occurred while loading the content.

Updated Xfree86, gnome wont run.

Expand Messages
  • Matt
    Hey guys. I seem to have a strange problem. Ive always wanted to use Linux, but the only computer to run it on was this old I8k laptop i m running. Ive tried
    Message 1 of 9 , Jan 15, 2005
    • 0 Attachment
      Hey guys. I seem to have a strange problem. Ive always wanted to use
      Linux, but the only computer to run it on was this old I8k laptop i'm
      running. Ive tried several times in the past to use Linux on it, but
      I never stayed because X never wanted to work on this laptop. The
      last time I tried to run linux, I got X to work, but it was running
      off the processor isntead of the graphics card, so X was pretty slow.
      This time, I felt determined to get it working. I have RH9, the
      LinuxUser and Developer version I got out of a magazine. I installed
      it no problem, but as always, X didnt want to work. I found an
      Xconfig on this forum, in the files section, tried giving that a
      whirl, but alas, X didnt work. I decided to update my xfree86
      install, got the newest source, ran the install utility, and used
      startx. Low and behold, It works, but it only showed up using the Twm
      manager, so I rebooted, and was able to finally do the FirstBoot
      portion of the install, where I create a regular user and such. After
      that was done I was able to use the graphical login screen, so I chose
      Gnome as my session and logged in as my user. And just my luck, it
      runs the Twm manager. Ive done some searching on my system, and Gnome
      looks to be installed. I even tried reinstalling the RPM from my cd,
      but that didnt work. I tried logging as root and I still get the same
      manager. I tried a bit of fiddling with xinitrc file, but that didnt
      work. The funny thing is, I can run the gnome apps via the xterm
      window, I used to be able to even run gnome-session from it and it
      would open a window with my gnome desktop and another window with the
      gnome bar.

      So i'm coming to you guys. Anyone have any ideas why now that X will
      run, gnome wont?
    • Damien Solley
      If you re starting X with startx , then it looks for your specified windowmanager in a file called .xinitrc . If you have Gnome installed, and you want to
      Message 2 of 9 , Jan 15, 2005
      • 0 Attachment
        If you're starting X with "startx", then it looks for your specified
        windowmanager in a file called ".xinitrc". If you have Gnome installed,
        and you want to start it, do:
        touch .xinitrc
        chmod +x .xinitrc
        echo "gnome-session" > .xinitrc
        Then, when you run startx, you'll get a gnome session.
        Regards
        Damien

        On Sat, 2005-01-15 at 21:49 +0000, Matt wrote:
        >
        > Hey guys. I seem to have a strange problem. Ive always wanted to use
        > Linux, but the only computer to run it on was this old I8k laptop i'm
        > running. Ive tried several times in the past to use Linux on it, but
        > I never stayed because X never wanted to work on this laptop. The
        > last time I tried to run linux, I got X to work, but it was running
        > off the processor isntead of the graphics card, so X was pretty slow.
        > This time, I felt determined to get it working. I have RH9, the
        > LinuxUser and Developer version I got out of a magazine. I installed
        > it no problem, but as always, X didnt want to work. I found an
        > Xconfig on this forum, in the files section, tried giving that a
        > whirl, but alas, X didnt work. I decided to update my xfree86
        > install, got the newest source, ran the install utility, and used
        > startx. Low and behold, It works, but it only showed up using the Twm
        > manager, so I rebooted, and was able to finally do the FirstBoot
        > portion of the install, where I create a regular user and such. After
        > that was done I was able to use the graphical login screen, so I chose
        > Gnome as my session and logged in as my user. And just my luck, it
        > runs the Twm manager. Ive done some searching on my system, and Gnome
        > looks to be installed. I even tried reinstalling the RPM from my cd,
        > but that didnt work. I tried logging as root and I still get the same
        > manager. I tried a bit of fiddling with xinitrc file, but that didnt
        > work. The funny thing is, I can run the gnome apps via the xterm
        > window, I used to be able to even run gnome-session from it and it
        > would open a window with my gnome desktop and another window with the
        > gnome bar.
        >
        > So i'm coming to you guys. Anyone have any ideas why now that X will
        > run, gnome wont?
        >
        >
        >
        >
        >
        > --------------------------------------------------------------
        > Please post your X config files in the group links or database
        > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        > FAQ: http://www.whacked.net/ldl/faq
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
        >
      • Matt
        Hey Damien, Sorry I wasnt clear earlier, but I only ran startx after updating my xfree install to check that it installed correctly. I m at runlevel 5, and X
        Message 3 of 9 , Jan 15, 2005
        • 0 Attachment
          Hey Damien,

          Sorry I wasnt clear earlier, but I only ran startx after updating my
          xfree install to check that it installed correctly. I'm at runlevel
          5, and X starts as soon as I boot and brings me to the redhat login
          screen, where i'm able to choose sessions, as well as log in. I have
          my session chosen as gnome from there, yet it always starts as Twm.

          If you need to see any files, i'd be glad to paste them. As of now,
          i'm using the xterm to run firefox so I can read and reply to posts,
          but i'm also dualbooting winxp.

          I was wondering though, if the .xinitrc file works for startx, would I
          be able to change my runlevel down to 3 and use startx? If so, i'm
          not quite sure how to change the runlevel, but i'd be willing to try.
          I'd rather be able to boot straight in to X, but i'll take what I can
          get if that turns out to be the only option.

          Regards,
          Matt

          --- In linux-dell-laptops@yahoogroups.com, Damien Solley
          <dsolley.listmail@g...> wrote:
          > If you're starting X with "startx", then it looks for your specified
          > windowmanager in a file called ".xinitrc". If you have Gnome installed,
          > and you want to start it, do:
          > touch .xinitrc
          > chmod +x .xinitrc
          > echo "gnome-session" > .xinitrc
          > Then, when you run startx, you'll get a gnome session.
          > Regards
          > Damien
          >
          > On Sat, 2005-01-15 at 21:49 +0000, Matt wrote:
          > >
          > > Hey guys. I seem to have a strange problem. Ive always wanted to use
          > > Linux, but the only computer to run it on was this old I8k laptop i'm
          > > running. Ive tried several times in the past to use Linux on it, but
          > > I never stayed because X never wanted to work on this laptop. The
          > > last time I tried to run linux, I got X to work, but it was running
          > > off the processor isntead of the graphics card, so X was pretty slow.
          > > This time, I felt determined to get it working. I have RH9, the
          > > LinuxUser and Developer version I got out of a magazine. I installed
          > > it no problem, but as always, X didnt want to work. I found an
          > > Xconfig on this forum, in the files section, tried giving that a
          > > whirl, but alas, X didnt work. I decided to update my xfree86
          > > install, got the newest source, ran the install utility, and used
          > > startx. Low and behold, It works, but it only showed up using the Twm
          > > manager, so I rebooted, and was able to finally do the FirstBoot
          > > portion of the install, where I create a regular user and such. After
          > > that was done I was able to use the graphical login screen, so I chose
          > > Gnome as my session and logged in as my user. And just my luck, it
          > > runs the Twm manager. Ive done some searching on my system, and Gnome
          > > looks to be installed. I even tried reinstalling the RPM from my cd,
          > > but that didnt work. I tried logging as root and I still get the same
          > > manager. I tried a bit of fiddling with xinitrc file, but that didnt
          > > work. The funny thing is, I can run the gnome apps via the xterm
          > > window, I used to be able to even run gnome-session from it and it
          > > would open a window with my gnome desktop and another window with the
          > > gnome bar.
          > >
          > > So i'm coming to you guys. Anyone have any ideas why now that X will
          > > run, gnome wont?
          > >
          > >
          > >
          > >
          > >
          > > --------------------------------------------------------------
          > > Please post your X config files in the group links or database
          > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
          > > FAQ: http://www.whacked.net/ldl/faq
          > > Yahoo! Groups Links
          > >
          > >
          > >
          > >
          > >
          > >
          > >
        • Damien Solley
          Hi Matt, You could do runlevel 3, but it sounds like the login isn t working. Anyway, there s another option. From the login, the Default session looks for
          Message 4 of 9 , Jan 15, 2005
          • 0 Attachment
            Hi Matt,
            You could do runlevel 3, but it sounds like the login isn't working.
            Anyway, there's another option. From the login, the "Default" session
            looks for the file .xsession (identical to .xinitrc). So, I'd try (from
            your xterm):
            touch .xsession
            chmod +x .xsession
            echo "gnome-session" > .xsession
            Then log into the "Default" session.
            Also, are you sure you have Gnome installed?
            Regards
            Damien


            On Sun, 2005-01-16 at 00:09 +0000, Matt wrote:
            >
            > Hey Damien,
            >
            > Sorry I wasnt clear earlier, but I only ran startx after updating my
            > xfree install to check that it installed correctly. I'm at runlevel
            > 5, and X starts as soon as I boot and brings me to the redhat login
            > screen, where i'm able to choose sessions, as well as log in. I have
            > my session chosen as gnome from there, yet it always starts as Twm.
            >
            > If you need to see any files, i'd be glad to paste them. As of now,
            > i'm using the xterm to run firefox so I can read and reply to posts,
            > but i'm also dualbooting winxp.
            >
            > I was wondering though, if the .xinitrc file works for startx, would I
            > be able to change my runlevel down to 3 and use startx? If so, i'm
            > not quite sure how to change the runlevel, but i'd be willing to try.
            > I'd rather be able to boot straight in to X, but i'll take what I can
            > get if that turns out to be the only option.
            >
            > Regards,
            > Matt
            >
            > --- In linux-dell-laptops@yahoogroups.com, Damien Solley
            > <dsolley.listmail@g...> wrote:
            > > If you're starting X with "startx", then it looks for your specified
            > > windowmanager in a file called ".xinitrc". If you have Gnome installed,
            > > and you want to start it, do:
            > > touch .xinitrc
            > > chmod +x .xinitrc
            > > echo "gnome-session" > .xinitrc
            > > Then, when you run startx, you'll get a gnome session.
            > > Regards
            > > Damien
            > >
            > > On Sat, 2005-01-15 at 21:49 +0000, Matt wrote:
            > > >
            > > > Hey guys. I seem to have a strange problem. Ive always wanted to use
            > > > Linux, but the only computer to run it on was this old I8k laptop i'm
            > > > running. Ive tried several times in the past to use Linux on it, but
            > > > I never stayed because X never wanted to work on this laptop. The
            > > > last time I tried to run linux, I got X to work, but it was running
            > > > off the processor isntead of the graphics card, so X was pretty slow.
            > > > This time, I felt determined to get it working. I have RH9, the
            > > > LinuxUser and Developer version I got out of a magazine. I installed
            > > > it no problem, but as always, X didnt want to work. I found an
            > > > Xconfig on this forum, in the files section, tried giving that a
            > > > whirl, but alas, X didnt work. I decided to update my xfree86
            > > > install, got the newest source, ran the install utility, and used
            > > > startx. Low and behold, It works, but it only showed up using the Twm
            > > > manager, so I rebooted, and was able to finally do the FirstBoot
            > > > portion of the install, where I create a regular user and such. After
            > > > that was done I was able to use the graphical login screen, so I chose
            > > > Gnome as my session and logged in as my user. And just my luck, it
            > > > runs the Twm manager. Ive done some searching on my system, and Gnome
            > > > looks to be installed. I even tried reinstalling the RPM from my cd,
            > > > but that didnt work. I tried logging as root and I still get the same
            > > > manager. I tried a bit of fiddling with xinitrc file, but that didnt
            > > > work. The funny thing is, I can run the gnome apps via the xterm
            > > > window, I used to be able to even run gnome-session from it and it
            > > > would open a window with my gnome desktop and another window with the
            > > > gnome bar.
            > > >
            > > > So i'm coming to you guys. Anyone have any ideas why now that X will
            > > > run, gnome wont?
            > > >
            > > >
            > > >
            > > >
            > > >
            > > > --------------------------------------------------------------
            > > > Please post your X config files in the group links or database
            > > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
            > > > FAQ: http://www.whacked.net/ldl/faq
            > > > Yahoo! Groups Links
            > > >
            > > >
            > > >
            > > >
            > > >
            > > >
            > > >
            >
            >
            >
            >
            >
            > --------------------------------------------------------------
            > Please post your X config files in the group links or database
            > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
            > FAQ: http://www.whacked.net/ldl/faq
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
            >
          • Matt
            Damien, Thanks so much, creating the .xsession did the trick. Somehow it either got erased or it was never there, but now it boots straight into gnome. I
            Message 5 of 9 , Jan 15, 2005
            • 0 Attachment
              Damien,

              Thanks so much, creating the .xsession did the trick. Somehow it
              either got erased or it was never there, but now it boots straight
              into gnome. I appreciate your help, and now that everything seems to
              be working flawlessly, i'll give linux a serious try.

              Thanks so much,
              Matt


              --- In linux-dell-laptops@yahoogroups.com, Damien Solley
              <dsolley.listmail@g...> wrote:
              > Hi Matt,
              > You could do runlevel 3, but it sounds like the login isn't working.
              > Anyway, there's another option. From the login, the "Default" session
              > looks for the file .xsession (identical to .xinitrc). So, I'd try (from
              > your xterm):
              > touch .xsession
              > chmod +x .xsession
              > echo "gnome-session" > .xsession
              > Then log into the "Default" session.
              > Also, are you sure you have Gnome installed?
              > Regards
              > Damien
              >
              >
              > On Sun, 2005-01-16 at 00:09 +0000, Matt wrote:
              > >
              > > Hey Damien,
              > >
              > > Sorry I wasnt clear earlier, but I only ran startx after updating my
              > > xfree install to check that it installed correctly. I'm at runlevel
              > > 5, and X starts as soon as I boot and brings me to the redhat login
              > > screen, where i'm able to choose sessions, as well as log in. I have
              > > my session chosen as gnome from there, yet it always starts as Twm.
              > >
              > > If you need to see any files, i'd be glad to paste them. As of now,
              > > i'm using the xterm to run firefox so I can read and reply to posts,
              > > but i'm also dualbooting winxp.
              > >
              > > I was wondering though, if the .xinitrc file works for startx, would I
              > > be able to change my runlevel down to 3 and use startx? If so, i'm
              > > not quite sure how to change the runlevel, but i'd be willing to try.
              > > I'd rather be able to boot straight in to X, but i'll take what I can
              > > get if that turns out to be the only option.
              > >
              > > Regards,
              > > Matt
              > >
              > > --- In linux-dell-laptops@yahoogroups.com, Damien Solley
              > > <dsolley.listmail@g...> wrote:
              > > > If you're starting X with "startx", then it looks for your specified
              > > > windowmanager in a file called ".xinitrc". If you have Gnome
              installed,
              > > > and you want to start it, do:
              > > > touch .xinitrc
              > > > chmod +x .xinitrc
              > > > echo "gnome-session" > .xinitrc
              > > > Then, when you run startx, you'll get a gnome session.
              > > > Regards
              > > > Damien
              > > >
              > > > On Sat, 2005-01-15 at 21:49 +0000, Matt wrote:
              > > > >
              > > > > Hey guys. I seem to have a strange problem. Ive always wanted
              to use
              > > > > Linux, but the only computer to run it on was this old I8k
              laptop i'm
              > > > > running. Ive tried several times in the past to use Linux on
              it, but
              > > > > I never stayed because X never wanted to work on this laptop. The
              > > > > last time I tried to run linux, I got X to work, but it was
              running
              > > > > off the processor isntead of the graphics card, so X was
              pretty slow.
              > > > > This time, I felt determined to get it working. I have RH9, the
              > > > > LinuxUser and Developer version I got out of a magazine. I
              installed
              > > > > it no problem, but as always, X didnt want to work. I found an
              > > > > Xconfig on this forum, in the files section, tried giving that a
              > > > > whirl, but alas, X didnt work. I decided to update my xfree86
              > > > > install, got the newest source, ran the install utility, and used
              > > > > startx. Low and behold, It works, but it only showed up using
              the Twm
              > > > > manager, so I rebooted, and was able to finally do the FirstBoot
              > > > > portion of the install, where I create a regular user and
              such. After
              > > > > that was done I was able to use the graphical login screen, so
              I chose
              > > > > Gnome as my session and logged in as my user. And just my
              luck, it
              > > > > runs the Twm manager. Ive done some searching on my system,
              and Gnome
              > > > > looks to be installed. I even tried reinstalling the RPM from
              my cd,
              > > > > but that didnt work. I tried logging as root and I still get
              the same
              > > > > manager. I tried a bit of fiddling with xinitrc file, but
              that didnt
              > > > > work. The funny thing is, I can run the gnome apps via the xterm
              > > > > window, I used to be able to even run gnome-session from it and it
              > > > > would open a window with my gnome desktop and another window
              with the
              > > > > gnome bar.
              > > > >
              > > > > So i'm coming to you guys. Anyone have any ideas why now that
              X will
              > > > > run, gnome wont?
              > > > >
              > > > >
              > > > >
              > > > >
              > > > >
              > > > > --------------------------------------------------------------
              > > > > Please post your X config files in the group links or database
              > > > > To unsubscribe, email:
              linux-dell-laptops-unsubscribe@yahoogroups.com
              > > > > FAQ: http://www.whacked.net/ldl/faq
              > > > > Yahoo! Groups Links
              > > > >
              > > > >
              > > > >
              > > > >
              > > > >
              > > > >
              > > > >
              > >
              > >
              > >
              > >
              > >
              > > --------------------------------------------------------------
              > > Please post your X config files in the group links or database
              > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
              > > FAQ: http://www.whacked.net/ldl/faq
              > > Yahoo! Groups Links
              > >
              > >
              > >
              > >
              > >
              > >
              > >
            • Damien Solley
              Hi Matt Usually .xsession doesn t need to exist. However, your login manager isn t working correctly (ie only giving you twm), so it s a good backup. I d
              Message 6 of 9 , Jan 15, 2005
              • 0 Attachment
                Hi Matt
                Usually .xsession doesn't need to exist. However, your login manager
                isn't working correctly (ie only giving you twm), so it's a good
                backup.
                I'd suspect that a newer distribution (such as Redhat Fedora Core 3)
                would have supported your laptop screen without hassles.
                Note that you can upgrade to the latest version (if you have a fast
                internet connection) using the package "yum".
                http://www.brandonhutchinson.com/Upgrading_Red_Hat_Linux_with_yum.html
                Regards
                Damien

                On Sun, 2005-01-16 at 00:37 +0000, Matt wrote:
                >
                > Damien,
                >
                > Thanks so much, creating the .xsession did the trick. Somehow it
                > either got erased or it was never there, but now it boots straight
                > into gnome. I appreciate your help, and now that everything seems to
                > be working flawlessly, i'll give linux a serious try.
                >
                > Thanks so much,
                > Matt
                >
                >
                > --- In linux-dell-laptops@yahoogroups.com, Damien Solley
                > <dsolley.listmail@g...> wrote:
                > > Hi Matt,
                > > You could do runlevel 3, but it sounds like the login isn't working.
                > > Anyway, there's another option. From the login, the "Default" session
                > > looks for the file .xsession (identical to .xinitrc). So, I'd try (from
                > > your xterm):
                > > touch .xsession
                > > chmod +x .xsession
                > > echo "gnome-session" > .xsession
                > > Then log into the "Default" session.
                > > Also, are you sure you have Gnome installed?
                > > Regards
                > > Damien
                > >
                > >
                > > On Sun, 2005-01-16 at 00:09 +0000, Matt wrote:
                > > >
                > > > Hey Damien,
                > > >
                > > > Sorry I wasnt clear earlier, but I only ran startx after updating my
                > > > xfree install to check that it installed correctly. I'm at runlevel
                > > > 5, and X starts as soon as I boot and brings me to the redhat login
                > > > screen, where i'm able to choose sessions, as well as log in. I have
                > > > my session chosen as gnome from there, yet it always starts as Twm.
                > > >
                > > > If you need to see any files, i'd be glad to paste them. As of now,
                > > > i'm using the xterm to run firefox so I can read and reply to posts,
                > > > but i'm also dualbooting winxp.
                > > >
                > > > I was wondering though, if the .xinitrc file works for startx, would I
                > > > be able to change my runlevel down to 3 and use startx? If so, i'm
                > > > not quite sure how to change the runlevel, but i'd be willing to try.
                > > > I'd rather be able to boot straight in to X, but i'll take what I can
                > > > get if that turns out to be the only option.
                > > >
                > > > Regards,
                > > > Matt
                > > >
                > > > --- In linux-dell-laptops@yahoogroups.com, Damien Solley
                > > > <dsolley.listmail@g...> wrote:
                > > > > If you're starting X with "startx", then it looks for your specified
                > > > > windowmanager in a file called ".xinitrc". If you have Gnome
                > installed,
                > > > > and you want to start it, do:
                > > > > touch .xinitrc
                > > > > chmod +x .xinitrc
                > > > > echo "gnome-session" > .xinitrc
                > > > > Then, when you run startx, you'll get a gnome session.
                > > > > Regards
                > > > > Damien
                > > > >
                > > > > On Sat, 2005-01-15 at 21:49 +0000, Matt wrote:
                > > > > >
                > > > > > Hey guys. I seem to have a strange problem. Ive always wanted
                > to use
                > > > > > Linux, but the only computer to run it on was this old I8k
                > laptop i'm
                > > > > > running. Ive tried several times in the past to use Linux on
                > it, but
                > > > > > I never stayed because X never wanted to work on this laptop. The
                > > > > > last time I tried to run linux, I got X to work, but it was
                > running
                > > > > > off the processor isntead of the graphics card, so X was
                > pretty slow.
                > > > > > This time, I felt determined to get it working. I have RH9, the
                > > > > > LinuxUser and Developer version I got out of a magazine. I
                > installed
                > > > > > it no problem, but as always, X didnt want to work. I found an
                > > > > > Xconfig on this forum, in the files section, tried giving that a
                > > > > > whirl, but alas, X didnt work. I decided to update my xfree86
                > > > > > install, got the newest source, ran the install utility, and used
                > > > > > startx. Low and behold, It works, but it only showed up using
                > the Twm
                > > > > > manager, so I rebooted, and was able to finally do the FirstBoot
                > > > > > portion of the install, where I create a regular user and
                > such. After
                > > > > > that was done I was able to use the graphical login screen, so
                > I chose
                > > > > > Gnome as my session and logged in as my user. And just my
                > luck, it
                > > > > > runs the Twm manager. Ive done some searching on my system,
                > and Gnome
                > > > > > looks to be installed. I even tried reinstalling the RPM from
                > my cd,
                > > > > > but that didnt work. I tried logging as root and I still get
                > the same
                > > > > > manager. I tried a bit of fiddling with xinitrc file, but
                > that didnt
                > > > > > work. The funny thing is, I can run the gnome apps via the xterm
                > > > > > window, I used to be able to even run gnome-session from it and it
                > > > > > would open a window with my gnome desktop and another window
                > with the
                > > > > > gnome bar.
                > > > > >
                > > > > > So i'm coming to you guys. Anyone have any ideas why now that
                > X will
                > > > > > run, gnome wont?
                > > > > >
                > > > > >
                > > > > >
                > > > > >
                > > > > >
                > > > > > --------------------------------------------------------------
                > > > > > Please post your X config files in the group links or database
                > > > > > To unsubscribe, email:
                > linux-dell-laptops-unsubscribe@yahoogroups.com
                > > > > > FAQ: http://www.whacked.net/ldl/faq
                > > > > > Yahoo! Groups Links
                > > > > >
                > > > > >
                > > > > >
                > > > > >
                > > > > >
                > > > > >
                > > > > >
                > > >
                > > >
                > > >
                > > >
                > > >
                > > > --------------------------------------------------------------
                > > > Please post your X config files in the group links or database
                > > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                > > > FAQ: http://www.whacked.net/ldl/faq
                > > > Yahoo! Groups Links
                > > >
                > > >
                > > >
                > > >
                > > >
                > > >
                > > >
                >
                >
                >
                >
                >
                > --------------------------------------------------------------
                > Please post your X config files in the group links or database
                > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                > FAQ: http://www.whacked.net/ldl/faq
                > Yahoo! Groups Links
                >
                >
                >
                >
                >
                >
                >
              • Damien Solley
                Also, their is a site for keeping your RH9 installation up to date: http://fedoralegacy.org Regards Damien
                Message 7 of 9 , Jan 15, 2005
                • 0 Attachment
                  Also, their is a site for keeping your RH9 installation up to date:
                  http://fedoralegacy.org
                  Regards
                  Damien

                  On Sun, 2005-01-16 at 00:37 +0000, Matt wrote:
                  >
                  > Damien,
                  >
                  > Thanks so much, creating the .xsession did the trick. Somehow it
                  > either got erased or it was never there, but now it boots straight
                  > into gnome. I appreciate your help, and now that everything seems to
                  > be working flawlessly, i'll give linux a serious try.
                  >
                  > Thanks so much,
                  > Matt
                  >
                  >
                  > --- In linux-dell-laptops@yahoogroups.com, Damien Solley
                  > <dsolley.listmail@g...> wrote:
                  > > Hi Matt,
                  > > You could do runlevel 3, but it sounds like the login isn't working.
                  > > Anyway, there's another option. From the login, the "Default" session
                  > > looks for the file .xsession (identical to .xinitrc). So, I'd try (from
                  > > your xterm):
                  > > touch .xsession
                  > > chmod +x .xsession
                  > > echo "gnome-session" > .xsession
                  > > Then log into the "Default" session.
                  > > Also, are you sure you have Gnome installed?
                  > > Regards
                  > > Damien
                  > >
                  > >
                  > > On Sun, 2005-01-16 at 00:09 +0000, Matt wrote:
                  > > >
                  > > > Hey Damien,
                  > > >
                  > > > Sorry I wasnt clear earlier, but I only ran startx after updating my
                  > > > xfree install to check that it installed correctly. I'm at runlevel
                  > > > 5, and X starts as soon as I boot and brings me to the redhat login
                  > > > screen, where i'm able to choose sessions, as well as log in. I have
                  > > > my session chosen as gnome from there, yet it always starts as Twm.
                  > > >
                  > > > If you need to see any files, i'd be glad to paste them. As of now,
                  > > > i'm using the xterm to run firefox so I can read and reply to posts,
                  > > > but i'm also dualbooting winxp.
                  > > >
                  > > > I was wondering though, if the .xinitrc file works for startx, would I
                  > > > be able to change my runlevel down to 3 and use startx? If so, i'm
                  > > > not quite sure how to change the runlevel, but i'd be willing to try.
                  > > > I'd rather be able to boot straight in to X, but i'll take what I can
                  > > > get if that turns out to be the only option.
                  > > >
                  > > > Regards,
                  > > > Matt
                  > > >
                  > > > --- In linux-dell-laptops@yahoogroups.com, Damien Solley
                  > > > <dsolley.listmail@g...> wrote:
                  > > > > If you're starting X with "startx", then it looks for your specified
                  > > > > windowmanager in a file called ".xinitrc". If you have Gnome
                  > installed,
                  > > > > and you want to start it, do:
                  > > > > touch .xinitrc
                  > > > > chmod +x .xinitrc
                  > > > > echo "gnome-session" > .xinitrc
                  > > > > Then, when you run startx, you'll get a gnome session.
                  > > > > Regards
                  > > > > Damien
                  > > > >
                  > > > > On Sat, 2005-01-15 at 21:49 +0000, Matt wrote:
                  > > > > >
                  > > > > > Hey guys. I seem to have a strange problem. Ive always wanted
                  > to use
                  > > > > > Linux, but the only computer to run it on was this old I8k
                  > laptop i'm
                  > > > > > running. Ive tried several times in the past to use Linux on
                  > it, but
                  > > > > > I never stayed because X never wanted to work on this laptop. The
                  > > > > > last time I tried to run linux, I got X to work, but it was
                  > running
                  > > > > > off the processor isntead of the graphics card, so X was
                  > pretty slow.
                  > > > > > This time, I felt determined to get it working. I have RH9, the
                  > > > > > LinuxUser and Developer version I got out of a magazine. I
                  > installed
                  > > > > > it no problem, but as always, X didnt want to work. I found an
                  > > > > > Xconfig on this forum, in the files section, tried giving that a
                  > > > > > whirl, but alas, X didnt work. I decided to update my xfree86
                  > > > > > install, got the newest source, ran the install utility, and used
                  > > > > > startx. Low and behold, It works, but it only showed up using
                  > the Twm
                  > > > > > manager, so I rebooted, and was able to finally do the FirstBoot
                  > > > > > portion of the install, where I create a regular user and
                  > such. After
                  > > > > > that was done I was able to use the graphical login screen, so
                  > I chose
                  > > > > > Gnome as my session and logged in as my user. And just my
                  > luck, it
                  > > > > > runs the Twm manager. Ive done some searching on my system,
                  > and Gnome
                  > > > > > looks to be installed. I even tried reinstalling the RPM from
                  > my cd,
                  > > > > > but that didnt work. I tried logging as root and I still get
                  > the same
                  > > > > > manager. I tried a bit of fiddling with xinitrc file, but
                  > that didnt
                  > > > > > work. The funny thing is, I can run the gnome apps via the xterm
                  > > > > > window, I used to be able to even run gnome-session from it and it
                  > > > > > would open a window with my gnome desktop and another window
                  > with the
                  > > > > > gnome bar.
                  > > > > >
                  > > > > > So i'm coming to you guys. Anyone have any ideas why now that
                  > X will
                  > > > > > run, gnome wont?
                  > > > > >
                  > > > > >
                  > > > > >
                  > > > > >
                  > > > > >
                  > > > > > --------------------------------------------------------------
                  > > > > > Please post your X config files in the group links or database
                  > > > > > To unsubscribe, email:
                  > linux-dell-laptops-unsubscribe@yahoogroups.com
                  > > > > > FAQ: http://www.whacked.net/ldl/faq
                  > > > > > Yahoo! Groups Links
                  > > > > >
                  > > > > >
                  > > > > >
                  > > > > >
                  > > > > >
                  > > > > >
                  > > > > >
                  > > >
                  > > >
                  > > >
                  > > >
                  > > >
                  > > > --------------------------------------------------------------
                  > > > Please post your X config files in the group links or database
                  > > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                  > > > FAQ: http://www.whacked.net/ldl/faq
                  > > > Yahoo! Groups Links
                  > > >
                  > > >
                  > > >
                  > > >
                  > > >
                  > > >
                  > > >
                  >
                  >
                  >
                  >
                  >
                  > --------------------------------------------------------------
                  > Please post your X config files in the group links or database
                  > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                  > FAQ: http://www.whacked.net/ldl/faq
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                • Matt
                  Thanks for the info on upgrading Damien, but when I try to install yum, it gives me a failed dependency for gettext. I ve downloaded several rpms with gettext
                  Message 8 of 9 , Jan 15, 2005
                  • 0 Attachment
                    Thanks for the info on upgrading Damien, but when I try to install
                    yum, it gives me a failed dependency for gettext. I've downloaded
                    several rpms with gettext in the title, but none have worked so far.
                    If anyone could give me the correct rpm to grab, i'd be greatful.

                    Regards,
                    Matt
                  • Matt
                    Hey guys, Sorry about that last post but I seem to have found the file I was missing on the RPM search site.
                    Message 9 of 9 , Jan 15, 2005
                    • 0 Attachment
                      Hey guys,

                      Sorry about that last post but I seem to have found the file I was
                      missing on the RPM search site.




                      --- In linux-dell-laptops@yahoogroups.com, "Matt"
                      <thegreatgalstaf@h...> wrote:
                      >
                      > Thanks for the info on upgrading Damien, but when I try to install
                      > yum, it gives me a failed dependency for gettext. I've downloaded
                      > several rpms with gettext in the title, but none have worked so far.
                      > If anyone could give me the correct rpm to grab, i'd be greatful.
                      >
                      > Regards,
                      > Matt
                    Your message has been successfully submitted and would be delivered to recipients shortly.