Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] i8100 + FC3 + Suspend

Expand Messages
  • bil Jeschke
    Did you add resume=/dev/whatever_your_swap_is to your grub line also? I am using acpi with resume=/dev/hda3 and it works fine, except when I use the official
    Message 1 of 12 , Dec 29, 2004
    • 0 Attachment
      Did you add resume=/dev/whatever_your_swap_is to your grub line also?
      I am using acpi with resume=/dev/hda3 and it works fine, except when I use the
      official ATI driver, X does not resume well with that.

      --- junkmale0 <junkmale0@...> wrote:

      >
      > As many others have noted, FC3 is a nice distro right out of the
      > box. Everything seems to work great including my Linksys WPG54G
      > Wireless (after installing ndiswrapper) and my NVidia GForce 2Go
      > after installing the latest Nvidia drivers.
      >
      > But -- the suspend / resume functionality is of course not there.
      > Suspends fine, won't resume. (Note: I'm trying this in run level 3 -
      > - terminal mode first with the nvidia kernel module removed as well
      > as the ndiswrapper module). When I hit the power button, it brings
      > back the screen, but I can't actually execute any commands. I have
      > no prompt, but can type away. Hitting enter just takes me to the
      > next line. The command interpreter seems dead.
      >
      > Some basic info - I have appended the items "acpi=off apm=on" to my
      > grub.conf. I have upgraded to the latest BIOS (A15 I believe) and
      > the latest kernel from the rpm repository. Nothing seems to help.
      >
      > I'm beginning to pull my hair out over this so any help would be
      > most appreciated! I'm beginning to think I'm going to have to
      > recompile my kernel to get this working....
      >
      > Thanks again.
      >
      > MWood
      >
      >
      >
      >



      =====
      I am the Lord of the Realm of Stupidity
      All are Welcome to My Domain
      Good to See you again!



      __________________________________
      Do you Yahoo!?
      Meet the all-new My Yahoo! - Try it today!
      http://my.yahoo.com
    • junkmale0
      Thanks for the tip. I tried your idea last night with no success. Has anyone gotten an i8100 working with any of the Fedora releases? If so, what version of
      Message 2 of 12 , Dec 30, 2004
      • 0 Attachment
        Thanks for the tip. I tried your idea last night with no success.
        Has anyone gotten an i8100 working with any of the Fedora releases?
        If so, what version of the BIOS are you running.

        I'm starting to think I'm going to have to go to Ubuntu (sp?) or
        Debian to get this to work, but I'd hate to switch with no
        guarentee. Anyone got any distros that they know the i8100 suspend /
        resume works with?

        Thanks!

        MWood

        --- In linux-dell-laptops@yahoogroups.com, bil Jeschke
        <theuteck@y...> wrote:
        > Did you add resume=/dev/whatever_your_swap_is to your grub line
        also?
        > I am using acpi with resume=/dev/hda3 and it works fine, except
        when I use the
        > official ATI driver, X does not resume well with that.
        >
        > --- junkmale0 <junkmale0@y...> wrote:
        >
        > >
        > > As many others have noted, FC3 is a nice distro right out of the
        > > box. Everything seems to work great including my Linksys WPG54G
        > > Wireless (after installing ndiswrapper) and my NVidia GForce 2Go
        > > after installing the latest Nvidia drivers.
        > >
        > > But -- the suspend / resume functionality is of course not
        there.
        > > Suspends fine, won't resume. (Note: I'm trying this in run level
        3 -
        > > - terminal mode first with the nvidia kernel module removed as
        well
        > > as the ndiswrapper module). When I hit the power button, it
        brings
        > > back the screen, but I can't actually execute any commands. I
        have
        > > no prompt, but can type away. Hitting enter just takes me to the
        > > next line. The command interpreter seems dead.
        > >
        > > Some basic info - I have appended the items "acpi=off apm=on" to
        my
        > > grub.conf. I have upgraded to the latest BIOS (A15 I believe)
        and
        > > the latest kernel from the rpm repository. Nothing seems to
        help.
        > >
        > > I'm beginning to pull my hair out over this so any help would be
        > > most appreciated! I'm beginning to think I'm going to have to
        > > recompile my kernel to get this working....
        > >
        > > Thanks again.
        > >
        > > MWood
        > >
        > >
        > >
        > >
        >
        >
        >
        > =====
        > I am the Lord of the Realm of Stupidity
        > All are Welcome to My Domain
        > Good to See you again!
        >
        >
        >
        > __________________________________
        > Do you Yahoo!?
        > Meet the all-new My Yahoo! - Try it today!
        > http://my.yahoo.com
      • Dave Kristol
        [Sorry, folks. I botched the Subject when I started this thread. It s an i8200, not i8100.] ... I had suspend/resume working just find, 100% reliable, with
        Message 3 of 12 , Dec 30, 2004
        • 0 Attachment
          [Sorry, folks. I botched the Subject when I started this thread.
          It's an i8200, not i8100.]

          --- In linux-dell-laptops@yahoogroups.com, "junkmale0"
          <junkmale0@y...> wrote:
          >
          > Thanks for the tip. I tried your idea last night with no success.
          > Has anyone gotten an i8100 working with any of the Fedora releases?
          > If so, what version of the BIOS are you running.
          >
          > I'm starting to think I'm going to have to go to Ubuntu (sp?) or
          > Debian to get this to work, but I'd hate to switch with no
          > guarentee. Anyone got any distros that they know the i8100 suspend /
          > resume works with?

          I had suspend/resume working just find, 100% reliable, with RH8 and
          RH9, although it took a little fussing. (See
          <http://kristol.org/david/dell-i8200/>.) Makes you wonder why I
          wanted to try to get FC3 running, eh? :-(

          Dave Kristol
        • Dave Kristol
          ... And oops again. This wasn t actually my thread. (Close, but not cigar.) Dave Kristol
          Message 4 of 12 , Dec 30, 2004
          • 0 Attachment
            --- In linux-dell-laptops@yahoogroups.com, "Dave Kristol"
            <dmk-yahoo@k...> wrote:
            >
            > [Sorry, folks. I botched the Subject when I started this thread.
            > It's an i8200, not i8100.]

            And oops again. This wasn't actually my thread. (Close, but not cigar.)

            Dave Kristol
          • Benjamin Long
            See this post on my blog: http://bipolar.longbros.com/index.php?p=67&more=1&c=1&tb=1&pb=1#more67 I got it working fine on my 600m. Benjamin Long
            Message 5 of 12 , Dec 30, 2004
            • 0 Attachment
              See this post on my blog:
              http://bipolar.longbros.com/index.php?p=67&more=1&c=1&tb=1&pb=1#more67

              I got it working fine on my 600m.

              Benjamin Long
              On Wed, 2004-12-29 at 18:05 +0000, junkmale0 wrote:
              >
              > As many others have noted, FC3 is a nice distro right out of the
              > box. Everything seems to work great including my Linksys WPG54G
              > Wireless (after installing ndiswrapper) and my NVidia GForce 2Go
              > after installing the latest Nvidia drivers.
              >
              > But -- the suspend / resume functionality is of course not there.
              > Suspends fine, won't resume. (Note: I'm trying this in run level 3 -
              > - terminal mode first with the nvidia kernel module removed as well
              > as the ndiswrapper module). When I hit the power button, it brings
              > back the screen, but I can't actually execute any commands. I have
              > no prompt, but can type away. Hitting enter just takes me to the
              > next line. The command interpreter seems dead.
              >
              > Some basic info - I have appended the items "acpi=off apm=on" to my
              > grub.conf. I have upgraded to the latest BIOS (A15 I believe) and
              > the latest kernel from the rpm repository. Nothing seems to help.
              >
              > I'm beginning to pull my hair out over this so any help would be
              > most appreciated! I'm beginning to think I'm going to have to
              > recompile my kernel to get this working....
              >
              > Thanks again.
              >
              > MWood
              >
              >
              >
              >
              >
              >
              > --------------------------------------------------------------
              > Please post your X config files in the group links or database
              > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
              > FAQ: http://www.whacked.net/ldl/faq
              > Yahoo! Groups Links
              >
              >
              >
              >
              >
              >
              >
            • junkmale0
              Actually... you didn t botch the thread title. This is a different thread that I started about problems on an Inspiron 8100. Your thread is still alive and
              Message 6 of 12 , Dec 30, 2004
              • 0 Attachment
                Actually... you didn't botch the thread title. This is a different
                thread that I started about problems on an Inspiron 8100.

                Your thread is still alive and well (but with no replies I don't
                think). However, I believe that the blog link posted in my thread
                may help you more than me.

                Good luck!

                MWood


                --- In linux-dell-laptops@yahoogroups.com, "Dave Kristol" <dmk-
                yahoo@k...> wrote:
                >
                > [Sorry, folks. I botched the Subject when I started this thread.
                > It's an i8200, not i8100.]
                >
                > --- In linux-dell-laptops@yahoogroups.com, "junkmale0"
                > <junkmale0@y...> wrote:
                > >
                > > Thanks for the tip. I tried your idea last night with no
                success.
                > > Has anyone gotten an i8100 working with any of the Fedora
                releases?
                > > If so, what version of the BIOS are you running.
                > >
                > > I'm starting to think I'm going to have to go to Ubuntu (sp?) or
                > > Debian to get this to work, but I'd hate to switch with no
                > > guarentee. Anyone got any distros that they know the i8100
                suspend /
                > > resume works with?
                >
                > I had suspend/resume working just find, 100% reliable, with RH8 and
                > RH9, although it took a little fussing. (See
                > <http://kristol.org/david/dell-i8200/>.) Makes you wonder why I
                > wanted to try to get FC3 running, eh? :-(
                >
                > Dave Kristol
              • Dave Kristol
                ... I looked at the blog ( ), but I couldn t find any specific instructions, actually.
                Message 7 of 12 , Dec 30, 2004
                • 0 Attachment
                  --- In linux-dell-laptops@yahoogroups.com, "junkmale0"
                  <junkmale0@y...> wrote:
                  >
                  > Actually... you didn't botch the thread title. This is a different
                  > thread that I started about problems on an Inspiron 8100.
                  >
                  > Your thread is still alive and well (but with no replies I don't
                  > think). However, I believe that the blog link posted in my thread
                  > may help you more than me.

                  I looked at the blog
                  (<http://bipolar.longbros.com/index.php?p=67&more=1&c=1&tb=1&pb=1#more67>),
                  but I couldn't find any specific instructions, actually. In
                  particular, I would like specific instructions about how to download
                  xorg-x11. (Warning to others: on my display, the baseurl to add to
                  yum.conf was cut off and read:
                  baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/de
                  unless I did some magic to scroll to the right.)

                  Also, and this is probably important, I've got an nVidia GeForce 440
                  Go video chip, rather than Radion ATI, and my built-in wireless is a
                  Prism (Agere) chipset, not Intel. My 1400x1050 video did *not* work
                  out of the box. I had to download and install nVidia's driver to get it.

                  I'm going to experiment with the Xorg nv driver to see whether it does
                  suspend/resume to try to finger the culprit....

                  Dave Kristol
                • Chris Worley
                  I don t have the same laptop, but I ve come to find that DELL has very bad (non-existent) support for Linux in general, laptops in particular (as they require
                  Message 8 of 12 , Dec 30, 2004
                  • 0 Attachment
                    I don't have the same laptop, but I've come to find that DELL has very
                    bad (non-existent) support for Linux in general, laptops in particular
                    (as they require manufacturer support for all manufacturer-specific
                    issues). Toshiba has folks on the inside that work on these issues. If
                    you have a DELL laptop, Hibernate is probably your only option.

                    Hibernate isn't a bad option; If I could only get one of suspend-to-ram
                    or suspend-to-disk working, I'd probably choose the latter anyway... and
                    for most DELL laptops, that's your only option.

                    >From the SuSE Laptop mailing list:

                    > Does suspend to ram work any better than it did in 9.1? Should I try
                    it in 9.2?

                    Salomonic answer: if you have hardware where it works, it works better
                    than
                    in 9.1.

                    > Or is this still futile (Dell Latitude D600)?

                    If the dell has an ATI or NVidia or Intel graphics chipset, it will
                    probably
                    not be successful.

                    On Wed, 2004-12-29 at 11:05, junkmale0 wrote:
                    > As many others have noted, FC3 is a nice distro right out of the
                    > box. Everything seems to work great including my Linksys WPG54G
                    > Wireless (after installing ndiswrapper) and my NVidia GForce 2Go
                    > after installing the latest Nvidia drivers.
                    >
                    > But -- the suspend / resume functionality is of course not there.
                    > Suspends fine, won't resume. (Note: I'm trying this in run level 3 -
                    > - terminal mode first with the nvidia kernel module removed as well
                    > as the ndiswrapper module). When I hit the power button, it brings
                    > back the screen, but I can't actually execute any commands. I have
                    > no prompt, but can type away. Hitting enter just takes me to the
                    > next line. The command interpreter seems dead.
                    >
                    > Some basic info - I have appended the items "acpi=off apm=on" to my
                    > grub.conf. I have upgraded to the latest BIOS (A15 I believe) and
                    > the latest kernel from the rpm repository. Nothing seems to help.
                    >
                    > I'm beginning to pull my hair out over this so any help would be
                    > most appreciated! I'm beginning to think I'm going to have to
                    > recompile my kernel to get this working....
                    >
                    > Thanks again.
                    >
                    > MWood
                    >
                    >
                    >
                    >
                    >
                    >
                    > --------------------------------------------------------------
                    > Please post your X config files in the group links or database
                    > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                    > FAQ: http://www.whacked.net/ldl/faq
                    > Yahoo! Groups Links
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                  • Benjamin Long
                    Um... just add the repo to yum.conf like I have in the post, then yum --enablerepo=rawhide install xorg-x11 It doesn t get much easier then that. :) Benjamin
                    Message 9 of 12 , Dec 30, 2004
                    • 0 Attachment
                      Um... just add the repo to yum.conf like I have in the post, then
                      "yum --enablerepo=rawhide install xorg-x11"
                      It doesn't get much easier then that. :)

                      Benjamin Long
                      On Thu, 2004-12-30 at 15:21 +0000, Dave Kristol wrote:
                      >
                      > --- In linux-dell-laptops@yahoogroups.com, "junkmale0"
                      > <junkmale0@y...> wrote:
                      > >
                      > > Actually... you didn't botch the thread title. This is a different
                      > > thread that I started about problems on an Inspiron 8100.
                      > >
                      > > Your thread is still alive and well (but with no replies I don't
                      > > think). However, I believe that the blog link posted in my thread
                      > > may help you more than me.
                      >
                      > I looked at the blog
                      > (<http://bipolar.longbros.com/index.php?p=67&more=1&c=1&tb=1&pb=1#more67>),
                      > but I couldn't find any specific instructions, actually. In
                      > particular, I would like specific instructions about how to download
                      > xorg-x11. (Warning to others: on my display, the baseurl to add to
                      > yum.conf was cut off and read:
                      > baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/de
                      > unless I did some magic to scroll to the right.)
                      >
                      > Also, and this is probably important, I've got an nVidia GeForce 440
                      > Go video chip, rather than Radion ATI, and my built-in wireless is a
                      > Prism (Agere) chipset, not Intel. My 1400x1050 video did *not* work
                      > out of the box. I had to download and install nVidia's driver to get it.
                      >
                      > I'm going to experiment with the Xorg nv driver to see whether it does
                      > suspend/resume to try to finger the culprit....
                      >
                      > Dave Kristol
                      >
                      >
                      >
                      >
                      >
                      >
                      > --------------------------------------------------------------
                      > Please post your X config files in the group links or database
                      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                      > FAQ: http://www.whacked.net/ldl/faq
                      > Yahoo! Groups Links
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                    • Dave Kristol
                      ... I use the ... In my old i8200 setup (for APM), I had resume=force. What s the difference between resume=force and resume=/dev/hda3? (For that matter,
                      Message 10 of 12 , Dec 30, 2004
                      • 0 Attachment
                        --- In linux-dell-laptops@yahoogroups.com, bil Jeschke <theuteck@y...>
                        wrote:
                        > Did you add resume=/dev/whatever_your_swap_is to your grub line also?
                        > I am using acpi with resume=/dev/hda3 and it works fine, except when
                        I use the
                        > official ATI driver, X does not resume well with that.

                        In my old i8200 setup (for APM), I had resume=force. What's the
                        difference between resume=force and resume=/dev/hda3? (For that
                        matter, where can I find a complete list of the kernel parameters like
                        "resume" and what they do?)

                        Thanks
                        Dave Kristol
                      • junkmale0
                        Thanks for all the help. I disabled APM in my kernel and enabled acpi and now the fan control and processor throttling are working. When I try to send the
                        Message 11 of 12 , Dec 31, 2004
                        • 0 Attachment
                          Thanks for all the help. I disabled APM in my kernel and enabled acpi
                          and now the fan control and processor throttling are working.

                          When I try to send the laptop to suspend "echo "3" >
                          /proc/acpi/sleep", the display comes on full white and then it looks
                          like it goes into suspend. Only problem is when I come back, the
                          display is all garbled. Now I tried what you mention in your blog and
                          it didn't seem to fix anything. Then again, I'm not trying under X,
                          just under a command prompt, so I guess it wouldn't matter anyway.

                          Any more ideas anyone? While I can't suspend, I can at least throttle
                          my cpu so the darn laptop doesn't get so hot.

                          MWood


                          --- In linux-dell-laptops@yahoogroups.com, Benjamin Long <bflong@s...>
                          wrote:
                          > See this post on my blog:
                          > http://bipolar.longbros.com/index.php?p=67&more=1&c=1&tb=1&pb=1#more67
                          >
                          > I got it working fine on my 600m.
                          >
                          > Benjamin Long
                          > On Wed, 2004-12-29 at 18:05 +0000, junkmale0 wrote:
                          > >
                          > > As many others have noted, FC3 is a nice distro right out of the
                          > > box. Everything seems to work great including my Linksys WPG54G
                          > > Wireless (after installing ndiswrapper) and my NVidia GForce 2Go
                          > > after installing the latest Nvidia drivers.
                          > >
                          > > But -- the suspend / resume functionality is of course not there.
                          > > Suspends fine, won't resume. (Note: I'm trying this in run level 3 -
                          > > - terminal mode first with the nvidia kernel module removed as well
                          > > as the ndiswrapper module). When I hit the power button, it brings
                          > > back the screen, but I can't actually execute any commands. I have
                          > > no prompt, but can type away. Hitting enter just takes me to the
                          > > next line. The command interpreter seems dead.
                          > >
                          > > Some basic info - I have appended the items "acpi=off apm=on" to my
                          > > grub.conf. I have upgraded to the latest BIOS (A15 I believe) and
                          > > the latest kernel from the rpm repository. Nothing seems to help.
                          > >
                          > > I'm beginning to pull my hair out over this so any help would be
                          > > most appreciated! I'm beginning to think I'm going to have to
                          > > recompile my kernel to get this working....
                          > >
                          > > Thanks again.
                          > >
                          > > MWood
                          > >
                          > >
                          > >
                          > >
                          > >
                          > >
                          > > --------------------------------------------------------------
                          > > Please post your X config files in the group links or database
                          > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                          > > FAQ: http://www.whacked.net/ldl/faq
                          > > Yahoo! Groups Links
                          > >
                          > >
                          > >
                          > >
                          > >
                          > >
                          > >
                        Your message has been successfully submitted and would be delivered to recipients shortly.