Loading ...
Sorry, an error occurred while loading the content.

Dell Inspiron 9100 WSXGA and Ubuntu/Debian

Expand Messages
  • froogleuk
    Hey all, I ve been having a nightmare time getting my Dell Inspiron to work with X at the correct resolution (1680x1050). I ve managed to get the latest ATI
    Message 1 of 6 , Dec 3, 2004
    • 0 Attachment
      Hey all,

      I've been having a nightmare time getting my Dell Inspiron to work
      with X at the correct resolution (1680x1050). I've managed to get
      the latest ATI drivers downloaded, compiled and installed, so I'm
      running X against the fglrx driver. I've also tried the "ati" driver
      (I'm in XFree 4 by the way) but X won't even start with that and
      crashes out saying No devices detected.

      SO, has anyone out there, with this screen, managed to get X working
      on Debian or Ubuntu at 1680x1050 resolution?

      PEte
    • danielluera@yahoo.com
      I m using gentoo for my install, though I have the nVidia card, but have the same screen. Another difference is that I m running Xorg. But, the part that you
      Message 2 of 6 , Dec 3, 2004
      • 0 Attachment
        I'm using gentoo for my install, though I have the nVidia card, but
        have the same screen.

        Another difference is that I'm running Xorg. But, the part that you
        need to put in is the mode lines for that screen. After I put mine in
        it worked like a champ.

        You can check out this site for the required edits.

        http://resolute.ucsd.edu/diwaker/articles/linux-dell-8600.html

        But, if you're too lazy to look there you can just add this to your
        XF86Config (beware of line wrap, you've been warned):

        Section "Modes"
        Identifier "16:10"
        # 1280x800 @ 75.00 Hz (GTF) hsync: 62.62 kHz; pclk: 107.21 MHz
        Modeline "1280x800" 107.21 1280 1360 1496 1712 800 801 804 835
        # 1280x800 @ 85.00 Hz (GTF) hsync: 71.40 kHz; pclk: 123.38 MHz
        Modeline "1280x800" 123.38 1280 1368 1504 1728 800 801 804 840
        # 1280x800 @ 100.00 Hz (GTF) hsync: 84.80 kHz; pclk: 147.89 MHz
        Modeline "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848
        # 1680x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 147.14 MHz
        Modeline "1680x1050" 147.14 1680 1784 1968 2256 1050 1051 1054 1087
        # 1680x1050 @ 75.00 Hz (GTF) hsync: 82.20 kHz; pclk: 188.07 MHz
        Modeline "1680x1050" 188.07 1680 1800 1984 2288 1050 1051 1054 1096
        # 1680x1050 @ 85.00 Hz (GTF) hsync: 93.76 kHz; pclk: 214.51 MHz
        Modeline "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103
        # 1680x1050 @ 100.00 Hz (GTF) hsync: 111.20 kHz; pclk: 256.20 MHz
        Modeline "1680x1050" 256.20 1680 1808 1992 2304 1050 1051 1054 1112
        # 1920x1200 @ 75.00 Hz (GTF) hsync: 93.97 kHz; pclk: 246.59 MHz
        Modeline "1920x1200" 246.59 1920 2064 2272 2624 1200 1201 1204 1253
        # 1920x1200 @ 85.00 Hz (GTF) hsync: 107.10 kHz; pclk: 282.74 MHz
        Modeline "1920x1200" 282.74 1920 2072 2280 2640 1200 1201 1204 1260
        # 1920x1200 @ 100.00 Hz (GTF) hsync: 127.10 kHz; pclk: 337.58 MHz
        Modeline "1920x1200" 337.58 1920 2072 2288 2656 1200 1201 1204 1271
        EndSection

        --- In linux-dell-laptops@yahoogroups.com, "froogleuk"
        <peterjwright@g...> wrote:
        >
        > Hey all,
        >
        > I've been having a nightmare time getting my Dell Inspiron to work
        > with X at the correct resolution (1680x1050). I've managed to get
        > the latest ATI drivers downloaded, compiled and installed, so I'm
        > running X against the fglrx driver. I've also tried the "ati" driver
        > (I'm in XFree 4 by the way) but X won't even start with that and
        > crashes out saying No devices detected.
        >
        > SO, has anyone out there, with this screen, managed to get X working
        > on Debian or Ubuntu at 1680x1050 resolution?
        >
        > PEte
      • ken
        ... The first thing to do is to get X working at *any* resolution. After that you can tweak it for the desired resolution. Moreover, if the video device
        Message 3 of 6 , Dec 5, 2004
        • 0 Attachment
          froogleuk wrote:

          >Hey all,
          >
          >I've been having a nightmare time getting my Dell Inspiron to work
          >with X at the correct resolution (1680x1050). I've managed to get
          >the latest ATI drivers downloaded, compiled and installed, so I'm
          >running X against the fglrx driver. I've also tried the "ati" driver
          >(I'm in XFree 4 by the way) but X won't even start with that and
          >crashes out saying No devices detected.
          >
          >SO, has anyone out there, with this screen, managed to get X working
          >on Debian or Ubuntu at 1680x1050 resolution?
          >
          >PEte
          >
          >

          The first thing to do is to get X working at *any* resolution. After
          that you can tweak it for the desired resolution. Moreover, if the
          video device isn't detected, you're not going to be able to get X going
          at all. Have you checked the log files?

          hth,
          ken

          --
          Reality is complicated.
          Bush is simple.
        • Pete Wright
          Thanks. Yes, I had X working with both the Vesa and the fglrx drivers without any problems. The problems kicked in when I tried to use a very specific
          Message 4 of 6 , Dec 5, 2004
          • 0 Attachment
            Thanks.

            Yes, I had X working with both the Vesa and the fglrx drivers without
            any problems. The problems kicked in when I tried to use a very
            specific resolution (1680x1050). XFree just wouldn't have it with any
            of the drivers insisting in all cases that there was no such mode.

            I've now upgraded to XOrg and it's all fine by default, so problem solved.

            Thanks for taking the time to reply

            PEte



            On Sun, 05 Dec 2004 06:52:17 -0500, ken <gebser@...> wrote:
            > froogleuk wrote:
            >
            > >Hey all,
            > >
            > >I've been having a nightmare time getting my Dell Inspiron to work
            > >with X at the correct resolution (1680x1050). I've managed to get
            > >the latest ATI drivers downloaded, compiled and installed, so I'm
            > >running X against the fglrx driver. I've also tried the "ati" driver
            > >(I'm in XFree 4 by the way) but X won't even start with that and
            > >crashes out saying No devices detected.
            > >
            > >SO, has anyone out there, with this screen, managed to get X working
            > >on Debian or Ubuntu at 1680x1050 resolution?
            > >
            > >PEte
            > >
            > >
            >
            > The first thing to do is to get X working at *any* resolution. After
            > that you can tweak it for the desired resolution. Moreover, if the
            > video device isn't detected, you're not going to be able to get X going
            > at all. Have you checked the log files?
            >
            > hth,
            > ken
            >
            > --
            > Reality is complicated.
            > Bush is simple.
            >
            >
            >
            > --------------------------------------------------------------
            > Please post your X config files in the group links or database
            > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
            > FAQ: http://www.whacked.net/ldl/faq
            >
            >
            >
            > Yahoo! Groups Sponsor
            >
            > ADVERTISEMENT
            >
            >
            > ________________________________
            > Yahoo! Groups Links
            >
            > To visit your group on the web, go to:
            > http://groups.yahoo.com/group/linux-dell-laptops/
            >
            > To unsubscribe from this group, send an email to:
            > linux-dell-laptops-unsubscribe@yahoogroups.com
            >
            > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
          • shfriedrich
            i have a similar problem. all works fine for internal display but when connecting to a Sony LCD, resolution only goes to 800x600, the display has 1600x1100. I
            Message 5 of 6 , Dec 5, 2004
            • 0 Attachment
              i have a similar problem. all works fine for internal display but
              when connecting to a Sony LCD, resolution only goes to 800x600, the
              display has 1600x1100. I run Xorg.

              Thanks, Lars

              --- In linux-dell-laptops@yahoogroups.com, Pete Wright
              <peterjwright@g...> wrote:
              > Thanks.
              >
              > Yes, I had X working with both the Vesa and the fglrx drivers
              without
              > any problems. The problems kicked in when I tried to use a very
              > specific resolution (1680x1050). XFree just wouldn't have it with
              any
              > of the drivers insisting in all cases that there was no such mode.
              >
              > I've now upgraded to XOrg and it's all fine by default, so problem
              solved.
              >
              > Thanks for taking the time to reply
              >
              > PEte
              >
              >
              >
              > On Sun, 05 Dec 2004 06:52:17 -0500, ken <gebser@s...> wrote:
              > > froogleuk wrote:
              > >
              > > >Hey all,
              > > >
              > > >I've been having a nightmare time getting my Dell Inspiron to
              work
              > > >with X at the correct resolution (1680x1050). I've managed to
              get
              > > >the latest ATI drivers downloaded, compiled and installed, so
              I'm
              > > >running X against the fglrx driver. I've also tried the "ati"
              driver
              > > >(I'm in XFree 4 by the way) but X won't even start with that
              and
              > > >crashes out saying No devices detected.
              > > >
              > > >SO, has anyone out there, with this screen, managed to get X
              working
              > > >on Debian or Ubuntu at 1680x1050 resolution?
              > > >
              > > >PEte
              > > >
              > > >
              > >
              > > The first thing to do is to get X working at *any* resolution.
              After
              > > that you can tweak it for the desired resolution. Moreover, if
              the
              > > video device isn't detected, you're not going to be able to get
              X going
              > > at all. Have you checked the log files?
              > >
              > > hth,
              > > ken
              > >
              > > --
              > > Reality is complicated.
              > > Bush is simple.
              > >
              > >
              > >
              > > --------------------------------------------------------------
              > > Please post your X config files in the group links or database
              > > To unsubscribe, email: linux-dell-laptops-
              unsubscribe@yahoogroups.com
              > > FAQ: http://www.whacked.net/ldl/faq
              > >
              > >
              > >
              > > Yahoo! Groups Sponsor
              > >
              > > ADVERTISEMENT
              > >
              > >
              > > ________________________________
              > > Yahoo! Groups Links
              > >
              > > To visit your group on the web, go to:
              <a href="http://www.clearanceclub.com">laptos</a>
              > > http://groups.yahoo.com/group/linux-dell-laptops/
              > >
              > > To unsubscribe from this group, send an email to:
              > > linux-dell-laptops-unsubscribe@yahoogroups.com
              > >
              > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
              Service.
            • Pete Wright
              Well, in the end I upgraded to xOrg and everything was fine. I used the ATI driver in XORG if that helps, but didn t need to add any modelines or anything. In
              Message 6 of 6 , Dec 6, 2004
              • 0 Attachment
                Well, in the end I upgraded to xOrg and everything was fine. I used
                the ATI driver in XORG if that helps, but didn't need to add any
                modelines or anything. In fact, the only thing I did change in the
                xorg.conf file was to explicitly state that I wanted a resolution of
                1680 x 1050 (my internal display resolution).

                Pete



                On Mon, 06 Dec 2004 05:34:21 -0000, shfriedrich <shfriedrich@...> wrote:
                >
                > i have a similar problem. all works fine for internal display but
                > when connecting to a Sony LCD, resolution only goes to 800x600, the
                > display has 1600x1100. I run Xorg.
                >
                > Thanks, Lars
                >
                > --- In linux-dell-laptops@yahoogroups.com, Pete Wright
                >
                >
                > <peterjwright@g...> wrote:
                > > Thanks.
                > >
                > > Yes, I had X working with both the Vesa and the fglrx drivers
                > without
                > > any problems. The problems kicked in when I tried to use a very
                > > specific resolution (1680x1050). XFree just wouldn't have it with
                > any
                > > of the drivers insisting in all cases that there was no such mode.
                > >
                > > I've now upgraded to XOrg and it's all fine by default, so problem
                > solved.
                > >
                > > Thanks for taking the time to reply
                > >
                > > PEte
                > >
                > >
                > >
                > > On Sun, 05 Dec 2004 06:52:17 -0500, ken <gebser@s...> wrote:
                > > > froogleuk wrote:
                > > >
                > > > >Hey all,
                > > > >
                > > > >I've been having a nightmare time getting my Dell Inspiron to
                > work
                > > > >with X at the correct resolution (1680x1050). I've managed to
                > get
                > > > >the latest ATI drivers downloaded, compiled and installed, so
                > I'm
                > > > >running X against the fglrx driver. I've also tried the "ati"
                > driver
                > > > >(I'm in XFree 4 by the way) but X won't even start with that
                > and
                > > > >crashes out saying No devices detected.
                > > > >
                > > > >SO, has anyone out there, with this screen, managed to get X
                > working
                > > > >on Debian or Ubuntu at 1680x1050 resolution?
                > > > >
                > > > >PEte
                > > > >
                > > > >
                > > >
                > > > The first thing to do is to get X working at *any* resolution.
                > After
                > > > that you can tweak it for the desired resolution. Moreover, if
                > the
                > > > video device isn't detected, you're not going to be able to get
                > X going
                > > > at all. Have you checked the log files?
                > > >
                > > > hth,
                > > > ken
                > > >
                > > > --
                > > > Reality is complicated.
                > > > Bush is simple.
                > > >
                > > >
                > > >
                > > > --------------------------------------------------------------
                > > > Please post your X config files in the group links or database
                > > > To unsubscribe, email: linux-dell-laptops-
                > unsubscribe@yahoogroups.com
                > > > FAQ: http://www.whacked.net/ldl/faq
                > > >
                > > >
                > > >
                > > > Yahoo! Groups Sponsor
                > > >
                > > > ADVERTISEMENT
                > > >
                > > >
                > > > ________________________________
                > > > Yahoo! Groups Links
                > > >
                > > > To visit your group on the web, go to:
                > <a href="http://www.clearanceclub.com">laptos</a>
                >
                >
                > > > http://groups.yahoo.com/group/linux-dell-laptops/
                > > >
                > > > To unsubscribe from this group, send an email to:
                > > > linux-dell-laptops-unsubscribe@yahoogroups.com
                > > >
                > > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of
                > Service.
                >
                >
                >
                >
                >
                >
                >
                > --------------------------------------------------------------
                > Please post your X config files in the group links or database
                > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                > FAQ: http://www.whacked.net/ldl/faq
                >
                >
                >
                > Yahoo! Groups Sponsor
                >
                > ADVERTISEMENT
                >
                >
                > ________________________________
                > Yahoo! Groups Links
                >
                > To visit your group on the web, go to:
                > http://groups.yahoo.com/group/linux-dell-laptops/
                >
                > To unsubscribe from this group, send an email to:
                > linux-dell-laptops-unsubscribe@yahoogroups.com
                >
                > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
              Your message has been successfully submitted and would be delivered to recipients shortly.