Loading ...
Sorry, an error occurred while loading the content.

Re: ndiswrapper, Inspiron XPS and TrueMobile 1300

Expand Messages
  • Mat R
    Thanks - I ll give it a go!
    Message 1 of 5 , Nov 1, 2004
    • 0 Attachment
      Thanks - I'll give it a go!

      --- In linux-dell-laptops@yahoogroups.com, "Robert" <falcatemoon@y...>
      wrote:
      >
      > Well first you should attempt turning off all wep from the router and
      > run it open just to see if it is working. I found that certain
      > routers, like my netgear does not work with linux with wep turned on,
      > however my 3com at work works fine.
      >
      > Secondly you need to create a ifcfg file for your card and router.
      >
      > here is mine for example:
      > File Name:
      > ifcfg-wlan0
      > Contents:
      > ######################
      > BOOTPROTO='dhcp'
      > DHCLIENT_SET_DOWN_LINK='yes'
      > MTU=''
      > REMOTE_IPADDR=''
      > STARTMODE='manual'
      > UNIQUE=''
      > WIRELESS_ESSID='Your ID Here'
      > WIRELESS_KEY='Your Key Here, leave blank if not using wep'
      > WIRELESS_MODE='Managed'
      > WIRELESS_NICK=''
      > WIRELESS_NWID=''
      > ######################
      >
      > copy this file to:
      > /etc/sysconfig/network/
      >
      > To access your network:
      > run the following commands...
      > (usually as root)
      > modprobe ndiswrapper
      > ifup wlan0 wlan0
      >
      > if you do not get an ip at first run dhcpcd, I dot not ever need to
      > run this though.
      >
      > You can configure modprobe to load this at start up but I do not do
      > this (so I no longer remember how to) as I connect to several wireless
      > networks.
      >
      > --- In linux-dell-laptops@yahoogroups.com, "Mat R" <riain@o...> wrote:
      > >
      > > Hello!
      > >
      > > I successfully installed SuSE 9.2 (I work for a Novell partner and
      > got
      > > an advance release) on my XPS, and I am just a step away from
      > getting
      > > the WiFi to work. I can't figure out what step I'm missing...
      > >
      > > I installed ndiswrapper during the default install, loaded the
      > driver
      > > for my card and I am able to see it successfully loaded. Iwconfig
      > > reports that wlan0 is up, and if I run iwlist wlan0 scan I can see
      > my
      > > access point. I tried giving wlan0 an IP address through ifconfig,
      > > but I am still unable to see/ping anything.
      > >
      > > When I shut the system down, it complained that wlan0 had no
      > > profile... Can someone point me in the right direction?
    • Mat R
      Thanks for the tip... It actually worked first time around - to my delight I was up and surfing the net. I couldn t ping any local addresses, oddly enough,
      Message 2 of 5 , Nov 1, 2004
      • 0 Attachment
        Thanks for the tip...

        It actually worked first time around - to my delight I was up and
        surfing the net. I couldn't ping any local addresses, oddly enough,
        but it was better than nothing.

        However, I couldn't leave well enough alone and I tried to edit the
        ifcfg file to allow for a static IP. I was no longer able to access
        the internet after that.

        To confound things I went into yast to see how the system viewed the
        card... This generated a new ifcfg file and overwrote my original
        settings.

        I have since gone back and recreated the original ifcfg file, but no
        luck. Whenever I type ifup wlan0, the dhcp request just times out.




        --- In linux-dell-laptops@yahoogroups.com, "Robert" <falcatemoon@y...>
        wrote:
        >
        > Well first you should attempt turning off all wep from the router and
        > run it open just to see if it is working. I found that certain
        > routers, like my netgear does not work with linux with wep turned on,
        > however my 3com at work works fine.
        >
        > Secondly you need to create a ifcfg file for your card and router.
        >
        > here is mine for example:
        > File Name:
        > ifcfg-wlan0
        > Contents:
        > ######################
        > BOOTPROTO='dhcp'
        > DHCLIENT_SET_DOWN_LINK='yes'
        > MTU=''
        > REMOTE_IPADDR=''
        > STARTMODE='manual'
        > UNIQUE=''
        > WIRELESS_ESSID='Your ID Here'
        > WIRELESS_KEY='Your Key Here, leave blank if not using wep'
        > WIRELESS_MODE='Managed'
        > WIRELESS_NICK=''
        > WIRELESS_NWID=''
        > ######################
        >
        > copy this file to:
        > /etc/sysconfig/network/
        >
        > To access your network:
        > run the following commands...
        > (usually as root)
        > modprobe ndiswrapper
        > ifup wlan0 wlan0
        >
        > if you do not get an ip at first run dhcpcd, I dot not ever need to
        > run this though.
        >
        > You can configure modprobe to load this at start up but I do not do
        > this (so I no longer remember how to) as I connect to several wireless
        > networks.
        >
        > --- In linux-dell-laptops@yahoogroups.com, "Mat R" <riain@o...> wrote:
        > >
        > > Hello!
        > >
        > > I successfully installed SuSE 9.2 (I work for a Novell partner and
        > got
        > > an advance release) on my XPS, and I am just a step away from
        > getting
        > > the WiFi to work. I can't figure out what step I'm missing...
        > >
        > > I installed ndiswrapper during the default install, loaded the
        > driver
        > > for my card and I am able to see it successfully loaded. Iwconfig
        > > reports that wlan0 is up, and if I run iwlist wlan0 scan I can see
        > my
        > > access point. I tried giving wlan0 an IP address through ifconfig,
        > > but I am still unable to see/ping anything.
        > >
        > > When I shut the system down, it complained that wlan0 had no
        > > profile... Can someone point me in the right direction?
      • Robert
        hmm that sounds like what happened the first time I tried ndiswrapper, I also overwrote my ifcfg file through yast. I did to things to fix the issue... I
        Message 3 of 5 , Nov 1, 2004
        • 0 Attachment
          hmm that sounds like what happened the first time I tried ndiswrapper,
          I also overwrote my ifcfg file through yast.

          I did to things to fix the issue...

          I complied the newest ndiswrapper from their site.

          I also found an older driver they recommended... ndiswrapper's site
          has a list of drivers that you can download.

          checkout:
          http://ndiswrapper.sourceforge.net/wiki/index.php/List

          This was all on 9.1 nut I can't imagine 9.2 is that much different.

          --- In linux-dell-laptops@yahoogroups.com, "Mat R" <riain@o...> wrote:
          >
          > Thanks for the tip...
          >
          > It actually worked first time around - to my delight I was up and
          > surfing the net. I couldn't ping any local addresses, oddly enough,
          > but it was better than nothing.
          >
          > However, I couldn't leave well enough alone and I tried to edit the
          > ifcfg file to allow for a static IP. I was no longer able to access
          > the internet after that.
          >
          > To confound things I went into yast to see how the system viewed the
          > card... This generated a new ifcfg file and overwrote my original
          > settings.
          >
          > I have since gone back and recreated the original ifcfg file, but no
          > luck. Whenever I type ifup wlan0, the dhcp request just times out.
          >
          >
          >
          >
          > --- In linux-dell-laptops@yahoogroups.com, "Robert" <falcatemoon@y...>
          > wrote:
          > >
          > > Well first you should attempt turning off all wep from the router and
          > > run it open just to see if it is working. I found that certain
          > > routers, like my netgear does not work with linux with wep turned on,
          > > however my 3com at work works fine.
          > >
          > > Secondly you need to create a ifcfg file for your card and router.
          > >
          > > here is mine for example:
          > > File Name:
          > > ifcfg-wlan0
          > > Contents:
          > > ######################
          > > BOOTPROTO='dhcp'
          > > DHCLIENT_SET_DOWN_LINK='yes'
          > > MTU=''
          > > REMOTE_IPADDR=''
          > > STARTMODE='manual'
          > > UNIQUE=''
          > > WIRELESS_ESSID='Your ID Here'
          > > WIRELESS_KEY='Your Key Here, leave blank if not using wep'
          > > WIRELESS_MODE='Managed'
          > > WIRELESS_NICK=''
          > > WIRELESS_NWID=''
          > > ######################
          > >
          > > copy this file to:
          > > /etc/sysconfig/network/
          > >
          > > To access your network:
          > > run the following commands...
          > > (usually as root)
          > > modprobe ndiswrapper
          > > ifup wlan0 wlan0
          > >
          > > if you do not get an ip at first run dhcpcd, I dot not ever need to
          > > run this though.
          > >
          > > You can configure modprobe to load this at start up but I do not do
          > > this (so I no longer remember how to) as I connect to several wireless
          > > networks.
          > >
          > > --- In linux-dell-laptops@yahoogroups.com, "Mat R" <riain@o...> wrote:
          > > >
          > > > Hello!
          > > >
          > > > I successfully installed SuSE 9.2 (I work for a Novell partner and
          > > got
          > > > an advance release) on my XPS, and I am just a step away from
          > > getting
          > > > the WiFi to work. I can't figure out what step I'm missing...
          > > >
          > > > I installed ndiswrapper during the default install, loaded the
          > > driver
          > > > for my card and I am able to see it successfully loaded. Iwconfig
          > > > reports that wlan0 is up, and if I run iwlist wlan0 scan I can see
          > > my
          > > > access point. I tried giving wlan0 an IP address through ifconfig,
          > > > but I am still unable to see/ping anything.
          > > >
          > > > When I shut the system down, it complained that wlan0 had no
          > > > profile... Can someone point me in the right direction?
        Your message has been successfully submitted and would be delivered to recipients shortly.