Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] 5150 and cpufreq

Expand Messages
  • Ivan Fernandez
    ... I ll attach the whole .config this time, see if you find something else that might make the difference. FYU, I have eight different frequency points. --
    Message 1 of 9 , Oct 31, 2004
    • 0 Attachment
      On Sun, Oct 31, 2004 at 07:45:01PM -0500, Gregory F. March wrote:
      >
      >
      > On Oct 31, 2004, Ivan Fernandez <ivan.fernandez@...> wrote:
      >
      > |See below the relevant sections from my .config file, from a 2.6.9
      > |vanilla home-compiled kernel. I think that the ACPI frequency driver
      > |(which you have compiled into the kernel, so it takes preemincence)
      > |conflicts with the P4 driver, which is what you actually need (at least,
      > |that's what's worked for me). Another issue could be the userspace
      > |daemon that controls frequency switching (you don't mention any). I use
      > |powernowd (sarge debian package, don't know if FC ships with it).
      >
      > Following your .config (actually, making mine look just like yours),
      > means that there is no /sys/devices/system/cpu/cpu0/cpufreq files.
      >
      > Is that what you have?
      >
      > Also, I still see only 1.6GHz and 3.06GHz according to the gnome applet
      > "CPU Frequency Scaling Monitor 0.1.3" and the gkrellm gx85info plugin.
      >
      I'll attach the whole .config this time, see if you find something else
      that might make the difference. FYU, I have eight different frequency
      points.

      --
      Ivan Fernández
      ivan.fernandez@...
    • Gregory F. March
      ... Ivan, Thanks for the help. I went through my .config and change it to mimic yours and now I have all 8 steps in the scaling_available_frequencies file.
      Message 2 of 9 , Nov 1, 2004
      • 0 Attachment
        On Oct 31, 2004, Ivan Fernandez <ivan.fernandez@...> wrote:

        |I'll attach the whole .config this time, see if you find something else
        |that might make the difference. FYU, I have eight different frequency
        |points.

        Ivan,

        Thanks for the help. I went through my .config and change it to mimic
        yours and now I have all 8 steps in the scaling_available_frequencies
        file.

        I'm running cpufreqd with a slightly modified cpufreqd.conf (basically
        it lets the processor scale even when on AC). and things seem to be
        working well.

        I notice that cpufreqd doesn't bump up the speed when the cpu is
        consumed by a "nice" process (like setiathome), and I can't figure out
        how to make it scale under that circumstance. I can live with that
        though.

        Also, I notice the fan stays on all the time (the temp is hovering
        around 68-74 C). It is on a lower rpm setting and I can make it go
        higher or lower (including off) if I muck with the i8kmon stuff. But,
        under normal operation, it is just "on low" all the time. Is that
        normal for you?

        Thanks for all your help...

        /greg




        --
        Gregory F. March | http://www.gfm.net:443/~march | AIM:GfmNet
      • Robert
        On a side note to this subject: I updated my bios to revision A37 and it seems to accomplish something similar to what you achieved. Before the update I was on
        Message 3 of 9 , Nov 1, 2004
        • 0 Attachment
          On a side note to this subject:

          I updated my bios to revision A37 and it seems to accomplish something
          similar to what you achieved.

          Before the update I was on A35, when linux came up it would sit around
          73-76C... I noticed that my fan never ran. Occasionally the computer
          would shut off.

          Updated my bios and now it sits around 68-74C, now the fans seems to
          run at full speed all of the time... much like yours.

          Still you really do not want your processor to go over 70c...

          At this point I just decided to turn of speedsteping in the bios...
          which brings my processor down to 1.6 but my temp stays at 54-58.

          I can't get i8k to work on my system, even though it appears to be
          complied in my kernel.. so I can't play around with that.

          hmmm

          --- In linux-dell-laptops@yahoogroups.com, "Gregory F. March"
          <march@g...> wrote:
          >
          > On Oct 31, 2004, Ivan Fernandez <ivan.fernandez@y...> wrote:
          >
          > |I'll attach the whole .config this time, see if you find something
          else
          > |that might make the difference. FYU, I have eight different
          frequency
          > |points.
          >
          > Ivan,
          >
          > Thanks for the help. I went through my .config and change it to
          mimic
          > yours and now I have all 8 steps in the scaling_
          available_frequencies
          > file.
          >
          > I'm running cpufreqd with a slightly modified cpufreqd.conf
          (basically
          > it lets the processor scale even when on AC). and things seem to be
          > working well.
          >
          > I notice that cpufreqd doesn't bump up the speed when the cpu is
          > consumed by a "nice" process (like setiathome), and I can't figure
          out
          > how to make it scale under that circumstance. I can live with that
          > though.
          >
          > Also, I notice the fan stays on all the time (the temp is hovering
          > around 68-74 C). It is on a lower rpm setting and I can make it go
          > higher or lower (including off) if I muck with the i8kmon stuff.
          But,
          > under normal operation, it is just "on low" all the time. Is that
          > normal for you?
          >
          > Thanks for all your help...
          >
          > /greg
          >
          >
          >
          >
          > --
          > Gregory F. March | http://www.gfm.net:443/~march |
          AIM:GfmNet
        • LaToya Parsee
          please take me off this e groups I don t want to recieve any more messages.
          Message 4 of 9 , Nov 1, 2004
          • 0 Attachment
            please take me off this e groups I don't want to
            recieve any more messages.
            --- Robert <falcatemoon@...> wrote:

            >
            > On a side note to this subject:
            >
            > I updated my bios to revision A37 and it seems to
            > accomplish something
            > similar to what you achieved.
            >
            > Before the update I was on A35, when linux came up
            > it would sit around
            > 73-76C... I noticed that my fan never ran.
            > Occasionally the computer
            > would shut off.
            >
            > Updated my bios and now it sits around 68-74C, now
            > the fans seems to
            > run at full speed all of the time... much like
            > yours.
            >
            > Still you really do not want your processor to go
            > over 70c...
            >
            > At this point I just decided to turn of speedsteping
            > in the bios...
            > which brings my processor down to 1.6 but my temp
            > stays at 54-58.
            >
            > I can't get i8k to work on my system, even though it
            > appears to be
            > complied in my kernel.. so I can't play around with
            > that.
            >
            > hmmm
            >
            > --- In linux-dell-laptops@yahoogroups.com, "Gregory
            > F. March"
            > <march@g...> wrote:
            > >
            > > On Oct 31, 2004, Ivan Fernandez
            > <ivan.fernandez@y...> wrote:
            > >
            > > |I'll attach the whole .config this time, see if
            > you find something
            > else
            > > |that might make the difference. FYU, I have
            > eight different
            > frequency
            > > |points.
            > >
            > > Ivan,
            > >
            > > Thanks for the help. I went through my .config
            > and change it to
            > mimic
            > > yours and now I have all 8 steps in the scaling_
            > available_frequencies
            > > file.
            > >
            > > I'm running cpufreqd with a slightly modified
            > cpufreqd.conf
            > (basically
            > > it lets the processor scale even when on AC). and
            > things seem to be
            > > working well.
            > >
            > > I notice that cpufreqd doesn't bump up the speed
            > when the cpu is
            > > consumed by a "nice" process (like setiathome),
            > and I can't figure
            > out
            > > how to make it scale under that circumstance. I
            > can live with that
            > > though.
            > >
            > > Also, I notice the fan stays on all the time (the
            > temp is hovering
            > > around 68-74 C). It is on a lower rpm setting and
            > I can make it go
            > > higher or lower (including off) if I muck with the
            > i8kmon stuff.
            > But,
            > > under normal operation, it is just "on low" all
            > the time. Is that
            > > normal for you?
            > >
            > > Thanks for all your help...
            > >
            > > /greg
            > >
            > >
            > >
            > >
            > > --
            > > Gregory F. March |
            > http://www.gfm.net:443/~march |
            > AIM:GfmNet
            >
            >
            >
            >
          • Ivan Fernandez
            ... I actually use powernowd, in spite of the name it works with any cpu that has a linux frequency stepping driver, not just AMDs. Right now I don t remember
            Message 5 of 9 , Nov 1, 2004
            • 0 Attachment
              On Mon, Nov 01, 2004 at 01:31:34PM -0500, Gregory F. March wrote:
              >
              > I'm running cpufreqd with a slightly modified cpufreqd.conf (basically
              > it lets the processor scale even when on AC). and things seem to be
              > working well.
              >
              > I notice that cpufreqd doesn't bump up the speed when the cpu is
              > consumed by a "nice" process (like setiathome), and I can't figure out
              > how to make it scale under that circumstance. I can live with that
              > though.

              I actually use powernowd, in spite of the name it works with any cpu
              that has a linux frequency stepping driver, not just AMDs. Right now I
              don't remember the exact reason, but I do remember trying cpufreqd and
              preferring powernowd. I think it's more responsive.
              >
              > Also, I notice the fan stays on all the time (the temp is hovering
              > around 68-74 C). It is on a lower rpm setting and I can make it go
              > higher or lower (including off) if I muck with the i8kmon stuff. But,
              > under normal operation, it is just "on low" all the time. Is that
              > normal for you?

              Unfortunately, this seems to be the case. If you unload i8k (so BIOS
              takes charge of everything), the temperature generally goes down, but
              the fan kicks in earlier.

              Glad to be useful

              --
              Ivan Fernández
              ivan.fernandez@...
            • Gregory F. March
              ... Interesting research here... So, I am trying to compare the apples and oranges of what different tools claim to report with respect to cpu speed. So
              Message 6 of 9 , Nov 2, 2004
              • 0 Attachment
                On Nov 1, 2004, Ivan Fernandez <ivan.fernandez@...> wrote:

                |I actually use powernowd, in spite of the name it works with any cpu
                |that has a linux frequency stepping driver, not just AMDs. Right now I
                |don't remember the exact reason, but I do remember trying cpufreqd and
                |preferring powernowd. I think it's more responsive.

                Interesting research here... So, I am trying to compare the apples and
                oranges of what different tools "claim" to report with respect to cpu
                speed. So far, the gnome-cpufreq-applet (GCA) seems to be the most
                accurate.

                I downloaded nbench, the old Byte benchmarks and ran the "numeric sort"
                test. With cpufreqd running, I could see the cpu go to its full speed
                according to GCA. And, the results were 418 iterations/sec.

                I then shut off cpufreqd and ran powernowd by hand with verbosity set
                to show the speed it was switching to. It claimed to be switching to
                different speeds, but nbench consistently reported around 220
                iterations/sec.

                I then played with cpufreqd by hand and killed it at various speeds.
                Sure enough, the results of the test were in line with the different
                speeds.

                Now, that said, I still rarely see the cpu go below 1.1GHz with cpufreqd
                and the default config. It does bump up to 3.06 though when the demand
                is there. After modifying the config file, cpufreq does seem to work
                the best.

                /greg




                --
                Gregory F. March | http://www.gfm.net:443/~march | AIM:GfmNet
              Your message has been successfully submitted and would be delivered to recipients shortly.