Loading ...
Sorry, an error occurred while loading the content.
 

Re: [linux-dell-laptops] How to disable the joystick?

Expand Messages
  • Alexandre Tessier
    ... I think you can disable the joystick AND the touchpad in the BIOS. If you have an USB external mouse you can also remove the InputDevice section concerning
    Message 1 of 7 , Oct 6, 2004
      Marc Chamberlin wrote:
      > I have a Dell Inspiron 8100 laptop running SuSE 9.1. Recently, for some
      > odd reason, under both Windows and Linux, my cursor has started acting
      > up and will start to wander around on its own. Contacting Dell, I found
      > out that the cause is due to the joystick (located in the middle of the
      > keyboard) is going into calibrate mode and their recommendation is to
      > disable the joystick. This is OK by me, I never use the darn thing
      > anywise... Unfortunately, their only instructions for doing so applies
      > to Windoz... Anyone got a clue as to how to disable the joystick under
      > SuSE Linux?

      I think you can disable the joystick AND the touchpad in the BIOS.
      If you have an USB external mouse you can also remove the InputDevice
      section concerning the PS/2 mouse.
      Search in the list archive, you should find previous POST on joystick
      calibrate issues.

      Alex.

      >
      > Now before you reply, I have also found a secondary problem that may be
      > related somehow... I tried to go into YAST > Hardware > Select Mouse
      > Model to see if there was any settings there. Unfortunately, when I
      > select that, something is going terribly wrong and my login session
      > immediately closes and I am taken back to the login window!
      >
      > Marc...
      >
      >
      >
      >
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
      > FAQ: http://www.whacked.net/ldl/faq
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      >
      >
      >
      >
    • Marc Chamberlin
      Thanks Alex for your reply. I was, (am still) hoping for an answer that is a bit smaller of a hammer. ;-) For the moment, I have turned off the joystick and
      Message 2 of 7 , Oct 6, 2004
        Thanks Alex for your reply. I was, (am still) hoping for an answer that
        is a bit smaller of a hammer. ;-) For the moment, I have turned off the
        joystick and the touchpad via the bios and am using a USB mouse which
        does work. I followed the suggested procedure that Dell made, for the
        Windows side, to turn of just the joystick and that also worked. Now if
        only I could find an equivalent method to turn of just the joystick on
        my Linux side, I will be a happy camper!

        BTW. now that I have disabled the Synaptics touchpad and joystick
        entirely, the secondary problem I described, trying to select a mouse
        from YAST2 has also gone away. So I think this is narrowing down much of
        my troubles to the Synaptics driver under Linux...

        Anywise, since I believe the keypad/ joystick has gone bad, I will be
        pushing on Dell to get a replacement, but I still would like to find a
        solution that will just disable the joystick...

        Marc....



        Alexandre Tessier wrote:

        > Marc Chamberlin wrote:
        > > I have a Dell Inspiron 8100 laptop running SuSE 9.1. Recently, for some
        > > odd reason, under both Windows and Linux, my cursor has started acting
        > > up and will start to wander around on its own. Contacting Dell, I found
        > > out that the cause is due to the joystick (located in the middle of the
        > > keyboard) is going into calibrate mode and their recommendation is to
        > > disable the joystick. This is OK by me, I never use the darn thing
        > > anywise... Unfortunately, their only instructions for doing so applies
        > > to Windoz... Anyone got a clue as to how to disable the joystick under
        > > SuSE Linux?
        >
        > I think you can disable the joystick AND the touchpad in the BIOS.
        > If you have an USB external mouse you can also remove the InputDevice
        > section concerning the PS/2 mouse.
        > Search in the list archive, you should find previous POST on joystick
        > calibrate issues.
        >
        > Alex.
        >
        > >
        > > Now before you reply, I have also found a secondary problem that may be
        > > related somehow... I tried to go into YAST > Hardware > Select Mouse
        > > Model to see if there was any settings there. Unfortunately, when I
        > > select that, something is going terribly wrong and my login session
        > > immediately closes and I am taken back to the login window!
        > >
        > > Marc...
        > >
        > >
        > >
        > >
        > >
        > >
        > > --------------------------------------------------------------
        > > Please post your X config files in the group links or database
        > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        > > FAQ: http://www.whacked.net/ldl/faq
        > > Yahoo! Groups Links
        > >
        > >
        > >
        > >
        > >
        > >
        > >
        > >
        > >
        >
        >
        > --------------------------------------------------------------
        > Please post your X config files in the group links or database
        > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        > FAQ: http://www.whacked.net/ldl/faq
        >
        >
        > *Yahoo! Groups Sponsor*
        > ADVERTISEMENT
        > click here
        > <http://us.ard.yahoo.com/SIG=129tpuuna/M=294855.5468653.6549235.3001176/D=groups/S=1708211820:HM/EXP=1097184012/A=2376776/R=0/SIG=11ldm1jvc/*http://promotions.yahoo.com/ydomains2004/index.html>
        >
        >
        >
        > ------------------------------------------------------------------------
        > *Yahoo! Groups Links*
        >
        > * To visit your group on the web, go to:
        > http://groups.yahoo.com/group/linux-dell-laptops/
        >
        > * To unsubscribe from this group, send an email to:
        > linux-dell-laptops-unsubscribe@yahoogroups.com
        > <mailto:linux-dell-laptops-unsubscribe@yahoogroups.com?subject=Unsubscribe>
        >
        > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
        > Service <http://docs.yahoo.com/info/terms/>.
        >
        >
      • Alexandre Tessier
        ... First, I think you cannot disable joystick without disabling touchpad. Second, I can t answer on yast because I have never used suse. Third, you can enable
        Message 3 of 7 , Oct 7, 2004
          Marc Chamberlin wrote:
          > Thanks Alex for your reply. I was, (am still) hoping for an answer that
          > is a bit smaller of a hammer. ;-) For the moment, I have turned off the
          > joystick and the touchpad via the bios and am using a USB mouse which
          > does work. I followed the suggested procedure that Dell made, for the
          > Windows side, to turn of just the joystick and that also worked. Now if
          > only I could find an equivalent method to turn of just the joystick on
          > my Linux side, I will be a happy camper!
          >
          > BTW. now that I have disabled the Synaptics touchpad and joystick
          > entirely, the secondary problem I described, trying to select a mouse
          > from YAST2 has also gone away. So I think this is narrowing down much of
          > my troubles to the Synaptics driver under Linux...

          First, I think you cannot disable joystick without disabling touchpad.

          Second, I can't answer on yast because I have never used suse.

          Third, you can enable joystick (and touchpad) in the bios and disable it
          under X. If you use XFree, edit your XF86Config (or XF86Config-4, it
          depends on your distro). You should have at least one InputDevice
          section concerning the mouse. Remove the InputDevice section about your
          PS/2 mouse and add an InputDevice section about your USB mouse, for
          example I have the two sections in my /etc/XF86Config-4:

          Section "InputDevice"
          Identifier "PS/2 Mouse"
          Driver "mouse"
          Option "Protocol" "PS/2"
          Option "Device" "/dev/psaux"
          Option "Emulate3Buttons"
          Option "Emulate3Timeout" "50"
          EndSection

          Section "InputDevice"
          Identifier "USB Mouse"
          Driver "mouse"
          Option "Protocol" "ExplorerPS/2"
          # Option "Protocol" "IMPS/2"
          Option "Device" "/dev/mouse"
          # Option "Device" "/dev/usbmouse"
          Option "ZAxisMapping" "6 7"
          # Option "ZAxisMapping" "4 5"
          EndSection

          The first one is for the joystick/touchpad (or an external PS/2 mouse)
          and the second one is for the USB mouse (generaly you have to use IMPS/2
          protocol and "4 5" for ZAxisMapping). The devices (/dev/psaux,
          /dev/mouse, /dev/usbmouse...) depends on your system (I don't know how
          it is managed by suse).
          My ServerLayout section is:

          Section "ServerLayout"
          Identifier "layout"
          InputDevice "Keyboard" "CoreKeyboard"
          InputDevice "PS/2 Mouse" "SendCoreEvents"
          InputDevice "USB Mouse" "CorePointer"
          Screen "screen"
          EndSection

          The main mouse is the USB mouse (CorePointer) but it also takes into
          account events of the PS/2 mouse (SendCoreEvents). You have to remove
          the line:
          InputDevice "PS/2 Mouse" "SendCoreEvents"

          >
          > Anywise, since I believe the keypad/ joystick has gone bad, I will be
          > pushing on Dell to get a replacement, but I still would like to find a
          > solution that will just disable the joystick...

          If the computer is under warranty, ask Dell for a replacement.

          Hope this help,

          Alex.
        • vona@mit.edu
          ... I have a 4100 which had the same problem. Solution: joystick-ectomy. Take out the screws that hold the keyboard in place. Remove keyboard. Locate flex
          Message 4 of 7 , Oct 7, 2004
            > I have a Dell Inspiron 8100 laptop running SuSE 9.1. Recently, for some
            > odd reason, under both Windows and Linux, my cursor has started acting
            > up and will start to wander around on its own. Contacting Dell, I found
            > out that the cause is due to the joystick (located in the middle of the
            > keyboard) is going into calibrate mode and their recommendation is to
            > disable the joystick.

            I have a 4100 which had the same problem.

            Solution: joystick-ectomy.

            Take out the screws that hold the keyboard in place. Remove keyboard. Locate flex circuit that connects joystick to mobo. Disconnect it (this can be done non-destructively).

            Viola. You will never be bothered by it again.

            Luck,
            Marty
          • Martin Egge
            Hi, ... Great idea! That has solved the problem. My workaround so far: Bending the chasis holding it at the left and right front edge. But this has always
            Message 5 of 7 , Oct 10, 2004
              Hi,

              > Solution: joystick-ectomy.

              Great idea! That has solved the problem.

              My workaround so far: Bending the chasis holding it at the left and right
              front edge. But this has always solved the problem only for a few hours.

              Greetz
              Martin
            Your message has been successfully submitted and would be delivered to recipients shortly.