Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] Re: "Read-only file system" error in Fedora Core 2

Expand Messages
  • Andy Farlie
    Not answering the read-only issue, but if you are intending to regularly backup from one drive to the other, consider using rsync instead of cp. If you want to
    Message 1 of 11 , Aug 1, 2004
    • 0 Attachment
      Not answering the read-only issue, but if you are intending to regularly
      backup from one drive to the other, consider using rsync instead of cp.
      If you want to go with rolling backups then you can use a combination of
      cp -l on disk2 to create an apparent copy of the previous backup and
      then rsync -a to copy the changed files from disk1 to disk2.

      If it is just a one off copy then cp -r would work fine.

      Andy

      On Fri, 2004-07-30 at 03:23, Hamish Morgan wrote:
      > Hi Amjad,
      >
      > Hmm yes that is strange. Could you check your /etc/mtab file when it
      > is mounted to see what mount options disk2 has defaulted to.
      >
      > Another place where a disk can be flagged read-only is using the
      > hdparm command. Type "hdparm -r /dev/disk" to see what's going there.
      >
      > Regards,
      > Hamish
      >
      > --- In linux-dell-laptops@yahoogroups.com, "Amjad Farooq"
      > <amjadfarooq@y...> wrote:
      > > Hi Hamish,
      > >
      > > Thanks for your suggestions.
      > >
      > > I mount my disks manually, after reboot, as follows:
      > >
      > > > mount /dev/disk /mnt/disk
      > >
      > > I believe the default setting for this is -rw. Thus using the command
      > >
      > > > mount -rw /dev/disk /mnt/disk
      > >
      > > makes no difference.
      > >
      > > Actually my data can now be copied but the only thing I do not
      > > understand is that sometimes the command
      > >
      > > >cp -r /disk1/mydata /disk2/mydata
      > >
      > > works and sometimes it does not!! In other words, if it returns the
      > > error "Read-only file system" then if I reboot my machine, and apply
      > > the above command again, it works. Occasionally, it does not! Seems
      > > scary. I believe there is some sort of bug in Fedora but this is only
      > > a minor distraction. Overall, Fedora is awesome.
      > >
      > > Take care,
      > > Amjad
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > > --- In linux-dell-laptops@yahoogroups.com, "Hamish Morgan"
      > > <hamish_iam@y...> wrote:
      > > > Hi Amjad
      > > >
      > > > You are mounting disk2 as read only. You will probably see in your
      > > > /etc/fstab that in the line for /disk2/mydata you have "ro" in the
      > > > options. Change this to "rw". Then remout it:
      > > > umount /disk2/mydata; mount /disk2/mydata
      > > > And it should work now.
      > > >
      > > > Regards,
      > > > Hamish
      > > >
      > > >
      > > > --- In linux-dell-laptops@yahoogroups.com, "Amjad Farooq"
      > > > <amjadfarooq@y...> wrote:
      > > > > Dear all,
      > > > >
      > > > > I have two Maxtor drives which I mounted on Fedora Core 2
      > installed on
      > > > > Dell laptop Inspiron XPS. One is 120Gb (disk1) and the other 250GB
      > > > > (disk2). Both the external drives were ext3-formatted using the
      > > command:
      > > > >
      > > > > >mkfs -t ext3 /dev/disk
      > > > >
      > > > > I have about 50GB on disk1. I want to back this up on disk2. When I
      > > > > apply the command:
      > > > >
      > > > > >cp -r /disk1/mydata /disk2/mydata
      > > > >
      > > > > the output complains of "Read-only file system" error for some
      > files.
      > > > > I am carrying out this operation as "root" and the permission status
      > > > > on all files and directories is the same: drwxr-xr-x or
      > -rwxr-xr-x.
      > > > >
      > > > > Why the "Read-only file system" error? Is there some bug in Fedora?
      > > > > Any suggestions will be greatly appreciated.
      > > > >
      > > > > Many thanks in advance.
      > > > > Amjad
      >
      >
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
      > FAQ: http://www.whacked.net/ldl/faq
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
    • Amjad Farooq
      Hamish, fdisk -l command returns the following: /dev/sda1 /dev/sdb1 I have two external SCSI (maxtor) drives and i respectively mount them to the following
      Message 2 of 11 , Aug 1, 2004
      • 0 Attachment
        Hamish,

        "fdisk -l" command returns the following:

        /dev/sda1
        /dev/sdb1

        I have two external SCSI (maxtor) drives and i respectively mount them
        to the following points:

        /mnt/disk1
        /mnt/disk2

        cheers,
        Amjad



        --- In linux-dell-laptops@yahoogroups.com, "Hamish Morgan"
        <hamish_iam@y...> wrote:
        > As per what David Carlton said, hdparm shows that readonly is off -
        > i.e read/write is on. So basicly there is nothing wrong there. However
        > it just occured to me that hdparm is mean to be used againt physical
        > disks not partitions. When you say /dev/disk or dev/disk1 this is
        > rather ambiguous since they are probably symlinks to the real devices.
        > Please could you be more specific about exactly what disks and
        > partitions you are formating/mounting/using. Run:
        >
        > symlinks /dev/
        >
        > To see what the actual device names are, and to see what real
        > partitions you have run:
        >
        > fdisk -l
        >
        > ...I'm crossing my fingers and hoping this will turn something new
        up. :)
        >
        > Regards,
        > Hamish
        >
        > --- In linux-dell-laptops@yahoogroups.com, "Amjad Farooq"
        > <amjadfarooq@y...> wrote:
        > > Hamish,
        > >
        > > The /etc/mtab file shows this info reagrding disk2:
        > >
        > > /dev/disk2 /mnt/disk2 ext3 rw 0 0
        > >
        > > But when I type "hdparm -r /dev/disk2" on the command line, I get this
        > > message:
        > >
        > > /dev/disk2:
        > > readonly = 0 (off)
        > >
        > > I dont get it. The /etc/mtab file shows that disk2 is read-write but
        > > hparm indicates that it is readonly.
        > >
        > > Any suggestions how I could fix this?
        > >
        > > Many thanks,
        > > Amjad
        > >
        > >
        > >
        > > --- In linux-dell-laptops@yahoogroups.com, "Hamish Morgan"
        > > <hamish_iam@y...> wrote:
        > > > Hi Amjad,
        > > >
        > > > Hmm yes that is strange. Could you check your /etc/mtab file when it
        > > > is mounted to see what mount options disk2 has defaulted to.
        > > >
        > > > Another place where a disk can be flagged read-only is using the
        > > > hdparm command. Type "hdparm -r /dev/disk" to see what's going
        there.
        > > >
        > > > Regards,
        > > > Hamish
        > > >
        > > > --- In linux-dell-laptops@yahoogroups.com, "Amjad Farooq"
        > > > <amjadfarooq@y...> wrote:
        > > > > Hi Hamish,
        > > > >
        > > > > Thanks for your suggestions.
        > > > >
        > > > > I mount my disks manually, after reboot, as follows:
        > > > >
        > > > > > mount /dev/disk /mnt/disk
        > > > >
        > > > > I believe the default setting for this is -rw. Thus using the
        > command
        > > > >
        > > > > > mount -rw /dev/disk /mnt/disk
        > > > >
        > > > > makes no difference.
        > > > >
        > > > > Actually my data can now be copied but the only thing I do not
        > > > > understand is that sometimes the command
        > > > >
        > > > > >cp -r /disk1/mydata /disk2/mydata
        > > > >
        > > > > works and sometimes it does not!! In other words, if it
        returns the
        > > > > error "Read-only file system" then if I reboot my machine, and
        apply
        > > > > the above command again, it works. Occasionally, it does not!
        Seems
        > > > > scary. I believe there is some sort of bug in Fedora but this is
        > only
        > > > > a minor distraction. Overall, Fedora is awesome.
        > > > >
        > > > > Take care,
        > > > > Amjad
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > >
        > > > > --- In linux-dell-laptops@yahoogroups.com, "Hamish Morgan"
        > > > > <hamish_iam@y...> wrote:
        > > > > > Hi Amjad
        > > > > >
        > > > > > You are mounting disk2 as read only. You will probably see
        in your
        > > > > > /etc/fstab that in the line for /disk2/mydata you have "ro"
        in the
        > > > > > options. Change this to "rw". Then remout it:
        > > > > > umount /disk2/mydata; mount /disk2/mydata
        > > > > > And it should work now.
        > > > > >
        > > > > > Regards,
        > > > > > Hamish
        > > > > >
        > > > > >
        > > > > > --- In linux-dell-laptops@yahoogroups.com, "Amjad Farooq"
        > > > > > <amjadfarooq@y...> wrote:
        > > > > > > Dear all,
        > > > > > >
        > > > > > > I have two Maxtor drives which I mounted on Fedora Core 2
        > > > installed on
        > > > > > > Dell laptop Inspiron XPS. One is 120Gb (disk1) and the other
        > 250GB
        > > > > > > (disk2). Both the external drives were ext3-formatted
        using the
        > > > > command:
        > > > > > >
        > > > > > > >mkfs -t ext3 /dev/disk
        > > > > > >
        > > > > > > I have about 50GB on disk1. I want to back this up on disk2.
        > > When I
        > > > > > > apply the command:
        > > > > > >
        > > > > > > >cp -r /disk1/mydata /disk2/mydata
        > > > > > >
        > > > > > > the output complains of "Read-only file system" error for some
        > > > files.
        > > > > > > I am carrying out this operation as "root" and the permission
        > > status
        > > > > > > on all files and directories is the same: drwxr-xr-x or
        > > > -rwxr-xr-x.
        > > > > > >
        > > > > > > Why the "Read-only file system" error? Is there some bug in
        > > Fedora?
        > > > > > > Any suggestions will be greatly appreciated.
        > > > > > >
        > > > > > > Many thanks in advance.
        > > > > > > Amjad
      • Hamish Morgan
        Hi Amjad, Well I m scraping the bottom of the barrel here but try running hdparm -r /dev/sdb Instead /dev/disk2 since hdparm is designed for setting device
        Message 3 of 11 , Aug 2, 2004
        • 0 Attachment
          Hi Amjad,

          Well I'm scraping the bottom of the barrel here but try running
          hdparm -r /dev/sdb
          Instead /dev/disk2 since hdparm is designed for setting device wide
          flags not partition flags.

          It might be a hardware error, or it might be a bug in FC2. Try running
          Knoppix or some other bootable distro and see if you can copy the data
          from there.

          Other than that, I am stumped... I give up :(
          Sorry I couldn't help you with this one.

          Good luck,
          Hamish




          --- In linux-dell-laptops@yahoogroups.com, "Amjad Farooq"
          <amjadfarooq@y...> wrote:
          > Hamish,
          >
          > "fdisk -l" command returns the following:
          >
          > /dev/sda1
          > /dev/sdb1
          >
          > I have two external SCSI (maxtor) drives and i respectively mount them
          > to the following points:
          >
          > /mnt/disk1
          > /mnt/disk2
          >
          > cheers,
          > Amjad
          >
          >
          >
          > --- In linux-dell-laptops@yahoogroups.com, "Hamish Morgan"
          > <hamish_iam@y...> wrote:
          > > As per what David Carlton said, hdparm shows that readonly is off -
          > > i.e read/write is on. So basicly there is nothing wrong there. However
          > > it just occured to me that hdparm is mean to be used againt physical
          > > disks not partitions. When you say /dev/disk or dev/disk1 this is
          > > rather ambiguous since they are probably symlinks to the real devices.
          > > Please could you be more specific about exactly what disks and
          > > partitions you are formating/mounting/using. Run:
          > >
          > > symlinks /dev/
          > >
          > > To see what the actual device names are, and to see what real
          > > partitions you have run:
          > >
          > > fdisk -l
          > >
          > > ...I'm crossing my fingers and hoping this will turn something new
          > up. :)
          > >
          > > Regards,
          > > Hamish
          > >
          > > --- In linux-dell-laptops@yahoogroups.com, "Amjad Farooq"
          > > <amjadfarooq@y...> wrote:
          > > > Hamish,
          > > >
          > > > The /etc/mtab file shows this info reagrding disk2:
          > > >
          > > > /dev/disk2 /mnt/disk2 ext3 rw 0 0
          > > >
          > > > But when I type "hdparm -r /dev/disk2" on the command line, I
          get this
          > > > message:
          > > >
          > > > /dev/disk2:
          > > > readonly = 0 (off)
          > > >
          > > > I dont get it. The /etc/mtab file shows that disk2 is read-write but
          > > > hparm indicates that it is readonly.
          > > >
          > > > Any suggestions how I could fix this?
          > > >
          > > > Many thanks,
          > > > Amjad
          > > >
          > > >
          > > >
          > > > --- In linux-dell-laptops@yahoogroups.com, "Hamish Morgan"
          > > > <hamish_iam@y...> wrote:
          > > > > Hi Amjad,
          > > > >
          > > > > Hmm yes that is strange. Could you check your /etc/mtab file
          when it
          > > > > is mounted to see what mount options disk2 has defaulted to.
          > > > >
          > > > > Another place where a disk can be flagged read-only is using the
          > > > > hdparm command. Type "hdparm -r /dev/disk" to see what's going
          > there.
          > > > >
          > > > > Regards,
          > > > > Hamish
          > > > >
          > > > > --- In linux-dell-laptops@yahoogroups.com, "Amjad Farooq"
          > > > > <amjadfarooq@y...> wrote:
          > > > > > Hi Hamish,
          > > > > >
          > > > > > Thanks for your suggestions.
          > > > > >
          > > > > > I mount my disks manually, after reboot, as follows:
          > > > > >
          > > > > > > mount /dev/disk /mnt/disk
          > > > > >
          > > > > > I believe the default setting for this is -rw. Thus using the
          > > command
          > > > > >
          > > > > > > mount -rw /dev/disk /mnt/disk
          > > > > >
          > > > > > makes no difference.
          > > > > >
          > > > > > Actually my data can now be copied but the only thing I do not
          > > > > > understand is that sometimes the command
          > > > > >
          > > > > > >cp -r /disk1/mydata /disk2/mydata
          > > > > >
          > > > > > works and sometimes it does not!! In other words, if it
          > returns the
          > > > > > error "Read-only file system" then if I reboot my machine, and
          > apply
          > > > > > the above command again, it works. Occasionally, it does not!
          > Seems
          > > > > > scary. I believe there is some sort of bug in Fedora but this is
          > > only
          > > > > > a minor distraction. Overall, Fedora is awesome.
          > > > > >
          > > > > > Take care,
          > > > > > Amjad
          > > > > >
          > > > > >
          > > > > >
          > > > > >
          > > > > >
          > > > > >
          > > > > >
          > > > > >
          > > > > >
          > > > > >
          > > > > >
          > > > > >
          > > > > >
          > > > > > --- In linux-dell-laptops@yahoogroups.com, "Hamish Morgan"
          > > > > > <hamish_iam@y...> wrote:
          > > > > > > Hi Amjad
          > > > > > >
          > > > > > > You are mounting disk2 as read only. You will probably see
          > in your
          > > > > > > /etc/fstab that in the line for /disk2/mydata you have "ro"
          > in the
          > > > > > > options. Change this to "rw". Then remout it:
          > > > > > > umount /disk2/mydata; mount /disk2/mydata
          > > > > > > And it should work now.
          > > > > > >
          > > > > > > Regards,
          > > > > > > Hamish
          > > > > > >
          > > > > > >
          > > > > > > --- In linux-dell-laptops@yahoogroups.com, "Amjad Farooq"
          > > > > > > <amjadfarooq@y...> wrote:
          > > > > > > > Dear all,
          > > > > > > >
          > > > > > > > I have two Maxtor drives which I mounted on Fedora Core 2
          > > > > installed on
          > > > > > > > Dell laptop Inspiron XPS. One is 120Gb (disk1) and the other
          > > 250GB
          > > > > > > > (disk2). Both the external drives were ext3-formatted
          > using the
          > > > > > command:
          > > > > > > >
          > > > > > > > >mkfs -t ext3 /dev/disk
          > > > > > > >
          > > > > > > > I have about 50GB on disk1. I want to back this up on disk2.
          > > > When I
          > > > > > > > apply the command:
          > > > > > > >
          > > > > > > > >cp -r /disk1/mydata /disk2/mydata
          > > > > > > >
          > > > > > > > the output complains of "Read-only file system" error
          for some
          > > > > files.
          > > > > > > > I am carrying out this operation as "root" and the
          permission
          > > > status
          > > > > > > > on all files and directories is the same: drwxr-xr-x or
          > > > > -rwxr-xr-x.
          > > > > > > >
          > > > > > > > Why the "Read-only file system" error? Is there some bug in
          > > > Fedora?
          > > > > > > > Any suggestions will be greatly appreciated.
          > > > > > > >
          > > > > > > > Many thanks in advance.
          > > > > > > > Amjad
        • John Ruschmeyer
          Silly question, but has the OP tried reading the output of dmesg when the disk is in read-only mode? I m wondering if it is pulling some kind of error
          Message 4 of 11 , Aug 2, 2004
          • 0 Attachment
            Silly question, but has the OP tried reading the output of 'dmesg'
            when the disk is in read-only mode? I'm wondering if it is pulling
            some kind of error (either a drive error or an EXT3fs journaling
            error) and being put into read-only mode.

            FWIW, it might also be worth booting a LiveCD distro like Knoppix. And
            manually running e2fsck on the partitions in question.

            <<<john.>>
          Your message has been successfully submitted and would be delivered to recipients shortly.