Loading ...
Sorry, an error occurred while loading the content.

Re: Inspiron 5k: XF86 4.3bad, 4.1 good!

Expand Messages
  • hamish_iam
    Hi, You aren t by any chance using framebuffer console are you? If so then the problem might be a conflict between the kernel framebuffer driver and your X
    Message 1 of 2 , Jul 27, 2004
    • 0 Attachment
      Hi,

      You aren't by any chance using framebuffer console are you? If so then
      the problem might be a conflict between the kernel framebuffer driver
      and your X graphics driver. Try booting the system with "vga=0" kernel
      parameter.

      Also you probably don't need the "Modes" section in your XFConfig file
      - it is likely to do more harm than good. And that goes for most of
      the options in the "Monitor" section to. I find a good tactic for X
      configuration is using the minimum number of options - let X do its
      guessing work and only override it when it is getting things wrong.

      Regards,
      Hamish

      --- In linux-dell-laptops@yahoogroups.com, "jvarsoke"
      <jvarsoke_lists@g...> wrote:
      > I'm running Debian Sarge. When apt-get updated XF86 4.1.0.1 to 4.3 I
      > got a big blank screen. No idea why. If I use my old XF86Config-4 or
      > one generated by the auto-detect foo of the Debian installer I get the
      > same blank screen -- almost as if the screen saver were on.
      >
      > I reinstalled the entire distro just to make sure one of my libraries
      > wasn't corrupt (after trying just re-installing X).
      >
      > Here's the config file I've been carrying with me since my SuSE days.
      > Works great for XF86 4.1.0.1.
      >
      > Just wondering if anyone else has had this problem.
      >
      > -j
      >
      > ---/etc/X11/XF86Config-4---
      > # /.../
      > # SaX generated XFree86 config file
      > # Created on: 2003-06-07.
      > #
      > # Version: 4.7
      > # Contact: Marcus Schaefer <sax@s...>, 2002
      > #
      > # Automatically generated by [ISaX] (4.7)
      > # PLEASE DO NOT EDIT THIS FILE!
      > #
      > Section "Files"
      > FontPath "unix/:7100" # local font
      > server
      > # if the local font server has problems, we can fall back on
      these
      > FontPath "/usr/lib/X11/fonts/misc"
      > # FontPath "/usr/lib/X11/fonts/cyrillic"
      > FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
      > FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
      > FontPath "/usr/lib/X11/fonts/Type1"
      > # FontPath "/usr/lib/X11/fonts/CID"
      > FontPath "/usr/lib/X11/fonts/Speedo"
      > FontPath "/usr/lib/X11/fonts/100dpi"
      > FontPath "/usr/lib/X11/fonts/75dpi"
      > EndSection
      > Section "Module"
      > Load "GLcore"
      > Load "bitmap"
      > Load "dbe"
      > Load "ddc"
      > Load "dri"
      > Load "extmod"
      > Load "freetype"
      > Load "glx"
      > Load "int10"
      > Load "record"
      > Load "speedo"
      > Load "type1"
      > Load "vbe"
      > EndSection
      >
      > Section "ServerFlags"
      > Option "AllowMouseOpenFail"
      > EndSection
      >
      > Section "InputDevice"
      > Driver "Keyboard"
      > Identifier "Keyboard[0]"
      > Option "MapName" "Standard Keyboard [ pc104 ]"
      > Option "Protocol" "Standard"
      > Option "XkbLayout" "us"
      > Option "XkbModel" "pc104"
      > Option "XkbRules" "xfree86"
      > EndSection
      > Section "InputDevice"
      > Identifier "Mouse[0]"
      > Driver "mouse"
      > Option "Protocol" "PS/2"
      > Option "Device" "/dev/mouse"
      > Option "ZAxisMapping" "4 5"
      > Option "Emulate3Buttons"
      > Option "Emulate3Timeout" "50"
      > EndSection
      >
      > Section "InputDevice"
      > Driver "mouse"
      > Identifier "Mouse[1]"
      > Option "ButtonNumber" "5"
      > Option "Device" "/dev/input/mice"
      > Option "Name" "Autodetection"
      > Option "Protocol" "imps/2"
      > Option "Vendor" "Sysp"
      > Option "ZAxisMapping" "4 5"
      > EndSection
      >
      > Section "Monitor"
      > Option "CalcAlgorithm" "CheckDesktopGeometry"
      > DisplaySize 320 240
      > HorizSync 30-90
      > Identifier "Monitor[0]"
      > ModelName "1400X1050@60HZ"
      > Option "DPMS"
      > VendorName "--> LCD"
      > VertRefresh 40-60
      > UseModes "Modes[0]"
      > EndSection
      >
      > Section "Modes"
      > Identifier "Modes[0]"
      > Modeline "1400x1050" 114.41 1400 1416 1704 1944 1050 1050
      1060 1097
      > Modeline "1024x768" 61.19 1024 1040 1216 1400 768 768 775 802
      > Modeline "800x600" 37.44 800 816 928 1072 600 600 605 626
      > EndSection
      >
      > Section "Screen"
      > DefaultDepth 24
      > SubSection "Display"
      > Depth 15
      > Modes "1024x768"
      > EndSubSection
      > SubSection "Display"
      > Depth 16
      > Modes "1400x1050"
      > EndSubSection
      > SubSection "Display"
      > Depth 24
      > Modes "1400x1050" "1024x768" "800x600"
      > EndSubSection
      > SubSection "Display"
      > Depth 32
      > Modes "1024x768"
      > EndSubSection
      > SubSection "Display"
      > Depth 8
      > Modes "1024x768"
      > EndSubSection
      > Device "Device[0]"
      > Identifier "Screen[0]"
      > Monitor "Monitor[0]"
      > EndSection
      >
      > Section "Device"
      > BoardName "3D Rage P/M Mobility AGP 2x"
      > BusID "1:0:0"
      > Driver "ati"
      > Identifier "Device[0]"
      > VendorName "ATI"
      > EndSection
      >
      > Section "ServerLayout"
      > Identifier "Layout[all]"
      > InputDevice "Keyboard[0]" "CoreKeyboard"
      > InputDevice "Mouse[0]" "CorePointer"
      > InputDevice "Mouse[1]" "SendCoreEvents"
      > Option "Clone" "off"
      > Option "Xinerama" "off"
      > Screen "Screen[0]"
      > EndSection
      >
      > Section "DRI"
      > Group "video"
      > Mode 0660
      > EndSection
    Your message has been successfully submitted and would be delivered to recipients shortly.