Loading ...
Sorry, an error occurred while loading the content.

Re: HELP!!! PLEASE!! Dell Inspiron 4150 will no longer boot.

Expand Messages
  • Michelle L. Gill
    Hi Haedn, Thanks for the info. I actually wasn t able to mount anything from the prompt or when I tried to boot with a floppy. I am fairly proficient at
    Message 1 of 3 , Jul 26, 2004
    • 0 Attachment
      Hi Haedn,

      Thanks for the info. I actually wasn't able to mount anything from
      the prompt or when I tried to boot with a floppy. I am fairly
      proficient at general unix commands and the vi editor because I work
      on an SGI (the desktop GUI isn't much to look at and vi is the only
      text editor available). There's no way you could have known that from
      my post. RH and SuSE are pretty cushy.

      I reinstalled everything and it seems to be working now.

      Thanks again,
      Michelle Gill

      --- In linux-dell-laptops@yahoogroups.com, Haedn Thorn
      <lordhaedn@y...> wrote:
      > --- "Michelle L. Gill" <michelle.gill@y...> wrote:
      > > I have a Dell Inspiron 4150 and just got a new hard
      > > drive. I
      > > partitioned it and decided to put Suse 9.1 Personal
      > > on one and
      > > Windows on the other. I have done this before, just
      > > with Red Hat
      > > 8.0 being on the linux parition.
      > >
      > > Everything was working fine until I accidentally hit
      > > "Failsafe" at
      > > the boot screen instead of "Dos". Now all I can get
      > > to come up is
      > > something about "GRUB loading stage2" and "Error
      > > 18:Selected
      > > cylinder exceeds maximum supported by BIOS" and a
      > > terminal. I've
      > > tried restarting it several times. I can
      > > sucessfully "halt" the
      > > terminal and "reboot" but I always end up at the
      > > same place.
      > >
      > > I'm guessing I need to do some fancy kernel loading
      > > or something,
      > > but I have absolutely no clue what to do.
      > >
      > > This is so frustrating...I am a scientist and just
      > > loaded all of my
      > > data onto linux. It's so ridiculous that an
      > > accidental push of a
      > > button could kill everything on my computer. Linux
      > > frustrates me so
      > > much!
      > >
      > > Any advice would be helpful...and probably save me
      > > days of setting
      > > this up again.
      > Can you 'mount' from the terminal? If so, do 'mount
      > /dev/hda?' where ? is the partition number Linux lives
      > on. You might have to give it a mount point which
      > should be an empty directory in your current setup. If
      > you're coming from RedHat and SuSe, I have to assume
      > you are probably not at home with the command prompt?
      > A few basics may be in order...
      >
      > Hopefully your prompt ends in "#", that means you are
      > 'root' and have access to everything. If you aren't
      > certain, type 'whoami' and hopefully that will say
      > "root" .. If your prompt doesn't say what directory
      > you're in (usually fresh logins start at "~/" your
      > 'home' directory') you can do 'pwd' to tell your
      > currect directory. 'cd' is Change Directory, 'ls' is
      > LiSt files. 'vi' is one possible text editor, though,
      > if you aren't at home on the command line interface,
      > you won't likely guess the cryptic commands for vi.. I
      > use pico, myself, but it isn't available on every
      > system. 'mkdir' is MaKe DIRedtory, and that is what
      > you will have to do to create an empty directory if
      > you can't find a suitible one to mount to.
      >
      > OK, basics aside. I only have experience with the LILO
      > boot loader, so my help on GRUB will be pretty weak.
      > In LILO, they always warn about not being able to boot
      > to a partition which begins past the 1024th cylinder.
      > This is what it sounds like is happening to you. The
      > option of 'FailSafe' probably told it that you were ok
      > within these specs. Basically, if your Linux partition
      > is last on the drive and you have an older system, you
      > have to either tell lilo/grub that it's ok to try to
      > boot past 1024, or you have to create a boot partition
      > that comes soon enough on the drive. I'm not sure how
      > to do this exactly in grub, but a HOWTO at
      > www.tldp.org should get you there.
      >
      > In any case, if you can mount the partition, you can
      > gain access to your data. I'd start by recovering the
      > data, and then either mess with getting the thing to
      > boot, or reload back to something you're more
      > comfortable with.
    Your message has been successfully submitted and would be delivered to recipients shortly.