Loading ...
Sorry, an error occurred while loading the content.

Re: Followup to "HELP!!! PLEASE!! Dell Inspiron 4150 will no longer boot."

Expand Messages
  • Michelle L. Gill
    Hi Ken, I actually tried that (after my post, of course) and I was completely unable to access any files on my system from a boot disk (CD-ROM in my case).
    Message 1 of 3 , Jul 26, 2004
    • 0 Attachment
      Hi Ken,

      I actually tried that (after my post, of course) and I was completely
      unable to access any files on my system from a boot disk (CD-ROM in my
      case). The only files present were those from the minix files on the
      CD-ROM.

      I ended up just reinstalling everything. (It was a major pain, but
      everything was at least backed up.) It seems to be working now. I
      also checked the "failsafe" option (which I have now dubbed the
      "failalways" option and it seems fine. Something must have went awry
      during my first install. It's ok..I have it better set up this time
      through, anyway.

      Thanks for the info.
      Michelle Gill
      --- In linux-dell-laptops@yahoogroups.com, gebser@s... wrote:
      >
      > Michelle,
      >
      > You need a linux boot floppy. You can probably find one on the web
      > somewhere, but there should also be one on one of your install CDs,
      > likely the first one. (Caveat: I'm not too familia with Suse, but RH
      > always had a file on the first CD which could be written to a floppy to
      > make a boot disk. If you need more help making/getting this boot disk,
      > come back and ask for it.
      >
      > This boot disk should have a utility on it called 'fdisk'. If it
      > doesn't, copy it onto it.
      >
      > Second: use this Linux boot floppy to boot your machine. Then run
      > 'fdisk /dev/hda' (the hda refers to the first IDE drive). fdisk uses a
      > menu so it's pretty easy to navigate and use. You should be able to
      > find an fdisk manpage on the web, but you probably won't need it.
      >
      > Once into fdisk, hit 'p' and Return. This will list the partitions on
      > the drive. Then hit 'l' (el) and Return. This will reveal the
      > numerical codes for the partition types.
      >
      > Grab a half a sandwich and look over the partitions and figure out what
      > is where. As said before, your boot partition must be completely
      within
      > the first 1024 cylindders, i.e., within cylinders 0 - 1023. If it
      > isn't, then that's your problem.
      >
      > hth,
      > ken
      >
      > P.S. Save that Linux boot disk. It's a real handy thing to have around.
      >
      >
      >
      > At 13:02 (UTC-0000) on Sun, 25 Jul 2004 Michelle L. Gill said:
      >
      > = After doing some browsing ala the Google manual, I think I
      > = understand WHY I'm having this problem, just not how to fix it and
      > = keep it from happening again. (The text of my previous post is below
      > = the asterisk line).
      > =
      > = >From my (very basic) understanding of GRUB, I'm getting a cylinder
      > = error because of where my boot sector is located on my hard drive.
      > = I installed the Windows NTFS partition first (~25 GB) and created a
      > = small FAT32 swap space (~5GB). Then I installed Suse, so my boot
      > = sector is probably about 30 BG into my 60 GB hard drive. This boot
      > = sector is followed by my linux partition and the linux swap space.
      > = (I believe this order is correct, although I can no longer check
      > = since I can't boot into anything but a terminal.)
      > =
      > = Does this seem like it would be the cause of my problem? One
      > = seeming contradiction with this is that I'm guessing most people do
      > = their installs in this order and end up with a similar setup. I
      > = also read that supposed recent versions of GRUB (I'm assuming I have
      > = this since I'm installing a brand new SuSE OS) don't have this
      > = problem. So it seems odd that I AM having this problem.
      > =
      > = When I had Red Hat 8.0 (a much older distribution) on my computer,
      > = my windows parition was first and was about 20 GB. I never had
      > = problems then. Although, Red Hat doesn't give you a failsafe option
      > = at boot time, so maybe they were just a little more "idiot"
      > = proof. :)
      > =
      > = There is ONE caveat to my above assumptions. I don't recall exactly
      > = where the boot sector is, so it's possible that SuSE could have put
      > = it at the very end of my hard drive. Would the suppossed "new"
      > = version of GRUB still be having problems if it were located at over
      > = 55 GB into the hard disk? Maybe this is too much, even for the
      > = update. If this is the case, it's odd that I've been using my
      > = computer without problems for two days until now. Any expertise out
      > = there would be helpful. If this IS the problem, I assume a simple
      > = reformat/reload while paying careful attention to what SuSE does
      > = with my partitions would be the fix.
      > =
      > = What I'm not sure about are:
      > = 1. How to determine the order of my partitions within GRUB.
      > = 2. How to fix it at least temporarily so I can get a few things off
      > = of my hard drive.
      > = 3. If there is a permanent fix besides reformatting my hard drive to
      > = put the boot sector elsewhere.
      > = 3. If reformatting is the only answer and a location of 30 GB into
      > = the hard drisk is too much, how do I get my boot sector at the
      > = beginning of my hard drive if (as I've always been told) you have to
      > = install Windows first.
      > =
      > = Thanks again.
      > =
      > = *****************************************************
      > = I have a Dell Inspiron 4150 and just got a new hard drive. I
      > = partitioned it and decided to put Suse 9.1 Personal on one and
      > = Windows on the other. I have done this before, just with Red Hat
      > = 8.0 being on the linux parition.
      > =
      > = Everything was working fine until I accidentally hit "Failsafe" at
      > = the boot screen instead of "Dos". Now all I can get to come up is
      > = something about "GRUB loading stage2" and "Error 18:Selected
      > = cylinder exceeds maximum supported by BIOS" and a terminal. I've
      > = tried restarting it several times. I can sucessfully "halt" the
      > = terminal and "reboot" but I always end up at the same place.
      > =
      > = I'm guessing I need to do some fancy kernel loading or something,
      > = but I have absolutely no clue what to do.
      > =
      > = This is so frustrating...I am a scientist and just loaded all of my
      > = data onto linux. It's so ridiculous that an accidental push of a
      > = button could kill everything on my computer. Linux frustrates me so
      > = much!
      > =
      > = Any advice would be helpful...and probably save me days of setting
      > = this up again.
      > =
      > =
      > =
      > =
      > =
      > = --------------------------------------------------------------
      > = Please post your X config files in the group links or database
      > = To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
      > = FAQ: http://www.whacked.net/ldl/faq
      > = Yahoo! Groups Links
      > =
      > =
      > =
      > =
      > =
      > =
    Your message has been successfully submitted and would be delivered to recipients shortly.