Loading ...
Sorry, an error occurred while loading the content.

Bootsplash with Inspiron 1100

Expand Messages
  • draino-dell1315@mailblocks.com
    I was wondering if anyone had any luck getting bootsplash to work with the Inspiron 1100. I am at my wits end trying to get it to work with no luck.. I m about
    Message 1 of 2 , Feb 28, 2004
    • 0 Attachment

      I was wondering if anyone had any luck getting bootsplash to work with the Inspiron 1100. I am at my wits end trying to get it to work with no luck.. I'm about to give up thinking it's hardware related.. If anyone has any info. please share! Framebuffer works fine for me, grub splash works fine, but the actual bootsplash isn't working.. I am currently running Gentoo with the 2.6.3-love6 kernel.

         Thanks,

            -Josh

    • Andy Stenger
      Hi, this is what fixed my bootsplash (on Suse 9.0, Lattitude C840): earth:~ # mkinitrd Root device: /dev/hda3 (mounted on / as reiserfs) Module list:
      Message 2 of 2 , Mar 3, 2004
      • 0 Attachment
        Hi,

        this is what fixed my bootsplash (on Suse 9.0, Lattitude C840):

        earth:~ # mkinitrd
        Root device:    /dev/hda3 (mounted on / as reiserfs)
        Module list:    reiserfs
        Kernel version: 2.4.21-192-default (i386)
        Kernel image:   /boot/vmlinuz-2.4.21-192-default
        Initrd image:   /boot/initrd-2.4.21-192-default
        Shared libs:    none
        Modules:        kernel/fs/reiserfs/reiserfs.o
        Bootsplash:     SuSE (1600x1200)
        # # note the comment about the bootsplash above. If you don't get it, it's not in the ram disk

        # grub --batch </etc/grub.conf

        If you just rebuild the initrd it probably won't help since the pointer to the initrd in your grub boot stub is not updated.

        Beforehand I checked the configuration in yast. There are a couple of variables that say that splash should be enabled.

        Go to yast and use the "Editor for /etc/sysconfg Files". Search for "splash". Make sure that "SPLASH" is set to "yes" and some theme is enabled (mine was set to "SuSE" by default).

        I did a fresh install and the bootsplash didn't work. The values in the config were already o.k., though. I suppose Sissi 9.0 just forgets to rebuild the initrd before calling grub. If I recall this correctly Sissi 8.2 did not have that problem.

        I don't think this is relevant, but this is my Linux entry from /boot/grub/menu.lst. Be careful with copying the vga= setting since my display resolution is rather high. Notice the initrd setting that has to point to the proper device and path. Be aware that grub device numbering differs from Linux numbering. My root on /dev/hda3 corresponds to (hd0,2) for grub. You can see from the entries below that I do not have a separate /boot partition:

        title Linux
            kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 vga=0x346 splash=silent desktop hdb=ide-scsi hdblun=0 showopts
            initrd (hd0,2)/boot/initrd

        The splash=silent means that the progress bar appears during boot where you can get to the detailed reports by pressing F2.

        Hope this helps.

        Cheers!

        Andy

      Your message has been successfully submitted and would be delivered to recipients shortly.