Loading ...
Sorry, an error occurred while loading the content.

Connecting external drive to my Dell Linux machine

Expand Messages
  • R F
    Hi, I have an external harddrive that is NTFS partitioned. When I connect it to my laptop (running Linux 8.2) the drive mounts and I can access the files only
    Message 1 of 14 , Feb 26, 2004
    • 0 Attachment
      Hi,
      I have an external harddrive that is NTFS partitioned. When I
      connect it to my laptop (running Linux 8.2) the drive mounts and I
      can access the files only if I'm logged in as root. Also once I've
      connected I can only read files on the drive. I can't copy or delete.

      Could anyone offer some advice on what the cause might be and how I
      can fis the problem?

      I'd really like to be able to access the drive with my normal login
      also.

      Cheers,
      - Richard
    • IbericoVespucio
      R F escribía: [[linux-dell-laptops] Connecting external drive to my Dell Linux machine], el 26 de febrero de 2004 a las 10:16:26 (-0000) ... Try mounting with
      Message 2 of 14 , Feb 26, 2004
      • 0 Attachment
        R F escribía: [[linux-dell-laptops] Connecting external drive to my Dell Linux machine], el 26 de febrero de 2004 a las 10:16:26 (-0000)
        > Hi,
        > I have an external harddrive that is NTFS partitioned. When I
        > connect it to my laptop (running Linux 8.2) the drive mounts and I
        > can access the files only if I'm logged in as root. Also once I've
        > connected I can only read files on the drive. I can't copy or delete.
        >
        > Could anyone offer some advice on what the cause might be and how I
        > can fis the problem?
        >
        > I'd really like to be able to access the drive with my normal login
        > also.

        Try mounting with -o umask=0000

        You can add the option in your fstab as

        /dev/sda1 /mnt/sda1 vfat defaults,user,umask=000


        Ángel.

        --
        ibericovespucio
        @...

        "Hay que darle al niño malo, más amor y menos palo."
        -- Refrán.
      • Bill Bailey
        I would also caution against trying to delete and or write to this drive it could very well prove to be a major issue. ... I would also caution against trying
        Message 3 of 14 , Feb 26, 2004
        • 0 Attachment
          I would also caution against trying to delete and or write to this drive it could very well prove to be a major issue.


          IbericoVespucio wrote:
          R F escribía: [[linux-dell-laptops] Connecting external drive to my Dell Linux machine], el 26 de febrero de 2004 a las 10:16:26 (-0000) 
            
          Hi,
           I have an external harddrive that is NTFS partitioned. When I 
          connect it to my laptop (running Linux 8.2) the drive mounts and I 
          can access the files only if I'm logged in as root. Also once I've 
          connected I can only read files on the drive. I can't copy or delete. 
          
          Could anyone offer some advice on what the cause might be and how I 
          can fis the problem? 
          
          I'd really like to be able to access the drive with my normal login 
          also. 
              
          Try mounting with -o umask=0000
          
          You can add the option in your fstab as 
          
          /dev/sda1       /mnt/sda1       vfat    defaults,user,umask=000
          
          
            Ángel.
          
            
        • R F
          Thanks Refrán, I m new to Linux so I m not 100% sure on what you mean below. Where can I set this setting?
          Message 4 of 14 , Feb 26, 2004
          • 0 Attachment
            Thanks Refrán,

            I'm new to Linux so I'm not 100% sure on what you mean below.

            Where can I set this setting?

            > Try mounting with -o umask=0000
            >
            > You can add the option in your fstab as
            >
            > /dev/sda1 /mnt/sda1 vfat defaults,user,umask=000
            >
            >
            > Ángel.
            >
            > --
            > ibericovespucio
            > @...
            >
            > "Hay que darle al niño malo, más amor y menos palo."
            > -- Refrán.
          • IbericoVespucio
            R F escribía: [[linux-dell-laptops] Re: Connecting external drive to my Dell Linux machine], el 26 de febrero de 2004 a las 12:58:23 (-0000) ... When you
            Message 5 of 14 , Feb 26, 2004
            • 0 Attachment
              R F escribía: [[linux-dell-laptops] Re: Connecting external drive to my Dell Linux machine], el 26 de febrero de 2004 a las 12:58:23 (-0000)
              > Thanks Refrán,
              >
              > I'm new to Linux so I'm not 100% sure on what you mean below.
              >
              > Where can I set this setting?

              When you mount the drive, probably write something as

              mount /dev/sda1 /mnt/sda1

              Try with:

              mount -oumask=000 /dev/sda1 /mnt/sda1

              Also, you can put a line in yout /etc/fstab as

              /dev/sda1 /mnt/sda1 vfat defaults,user,umask=000

              in order to make the option permanent. For more information:

              man mount


              Ángel.

              --
              ibericovespucio
              @...

              "Cómo sople el viento puede variar la velocidad del barco.
              Su dirección la fija el timonel."
            • Steffen Lorch
              ... in /etc/fstab. Try: nano -w /etc/fstab or vim /etc/fstab cu Steffen -- BOFH Excuse #399: We are a 100% Microsoft Shop.
              Message 6 of 14 , Feb 26, 2004
              • 0 Attachment
                Du (R F) schriebst:

                > > Try mounting with -o umask=0000
                > >
                > > You can add the option in your fstab as
                > >
                > > /dev/sda1 /mnt/sda1 vfat defaults,user,umask=000

                > I'm new to Linux so I'm not 100% sure on what you mean below.
                >
                > Where can I set this setting?

                in /etc/fstab. Try:

                nano -w /etc/fstab

                or

                vim /etc/fstab


                cu
                Steffen

                --
                BOFH Excuse #399:

                We are a 100% Microsoft Shop.
              • Douglas S. Oliver
                Vfat is not NTFS. Vfat is used for normal windows fat32 partitions. When I make/compile a custom kernel, there are two ntfs options. The stable one is a
                Message 7 of 14 , Feb 26, 2004
                • 0 Attachment
                  Vfat is not NTFS. Vfat is used for normal windows fat32 partitions. When
                  I make/compile a custom kernel, there are two ntfs options. The stable
                  one is a read-only module as you have. The r/w ntfs module is highly
                  experimental. It's suggested to only use this with caution--that's in
                  the source documentation.

                  Windows 2000 and XP can be set up to use fat32 (vfat) partitions, but
                  the default is ntfs. You could take the drive to a windows box and use
                  any of a number of programs to convert the ntfs partitions to fat32.

                  A couple of days ago, a program was mentioned that allows us linux users
                  to access ntfs partitions in r/w mode, but that's not a normal part of
                  the kernel or its modules (at least the 2.4 kernels).

                  -- d

                  On Thu, 2004-02-26 at 07:00, Steffen Lorch wrote:
                  > Du (R F) schriebst:
                  >
                  > > > Try mounting with -o umask=0000
                  > > >
                  > > > You can add the option in your fstab as
                  > > >
                  > > > /dev/sda1 /mnt/sda1 vfat defaults,user,umask=000
                  >
                  > > I'm new to Linux so I'm not 100% sure on what you mean below.
                  > >
                  > > Where can I set this setting?
                  >
                  > in /etc/fstab. Try:
                  >
                  > nano -w /etc/fstab
                  >
                  > or
                  >
                  > vim /etc/fstab
                  >
                  >
                  > cu
                  > Steffen
                • Steffen Lorch
                  ... so? ... so? ... sure? x x NTFS file system support x x x x [ ] NTFS debugging support (NEW) x x x x [ ]
                  Message 8 of 14 , Feb 26, 2004
                  • 0 Attachment
                    Du (Douglas S. Oliver) schriebst:

                    > Vfat is not NTFS.

                    so?

                    > Vfat is used for normal windows fat32 partitions.

                    so?

                    > When I make/compile a custom kernel, there are two ntfs options. The
                    > stable one is a read-only module as you have. The r/w ntfs module is
                    > highly experimental. It's suggested to only use this with
                    > caution--that's in the source documentation.

                    sure?

                    x x <M> NTFS file system support
                    x x x x [ ] NTFS debugging support (NEW)
                    x x x x [ ] NTFS write support (NEW)

                    Help:
                    --- snip ---
                    This enables the partial, but safe, write support in the NTFS driver.
                    The only supported operation is overwriting existing files, without
                    changing the file length. No file or directory creation, deletion or
                    renaming is possible. Note only non-resident files can be written to
                    so you may find that some very small files (<500 bytes or so) cannot
                    be written to.
                    While we cannot guarantee that it will not damage any data, we have
                    so far not received a single report where the driver would have
                    damaged someones data so we assume it is perfectly safe to use.
                    --- snap ---

                    but ACK to you, I would not use it.

                    > A couple of days ago, a program was mentioned that allows us linux
                    > users to access ntfs partitions in r/w mode, but that's not a normal
                    > part of the kernel or its modules (at least the 2.4 kernels).

                    Ok, the above mentioned doku is from 2.6.3 ;)


                    cu
                    Steffen

                    --
                    BOFH Excuse #307:

                    emissions from GSM-phones
                  • Douglas S. Oliver
                    X-eGroups-Return: sentto-1288743-22930-1077826423-dsoliver=earthlink.net@returns.groups.yahoo.com X-Sender: steffen.lorch@stlo.de X-Apparently-To:
                    Message 9 of 14 , Feb 26, 2004
                    • 0 Attachment
                      X-eGroups-Return: sentto-1288743-22930-1077826423-dsoliver=earthlink.net@...
                      X-Sender: steffen.lorch@...
                      X-Apparently-To: linux-dell-laptops@yahoogroups.com
                      Organization: -- none --
                      X-eGroups-Remote-IP: 81.169.145.166
                      From: Steffen Lorch <Steffen.Lorch@...>
                      X-Yahoo-Profile: majipoorlorch
                      Mailing-List: list linux-dell-laptops@yahoogroups.com; contact linux-dell-laptops-owner@yahoogroups.com
                      Date: Thu, 26 Feb 2004 21:15:31 +0000
                      Reply-To: linux-dell-laptops@yahoogroups.com

                      Du (Douglas S. Oliver) schriebst:

                      > Vfat is not NTFS.

                      so?

                      So if you use vfat to read ntfs, it won't work.

                      > Vfat is used for normal windows fat32 partitions.

                      so?

                      Ditto, here. I thought we were talking about ntfs.

                      > When I make/compile a custom kernel, there are two ntfs options. The
                      > stable one is a read-only module as you have. The r/w ntfs module is
                      > highly experimental. It's suggested to only use this with
                      > caution--that's in the source documentation.

                      sure?

                      --- snap ---

                      but ACK to you, I would not use it.

                      > A couple of days ago, a program was mentioned that allows us linux
                      > users to access ntfs partitions in r/w mode, but that's not a normal
                      > part of the kernel or its modules (at least the 2.4 kernels).

                      Ok, the above mentioned doku is from 2.6.3 ;)


                      cu
                      Steffen
                      I think this is really good about 2.6.3. I obviously haven't started
                      using it yet. Maybe I'll give it a try sometime soon. Thanks -- d
                    • AthlonRob
                      ... I think I know what is wrong. It likely has something to do with the time traveling procedure your laptop went through to get to you. Linux 8.2, which
                      Message 10 of 14 , Feb 26, 2004
                      • 0 Attachment
                        On Thu, 2004-02-26 at 02:16, R F wrote:

                        > I have an external harddrive that is NTFS partitioned. When I
                        > connect it to my laptop (running Linux 8.2) the drive mounts and I
                        > can access the files only if I'm logged in as root. Also once I've
                        > connected I can only read files on the drive. I can't copy or delete.

                        I think I know what is wrong. It likely has something to do with the
                        time traveling procedure your laptop went through to get to you. Linux
                        8.2, which will probably be released within the next six decades,
                        probably will no longer have support for (then) ancient hardware like
                        hard drives. If it happens to work, count your blessings.

                        Rob

                        (hint - Linux is the kernel, you meant either RedHat 8.2, Mandrake 8.2,
                        or something else 8.2 - most of us are *not* using RedHat)
                      • AthlonRob
                        ... I would have included an answer to your query in my last email, making a point about your use of the word Linux where you likely meant RedHat, but I had
                        Message 11 of 14 , Feb 26, 2004
                        • 0 Attachment
                          On Thu, 2004-02-26 at 02:16, R F wrote:

                          > I have an external harddrive that is NTFS partitioned. When I
                          > connect it to my laptop (running Linux 8.2) the drive mounts and I
                          > can access the files only if I'm logged in as root. Also once I've
                          > connected I can only read files on the drive. I can't copy or delete.

                          I would have included an answer to your query in my last email, making a
                          point about your use of the word Linux where you likely meant RedHat,
                          but I had assumed the software recently available was more well known
                          than it apparently was.

                          Linux and NTFS have, for years, not gotten along. Microsoft has NTFS
                          all locked up, pretty much. It's a fairly complex system, especially
                          when trying to figure it out from the outside.

                          A few years ago NTFS read support appeared in the Kernel. All were
                          happy. Then people started clammoring for NTFS write support. In the
                          2.4 series of kernels, there was a very dangerous option to enable very
                          limited NTFS writing... it tended to break filesystems as often as not
                          and certainly wasn't very full featured.

                          In the 2.6 kernel, NTFS write support has been made safe. However, it
                          has to be *the most* limited write support of anything in the world.
                          :-)

                          It can not do anything except write to pre-existing files, and cannot
                          modify the file lengths when it does that. It is, for all intents and
                          purposes, completely useless except perhaps to cat 0's over a virus
                          executable from a rescue disk.

                          Within the last year or two, people have been using the idea of allowing
                          Microsoft to do all the work for things. Rather than porting things to
                          Linux, we just use the Windows binaries and trick them into doing the
                          work. The NDIS wrappers are, I think, a good example of this.

                          Along the same lines as those NDIS wrappers is a fairly new project
                          called 'Captive' - it uses a few Windows files to give you full
                          read/write access to an NTFS partition. In my experience, it was unable
                          to recursively delete directories, but was otherwise a perfect solution.

                          http://www.jankratochvil.net/project/captive/

                          Now, the other posts about UMASK and stuff like that will allow non-root
                          users read-only access to the drive. But to really use the drive,
                          captive is going to be your best bet.

                          Have fun. :-)

                          Rob
                        • IbericoVespucio
                          Douglas S. Oliver escribía: [Re: [linux-dell-laptops] Re: Connecting external drive to my Dell Linux machine], el 26 de febrero de 2004 a las 08:24:53 (-0800)
                          Message 12 of 14 , Feb 27, 2004
                          • 0 Attachment
                            Douglas S. Oliver escribía: [Re: [linux-dell-laptops] Re: Connecting external drive to my Dell Linux machine], el 26 de febrero de 2004 a las 08:24:53 (-0800)

                            > Vfat is not NTFS. Vfat is used for normal windows fat32 partitions.

                            OPSS!

                            I did'n notice that there was NTFS. I'm sorry. I hope there has been
                            no damage on your files as a result of my advice.

                            Sorry again,

                            Ángel.

                            --
                            ibericovespucio
                            @...

                            "¿No tienes enemigos? ¿Es que jamás dijiste la verdad o jamás
                            amaste la justicia" -- Santiago Ramón y Cajal. (1852-1934)
                          • Steffen Lorch
                            ... Calm down ;) ... There would be an error message. But no damage. Be asured. Except you would use an bk Kernel. That would be of cause very dangerous. cu
                            Message 13 of 14 , Feb 27, 2004
                            • 0 Attachment
                              Du (IbericoVespucio) schriebst:

                              > Douglas S. Oliver escribía: [Re: [linux-dell-laptops] Re: Connecting
                              > external drive to my Dell Linux machine], el 26 de febrero de 2004 a
                              > las 08:24:53 (-0800)
                              >
                              > > Vfat is not NTFS. Vfat is used for normal windows fat32 partitions.
                              >
                              > OPSS!

                              Calm down ;)

                              > I did'n notice that there was NTFS. I'm sorry. I hope there has been
                              > no damage on your files as a result of my advice.

                              There would be an error message. But no damage. Be asured. Except you
                              would use an bk Kernel. That would be of cause very dangerous.


                              cu
                              Steffen

                              --
                              BOFH Excuse #272:

                              Netscape has crashed
                            • R F
                              Sweet - thanks for the very thorough advice.
                              Message 14 of 14 , Mar 1, 2004
                              • 0 Attachment
                                Sweet - thanks for the very thorough advice.
                              Your message has been successfully submitted and would be delivered to recipients shortly.