Loading ...
Sorry, an error occurred while loading the content.

Installing Kernel-2.6.2 on a Dell

Expand Messages
  • Marvin Pierce
    I posted this on the Libranet mailing list as I use Libranet2.8 which has been updated to L2.8.1 (Debian sid). I think it may be of benefit here as my system
    Message 1 of 1 , Feb 12, 2004
    • 0 Attachment
      I posted this on the Libranet mailing list as I use Libranet2.8 which
      has been updated to L2.8.1 (Debian sid).

      I think it may be of benefit here as my system is a Dell Inspiron 8100
      with 512Mb ram, 40Gb, 1600x1200 XSVGA, DVD-CD-Rom, Xircom 10/100
      Ethernet Card, Docking station with inbuilt 3com NIC, a USB PS2 mouse
      attached to the docking station along with a HP CD-RW 8200 and a 128Kb
      disk on key storage device that I plug in often.

      I'm assuming that you know how to configure /etc/fstab to get a USBhd
      device working and that you are know how to config /etc/X11/XF86Config-4
      to make a dual mouse working (file references are where files reside on
      a Debian system). Some references to programs, i.e., Adminmenu etc are
      specific to Libranet.

      Here is mandatory reading:

      HowTo Upgrade To The 2.6 Kernel
      http://kerneltrap.org/node/view/799

      Building and installing nVidia drivers with a 2.6 kernel in Debian
      GNU/Linux
      http://home.comcast.net/~andrex/nvidia-2.6-Debian/index.html

      NVIDIA Linux x86, x86-64 Driver Patches
      http://www.minion.de/nvidia.html

      Here is what I did with HowTo Upgrade as my bible (using my notebook as
      the example although I did the same thing on my server with mods):
      1) Made damn sure I had a boot disc of kernel-2.4.24 and printed out all
      my reference instructions.

      2) Did a final system upgrade from the Libranet servers and downloaded
      kernel-source-2.6.2 and since both boxes use nvidia drivers I also
      downloaded, nvidia-kernel-source and nvidia-kernel-common

      3) tar xjvf kernel-source-2.6.2.tar.bz2 && (rm -rf
      kernel-source-2.6.2.tar.bz2) && ln -s kernel-source-2.6.2/ linux
      NB - following the bible, you will not have to download any nvidia
      patches that he talks about in section 1 as you already have nvidia
      runnning if you use it.

      4) cd linux && cp /boot/config-2.4.24 /usr/src/linux/.config

      5) make menuconfig
      NB #1 - There are many new features, check and recheck your
      options!!!
      Anything I specifically needed I built-in, i.e., network cards,
      sound
      card support including everything to do with ALSA as well as, my PCI
      soundcard, pcmcia support and USB support (built in both OHCI and UHCI
      even though my system uses OHCI)
      NB #2 - In "Device Drivers/Input Device Support", my server which
      only has a PS2 mouse attached to it required that "Enable /dev/psaux
      device by default" was enabled so that it had a Corepointer. If this is
      not enbled, the new nvidia driver will keep trying to load but fail
      (reviewing the log said that there is no CorePointer - this resulted in
      a recompile). On my notebook which has both a USB mouse and synaptics
      touchpad, I did not enable this feature but enabled "Event Interface" as
      an in-built option (enabled this feature on both boxes).

      6) save options and cp .config /boot/config-2.6.2 (reminder without
      Adminmenu somethings do not automatically occur and this is one of the
      little things that will not happen).

      7) make-kpkg kernel_image
      This will be saved in /usr/src as
      kernel-image-2.6.2_10.00.Custom_i386.deb (both my server & notebook have
      the same file named for this package)
      The install will give you a some new messages talking about the
      modules and how they will not be installed until you reboot.

      NB - In section 2c of the bible, building the nvidia kernel module
      failed. He talks about this in troubleshooting but. I carried on after
      the failure to initially see what would happen.

      8) From the minion website, I now downloaded the nvidia patch which
      related to the version of the nvidia driver I downloaded and followed
      the instructions in the readme (create a directory somewhere to do this
      and not in /tmp as it will be zapped when you reboot):
      NVIDIA_kernel-1.0-4496.README NVIDIA_kernel-1.0-4496-2.6.diff

      9) Manually edited /boot/grub/menu.1st and did a yank (12 yy) of all
      references to kernel-2.4.24 and 2.4.24 (single user). Reinstalled the
      line references and changed 2.4.24 to 2.6.2 as default.

      10) Moment of truth - crossed fingers and rebooted. Lots of fatal error
      messages appeared on the screen referring to modules that could not load
      or could not be found; ugh oh, but she booted. Nvidia failed to load but
      experience has told me not to panic. I reboot again. Module messages now
      OK but still no nvidia.

      Fixing nvidia.
      11) I log in as root and make sure X is disabled by doing after it has
      told me it can't launch X at runlevel 3:
      /etc/init.d/gdm stop (if you don't stop it the next step will fail as
      it is running in the background)

      I now change to my ~/Eraseme/ folder where I have put the nvidia stuff
      and follow the directions in the readme file by installing the patch to
      nvidia, linking the makefile and then doing the make install (NB: I
      already had the nvidia package installer on my computer as Adminmenu had
      failed to upgrade the nvidia drivers when I switched to kernel-2.4.24
      and this updated and reinstalled them flawlessly).

      12) I issue the command:
      /etc/init.d/gmd start
      She works - X launches perfectly.

      I log in as a user and since my box on startup using the programs,
      saydate and saytime, tells me this information I hear it. Alsa is
      working. I ping my server - networking is working, I ping my ISP, there
      internet is working. I start launching apps including xmms and
      realplayer - they are working. I burn a test cd using K3b - everything
      is working and the responsiveness (speed) is really impressive and I've
      built and tested a lot of kernels since I started using Linux in 1995/6.
      Getting both mice working:
      13) Download and install the package, synaptics-0.12.4
      After untarring, follow the instructions in INSTALL that's it.
      If your mouse and touchpad worked before, it'll work the same under (as
      I've not noticed any difference in responsiveness).

      This was my trial by fire!

      I'm now going to make a floppy and I'll remove all references to
      kernel-2.4.24 within the next 24 hours as kernel-2.6.2 will have run
      perfectly for my 72-hour test period.

      PS - I also removed all of those old Alsa packages from the system. I've
      kept libasound and alsa-base so I could have aumix.

      Happy compiling!

      Marvin
      ---
    Your message has been successfully submitted and would be delivered to recipients shortly.