Loading ...
Sorry, an error occurred while loading the content.

Re: Beep unmutable

Expand Messages
  • turkeynip
    ... de December de 2003 a las 06:13:37 (-0000) ... If you look in your settings for your sound (at least that s where it is in Gnome) you can turn off the beep
    Message 1 of 12 , Jan 2, 2004
    • 0 Attachment
      --- In linux-dell-laptops@yahoogroups.com, IbericoVespucio
      <ibericovespucio@y...> wrote:
      > turkeynip escribía: [[linux-dell-laptops] Re: Beep unmutable], el 30
      de December de 2003 a las 06:13:37 (-0000)
      > > Something else you may want to do, if you're complaining about the
      > > beep before starting X (I know that annoys the heck out of me) is put
      > > the following line in your /etc/rc.d/rc.local file:
      > >
      > > setterm -blength 0
      > > echo "Setting default console beep to OFF"
      >
      > Great!
      >
      >
      > > The only thing is that this needs to be run for each ttylx, so if
      > > you're in ttyl0 then it'll work, but if you Ctrl-alt-F2 then you'll
      > > have the beep again unless your run rc.local again.
      >
      > Well. I have put it in /etc/profile so it is read at each login
      > and it works for every terminal.
      >
      > It does not work for Xterm :-( but, anyway the beep is not so
      > annoying in X as in consoles.
      >
      > Thanks a lot,
      >
      >
      > Ángel.
      >
      > --
      > ibericovespucio
      > @...
      >
      > Es detestable esa avaricia espiritual que tienen los que sabiendo
      > algo, no procuran la transmisión de esos conocimientos.
      > -- Miguel de Unamuno. (1864-1936)

      If you look in your settings for your sound (at least that's where it
      is in Gnome) you can turn off the beep (system beep). I'm not sure how
      to do it in other X environments, but I'm sure it'd be similar.

      Thanks for the idea about /etc/profile. I'll have to do that.
    • Andy Farlie
      ... xset b off Andy
      Message 2 of 12 , Jan 2, 2004
      • 0 Attachment
        On Fri, 2004-01-02 at 10:48, turkeynip wrote:
        > --- In linux-dell-laptops@yahoogroups.com, IbericoVespucio
        > <ibericovespucio@y...> wrote:
        > > turkeynip escribía: [[linux-dell-laptops] Re: Beep unmutable], el 30
        > de December de 2003 a las 06:13:37 (-0000)
        > > > Something else you may want to do, if you're complaining about the
        > > > beep before starting X (I know that annoys the heck out of me) is put
        > > > the following line in your /etc/rc.d/rc.local file:
        > > >
        > > > setterm -blength 0
        > > > echo "Setting default console beep to OFF"
        > >
        > > Great!
        > >
        > >
        > > > The only thing is that this needs to be run for each ttylx, so if
        > > > you're in ttyl0 then it'll work, but if you Ctrl-alt-F2 then you'll
        > > > have the beep again unless your run rc.local again.
        > >
        > > Well. I have put it in /etc/profile so it is read at each login
        > > and it works for every terminal.
        > >
        > > It does not work for Xterm :-( but, anyway the beep is not so
        > > annoying in X as in consoles.
        > >
        > > Thanks a lot,
        > >
        > >
        > > Ángel.
        > >
        > > --
        > > ibericovespucio
        > > @...
        > >
        > > Es detestable esa avaricia espiritual que tienen los que sabiendo
        > > algo, no procuran la transmisión de esos conocimientos.
        > > -- Miguel de Unamuno. (1864-1936)
        >
        > If you look in your settings for your sound (at least that's where it
        > is in Gnome) you can turn off the beep (system beep). I'm not sure how
        > to do it in other X environments, but I'm sure it'd be similar.
        >
        > Thanks for the idea about /etc/profile. I'll have to do that.
        >
        >
        >
        >
        > --------------------------------------------------------------
        > Please post your X config files in the group links or database
        > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        > FAQ: http://www.whacked.net/ldl/faq
        >
        > Yahoo! Groups Links
        >
        > To visit your group on the web, go to:
        > http://groups.yahoo.com/group/linux-dell-laptops/
        >
        > To unsubscribe from this group, send an email to:
        > linux-dell-laptops-unsubscribe@yahoogroups.com
        >
        > Your use of Yahoo! Groups is subject to:
        > http://docs.yahoo.com/info/terms/
        >

        xset b off

        Andy
      • IbericoVespucio
        Andy Farlie escribía: [Re: [linux-dell-laptops] Re: Beep unmutable], el 02 de January de 2004 a las 10:52:56 (-0800) ... Great!! Ángel. -- ibericovespucio
        Message 3 of 12 , Jan 3, 2004
        • 0 Attachment
          Andy Farlie escribía: [Re: [linux-dell-laptops] Re: Beep unmutable], el 02 de January de 2004 a las 10:52:56 (-0800)
          >
          > xset b off

          Great!!


          Ángel.

          --
          ibericovespucio
          @...

          "No hables, en manera alguna, hasta que tengas algo que decir."
          (Thomas Carlyle)
        • Pierre Lombard
          Hi, ... And for sake of completeness, adding: set bell-style none or set bell-style visible (if you prefer the screen to flash instead of beeping) to your
          Message 4 of 12 , Jan 7, 2004
          • 0 Attachment
            Hi,

            * IbericoVespucio <ibericovespucio@...> [2004-01-03 21:45]:
            > Andy Farlie escribía: [Re: [linux-dell-laptops] Re: Beep unmutable], el 02 de January de 2004 a las 10:52:56 (-0800)
            > >
            > > xset b off
            >
            > Great!!

            And for sake of completeness, adding:
            set bell-style none
            or
            set bell-style visible (if you prefer the screen to flash instead of beeping)

            to your /etc/inputc (man readline) may help too.

            --
            Best regards,
            Pierre Lombard
          • IbericoVespucio
            Pierre Lombard escribía: [Re: [linux-dell-laptops] Re: Beep unmutable], el 07 de January de 2004 a las 13:56:46 (+0100) ... I don t get the visible-bell.
            Message 5 of 12 , Jan 9, 2004
            • 0 Attachment
              Pierre Lombard escribía: [Re: [linux-dell-laptops] Re: Beep unmutable], el 07 de January de 2004 a las 13:56:46 (+0100)
              >
              > And for sake of completeness, adding:
              > set bell-style none
              > or
              > set bell-style visible (if you prefer the screen to flash instead of beeping)
              >
              > to your /etc/inputc (man readline) may help too.

              I don't get the visible-bell. Screen does not flash or anything.
              Just bell is off


              Otherwise, I found another interesting line for this file:

              set show-all-if-ambiguous on

              This agilize completion and avoid the beep at the first TAB
              pulsation


              Ángel.

              --
              ibericovespucio
              @...

              "Los hombres superficiales creen en la suerte y creen en las
              circunstancias... Los fuertes creen en las causas y los efectos"
              (Emerson)
            Your message has been successfully submitted and would be delivered to recipients shortly.