Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] samba ignoring my config files.

Expand Messages
  • Adrian Buss
    What you might try and do at the command line is smbclient -L -d5 //someserver/someshare It will list each config file as it opens it and what it is doing. Try
    Message 1 of 6 , Sep 24, 2003
    • 0 Attachment
      What you might try and do at the command line is
      smbclient -L -d5 //someserver/someshare

      It will list each config file as it opens it and what it is doing.


      Try that see how far you get...

      Adrian

      On Wed, 24 Sep 2003, John Gilmore wrote:

      > On 24 Sep 2003, Damien Solley wrote:
      >
      > > On Wed, 2003-09-24 at 03:17, John Gilmore wrote:
      > > > I've just installed RedHat 9. It works OK, (some suspend problems) but
      > > > I'm
      > > > having a hell of a time getting samba to work correctly.
      > > > smbclient -L Richard displays the workgroup as 'MYGROUP' and the
      > > > master as
      > > > 'LOCALHOST'
      > > >
      > > > Where is it getting 'MYGROUP'? I've changed it in /etc/samba/smb.conf!
      > > > OK, maybe it's looking at a different config file (years ago, I
      > > > ditched
      > > > redhat for slackware for a simular reason)
      > > >
      > > > strace smbd 2&>t
      > > > vi t
      > > >
      > > > Nope, it's reading the correct config file. Maybe it's got a default
      > > > setting?
      > > >
      > > > grep -i 'mygroup' /usr/sbin/smbd /usr/sbin/nmbd
      > > >
      > > > Nothing! Ok, maybe it's reading in a different config file as well?
      > > >
      > > > cd /etc &&grep -ir 'mygroup' *
      > > >
      > >
      > > If this command didn't return anything, then your /etc/samba/smb.conf
      > > does not contain the word mygroup! Make sure you save changes to your
      > > smb.conf, then restart the service: (just for good measure - should be
      > > unnecessary in recent versions of Samba)
      > > /etc/init.d/smb restart
      >
      >
      > Been there, done that! That's the primary source of my frustration. I
      > *KNOW* that my config file doesn't contain the string 'mygroup'. I *KNOW*
      > that there is no other config file (at least not in the /etc/ heirachy). I
      > *KNOW* that the executable doesn't contain that string. And *STILL* when I
      > restart it it claims that it's workgroup is 'MYGROUP'!!!!!! I'm reduced to
      > swearing at it, which isn't very effective and doesn't get me any closer
      > to a worknig system, and, contrary to rumor, doesn't really do anything to
      > relieve my frustrations either.
      >
      > I had a very simular experience with X on redhat 5 (or so) about four
      > years ago - no matter what garbage I put in the configuration file, it did
      > the same old thing over and over. Eventually I figured out that there was
      > another configuration file in /etc/X11 that was what it was actually
      > reading. But that was after I'd given up in frustration and switched to
      > slackware.
      >
      > Anyway, switching to Slackware isn't an option here - I'm on a 56K dialup,
      > limited power system (solar) and sharing the line with the rest of the
      > household. I've got to get this to work, and there's GOT to be a way to do
      > it.
      >
      > I'm sure it's that I'm missing something glaringly obvious. But, of
      > course, since I'm missing it, I have no idea of what. Even after the
      > restart, smbclient -L richard still says that it's workgroup is 'mygroup'
      > and the NETBios name is 'LOCALHOST' Though it finds it as 'richard'.
      >
      > It's not connected to a network (except the internal vmware network) so
      > it's not seeing some other machine, but what else it's doing I have no
      > idea. The Sambe server version is correct (Samba 2.2.7a) Oh, whait, I just
      > noticed that the 'Domain' reports as 'GILMORE' - which is what the
      > Workgroup should be. Hmm. So how do I specify the workgroup?
      >
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
      > FAQ: http://www.whacked.net/ldl/faq
      >
      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      >
      >

      --
      Adrian Buss - Senior Systems Administrator
      CIRA/ACEI - Canadian Internet Registration Authority http://www.cira.ca
      350 Sparks Street, Suite 1110 613-237-5335 ext. 239
      Ottawa, Ontario K1R 7S8 adrian.buss@...
    Your message has been successfully submitted and would be delivered to recipients shortly.