Loading ...
Sorry, an error occurred while loading the content.

Re: c400 external drive bay

Expand Messages
  • Justin Georgeson
    Ok, I m running GNOME, which was set to mount data cd s automatically, and the service autofs was running. I disabled the GNOME feature and stopped the autofs
    Message 1 of 16 , Sep 1, 2003
    • 0 Attachment
      Ok, I'm running GNOME, which was set to mount data cd's automatically,
      and the service autofs was running. I disabled the GNOME feature and
      stopped the autofs service, and I was able to unload the modules and
      disconnect the drive. I was then able to connect the floppy, access
      it, disconnect it, connect the cd, and mount a disc. But I still can't
      access the cd if it wasn't connected when the system booted. The devfs
      entry isn't created when I connect the drive and load the modules:
      "special device /dev/cdrom does not exist."

      --- In linux-dell-laptops@yahoogroups.com, Brock Campbell <brock@a...>
      wrote:
      > I see, unfortunately I'm not as familiar with Redhat's treatment of
      > this. If possible try it with Knoppix just to be sure it's not a
      > hardware specific thing. Other idea's, maybe there is a daemon,
      > something like automount that is watching for media changes, but not
      > device changes and thus locking up the bus.try looking in /etc/init.d/
      > for a script with mount in it's name (supermount, automount, etc.) and
      > try restarting it when you've disconnected it. this may stop the kernel
      > messages.
      >
      >
      >
      > On Mon, 2003-09-01 at 22:58, Justin Georgeson wrote:
      > > If I disconnect the cable, with the drive unmounted, I get a series of
      > > kernel messages listed below, but they don't stop until I reboot.
      > > Also, I can't unload any of the modules that are loaded for the drive
      > > during boot, even after physically disconnecting the drive. If I then
      > > attach the floppy, I get the set of messages at the end of this post
      > > in /var/log/messages over and over, and I can't read from the floppy.
      > > I can't use the cd drive unless it is connected at boot, and I can't
      > > use the floppy unless I shut down, disconnect the cd, and boot up.
      > > .
      > --
      > Brock Campbell
      > -- System Integration, Consulting, Disaster Recovery --
      > --- Accelerated Technology ---
      > -- brock@a... (306)222-2259 --
      > ----------- www.acceltech.ca -----------
    • Brock Campbell
      Try a lsmod with CD connected and without. there should be an entry corresponding to your CDrom drive. Good luck, I m off to bed, I ll check how you made out
      Message 2 of 16 , Sep 1, 2003
      • 0 Attachment
        Try a lsmod with CD connected and without. there should be an entry
        corresponding to your CDrom drive.

        Good luck, I'm off to bed, I'll check how you made out in the morning.

        On Tue, 2003-09-02 at 00:27, Justin Georgeson wrote:
        > Ok, I'm running GNOME, which was set to mount data cd's automatically,
        > and the service autofs was running. I disabled the GNOME feature and
        > stopped the autofs service, and I was able to unload the modules and
        > disconnect the drive. I was then able to connect the floppy, access
        > it, disconnect it, connect the cd, and mount a disc. But I still can't
        > access the cd if it wasn't connected when the system booted. The devfs
        > entry isn't created when I connect the drive and load the modules:
        > "special device /dev/cdrom does not exist."
        >
        > --- In linux-dell-laptops@yahoogroups.com, Brock Campbell <brock@a...>
        > wrote:
        > > I see, unfortunately I'm not as familiar with Redhat's treatment of
        > > this. If possible try it with Knoppix just to be sure it's not a
        > > hardware specific thing. Other idea's, maybe there is a daemon,
        > > something like automount that is watching for media changes, but not
        > > device changes and thus locking up the bus.try looking in
        > /etc/init.d/
        > > for a script with mount in it's name (supermount, automount, etc.)
        > and
        > > try restarting it when you've disconnected it. this may stop the
        > kernel
        > > messages.
        > >
        > >
        > >
        > > On Mon, 2003-09-01 at 22:58, Justin Georgeson wrote:
        > > > If I disconnect the cable, with the drive unmounted, I get a
        > series of
        > > > kernel messages listed below, but they don't stop until I reboot.
        > > > Also, I can't unload any of the modules that are loaded for the
        > drive
        > > > during boot, even after physically disconnecting the drive. If I
        > then
        > > > attach the floppy, I get the set of messages at the end of this
        > post
        > > > in /var/log/messages over and over, and I can't read from the
        > floppy.
        > > > I can't use the cd drive unless it is connected at boot, and I
        > can't
        > > > use the floppy unless I shut down, disconnect the cd, and boot up.
        > > > .
        > > --
        > > Brock Campbell
        > > -- System Integration, Consulting, Disaster Recovery --
        > > --- Accelerated Technology ---
        > > -- brock@a... (306)222-2259 --
        > > ----------- www.acceltech.ca -----------
        >
        >
        > Yahoo! Groups Sponsor
        > ADVERTISEMENT
        > Click Here!
        >
        > --------------------------------------------------------------
        > Please post your X config files in the group links or database
        > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        > FAQ: http://www.whacked.net/ldl/faq
        >
        > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
        --
        Brock Campbell
        -- System Integration, Consulting, Disaster Recovery --
        --- Accelerated Technology ---
        -- brock@... (306)222-2259 --
        ----------- www.acceltech.ca -----------
      • Justin Georgeson
        Already tried it. I wonder if there should be an entry in /etc/modules.conf linking one of the modules with a block-major device.
        Message 3 of 16 , Sep 2, 2003
        • 0 Attachment
          Already tried it. I wonder if there should be an entry in
          /etc/modules.conf linking one of the modules with a block-major device.

          --- In linux-dell-laptops@yahoogroups.com, Brock Campbell <brock@a...>
          wrote:
          > Try a lsmod with CD connected and without. there should be an entry
          > corresponding to your CDrom drive.
          >
          > Good luck, I'm off to bed, I'll check how you made out in the morning.
          >
          > On Tue, 2003-09-02 at 00:27, Justin Georgeson wrote:
          > > Ok, I'm running GNOME, which was set to mount data cd's automatically,
          > > and the service autofs was running. I disabled the GNOME feature and
          > > stopped the autofs service, and I was able to unload the modules and
          > > disconnect the drive. I was then able to connect the floppy, access
          > > it, disconnect it, connect the cd, and mount a disc. But I still can't
          > > access the cd if it wasn't connected when the system booted. The devfs
          > > entry isn't created when I connect the drive and load the modules:
          > > "special device /dev/cdrom does not exist."
          > >
          > > --- In linux-dell-laptops@yahoogroups.com, Brock Campbell <brock@a...>
          > > wrote:
          > > > I see, unfortunately I'm not as familiar with Redhat's treatment of
          > > > this. If possible try it with Knoppix just to be sure it's not a
          > > > hardware specific thing. Other idea's, maybe there is a daemon,
          > > > something like automount that is watching for media changes, but not
          > > > device changes and thus locking up the bus.try looking in
          > > /etc/init.d/
          > > > for a script with mount in it's name (supermount, automount, etc.)
          > > and
          > > > try restarting it when you've disconnected it. this may stop the
          > > kernel
          > > > messages.
          > > >
          > > >
          > > >
          > > > On Mon, 2003-09-01 at 22:58, Justin Georgeson wrote:
          > > > > If I disconnect the cable, with the drive unmounted, I get a
          > > series of
          > > > > kernel messages listed below, but they don't stop until I reboot.
          > > > > Also, I can't unload any of the modules that are loaded for the
          > > drive
          > > > > during boot, even after physically disconnecting the drive. If I
          > > then
          > > > > attach the floppy, I get the set of messages at the end of this
          > > post
          > > > > in /var/log/messages over and over, and I can't read from the
          > > floppy.
          > > > > I can't use the cd drive unless it is connected at boot, and I
          > > can't
          > > > > use the floppy unless I shut down, disconnect the cd, and boot up.
          > > > > .
          > > > --
          > > > Brock Campbell
          > > > -- System Integration, Consulting, Disaster Recovery --
          > > > --- Accelerated Technology ---
          > > > -- brock@a... (306)222-2259 --
          > > > ----------- www.acceltech.ca -----------
          > >
          > >
          > > Yahoo! Groups Sponsor
          > > ADVERTISEMENT
          > > Click Here!
          > >
          > > --------------------------------------------------------------
          > > Please post your X config files in the group links or database
          > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
          > > FAQ: http://www.whacked.net/ldl/faq
          > >
          > > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
          > --
          > Brock Campbell
          > -- System Integration, Consulting, Disaster Recovery --
          > --- Accelerated Technology ---
          > -- brock@a... (306)222-2259 --
          > ----------- www.acceltech.ca -----------
        Your message has been successfully submitted and would be delivered to recipients shortly.