Loading ...
Sorry, an error occurred while loading the content.

Re: MBR problem/Dual Boot

Expand Messages
  • astuermer2001
    Hello there, thanks to all replies so far. as i reinstalled linux (no update from 8.0), i simply accepted the default boot-loader option of GRUB. I checked
    Message 1 of 6 , Aug 31, 2003
    • 0 Attachment
      Hello there,

      thanks to all replies so far. as i reinstalled linux (no update from
      8.0), i simply
      accepted the default boot-loader option of GRUB.
      I checked the status of my xp-partition with cfdisk and it was
      initially a (visible)
      ntfs partition (as it should be, correct?)
      since i`ve played around with manually editing my /boot/grub/menu.lst
      according to
      what damien advised and what i'd seen in numerous other places on the
      web. last
      attempt was:
      title windows
      rootnoverify (hd0,1)
      makeactive
      chainloader +1
      seemed to help, as now the booting of windows would start - but then
      i get an error
      "autocheck program not found" and boot terminates. cfdisk now tells
      me the
      xp-partition is a hidden ntfs and "bootable". just as i was about to
      assume i?d have
      to reinstall xp i found something on another group that seems to be
      exactly the
      problem i'm having:
      http://www.linuxquestions.org/questions/archive/1/2003/07/3/66137
      apparantly the resolution was simply unhiding the partition with
      cfdisk. my
      question now is though: is that really a safe thing to do? read
      somewhere else,
      that might not be a good idea...
      again, thanks for the help so far!
      greetz,
      arne

      --- In linux-dell-laptops@yahoogroups.com, iriXx <dev_null@i...>
      wrote:
      > ahhh this sounds all too familiar.
      >
      > i suspect you've ended up with a hidden XP partition. its one of
      those
      > joys of microspaz.
      >
      > boot into linux and run cfdisk.
      >
      > choose 'type'
      >
      > and make sure the type of partition for XP is set to
      visible/unhidden,
      > FAT32 or whatever yours is supposed to be (it might have been NTFS)
      >
      > be VERY careful....
      >
      > good luck
      >
      > m~
      >
      > astuermer2001 wrote:
      >
      > > Hey there,
      > > hoping someone here will be able to help me with a problem I'm
      having with
      > > dual booting on my Dell Inspiron 8200...
      > > I installed SuSE 8.2 alongside my XP Home, wanting to emulate the
      dual
      > > booting set-up I had previously with SuSE 8.0, ie. using the XP
      boot-loader.
      > > Must've screwed something up, cause I get the black screen with
      blinking
      > > cursor after start-up and go nowhere from there. Thankfully I
      can use Linux,
      > > booting through the Installation DVD's. Seems there's no way to
      fix the MBR
      > > with the XP-Recovery CD (for me), as the admin password required
      does not
      > > seem to be identival to that of the admin user... Or am I wrong?
      MS online
      > > help only works for me if I could get at my XP Control Panels...
      Is it a risk to
      > > just reinstall Linux and let it write LILO or GRUB to the MBR?
      What's the best
      > > way forward?
      > > Thanks for any help you can give me!
      > > Cheers, Arne
      > >
      > >
      > >
      > > --------------------------------------------------------------
      > > Please post your X config files in the group links or database
      > > To unsubscribe, email: linux-dell-laptops-unsu
      bscribe@yahoogroups.com
      > > FAQ: http://www.whacked.net/ldl/faq
      > >
      > > Your use of Yahoo! Groups is subject to http:/
      /docs.yahoo.com/info/terms/
      > >
      > >
      > >
      > >
      >
      > --
      > |\ _,,,---,,_
      > ZZZzz /,`.-'`' -. ;-;;,_ HTTP 503: Too Busy
      > |,4- ) )-,_. ,\ ( `'-'
      > '---''(_/--' `-'\_) fL
      >
      >
      > "Do not meddle in the affairs of cats, for they are
      > subtle and will piss on your computer."
      > -- Bruce Graham
      >
      >
      > Musicians say No to RIAA Persecution and Prosecution of Music
      Lovers!
      >
      > Sign the petition at http://www.copyleftmedia.org.uk/justsayno/
      >
      >
      > .::. www.iriXx.org .::. www.copyleftmedia.org.uk .::.
    • Damien Solley
      ... arne Unhiding the partition won t change the partition itself, but only set the hidden flag in the mbr to off. It won t change the contents of the
      Message 2 of 6 , Sep 1 12:17 AM
      • 0 Attachment
        On Mon, 2003-09-01 at 16:30, astuermer2001 wrote:
        > Hello there,
        >
        > thanks to all replies so far. as i reinstalled linux (no update from
        > 8.0), i simply
        > accepted the default boot-loader option of GRUB.
        > I checked the status of my xp-partition with cfdisk and it was
        > initially a (visible)
        > ntfs partition (as it should be, correct?)
        > since i`ve played around with manually editing my /boot/grub/menu.lst
        > according to
        > what damien advised and what i'd seen in numerous other places on the
        > web. last
        > attempt was:
        > title windows
        > rootnoverify (hd0,1)
        > makeactive
        > chainloader +1
        > seemed to help, as now the booting of windows would start - but then
        > i get an error
        > "autocheck program not found" and boot terminates. cfdisk now tells
        > me the
        > xp-partition is a hidden ntfs and "bootable". just as i was about to
        > assume i?d have
        > to reinstall xp i found something on another group that seems to be
        > exactly the
        > problem i'm having:
        > http://www.linuxquestions.org/questions/archive/1/2003/07/3/66137
        > apparantly the resolution was simply unhiding the partition with
        > cfdisk. my
        > question now is though: is that really a safe thing to do? read
        > somewhere else,
        > that might not be a good idea...
        > again, thanks for the help so far!
        > greetz,
        arne


        Unhiding the partition won't change the partition itself, but only set
        the 'hidden' flag in the mbr to off. It won't change the contents of the
        partition, or damage the mbr. I've used it many times on fat32 and ntfs
        partitions without any problems.

        If you are paranoid about causing a problem, you can backup your mbr(s).
        Use the dd program. For example, the command:
        dd if=/dev/hda of=backupofmbr_hda bs=512 count=1
        Will save the partition information to a file (backupofmbr_hda). You can
        save this file on a floppy or somewhere. You might also like to backup
        the mbr of /dev/hda1 (if windoze is on hda1) - just edit the command
        above.
        Then, play with cfdisk, make your changes and boot windows.
        If you don't like the changes, then restore the mbr as follows:
        dd if=backupofmbr_hda of=/dev/hda bs=512 count=1

        Have fun, and read man dd.

        Damien


        --


        ~~~~~~~~~~~~~~~~~~~~~~~~~~
        Using Linux on the Inspiron 1100:
        http://geocities.com/randomnumbergenerator2001/
        *regularly updated*
      Your message has been successfully submitted and would be delivered to recipients shortly.