Loading ...
Sorry, an error occurred while loading the content.

IRDA on C640, what ttyS?

Expand Messages
  • firestorm1325
    I m running Mandrake 9.1 on a Latitude C640 and am trying to configure IRDA for use with a handheld computer. My main problem right now is in identifying
    Message 1 of 3 , Jul 7, 2003
    • 0 Attachment
      I'm running Mandrake 9.1 on a Latitude C640 and am trying to configure
      IRDA for use with a handheld computer. My main problem right now is
      in identifying which ttyS my IR port is on. $ dmesg | grep tty gives
      only one tty port... can I assume that's my serial port? I was under
      the impression that two ports should show up. Here's what I've tried
      already, and thanks in advance for any pointers you can give!

      Tim

      IR settings in BIOS:
      COM1, FIR

      1. Installed irda-utils, the default package included with Mandrake
      9.1. Then rebooted to check what loads at boot (sorry, recent Linux
      convert).

      System after boot:
      $ dmesg | grep tty
      ttyS00 at 0x03f8 (irq = 4) is a 16550A
      (Shouldn't there be a second entry: ttyS01?)

      $ cat /var/log/messages | grep tty
      ...
      Jul 7 15:51:22 inferno kernel: ttyS00 at 0x03f8 (irq = 4) is a 16550A
      Jul 7 15:51:28 inferno irattach: Failed to open /dev/ttyS2: No such
      file or directory

      $ cat /var/log/messages | grep ira
      Jul 7 15:51:28 inferno irattach: 1.1 Tue Nov 9 15:30:55 1999 Dag Brattli
      Jul 7 15:51:28 inferno irattach: Failed to open /dev/ttyS2: No such
      file or directory
      Jul 7 15:51:28 inferno irda: irattach startup succeeded

      $ cat /etc/sysconfig/irda
      IRDA=yes
      DEVICE=/dev/ttyS2
      #DONGLE=actisys+
      DISCOVERY=yes

      2. The /dev/ttyS2 doesn't seem to line up with COM1, so edited
      /etc/sysconfig/irda to
      DEVICE=/dev/ttyS1

      $ sudo irattach /dev/ttyS1 -s 1
      shows the following results from /var/log/messages:
      Jul 7 16:12:12 inferno sudo: tim : TTY=pts/1 ;
      PWD=/etc/sysconfig ; USER=root ; COMMAND=/usr/sbin/irattach /dev/ttyS1
      -s 1
      Jul 7 16:12:12 inferno irattach: Failed to open /dev/ttyS1: No such
      file or directory

      3. Rebooted, changed BIOS so IR port is COM2
      $ cat /var/log/messages | grep tty
      ...
      Jul 7 16:18:22 inferno kernel: ttyS00 at 0x03f8 (irq = 4) is a 16550A
      Jul 7 16:18:28 inferno irattach: Failed to open /dev/ttyS1: No such
      file or directory

      4. Changed /etc/sysconfig/irda back to
      DEVICE=/dev/ttyS2

      5. Added the standard lines to /etc/modules.conf
      # IrDA over a normal serial port, or a serial port compatible IrDA port
      alias tty-ldisc-11 irtty
      # IrCOMM (for printing, PPP, Minicom etc)
      alias char-major-161 ircomm-tty # if you want IrCOMM support
      # IRLAN
      alias irlan0 irlan
      # To be able to attach some serial dongles
      # These values are hard-coded in irattach (not instance order)
      alias irda-dongle-0 tekram # Tekram IrMate IR-210B
      alias irda-dongle-1 esi # ESI JetEye
      alias irda-dongle-2 actisys # Actisys IR-220L
      alias irda-dongle-3 actisys # Actisys IR-220L+
      alias irda-dongle-4 girbil # Greenwich GIrBIL
      alias irda-dongle-5 litelink # Parallax LiteLink
      alias irda-dongle-6 airport # Adaptec Airport 1000 and 2000
      # To use the FIR driver. This applies only to the specific device!!!
      #options nsc-ircc dongle_id=0x09 # NSC driver on a IBM Thinkpad
      laptop
      #options nsc-ircc dongle_id=0x08 # HP Omnibook 6000
      #alias irda0 nsc-ircc
      #alias irda0 smc-ircc
      # IrNET module...
      alias char-major-10-187 irnet # Official allocation of IrNET

      6. $ depmod -a
      But no difference between lsmod before and after

      7. $ sudo service irda start
      It starts [OK], but now what? ttyS2 is still wrong and $ file ttyS2
      says it doesn't exist.

      Now I'm stuck as far as what to do next. Any ideas?
    • Peter Møller Neergaard
      My first guess is that you are confused by the fact that Linux counts like a computer scientist: 0, 1, 2, ... In other words ttyS00 = COM1. It would try using
      Message 2 of 3 , Jul 7, 2003
      • 0 Attachment
        My first guess is that you are confused by the fact that Linux counts
        like a computer scientist: 0, 1, 2, ...

        In other words ttyS00 = COM1.

        It would try using /dev/ttyS0 first and also make sure that the port
        is R/W by the users attaches it. With devfsd.conf, that might take
        some extra configuration. If this does not help try some of the
        advises below.

        On Mon, Jul 07, 2003 at 09:00:07PM -0000, firestorm1325 wrote:
        > I'm running Mandrake 9.1 on a Latitude C640 and am trying to configure
        > IRDA for use with a handheld computer. My main problem right now is
        > in identifying which ttyS my IR port is on. $ dmesg | grep tty gives
        > only one tty port... can I assume that's my serial port? I was under
        > the impression that two ports should show up.

        This depends on what you have enabled in the BIOS. If you have
        disabled the serial port, it will not show up.

        > IR settings in BIOS:
        > COM1, FIR

        Seems OK. I have COM2, and a port as COM1. I get

        pan:~ > dmesg | grep tty
        ttyS00 at 0x03f8 (irq = 4) is a 16550A
        ttyS01 at 0x02f8 (irq = 3) is a 16550A
        pan:~ >

        > System after boot:
        > $ dmesg | grep tty
        > ttyS00 at 0x03f8 (irq = 4) is a 16550A
        > (Shouldn't there be a second entry: ttyS01?)

        No, see above, ttyS00 = COM1

        > 2. The /dev/ttyS2 doesn't seem to line up with COM1, so edited
        > /etc/sysconfig/irda to
        > DEVICE=/dev/ttyS1

        If you have it on COM1, it should be /dev/ttyS0.

        I have DEVICE=/dev/ttyS1 to use COM2.

        > 5. Added the standard lines to /etc/modules.conf
        > ...

        You might also consider

        below ircomm-tty ircomm
        below ircomm irda
        below ircomm irtty

        though I don't think this is directly related to your problem.

        > 7. $ sudo service irda start
        > It starts [OK], but now what? ttyS2 is still wrong and $ file ttyS2
        > says it doesn't exist.

        The serial port has to be writable---if that is not already the case
        do the following: if you have disabled devfs you can just use chmod.
        Otherwise add the following to devfsd.conf:

        # Make the serial port be R/W. Neccessary for at least irattach.
        # REGISTER ^tts/.* PERMISSIONS root.uucp 0660
        REGISTER ^ttyS0 PERMISSIONS root.irda 0660
        LOOKUP ^ttyS0 PERMISSIONS root.irda 0660

        # Configuration of infrared port: to be read and writable by group irda
        REGISTER ^ircomm[^/]* PERMISSIONS root.irda 0660

        and reconfigure devfsd using killall -HUP devfsd

        I hope this helps

        /Peter

        --
        http://www.linearity.org/turtle/contact.html
        ``If we're an arrogant nation, they'll resent us.
        If we're a humble nation but strong, they'll welcome us.''--George W. Bush
      • firestorm1325
        Thanks! Slow IRDA is working perfectly now. I had to change the settings in the BIOS so it didn t conflict with the regular serial port and now ttyS01 is Com2
        Message 3 of 3 , Aug 1, 2003
        • 0 Attachment
          Thanks! Slow IRDA is working perfectly now. I had to change the
          settings in the BIOS so it didn't conflict with the regular serial
          port and now ttyS01 is Com2 (in the BIOS) and the IRDA port is talking
          to it. I can sync my Palm with JPilot, Kpilot, etc.

          I'm never satisfied with good enough, I guess, and I'm wondering if
          anyone has any clue as to the IRDA chipset on the Latitude C640 and if
          it is capable of the Fast InfraRed protocol? The easiest would
          probably be to load the FIR modules, but I'm not finding the
          documentation for how to do that. Has anyone tried this?

          Thanks,

          Tim


          --- In linux-dell-laptops@yahoogroups.com, Peter Møller Neergaard
          <turtle@a...> wrote:
          > My first guess is that you are confused by the fact that Linux counts
          > like a computer scientist: 0, 1, 2, ...
          >
          > In other words ttyS00 = COM1.
          >
          > It would try using /dev/ttyS0 first and also make sure that the port
          > is R/W by the users attaches it. With devfsd.conf, that might take
          > some extra configuration. If this does not help try some of the
          > advises below.
          >
          > On Mon, Jul 07, 2003 at 09:00:07PM -0000, firestorm1325 wrote:
          > > I'm running Mandrake 9.1 on a Latitude C640 and am trying to configure
          > > IRDA for use with a handheld computer. My main problem right now is
          > > in identifying which ttyS my IR port is on. $ dmesg | grep tty gives
          > > only one tty port... can I assume that's my serial port? I was under
          > > the impression that two ports should show up.
          >
          > This depends on what you have enabled in the BIOS. If you have
          > disabled the serial port, it will not show up.
          >
          > > IR settings in BIOS:
          > > COM1, FIR
          >
          > Seems OK. I have COM2, and a port as COM1. I get
          >
          > pan:~ > dmesg | grep tty
          > ttyS00 at 0x03f8 (irq = 4) is a 16550A
          > ttyS01 at 0x02f8 (irq = 3) is a 16550A
          > pan:~ >
          >
          > > System after boot:
          > > $ dmesg | grep tty
          > > ttyS00 at 0x03f8 (irq = 4) is a 16550A
          > > (Shouldn't there be a second entry: ttyS01?)
          >
          > No, see above, ttyS00 = COM1
          >
          > > 2. The /dev/ttyS2 doesn't seem to line up with COM1, so edited
          > > /etc/sysconfig/irda to
          > > DEVICE=/dev/ttyS1
          >
          > If you have it on COM1, it should be /dev/ttyS0.
          >
          > I have DEVICE=/dev/ttyS1 to use COM2.
          >
          > > 5. Added the standard lines to /etc/modules.conf
          > > ...
          >
          > You might also consider
          >
          > below ircomm-tty ircomm
          > below ircomm irda
          > below ircomm irtty
          >
          > though I don't think this is directly related to your problem.
          >
          > > 7. $ sudo service irda start
          > > It starts [OK], but now what? ttyS2 is still wrong and $ file ttyS2
          > > says it doesn't exist.
          >
          > The serial port has to be writable---if that is not already the case
          > do the following: if you have disabled devfs you can just use chmod.
          > Otherwise add the following to devfsd.conf:
          >
          > # Make the serial port be R/W. Neccessary for at least irattach.
          > # REGISTER ^tts/.* PERMISSIONS root.uucp 0660
          > REGISTER ^ttyS0 PERMISSIONS root.irda 0660
          > LOOKUP ^ttyS0 PERMISSIONS root.irda 0660
          >
          > # Configuration of infrared port: to be read and writable by
          group irda
          > REGISTER ^ircomm[^/]* PERMISSIONS root.irda 0660
          >
          > and reconfigure devfsd using killall -HUP devfsd
          >
          > I hope this helps
          >
          > /Peter
          >
          > --
          > http://www.linearity.org/turtle/contact.html
          > ``If we're an arrogant nation, they'll resent us.
          > If we're a humble nation but strong, they'll welcome us.''--George
          W. Bush
        Your message has been successfully submitted and would be delivered to recipients shortly.