Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] Inspiron 5100: modem problem

Expand Messages
  • Andy Farlie
    I think that the modem is busy message appears if the device cannot be opened. When the HSF modem driver gets installed it generally adds ttySHSF0, cuaHSF0. It
    Message 1 of 5 , Jun 1 7:51 AM
    • 0 Attachment
      I think that the modem is busy message appears if the device cannot be
      opened. When the HSF modem driver gets installed it generally adds
      ttySHSF0, cuaHSF0. It should also link modem to ttySHSF0. Check to see
      if there are those devices in /dev and also check to see what the device
      is that kppp is expecting (/dev/modem is the default).

      Andy


      So On Sat, 2003-05-31 at 20:58, wolf_mibu wrote:
      > I have Red Hat 9 with a 2.4.20-13 kernel
      >
      > I read in a post at this forum how tu configure the modem but I still
      > can get it to work
      >
      > I downloaded the hsflinmodem-5.03.27lnxtbeta03042700.tar and compiled
      > it without any problem
      >
      > everything went fine as the install file said but everytime I try to
      > dial with kppp it apear the same error "the modem is busy".... at the
      > "network device manager" when I try to activate the modem it appears a
      > window with something like "activating ppp0..." but it´s stays there,
      > nothing else happens.
      >
      > Does somebody know which is the problem???
      > How can I see what is the modem doing or why it says that it busy?
      >
      > I´m new in Linux so I don´t know how to configure things so maybe my
      > problem is at the network device manager settings so if someone that
      > has his modem working could explain me step by step what he or she did
      > I´ll be very grateful
      >
      > thanks
      >
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
      > FAQ: http://www.whacked.net/ldl/faq
      >
      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
      >
    • wolf_mibu
      I enter de /dev directory and ttySHSF0 and cuaHSF0 are there, with all permissions (just one thing that I don´t know if it is normal, I entered using
      Message 2 of 5 , Jun 1 11:12 AM
      • 0 Attachment
        I enter de /dev directory and ttySHSF0 and cuaHSF0 are there, with all
        permissions (just one thing that I don´t know if it is normal, I
        entered using konkeror and the size of those files is 0B, I tried
        with other files and they showed the same size)

        the kppp "device" tab is configured to use "/dev/modem" which is
        pointing to /dev/ttySHSF0

        I tried to add directly /dev/ttySHSF0 but it doesn´t appear in the
        options and I couldn´t add it.

        by the way I put in the "device" tab other options , the ones below
        "dev/modem" tty0-tty3 I think, and with them i tried to connect and it
        also says that the modem is busy.....

        is there other way to connect through the modem without using kppp???
        like through the shell?


        --- In linux-dell-laptops@yahoogroups.com, Andy Farlie
        <andy_farlie@y...> wrote:
        > I think that the modem is busy message appears if the device cannot be
        > opened. When the HSF modem driver gets installed it generally adds
        > ttySHSF0, cuaHSF0. It should also link modem to ttySHSF0. Check to see
        > if there are those devices in /dev and also check to see what the device
        > is that kppp is expecting (/dev/modem is the default).
        >
        > Andy
        >
        >
        > So On Sat, 2003-05-31 at 20:58, wolf_mibu wrote:
        > > I have Red Hat 9 with a 2.4.20-13 kernel
        > >
        > > I read in a post at this forum how tu configure the modem but I still
        > > can get it to work
        > >
        > > I downloaded the hsflinmodem-5.03.27lnxtbeta03042700.tar and compiled
        > > it without any problem
        > >
        > > everything went fine as the install file said but everytime I try to
        > > dial with kppp it apear the same error "the modem is busy".... at the
        > > "network device manager" when I try to activate the modem it appears a
        > > window with something like "activating ppp0..." but it´s stays there,
        > > nothing else happens.
        > >
        > > Does somebody know which is the problem???
        > > How can I see what is the modem doing or why it says that it busy?
        > >
        > > I´m new in Linux so I don´t know how to configure things so maybe my
        > > problem is at the network device manager settings so if someone that
        > > has his modem working could explain me step by step what he or she did
        > > I´ll be very grateful
        > >
        > > thanks
        > >
        > >
        > >
        > > --------------------------------------------------------------
        > > Please post your X config files in the group links or database
        > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
        > > FAQ: http://www.whacked.net/ldl/faq
        > >
        > > Your use of Yahoo! Groups is subject to
        http://docs.yahoo.com/info/terms/
        > >
      • scottseagroves
        ... You could look into wvdial. Try, as a test, wvdialconf testconf , this will put some minimal information in a file testconf which you could then post to
        Message 3 of 5 , Jun 1 12:52 PM
        • 0 Attachment
          --- In linux-dell-laptops@yahoogroups.com, "wolf_mibu"
          <wolf_mibu@y...> wrote:

          > is there other way to connect through the modem without using kppp???
          > like through the shell?

          You could look into wvdial.

          Try, as a test, "wvdialconf testconf", this will put some minimal
          information in a file "testconf" which you could then post to the list.

          hth,
          Scott
        • wolf_mibu
          Hi, I did what you said Scott and here are the results: 1) first I typed wvdial and this was the result [root@localhost root]# wvdial -- WvDial: Internet
          Message 4 of 5 , Jun 1 2:21 PM
          • 0 Attachment
            Hi, I did what you said Scott and here are the results:

            1) first I typed wvdial and this was the result

            [root@localhost root]# wvdial

            --> WvDial: Internet dialer version 1.53
            --> Warning: section [Dialer Defaults] does not exist in wvdial.conf.
            --> Cannot open /dev/modem: Input/output error
            --> Cannot open /dev/modem: Input/output error
            --> Cannot open /dev/modem: Input/output error

            2) then I did the second thing but it stays at "USB15" and it doesn´t
            create the file, I got this directly from the shell

            [root@localhost root]# wvdialconf /root/D*/testconf
            Scanning your serial ports for a modem.
            Port Scan<*1>: Scanning ttySHSF0 first, /dev/modem is a link to it.
            Port Scan<*1>: SHSF0 S0 S1 S2 S3 S4 S5 S6
            Port Scan<*1>: S7 S8 S9 S10 S11 S12 S13 S14
            Port Scan<*1>: S15 S16 S17 S18 S19 S20 S21 S22
            Port Scan<*1>: S23 S24 S25 S26 S27 S28 S29 S30
            Port Scan<*1>: S31 SA0 SA1 SA2 SC0 SC1 SC2 SC3
            Port Scan<*1>: SI0 SI1 SI2 SI3 SI4 SI5 SI6 SI7
            Port Scan<*1>: SI8 SI9 SI10 SI11 SI12 SI13 SI14 SI15
            Port Scan<*1>: SR0 SR1 SR2 SR3 SR4 SR5 SR6 SR7
            Port Scan<*1>: SR8 SR9 SR10 SR11 SR12 SR13 SR14 SR15
            Port Scan<*1>: SR16 SR17 SR18 SR19 SR20 SR21 SR22 SR23
            Port Scan<*1>: SR24 SR25 SR26 SR27 SR28 SR29 SR30 SR31
            Port Scan<*1>: SR256 SR257 SR258 SR259 SR260 SR261 SR262 SR263
            Port Scan<*1>: SR264 SR265 SR266 SR267 SR268 SR269 SR270 SR271
            Port Scan<*1>: SR272 SR273 SR274 SR275 SR276 SR277 SR278 SR279
            Port Scan<*1>: SR280 SR281 SR282 SR283 SR284 SR285 SR286 SR287
            Port Scan<*1>: USB0 USB1 USB2 USB3 USB4 USB5 USB6 USB7
            Port Scan<*1>: USB8 USB9 USB10 USB11 USB12 USB13 USB14 USB15

            I hope that with this is easier to help me

            thanks
          Your message has been successfully submitted and would be delivered to recipients shortly.