Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] Re: Have to install NVIDIA kernel every time to use X windows !?!

Expand Messages
  • Raju Kurunkad
    ... Try adding NVdriver to /etc/modules Raju
    Message 1 of 11 , Mar 31, 2003
    • 0 Attachment
      > > you need to make sure that the module NVdriver.o is loaded before
      > starting X,
      > > 'insmod NVdriver.o'. This is acheaved differently on different
      > distributions.
      > >
      > > Alan
      >
      > If someone can give me VERY explicit instructions on how to do this
      > with Debian, it would be most useful. No matter how hard I try, I
      > cannot seem to figure out how to do this. I've looked about the net
      > and found nothing that makes this point clear to me.

      Try adding NVdriver to /etc/modules

      Raju
    • ronin2@bellatlantic.net
      On Mon, 31 Mar 2003 22:28:29 -0800 ... This will cause NVdriver to be inserted during startup. I m skeptical of all this. I ve been using NVIDIA for almost two
      Message 2 of 11 , Apr 1, 2003
      • 0 Attachment
        On Mon, 31 Mar 2003 22:28:29 -0800
        Raju Kurunkad <rajukv@...> wrote:

        > Try adding NVdriver to /etc/modules

        This will cause NVdriver to be inserted during startup.

        I'm skeptical of all this. I've been using NVIDIA for almost two years,
        and I've never been required to insert NVdriver before I startx. In fact
        inserting NVdriver is part of startx.

        I believe the problem is somewhere else, but I'll confess I don't know
        where.

        Kevin
      • Philip Trickett
        ... Try putting this in your /etc/modules.conf alias char-major-195 nvidia That should fix it hopefully. Phil
        Message 3 of 11 , Apr 1, 2003
        • 0 Attachment
          On Tue, 2003-04-01 at 18:03, ronin2@... wrote:
          > On Mon, 31 Mar 2003 22:28:29 -0800
          > Raju Kurunkad <rajukv@...> wrote:
          >
          > > Try adding NVdriver to /etc/modules
          >
          > This will cause NVdriver to be inserted during startup.
          >
          > I'm skeptical of all this. I've been using NVIDIA for almost two years,
          > and I've never been required to insert NVdriver before I startx. In fact
          > inserting NVdriver is part of startx.


          Try putting this in your /etc/modules.conf

          alias char-major-195 nvidia

          That should fix it hopefully.

          Phil
        • W.K. Vladmir Ward
          There are two parts of the nvidia driver. One is the kernel module, which needs to be loaded before startx. The second is the X driver which is loaded in your
          Message 4 of 11 , Apr 1, 2003
          • 0 Attachment

            There are two parts of the nvidia driver. One is the kernel module, which needs to be loaded before startx. The second is the X driver which is loaded in your XF86Config file.

            Under slackware (which doesn't help much if you're using a different distro which basically sets everything up for you), you would add "/usr/sbin/modprobe nvidia" (I believe that's the path to modprobe...? not on a linux machine at the moment)

            Probably doesn't help you too much though, sorry :(

             ronin2@... wrote:

            On Mon, 31 Mar 2003 22:28:29 -0800
            Raju Kurunkad <rajukv@...> wrote:

            > Try adding NVdriver to /etc/modules

            This will cause NVdriver to be inserted during startup.

            I'm skeptical of all this. I've been using NVIDIA for almost two years,
            and I've never been required to insert NVdriver before I startx. In fact
            inserting NVdriver is part of startx.

            I believe the problem is somewhere else, but I'll confess I don't know
            where.

            Kevin


            --------------------------------------------------------------
            Please post your X config files in the group links or database
            To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
            FAQ: http://www.whacked.net/ldl/faq


            Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.


            "Walking side by side with death, the devil mocks their every step
            The snow drives back the foot that's slow, the dogs of doom are howling more
            They carry news that must get through, to build a dream for me and you
            They choose the path where no-one goes."

            -Led Zeppelin, "No Quarter"



            Do you Yahoo!?
            Yahoo! Tax Center - File online, calculators, forms, and more

          • ronin2@bellatlantic.net
            On Tue, 1 Apr 2003 09:32:47 -0800 (PST) ... The NVIDIA kernel module does NOT need to be loaded before startx. That was the whole point of my message. I just
            Message 5 of 11 , Apr 1, 2003
            • 0 Attachment
              On Tue, 1 Apr 2003 09:32:47 -0800 (PST)
              "W.K. Vladmir Ward" <web_raptor.geo@...> wrote:

              >
              > There are two parts of the nvidia driver. One is the kernel module,
              > >which needs to be loaded before startx. The second is the X driver
              > >>which is loaded in your XF86Config file.

              The NVIDIA kernel module does NOT need to be loaded before startx. That
              was the whole point of my message.

              I just verified this by leaving the X environment and removing NVdriver
              with rmmod. Then I did "startx" and it came up just fine.

              Once again, NVdriver does NOT need to be loaded before starting X. If X
              is properly configured loading the driver is part of starting X.

              Kevin
            • Adam Lowry
              ... This is not entirely true. startx does not use insmod or modprobe; it makes a request to the kernel module loader. If NVdriver is not loaded at startup
              Message 6 of 11 , Apr 1, 2003
              • 0 Attachment
                ronin2@... wrote:
                > The NVIDIA kernel module does NOT need to be loaded before startx. That
                > was the whole point of my message.
                >
                > I just verified this by leaving the X environment and removing NVdriver
                > with rmmod. Then I did "startx" and it came up just fine.
                >
                > Once again, NVdriver does NOT need to be loaded before starting X. If X
                > is properly configured loading the driver is part of starting X.
                >
                > Kevin

                This is not entirely true. startx does not use insmod or modprobe; it
                makes a request to the kernel module loader. If NVdriver is not loaded
                at startup (which is perfectly acceptable and has no ill effects) then
                it will look for the character device 195. If you're running the nvidia
                driver 3123 or less, the line to add to modules.conf is

                alias char-major-195 NVdriver

                If you're using > 3123, use

                alias char-major-195 nvidia

                just like Mr. Trickett stated.

                But loading the module at startup is not really a problem, in my opinion.

                --
                Adam Lowry adam at therobots dot org
                "Irrationality is the square root of all evil"
                -- Douglas Hofstadter
              • ronin2@bellatlantic.net
                On Wed, 02 Apr 2003 10:55:30 +0800 ... What part of what I said do you believe to be wrong? I said loading NVdriver is part of startx. I said you don t need to
                Message 7 of 11 , Apr 1, 2003
                • 0 Attachment
                  On Wed, 02 Apr 2003 10:55:30 +0800
                  Adam Lowry <adam@...> wrote:

                  > This is not entirely true. startx does not use insmod or modprobe; it
                  > makes a request to the kernel module loader. If NVdriver is not loaded
                  > at startup (which is perfectly acceptable and has no ill effects) then
                  > it will look for the character device 195. If you're running the
                  > nvidia driver 3123 or less, the line to add to modules.conf is
                  > alias char-major-195 NVdriver
                  > If you're using > 3123, use
                  > alias char-major-195 nvidia
                  > just like Mr. Trickett stated.

                  What part of what I said do you believe to be wrong?

                  I said loading NVdriver is part of startx. I said you don't need to load
                  NVdriver before doing startx.

                  Both of these are repeatably, verifiably correct.

                  What you said about char-major is true but I didn't address that.

                  Kevin
                Your message has been successfully submitted and would be delivered to recipients shortly.