Loading ...
Sorry, an error occurred while loading the content.

Re: wireless Netgear MA401 (& LinkSys WPC11 rev3) - using orinoco

Expand Messages
  • Bob
    Ryan, Sorry it took me so long - I only get the daily digest of the list. ... I didn t try it myself, but many postings I found seemed to suggest the wlan
    Message 1 of 1 , Jan 31, 2003
    • 0 Attachment
      Ryan,

      Sorry it took me so long - I only get the daily digest of the list.

      >>If you want to avoid the hassle of installing wlan-ng drivers, you might
      >>be
      >>able to use orinoco/orinoco_cs with hermes out of the box (RedHat/Mandrake
      >>latest distros).

      >Is it a hassle under RedHat/Mandrake? I haven't touched either of those
      >distributions in years. It was incredibly easy in Gentoo:
      >
      >emerge linux-wlan-ng
      >
      >Then if you have special WLAN settings:
      > edit /etc/conf.d/wlan.conf and to put in your SSID,
      > cp /etc/conf.d/wlancfg-DEFAULT /etc/conf.d/wlancfg-YOURSSID
      > edit YOURSSID cfg file with your network settings.
      >Otherwise the defaults will connect to any detected open network.
      >
      >/etc/init.d/wlan start
      >ifconfig wlan0 <settings> or dhcpcd wlan0

      I didn't try it myself, but many postings I found seemed to suggest the wlan
      drivers as a last resort because they thought it required more setup.

      >>Note that these steps also work for a LinkSys WPC11 rev3 card as well
      >>(though I didn't try WEP on it, yet, as I only really need the one card
      >>right now).

      >I was under the impression that WEP should work for any supported WLAN
      >adapter since the crypto functions were done in software with the crypto
      >libraries and not in hardware.

      I only said I hadn't tried it, so couldn't say for sure. Some postings I've
      read talked about firmware issues on some cards, including at least some
      versions of the WPC11 at some time last year. In the meantime, I have
      tried it and found that I can insert either card and get about the same
      results.

      One problem: I have found that I cannot download files at anything close to
      the 11Mb/sec without losing the connection (regular web pages where there's
      lots of small transfers are fine). The card disconnects from the router
      because of "Tx excessive retries". In order to download files more than
      100K-1M, I have to force the rate to 1Mb/sec. While that's fine for the
      Internet (about 100K/sec through my cable modem), it seems I should get
      better. The LinkSys WPC11 I can keep at 2Mb (though I still get 1 or 2 Tx
      errors in a 30-40 M file transfer). Both can do better without WEP (40/64
      bit) enabled, but not much (they still drop sometimes even at 5.5M).

      I do not seem to be able to set either Sensitivity or fragmentation or RTS
      throttle or Tx retries (only Rate and Key) using iwconfig. Does anyone
      know if this is a limitation of the cards (both WPC11 and MA401 act the
      same), or the orinoco drivers, or what? The iwlist gives values for retry
      like below (for WPC11, the link quality varies from 92 down to 32 sitting 5
      feet from the router):

      [root@localhost bob-amisys-200212]# iwconfig
      eth1 IEEE 802.11-DS ESSID:"Wireless" Nickname:"Prism I"
      Mode:Managed Frequency:2.412GHz Access Point: 00:xx:xx:xx:xx:xx
      Bit Rate=1Mb/s Tx-Power=15 dBm Sensitivity:1/3
      Retry min limit:8 RTS thr:off Fragment thr:off
      Encryption key:xxxx-xxxx-xx Encryption mode:open
      Power Management:off
      Link Quality:82/92 Signal level:-72 dBm Noise level:-139 dBm
      Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
      Tx excessive retries:0 Invalid misc:0 Missed beacon:0

      [root@localhost bob]# iwlist eth1 retry
      eth1 Fixed limit ; min limit:0
      max limit:65535
      Fixed lifetime ; min lifetime:0us
      max lifetime:65.535s
      Current mode:on
      min limit:8 max limit:5
      lifetime:512ms

      [root@localhost bob]# iwconfig eth1 retry 16
      Error for wireless request "Set Retry Limit" (8B28) :
      SET failed on device eth1 ; Operation not supported.

      Do you think I might get different results with the wlan drivers? I really
      don't want to spend all this time, but the 1M/sec thing is bugging me, even
      if it is good enough for my current purposes.

      Thanks for any suggestions,
      Bob
    Your message has been successfully submitted and would be delivered to recipients shortly.