Loading ...
Sorry, an error occurred while loading the content.
 

Re: [linux-dell-laptops] Re: touchpad - tpconfig story

Expand Messages
  • Vance Wheelock
    With all this information about tpconfig flying around, I had figured out how to unset the tapmode which I despise, but now I would like the top right mouse
    Message 1 of 12 , Dec 6, 2000
      With all this information about tpconfig flying around, I had figured
      out how to unset the tapmode which I despise, but now I would like the
      top right mouse button to be behave as the third mouse button. I have
      tried setting it with the -3 option but I cannot seem to get it to work.
      What is strange is that when I'm at the console gpm seems to do exactly
      what I want, but when I launc X it seems to ignore it completely and use
      the 1-3/2-4 button mapping.with only clicking both sets to equal a 3rd
      button.

      Is there another option or am I doing something wrong? This seems more
      to do the defining a ps/2 mouse button within the xf86config file. Is
      this what everyone uses?

      Has anyone succeeded in getting the topright mouse button under X to
      behave as the 3rd mouse button?

      Vance

      --
      Vance Wheelock II, Software Engineer, weddingstreetjournal.com
      "On the side of the software box, in the 'System Requirements' section,
      it said 'Requires Windows 95 or better'. So I installed Linux."
      - Anonymous
    • Rob Yale
      One thing I m working on, that I believe must be done, is to patch a 2.2.17 kernel with kernel-2.2.17-psaux-exclusive.patch. I haven t yet been able to get
      Message 2 of 12 , Dec 7, 2000
        One thing I'm working on, that I believe must be done, is to patch a 2.2.17
        kernel with kernel-2.2.17-psaux-exclusive.patch. I haven't yet been able to
        get that kernel to compile on my RH 7 system.

        Rob Yale

        > -----Original Message-----
        > From: Richard Simpson [mailto:rsimpson@...]
        > Sent: December 6, 2000 12:36 PM
        > To: linux-dell-laptops@egroups.com
        > Subject: Re: [linux-dell-laptops] <More of> touchpad - tpconfig story
        >
        >
        > On Wed, 06 Dec 2000, you wrote:
        >
        > >Anyone with an I7500 been able to get tpconfig to support?
        > >
        > > zthreshold
        > > corner taps
        > > edgemode
        >
        > Well, no, but I haven't tried. It might be some help if you could explain
        > exactly what these 3 features are supposed to do. Since I only
        > have Linux on
        > my i7500 I have never been presented with these options.
        >
        > --
        > ------------------------------------------------------------------
        > ----------
        >
        > Richard Simpson
        > Farnborough, Hants, Uk Fax: 01252 392976
        > rsimpson@...
        >
        >
        > --------------------------------------------------------------
        > Please post your X config files in the group links or database
        >
      • Rob Yale
        I m still fighting with this problem. Do I actually have to rebuild my kernel as a 2.2.17? I ve been having a nightmare of a time trying to accomplish this.
        Message 3 of 12 , Dec 10, 2000
          I'm still fighting with this problem. Do I actually have to rebuild my
          kernel as a 2.2.17? I've been having a nightmare of a time trying to
          accomplish this. If it's the only way I'll be able to disable those
          obnoxious taps, I'll soldier on, but I have to say, it's not be a smooth
          process so far.

          Rob Yale

          > -----Original Message-----
          > From: root@... [mailto:root@...]On
          > Behalf Of Vance Wheelock
          > Sent: December 6, 2000 6:11 PM
          > To: linux-dell-laptops@egroups.com
          > Subject: Re: [linux-dell-laptops] Re: <More of> touchpad - tpconfig
          > story
          >
          >
          > With all this information about tpconfig flying around, I had figured
          > out how to unset the tapmode which I despise, but now I would like the
          > top right mouse button to be behave as the third mouse button. I have
          > tried setting it with the -3 option but I cannot seem to get it to work.
          > What is strange is that when I'm at the console gpm seems to do exactly
          > what I want, but when I launc X it seems to ignore it completely and use
          > the 1-3/2-4 button mapping.with only clicking both sets to equal a 3rd
          > button.
          >
          > Is there another option or am I doing something wrong? This seems more
          > to do the defining a ps/2 mouse button within the xf86config file. Is
          > this what everyone uses?
          >
          > Has anyone succeeded in getting the topright mouse button under X to
          > behave as the 3rd mouse button?
          >
          > Vance
          >
          > --
          > Vance Wheelock II, Software Engineer, weddingstreetjournal.com
          > "On the side of the software box, in the 'System Requirements' section,
          > it said 'Requires Windows 95 or better'. So I installed Linux."
          > - Anonymous
          >
          >
          > --------------------------------------------------------------
          > Please post your X config files in the group links or database
          >
        • Rob Yale
          What kernel are you using? Were you able to install tpconfig without patching the kernel with the psaux-exclusive patch for 2.2.17? I m also fighting with
          Message 4 of 12 , Dec 10, 2000
            What kernel are you using? Were you able to install tpconfig without
            patching the kernel with the 'psaux-exclusive' patch for 2.2.17? I'm also
            fighting with trying to customize the properties on my touchpad.

            Rob Yale

            > -----Original Message-----
            > From: georgehu@... [mailto:georgehu@...]
            > Sent: December 6, 2000 11:16 AM
            > To: linux-dell-laptops@egroups.com
            > Subject: [linux-dell-laptops] <More of> touchpad - tpconfig story
            >
            >
            > This is about a Synaptics touchpad on a DELL I7500.
            >
            > 1. tpconfig reports the touchpad's status as
            >
            > Firmware 4.3 (Single mode byte.)
            >
            > 2. tpconfig will run only once. To run it again,
            > I have to run gpm -t ps2 again and then
            > kill -KILL gpm again.
            >
            > 3. When I try to issue
            >
            > tpconfig --zthreshold=7
            >
            > it reports Z threshold not supported on this Touchpad.
            >
            > But, but, BUT, my DELL I7500 has both Windows 2000 -AND-
            > Red Hat 7 installed and W2K has no trouble setting the
            > Z threshold values, corner taps, etc.
            >
            > So why does tpconfig report these features are "not supported"?
            > Reading the source code for tpconfig, it looks like a property
            > called "single_mode_byte" is used to decide if these features
            > are supported.
            >
            > Anyone with an I7500 been able to get tpconfig to support?
            >
            > zthreshold
            > corner taps
            > edgemode
            >
            > Thanks for any help you might be able to give. I hope this
            > doesn't turn out to be like WinModems, where only Windows
            > operating systems are able to operate the hardware.
            >
            > g.
            >
            >
            >
            > --------------------------------------------------------------
            > Please post your X config files in the group links or database
            >
          • Rob Yale
            Hi, I just completed a five day odyssey that included upgrading, patching and rebuilding my kernel so that I could use tpconfig. I wanted to disable the
            Message 5 of 12 , Dec 11, 2000
              Hi,

              I just completed a five day odyssey that included upgrading, patching and
              rebuilding my kernel so that I could use tpconfig. I wanted to disable the
              annoying touch-click behaviour, so I installed the tpconfig 3.1.1 rpm, and
              an associated script from Bruce Kall, for turning off the touch-click.
              Unfortunately it's not working for me. I Installed a copy of the script in
              /etc/rc.d/init.d as touchpad, and created a symbolic link to it in
              /etc/rc.d/rc3.d as S84touchpad. Has anyone actually done this, and if so,
              how? Bruce's script follows:

              #!/bin/sh -x
              # touchpad
              # description: Start-up script to disable touchpad tapping
              # For Synaptics or ALPS touchpads.
              #
              # $Log$
              #
              # $Id$
              #
              #

              test -r /etc/rc.d/init.d/functions && . /etc/rc.d/init.d/functions


              echo ""
              echo -n "Turning off Touch-Pad 'tapping' "

              if [ -f /usr/bin/tpconfig ]; then
              /usr/bin/tpconfig --tapmode=0
              if [ $? ]; then
              echo_failure
              else
              echo_success
              fi
              else
              echo_failure
              fi
              echo ""
              exit 0
            • georgehu@mail.com
              ... patching and ... disable the ... rpm, and ... touch-click. ... script in ... if so, ... Yes, someone has done this and here s how.... 1. tpconfig was
              Message 6 of 12 , Dec 12, 2000
                --- In linux-dell-laptops@egroups.com, "Rob Yale" <robyale@s...>
                wrote:
                > Hi,
                >
                > I just completed a five day odyssey that included upgrading,
                patching and
                > rebuilding my kernel so that I could use tpconfig. I wanted to
                disable the
                > annoying touch-click behaviour, so I installed the tpconfig 3.1.1
                rpm, and
                > an associated script from Bruce Kall, for turning off the
                touch-click.
                > Unfortunately it's not working for me. I Installed a copy of the
                script in
                > /etc/rc.d/init.d as touchpad, and created a symbolic link to it in
                > /etc/rc.d/rc3.d as S84touchpad. Has anyone actually done this, and
                if so,
                > how?
                -------------------------------------------------------------------
                Yes, someone has done this and here's how....

                1. tpconfig was installed in /usr/bin
                2. two links to the script were created as follows
                cd /etc/rc.d/rc3.d
                ln -s ../init.d/tpconfig S84tpconfig
                cd /etc/rc.d/rc5.d
                ln -s ../init.d/tpconfig S84tpconfig

                3. Re-booted

                The two links were made so that "tap-to-click" would be
                turned off both in X and in console modes.

                Now, I can use my laptop without crazy windows popping
                up all the time, but it would be so nice to be able to
                have the touchpad work like it does in Windows with
                corner taps and an ADJUSTABLE "tap-to-click" feature.

                g.
              • Rob Yale
                Yes, thanks! I finally got my 2.2.17 kernel to compile and install last night, and the script worked. I only put it in rc3.d though. I m not really clear
                Message 7 of 12 , Dec 13, 2000
                  Yes, thanks! I finally got my 2.2.17 kernel to compile and install last
                  night, and the script worked. I only put it in rc3.d though. I'm not
                  really clear what init 5 is all about though. I'll guess I'll make a link
                  to it also.

                  Rob Yale

                  > -----Original Message-----
                  > From: georgehu@... [mailto:georgehu@...]
                  > Sent: December 12, 2000 2:58 PM
                  > To: linux-dell-laptops@egroups.com
                  > Subject: [linux-dell-laptops] Re: tpconfig script not working
                  >
                  >
                  > --- In linux-dell-laptops@egroups.com, "Rob Yale" <robyale@s...>
                  > wrote:
                  > > Hi,
                  > >
                  > > I just completed a five day odyssey that included upgrading,
                  > patching and
                  > > rebuilding my kernel so that I could use tpconfig. I wanted to
                  > disable the
                  > > annoying touch-click behaviour, so I installed the tpconfig 3.1.1
                  > rpm, and
                  > > an associated script from Bruce Kall, for turning off the
                  > touch-click.
                  > > Unfortunately it's not working for me. I Installed a copy of the
                  > script in
                  > > /etc/rc.d/init.d as touchpad, and created a symbolic link to it in
                  > > /etc/rc.d/rc3.d as S84touchpad. Has anyone actually done this, and
                  > if so,
                  > > how?
                  > -------------------------------------------------------------------
                  > Yes, someone has done this and here's how....
                  >
                  > 1. tpconfig was installed in /usr/bin
                  > 2. two links to the script were created as follows
                  > cd /etc/rc.d/rc3.d
                  > ln -s ../init.d/tpconfig S84tpconfig
                  > cd /etc/rc.d/rc5.d
                  > ln -s ../init.d/tpconfig S84tpconfig
                  >
                  > 3. Re-booted
                  >
                  > The two links were made so that "tap-to-click" would be
                  > turned off both in X and in console modes.
                  >
                  > Now, I can use my laptop without crazy windows popping
                  > up all the time, but it would be so nice to be able to
                  > have the touchpad work like it does in Windows with
                  > corner taps and an ADJUSTABLE "tap-to-click" feature.
                  >
                  > g.
                  >
                  >
                  >
                  >
                  > --------------------------------------------------------------
                  > Please post your X config files in the group links or database
                  >
                • Vance Wheelock
                  The rc(#).d directories are directories for run levels. You can see which runlevel you are currently using by looking in the /etc/inittab file. Look for a line
                  Message 8 of 12 , Dec 13, 2000
                    The rc(#).d directories are directories for run levels.
                    You can see which runlevel you are currently using by looking in the
                    /etc/inittab file. Look for a line like

                    id:5:initdefault:

                    The 5 will typically be a number between 1 and 6. Depending upon which
                    distro you are using they have defined different runlevels.

                    Why would someone want differ runlevels you ask? (or at least I do
                    rhetorically)

                    Well, you can customize the different levels to do different things. You
                    will notice that in the rc(#).d directories that all of these files are
                    just softlinks to ../init.d The init.d directory contains a bunch of
                    scripts to start daemons and devices and processes. So that when you
                    select a runlevel it will only start the process that are in that
                    runlevel directory. This is useful when you want to setup situations
                    where sometimes you may want to have processes automatically started
                    sometimes but at other times you don't. For instance RH sets it up so
                    that if you want to automatically go into X on boot then it will use
                    rc5.d directory. However if you didn't want X to start automatically
                    then you can change the 5 in the inittab file to a 3 and then you will
                    start in the console mode. Remember different distros use the different
                    runlevel directories for different purposes, in another words it is not
                    standard because in the old days it was left up to the system admin to
                    setup their own runlevels, but the current distros want to help new
                    users with default setups. Other reasons you may want to change/add
                    runlevels would be like if you were on the road and wanted to make sure
                    that the network stuff didn't load (other then loopback) you modify a
                    runlevel so that a link to the init.d/network script was not executed.

                    Also you will notice in the rc(#).d directories that the links all start
                    will either and S or and then followed by a number. The scripts that
                    start with an S will be executed on boot while the files starting with K
                    are executed on shutdown/reboot. The numbers indicate the order in which
                    the scripts execute so that when you make a link for touchpad you notice
                    that people have been using S84touchpad which is one less then S85gpm.
                    so that in this instance touchpad would start before gpm.

                    I hope this explains all of the questions about rc directories.

                    Vance

                    Rob Yale wrote:
                    >
                    > Yes, thanks! I finally got my 2.2.17 kernel to compile and install last
                    > night, and the script worked. I only put it in rc3.d though. I'm not
                    > really clear what init 5 is all about though. I'll guess I'll make a link
                    > to it also.
                    >
                    > Rob Yale
                    >
                    > > -----Original Message-----
                    > > From: georgehu@... [mailto:georgehu@...]
                    > > Sent: December 12, 2000 2:58 PM
                    > > To: linux-dell-laptops@egroups.com
                    > > Subject: [linux-dell-laptops] Re: tpconfig script not working
                    > >
                    > >
                    > > --- In linux-dell-laptops@egroups.com, "Rob Yale" <robyale@s...>
                    > > wrote:
                    > > > Hi,
                    > > >
                    > > > I just completed a five day odyssey that included upgrading,
                    > > patching and
                    > > > rebuilding my kernel so that I could use tpconfig. I wanted to
                    > > disable the
                    > > > annoying touch-click behaviour, so I installed the tpconfig 3.1.1
                    > > rpm, and
                    > > > an associated script from Bruce Kall, for turning off the
                    > > touch-click.
                    > > > Unfortunately it's not working for me. I Installed a copy of the
                    > > script in
                    > > > /etc/rc.d/init.d as touchpad, and created a symbolic link to it in
                    > > > /etc/rc.d/rc3.d as S84touchpad. Has anyone actually done this, and
                    > > if so,
                    > > > how?
                    > > -------------------------------------------------------------------
                    > > Yes, someone has done this and here's how....
                    > >
                    > > 1. tpconfig was installed in /usr/bin
                    > > 2. two links to the script were created as follows
                    > > cd /etc/rc.d/rc3.d
                    > > ln -s ../init.d/tpconfig S84tpconfig
                    > > cd /etc/rc.d/rc5.d
                    > > ln -s ../init.d/tpconfig S84tpconfig
                    > >
                    > > 3. Re-booted
                    > >
                    > > The two links were made so that "tap-to-click" would be
                    > > turned off both in X and in console modes.
                    > >
                    > > Now, I can use my laptop without crazy windows popping
                    > > up all the time, but it would be so nice to be able to
                    > > have the touchpad work like it does in Windows with
                    > > corner taps and an ADJUSTABLE "tap-to-click" feature.
                    > >
                    > > g.
                    > >
                    > >
                    > >
                    > >
                    > > --------------------------------------------------------------
                    > > Please post your X config files in the group links or database
                    > >
                    >
                    >
                    > --------------------------------------------------------------
                    > Please post your X config files in the group links or database

                    --
                    Vance Wheelock II, Software Engineer, weddingstreetjournal.com
                    "On the side of the software box, in the 'System Requirements' section,
                    it said 'Requires Windows 95 or better'. So I installed Linux."
                    - Anonymous
                  • Nick Drage
                    Hi, ... Intrigued by this I hopped over to my Linux partition to see how my Slackware 7.1 worked and whether I could turn off touchpad tapping too ( I
                    Message 9 of 12 , Dec 14, 2000
                      Hi,

                      On 11 Dec 2000, at 18:09, Rob Yale wrote:
                      > I just completed a five day odyssey that included upgrading, patching
                      > and rebuilding my kernel so that I could use tpconfig. I wanted to
                      > disable the annoying touch-click behaviour, so I installed the
                      > tpconfig 3.1.1 rpm, and an associated script from Bruce Kall, for
                      > turning off the touch-click. Unfortunately it's not working for me. I

                      <snip>

                      Intrigued by this I hopped over to my Linux partition to see how my
                      Slackware 7.1 worked and whether I could turn off touchpad tapping
                      too ( I hit it far more often by mistake than intentionally ).

                      The /etc/rc.d scripts call gpm, and looking at "man gpm" it says that
                      touchpad tapping is *disabled* by default, yet it definitely works
                      for me.

                      Any ideas why it works, and how to turn it off in gpm?

                      Dell Latitude LS btw.

                      --
                      Nick Drage - half understanding Pegasus until he gets his
                      Linux partition sorted out......
                    Your message has been successfully submitted and would be delivered to recipients shortly.