Loading ...
Sorry, an error occurred while loading the content.

APM and halt ?

Expand Messages
  • Pierre-Yves Bonnetain
    Hello, Well, I got my I8200 two days ago. RH8.0 went smoothly (as far as I m used to those things going smoothly, since I m a heavy tinkerer of packages to
    Message 1 of 3 , Nov 29, 2002
    • 0 Attachment
      Hello,

      Well, I got my I8200 two days ago. RH8.0 went smoothly (as far as
      I'm used to those things going smoothly, since I'm a heavy tinkerer of
      packages to install and the like). I've installe kernel 2.4.19, X
      4.2.1 + NVidia drivers all from sources, got the XConfig file right
      from the one sent to the list by yahoo@... (thanks !).
      So far, so good. Now for the bothering stuff.

      1/ When I halt the computer (through the halt command, not the
      power on/off button), Linux kernerl stops as requested. But the laptop
      does not power off automagically, which is irritating (I'm used to
      "halt and you can leave the room it will power off itself"). Any hints
      ?
      2/ What are the sound parameters to use while configuring the
      kernel ?
      3/ I think/believe (need to check) that the apmd plays tricks I do
      not really like. Such as slowing down the laptop when on battery (okay
      for me) but not putting it back to speed when on AC after that. Anyone
      seen this kind of weirdness ?

      Tia,

      -- Pierre-Yves Bonnetain
      Networks and Computers Security -- B&A Consultants
      Tél +33 (0) 563 277 241 -- Fax +33 (0) 563 277 245
    • Pierre Lombard
      Hi, ... I guess you need to enable APM support in kernel: General Setup / Power Management Support / Advanced Power Management BIOS support / ... FWIW, I
      Message 2 of 3 , Nov 29, 2002
      • 0 Attachment
        Hi,

        * Pierre-Yves Bonnetain <bonnetain@...> [2002-11-29 09:18]:
        > Well, I got my I8200 two days ago. RH8.0 went smoothly (as far as
        > I'm used to those things going smoothly, since I'm a heavy tinkerer of
        > packages to install and the like). I've installe kernel 2.4.19, X
        > 4.2.1 + NVidia drivers all from sources, got the XConfig file right
        > from the one sent to the list by yahoo@... (thanks !).

        > 1/ When I halt the computer (through the halt command, not the
        > power on/off button), Linux kernerl stops as requested. But the laptop
        > does not power off automagically, which is irritating (I'm used to
        > "halt and you can leave the room it will power off itself"). Any hints
        > ?

        I guess you need to enable APM support in kernel:
        General Setup / Power Management Support / Advanced Power Management
        BIOS support / ...
        FWIW, I enable Enable PM at boot time + Enable console blanking using APM
        + RTC stores time in GMT

        If it's already available with your RH kernel as a module you may have
        to load it "a la mano". I heard sometimes apm does not work correctly
        when it's compiled as a module so YMMV...

        > 2/ What are the sound parameters to use while configuring the
        > kernel ?

        Sound => Intel ICH (i8xx), SiS 7012, NVidia nForce Audio or AMD 768/811x

        Then add the following lines:
        alias sound i810_audio
        add options i810_audio clocking=48000
        alias char-major-14 sound
        alias midi off
        in your /etc/modules.conf (or RH's equivalent file)

        > 3/ I think/believe (need to check) that the apmd plays tricks I do
        > not really like. Such as slowing down the laptop when on battery (okay
        > for me) but not putting it back to speed when on AC after that. Anyone
        > seen this kind of weirdness ?

        AFAIK, apmd does not do CPU throttling by its own.
        You need to patch your kernel to enable speedstep facility (google +
        cpufreq), then you have to edit your apm scripts.

        The attached script goes into my /etc/apm/event.d/ directory (it's a
        debian so you might have to check how the trick is done on RH).

        --
        Best regards,
        Pierre Lombard <p-l-42@...>
      • Pierre-Yves Bonnetain
        ... I had already done that, to no avail. Which version of BIOS are you using ? -- Pierre-Yves Bonnetain Sécurité Informatique et Réseaux -- B&A Consultants
        Message 3 of 3 , Dec 4, 2002
        • 0 Attachment
          Pierre Lombard wrote:
          >
          > I guess you need to enable APM support in kernel:
          > General Setup / Power Management Support / Advanced Power Management
          > BIOS support / ...
          > FWIW, I enable Enable PM at boot time + Enable console blanking using APM
          > + RTC stores time in GMT
          >
          > If it's already available with your RH kernel as a module you may have
          > to load it "a la mano". I heard sometimes apm does not work correctly
          > when it's compiled as a module so YMMV...

          I had already done that, to no avail. Which version of BIOS are you
          using ?

          -- Pierre-Yves Bonnetain
          Sécurité Informatique et Réseaux -- B&A Consultants
          Tél +33 (0) 563 277 241 -- Fax +33 (0) 563 277 245
        Your message has been successfully submitted and would be delivered to recipients shortly.