Loading ...
Sorry, an error occurred while loading the content.

Changing resolution on X-display using keyboard

Expand Messages
  • oilpatchdog
    I recall the screen resolution can be changed under X by using Ctrl-Alt numeric + and - (assuming multiple screen sizes are in the Modes line). But the i8200
    Message 1 of 5 , Sep 28, 2002
    • 0 Attachment
      I recall the screen resolution can be changed under X by using
      Ctrl-Alt numeric + and - (assuming multiple screen sizes are in the
      Modes line).

      But the i8200 doesn't have numeric + and - keys. Anyone know how to
      do this?
    • James S. Adelman
      ... probably Fn-P = Keypad-Minus and Fn-; = Keypad-Plus or something similar see blue writing on your keyboard
      Message 2 of 5 , Sep 28, 2002
      • 0 Attachment
        On 2002.09.28 23:33 oilpatchdog wrote:
        > I recall the screen resolution can be changed under X by using
        > Ctrl-Alt numeric + and - (assuming multiple screen sizes are in the
        > Modes line).
        >
        > But the i8200 doesn't have numeric + and - keys. Anyone know how to
        > do this?

        probably Fn-P = Keypad-Minus
        and Fn-; = Keypad-Plus

        or something similar

        see blue writing on your keyboard
      • oilpatchdog
        Thanks. That seems to be it.
        Message 3 of 5 , Sep 28, 2002
        • 0 Attachment
          Thanks. That seems to be it.


          --- In linux-dell-laptops@y..., "James S. Adelman" <j.adelman@u...> wrote:
          > On 2002.09.28 23:33 oilpatchdog wrote:
          > > I recall the screen resolution can be changed under X by using
          > > Ctrl-Alt numeric + and - (assuming multiple screen sizes are in the
          > > Modes line).
          > >
          > > But the i8200 doesn't have numeric + and - keys. Anyone know how to
          > > do this?
          >
          > probably Fn-P = Keypad-Minus
          > and Fn-; = Keypad-Plus
          >
          > or something similar
          >
          > see blue writing on your keyboard
        • oilpatchdog
          Well, the sequences Fn P and Fn ; give numeric + and - all right, but have no effect on the screen resolution. That is Ctrl-Alt-Fn P has no effect (other than
          Message 4 of 5 , Sep 29, 2002
          • 0 Attachment
            Well, the sequences Fn P and Fn ; give numeric + and - all right, but
            have no effect on the screen resolution.

            That is Ctrl-Alt-Fn P has no effect (other than twisting your fingers).

            Has anyone gotten this working? It would be handy to change screen
            resolutions on the fly. One application is supporting LCD projectors
            that may want 800x600 for example.


            --- In linux-dell-laptops@y..., "oilpatchdog" <oilpatchdog@y...> wrote:
            > Thanks. That seems to be it.
            >

            > --- In linux-dell-laptops@y..., "James S. Adelman" <j.adelman@u...>
            > > probably Fn-P = Keypad-Minus
            > > and Fn-; = Keypad-Plus
            > >
            > > or something similar
            > >
            > > see blue writing on your keyboard
          • lorentey+linux-dell-laptop@elte.hu
            ... Try my XF86Config-4. (Works with NVidia GeForce 4 32Mb with UXGA LCD under XFree86 4.2.1. on Debian GNU/Linux sid.)
            Message 5 of 5 , Sep 30, 2002
            • 0 Attachment
              oilpatchdog@... <oilpatchdog@...> writes:
              > Well, the sequences Fn P and Fn ; give numeric + and - all right, but
              > have no effect on the screen resolution.
              >
              > That is Ctrl-Alt-Fn P has no effect (other than twisting your fingers).
              >
              > Has anyone gotten this working? It would be handy to change screen
              > resolutions on the fly. One application is supporting LCD projectors
              > that may want 800x600 for example.

              Try my XF86Config-4. (Works with NVidia GeForce 4 32Mb with UXGA LCD
              under XFree86 4.2.1. on Debian GNU/Linux sid.)

              http://caesar.elte.hu/~lorentey/XF86Config-4.inspiron.8200

              Using this configuration, the X server uses an LCD-only server layout
              by default (with resolutions 1600x1200, 1280x1024, 1280x960, 1152x864,
              1024x768, 800x600 and 640x480). I defined several alternative
              layouts for various external display modes. If you want to use
              these, you must add a -layout option when you start up your X server,
              e.g.:

              startx -- -layout TV

              Starting the X server with the "-layout CRT" option sets up X for
              external VGA display output. The frequency rates of the external
              monitor/projector are autodetected by the server. X switches to
              LCD-only mode by default. Pressing Ctl-Fn-Alt-; enables the external
              display using the highest resolution that it supports. Pressing
              Ctl-Fn-Alt-; repeatedly switches to lower resolutions. Note that
              changing the video mode does not change the size of the desktop.
              Nevertheless, most full-screen applications detect and use the
              geometry of the actual display (not the geometry of the desktop), so
              presentations etc. will come out nicely.

              I can enable the TV output by adding "-layout TV" to the X server
              command line. (I live in Hungary, you will certainly need to change
              the TV standard (PAL-x or NTSC-x) to match the one used in your
              country.) Again, the server comes up with TV-out disabled. Pressing
              Ctl-Fn-Alt-; enables high resolution (1024x768) TV-out, centered on
              the virtual desktop. Pressing Ctl-Fn-Alt-; repeatedly cycles among
              the available TV-out modes.

              Starting X with the "-layout Twin" option sets up X for dual-headed
              display (nifty!). Both the LCD and the external monitor are enabled,
              but this time they display different halves of a "widescreen"
              (3200x1200) virtual desktop. The configuration assumes that you place
              your notebook to the left of the external monitor. The external
              monitor must support 1600x1200.

              For me, the NVidia driver fails to set up the external display ports
              correctly when you press Ctl-Fn-Alt-; for the first time after X comes
              up. Temporarily switching to another mode and back seems to fix this.
              If the external display looks scrambled, try pressing Ctl-Fn-Alt-;
              followed by Ctl-Fn-Alt-p.

              The list of modes that Ctl-Fn-Alt-p cycles through is fully
              configurable; see Option "MetaModes" in NVidia's (really nice) driver
              documentation.

              If you want to use one of the above layouts as default, you need to
              edit your XF86Config-4 accordingly, or add the -layout option to one
              or more of the following files:

              - If you start X manually with startx or xinit: /etc/X11/xinit/xserverrc
              - If you use XDM: /etc/X11/xdm/Xservers
              - If you use KDE with KDM: /etc/kdm3/Xservers
              - If you use Gnome with GDM: some-similarly-named-file

              --
              Lőrentey Károly
            Your message has been successfully submitted and would be delivered to recipients shortly.