Loading ...
Sorry, an error occurred while loading the content.

X on the Inspiron 5000e(Thats right, there is more)

Expand Messages
  • beg14+@pitt.edu
    I took the advice of the group and downloaded the bz2 files from this group for use with my 5000e. When I installed over X 4.0 it works fine, except I can
    Message 1 of 3 , Nov 3, 2000
    • 0 Attachment
      I took the advice of the group and downloaded the bz2 files from this
      group for use with my 5000e. When I installed over X 4.0 it works
      fine, except I can only get 800x600, even though I have other
      modelines set(800x600 occurs nowhere in my XF86Config). Also, when I
      shutdown X my screen carmalizes immediately. I have checked
      /var/log/(Name of X's logfile here) for errors and none are reported.
      One more bit of information. Everyone here seems to havea rage
      mobility 128(AGP I assume) with 8 megs. Well, not me, I have 16
      megs. Is this possibly the cause of my grief.

      Thanks in advance for any help, Sincerely,
      Brandon Guy
    • Brett Viren
      ... I don t think it is the memory size. I also have 16 and dont have your troubles. Maybe the version of XFree86 is not new enough? I think you need 4.0.1c
      Message 2 of 3 , Nov 4, 2000
      • 0 Attachment
        beg14+@... writes:
        > I took the advice of the group and downloaded the bz2 files from this
        > group for use with my 5000e. When I installed over X 4.0 it works
        > fine, except I can only get 800x600, even though I have other
        > modelines set(800x600 occurs nowhere in my XF86Config). Also, when I
        > shutdown X my screen carmalizes immediately. I have checked
        > /var/log/(Name of X's logfile here) for errors and none are reported.
        > One more bit of information. Everyone here seems to havea rage
        > mobility 128(AGP I assume) with 8 megs. Well, not me, I have 16
        > megs. Is this possibly the cause of my grief.

        I don't think it is the memory size. I also have 16 and dont have
        your troubles.

        Maybe the version of XFree86 is not new enough? I think you need
        4.0.1c at least (maybe newer ones work also, but this is what I first
        got to work).

        Also: it seems that the r128 X server knows the correct timings to use
        and uses the convention of XXXxYYY for names so you don't have to have
        any explicit mention of modelines in the "Monitor" section, and maybe
        not even in the "Screen" section. Try putting the names (eg,
        "1600x1200") explicitly in your "Screen" section, as maybe it is
        defaulting to 800x600. Also try Ctrl-Alt-+ (where the + must be the
        Number Pad `+', you'll have to turn on NumLock) and see if that
        switches resolution.

        Luck,
        -Brett.
      • Allan Gottlieb
        ... I have 16MB and no problem. You must get the new driver. I suggest looking at http://www.cs.utexas.edu/users/kharker/linux-laptop/ and in particular
        Message 3 of 3 , Nov 4, 2000
        • 0 Attachment
          beg14+@... writes:

          > I took the advice of the group and downloaded the bz2 files from this
          > group for use with my 5000e. When I installed over X 4.0 it works
          > fine, except I can only get 800x600, even though I have other
          > modelines set(800x600 occurs nowhere in my XF86Config). Also, when I
          > shutdown X my screen carmalizes immediately. I have checked
          > /var/log/(Name of X's logfile here) for errors and none are reported.
          > One more bit of information. Everyone here seems to havea rage
          > mobility 128(AGP I assume) with 8 megs. Well, not me, I have 16
          > megs. Is this possibly the cause of my grief.

          I have 16MB and no problem. You must get the new driver. I suggest
          looking at

          http://www.cs.utexas.edu/users/kharker/linux-laptop/

          and in particular

          http://ibgwww.colorado.edu/~lessem/5000e/

          Basically you just get the new driver and put it in

          /usr/X11R6/lib/modules/drivers

          (at least for redhat 7). The driver is r128_drv.0.

          This assume you have Xfree 4.0.1. On redhat I have

          allan$ rpm -q XFree86
          XFree86-4.0.1-1
          allan$

          Hope this helps,
          allan gottlieb
        Your message has been successfully submitted and would be delivered to recipients shortly.