Loading ...
Sorry, an error occurred while loading the content.

Framebuffer on i8k2

Expand Messages
  • Thomas Deselaers
    Hello, is here someone successful in using vesa framebuffer on i8k2? I tried this, but it is not working, and another pity is: It seems that vesa-framebuffer
    Message 1 of 19 , Apr 30, 2002
    • 0 Attachment
      Hello,

      is here someone successful in using vesa framebuffer on i8k2?

      I tried this, but it is not working, and another pity is: It seems that
      vesa-framebuffer is not capable of resolutions higher than 1280x1024 but
      I would like 1600x1200.

      Greeting,
      thomas
      --
      thomas@... «<>» JabberID on request «<>» GPG/PGP key on request
      «< Unless stated otherwise everything I write is just my opinion >»
    • Nils-Anders Duesund Nottseter
      ... I have vesa framebuffer working perfectly on my i8k. You are correct, it is capable of maximum 1280x1024 but that is no problem. I have the 1600 lcd but
      Message 2 of 19 , Apr 30, 2002
      • 0 Attachment
        On Tue, 2002-04-30 at 11:55, Thomas Deselaers wrote:
        > Hello,
        >
        > is here someone successful in using vesa framebuffer on i8k2?
        >
        > I tried this, but it is not working, and another pity is: It seems that
        > vesa-framebuffer is not capable of resolutions higher than 1280x1024 but
        > I would like 1600x1200.
        >

        I have vesa framebuffer working perfectly on my i8k.

        You are correct, it is capable of maximum 1280x1024 but that is no
        problem. I have the 1600 lcd but 1280 is more than enough.
        (ok, if I had the option, I would use 1600...;)

        --
        Nils-Anders
      • Markus Kohli
        ... That s not true, I m sorry. I m using my i8k with fb-console and have 1600x1200 running. Code for LILO is 884 (with 16-bit). Or I just got that wrong, and
        Message 3 of 19 , Apr 30, 2002
        • 0 Attachment
          Am Dienstag, 30. April 2002 12.24 schrieb Nils-Anders Duesund Nottseter:
          > On Tue, 2002-04-30 at 11:55, Thomas Deselaers wrote:
          > > Hello,
          > >
          > > is here someone successful in using vesa framebuffer on i8k2?
          > >
          > > I tried this, but it is not working, and another pity is: It seems that
          > > vesa-framebuffer is not capable of resolutions higher than 1280x1024 but
          > > I would like 1600x1200.
          >
          > I have vesa framebuffer working perfectly on my i8k.
          >
          > You are correct, it is capable of maximum 1280x1024

          That's not true, I'm sorry. I'm using my i8k with fb-console and have
          1600x1200 running. Code for LILO is 884 (with 16-bit).
          Or I just got that wrong, and I'm not talking about the same like you... :-)

          Markus
          --
          Money is the root of all wealth.
        • Nils-Anders Duesund Nottseter
          ... I ve been using 0x307 for 1280 and if what you re telling me is correct then I ll change immediately. Thanks. -- Nils-Anders
          Message 4 of 19 , Apr 30, 2002
          • 0 Attachment
            On Tue, 2002-04-30 at 12:33, Markus Kohli wrote:
            > Am Dienstag, 30. April 2002 12.24 schrieb Nils-Anders Duesund Nottseter:
            > > On Tue, 2002-04-30 at 11:55, Thomas Deselaers wrote:
            > > > Hello,
            > > >
            > > > is here someone successful in using vesa framebuffer on i8k2?
            > > >
            > > > I tried this, but it is not working, and another pity is: It seems that
            > > > vesa-framebuffer is not capable of resolutions higher than 1280x1024 but
            > > > I would like 1600x1200.
            > >
            > > I have vesa framebuffer working perfectly on my i8k.
            > >
            > > You are correct, it is capable of maximum 1280x1024
            >
            > That's not true, I'm sorry. I'm using my i8k with fb-console and have
            > 1600x1200 running. Code for LILO is 884 (with 16-bit).
            > Or I just got that wrong, and I'm not talking about the same like you... :-)
            >

            I've been using 0x307 for 1280 and if what you're telling me is correct
            then I'll change immediately.
            Thanks.
            --
            Nils-Anders
          • Markus Kohli
            I hope I m right. Below you can see the relevant part of my lilo.conf It s pure 1600x1200 at 16bits. At least all my friends and profs are REALLY impressed
            Message 5 of 19 , Apr 30, 2002
            • 0 Attachment
              I hope I'm right.
              Below you can see the relevant part of my lilo.conf
              It's pure 1600x1200 at 16bits.
              At least all my friends and profs are REALLY impressed when they stare at my
              console ;-)


              boot = /dev/hda
              change-rules
              reset
              read-only
              menu-scheme = Wg:kw:Wg:Wg
              lba32
              prompt
              timeout = 80
              message = /boot/message

              image = /boot/vmlinuz
              label = linux
              root = /dev/hda7
              vga = 884
              initrd = /boot/initrd
              append = "disableapic hdc=ide-scsi"


              HTH

              Markus

              --
              Animal testing is futile: they always get nervous and give the wrong answers.
            • Nils-Anders Duesund Nottseter
              ... I m using grub and it looks like this: # For booting Linux title GNU/Linux Debian 2.4.17 root (hd0,3) kernel /boot/vmlinuz-2.4.17 root=/dev/hda4 vga=0x307
              Message 6 of 19 , Apr 30, 2002
              • 0 Attachment
                On Tue, 2002-04-30 at 12:43, Markus Kohli wrote:
                >
                > I hope I'm right.
                > Below you can see the relevant part of my lilo.conf
                > It's pure 1600x1200 at 16bits.
                > At least all my friends and profs are REALLY impressed when they stare at my
                > console ;-)
                >
                >
                > boot = /dev/hda
                > change-rules
                > reset
                > read-only
                > menu-scheme = Wg:kw:Wg:Wg
                > lba32
                > prompt
                > timeout = 80
                > message = /boot/message
                >
                > image = /boot/vmlinuz
                > label = linux
                > root = /dev/hda7
                > vga = 884
                > initrd = /boot/initrd
                > append = "disableapic hdc=ide-scsi"
                >
                >

                I'm using grub and it looks like this:

                # For booting Linux
                title GNU/Linux Debian 2.4.17
                root (hd0,3)
                kernel /boot/vmlinuz-2.4.17 root=/dev/hda4 vga=0x307 apm=on acpi=off


                Then change vga=0x307 to vga=0x884 for 1600x1200

                --
                Nils-Anders
              • Markus Kohli
                ... Don t think that s gonna work. The 0x??? format is octal or something like that. Try a pure vga=884, like in my config. -- Sex is only dirty if it s done
                Message 7 of 19 , Apr 30, 2002
                • 0 Attachment
                  > Then change vga=0x307 to vga=0x884 for 1600x1200

                  Don't think that's gonna work. The 0x??? format is octal or something like
                  that. Try a pure vga=884, like in my config.

                  --
                  Sex is only dirty if it's done right.
                • Brad Langhorst
                  ... don t fear non base 10 numbers ;) ... um - i m pretty sure it is supposed to be hex by the way anybody know the code for 1400x1050 or do i have to start
                  Message 8 of 19 , Apr 30, 2002
                  • 0 Attachment
                    --- Markus Kohli <kohli@...> wrote:
                    >
                    > > Then change vga=0x307 to vga=0x884 for 1600x1200
                    >
                    > Don't think that's gonna work. The 0x??? format is
                    > octal or something like
                    > that.
                    don't fear non base 10 numbers ;)
                    >Try a pure vga=884, like in my config.

                    um - i'm pretty sure it is supposed to be hex

                    by the way anybody know the code for 1400x1050
                    or do i have to start digging in the source?

                    from /usr/src/linux/Documentation/fb/vesafb.txt
                    ----+-------------------------------------
                    | 640x480 800x600 1024x768 1280x102
                    256 | 0x301 0x303 0x305 0x307
                    32k | 0x310 0x313 0x316 0x319
                    64k | 0x311 0x314 0x317 0x31A
                    16M | 0x312 0x315 0x318 0x31B

                    note the 0x31A

                    i'm pretty sure that lilo just interprets it as hex
                    but
                    you should pass it right in case that changes.

                    brad

                    __________________________________________________
                    Do You Yahoo!?
                    Yahoo! Health - your guide to health and wellness
                    http://health.yahoo.com
                  • Brad Langhorst
                    ... don t fear non base 10 numbers ;) ... um - i m pretty sure it is supposed to be hex by the way anybody know the code for 1400x1050 or do i have to start
                    Message 9 of 19 , Apr 30, 2002
                    • 0 Attachment
                      --- Markus Kohli <kohli@...> wrote:
                      >
                      > > Then change vga=0x307 to vga=0x884 for 1600x1200
                      >
                      > Don't think that's gonna work. The 0x??? format is
                      > octal or something like
                      > that.
                      don't fear non base 10 numbers ;)
                      >Try a pure vga=884, like in my config.

                      um - i'm pretty sure it is supposed to be hex

                      by the way anybody know the code for 1400x1050
                      or do i have to start digging in the source?

                      from /usr/src/linux/Documentation/fb/vesafb.txt
                      ----+-------------------------------------
                      | 640x480 800x600 1024x768 1280x102
                      256 | 0x301 0x303 0x305 0x307
                      32k | 0x310 0x313 0x316 0x319
                      64k | 0x311 0x314 0x317 0x31A
                      16M | 0x312 0x315 0x318 0x31B

                      note the 0x31A

                      i'm pretty sure that lilo just interprets it as hex
                      but
                      you should pass it right in case that changes.

                      brad

                      __________________________________________________
                      Do You Yahoo!?
                      Yahoo! Health - your guide to health and wellness
                      http://health.yahoo.com
                    • Brad Langhorst
                      ... don t fear non base 10 numbers ;) ... um - i m pretty sure it is supposed to be hex by the way anybody know the code for 1400x1050 or do i have to start
                      Message 10 of 19 , Apr 30, 2002
                      • 0 Attachment
                        --- Markus Kohli <kohli@...> wrote:
                        >
                        > > Then change vga=0x307 to vga=0x884 for 1600x1200
                        >
                        > Don't think that's gonna work. The 0x??? format is
                        > octal or something like
                        > that.
                        don't fear non base 10 numbers ;)
                        >Try a pure vga=884, like in my config.

                        um - i'm pretty sure it is supposed to be hex

                        by the way anybody know the code for 1400x1050
                        or do i have to start digging in the source?

                        from /usr/src/linux/Documentation/fb/vesafb.txt
                        ----+-------------------------------------
                        | 640x480 800x600 1024x768 1280x102
                        256 | 0x301 0x303 0x305 0x307
                        32k | 0x310 0x313 0x316 0x319
                        64k | 0x311 0x314 0x317 0x31A
                        16M | 0x312 0x315 0x318 0x31B

                        note the 0x31A

                        i'm pretty sure that lilo just interprets it as hex
                        but
                        you should pass it right in case that changes.

                        brad

                        __________________________________________________
                        Do You Yahoo!?
                        Yahoo! Health - your guide to health and wellness
                        http://health.yahoo.com
                      • Brad Langhorst
                        ... don t fear non base 10 numbers ;) ... um - i m pretty sure it is supposed to be hex by the way anybody know the code for 1400x1050 or do i have to start
                        Message 11 of 19 , Apr 30, 2002
                        • 0 Attachment
                          --- Markus Kohli <kohli@...> wrote:
                          >
                          > > Then change vga=0x307 to vga=0x884 for 1600x1200
                          >
                          > Don't think that's gonna work. The 0x??? format is
                          > octal or something like
                          > that.
                          don't fear non base 10 numbers ;)
                          >Try a pure vga=884, like in my config.

                          um - i'm pretty sure it is supposed to be hex

                          by the way anybody know the code for 1400x1050
                          or do i have to start digging in the source?

                          from /usr/src/linux/Documentation/fb/vesafb.txt
                          ----+-------------------------------------
                          | 640x480 800x600 1024x768 1280x102
                          256 | 0x301 0x303 0x305 0x307
                          32k | 0x310 0x313 0x316 0x319
                          64k | 0x311 0x314 0x317 0x31A
                          16M | 0x312 0x315 0x318 0x31B

                          note the 0x31A

                          i'm pretty sure that lilo just interprets it as hex
                          but
                          you should pass it right in case that changes.

                          brad

                          __________________________________________________
                          Do You Yahoo!?
                          Yahoo! Health - your guide to health and wellness
                          http://health.yahoo.com
                        • Brad Langhorst
                          ... don t fear non base 10 numbers ;) ... um - i m pretty sure it is supposed to be hex by the way anybody know the code for 1400x1050 or do i have to start
                          Message 12 of 19 , Apr 30, 2002
                          • 0 Attachment
                            --- Markus Kohli <kohli@...> wrote:
                            >
                            > > Then change vga=0x307 to vga=0x884 for 1600x1200
                            >
                            > Don't think that's gonna work. The 0x??? format is
                            > octal or something like
                            > that.
                            don't fear non base 10 numbers ;)
                            >Try a pure vga=884, like in my config.

                            um - i'm pretty sure it is supposed to be hex

                            by the way anybody know the code for 1400x1050
                            or do i have to start digging in the source?

                            from /usr/src/linux/Documentation/fb/vesafb.txt
                            ----+-------------------------------------
                            | 640x480 800x600 1024x768 1280x102
                            256 | 0x301 0x303 0x305 0x307
                            32k | 0x310 0x313 0x316 0x319
                            64k | 0x311 0x314 0x317 0x31A
                            16M | 0x312 0x315 0x318 0x31B

                            note the 0x31A

                            i'm pretty sure that lilo just interprets it as hex
                            but
                            you should pass it right in case that changes.

                            brad

                            __________________________________________________
                            Do You Yahoo!?
                            Yahoo! Health - your guide to health and wellness
                            http://health.yahoo.com
                          • Brad Langhorst
                            ... don t fear non base 10 numbers ;) ... um - i m pretty sure it is supposed to be hex by the way anybody know the code for 1400x1050 or do i have to start
                            Message 13 of 19 , Apr 30, 2002
                            • 0 Attachment
                              --- Markus Kohli <kohli@...> wrote:
                              >
                              > > Then change vga=0x307 to vga=0x884 for 1600x1200
                              >
                              > Don't think that's gonna work. The 0x??? format is
                              > octal or something like
                              > that.
                              don't fear non base 10 numbers ;)
                              >Try a pure vga=884, like in my config.

                              um - i'm pretty sure it is supposed to be hex

                              by the way anybody know the code for 1400x1050
                              or do i have to start digging in the source?

                              from /usr/src/linux/Documentation/fb/vesafb.txt
                              ----+-------------------------------------
                              | 640x480 800x600 1024x768 1280x102
                              256 | 0x301 0x303 0x305 0x307
                              32k | 0x310 0x313 0x316 0x319
                              64k | 0x311 0x314 0x317 0x31A
                              16M | 0x312 0x315 0x318 0x31B

                              note the 0x31A

                              i'm pretty sure that lilo just interprets it as hex
                              but
                              you should pass it right in case that changes.

                              brad


                              __________________________________________________
                              Do You Yahoo!?
                              Yahoo! Health - your guide to health and wellness
                              http://health.yahoo.com
                            • emil kirschner
                              what framebuffer driver do you guys use? vesa definitely doesn t work with 2.4.5 (actually it does, the problem is that if I close the screen (blank the
                              Message 14 of 19 , Apr 30, 2002
                              • 0 Attachment
                                what framebuffer driver do you guys use? vesa
                                definitely doesn't work with 2.4.5 (actually it does,
                                the problem is that if I close the screen (blank the
                                console) and reopen it, the screen coordinates are
                                translated (after clear yout cursor would be in the
                                middle of the screen). I'm about to upgrade to 2.4.18

                                did anyone else have this problem already?


                                Cheers,
                                e.

                                --- Brad Langhorst <bwlang@...> wrote:
                                >
                                > --- Markus Kohli <kohli@...> wrote:
                                > >
                                > > > Then change vga=0x307 to vga=0x884 for 1600x1200
                                > >
                                > > Don't think that's gonna work. The 0x??? format is
                                > > octal or something like
                                > > that.
                                > don't fear non base 10 numbers ;)
                                > >Try a pure vga=884, like in my config.
                                >
                                > um - i'm pretty sure it is supposed to be hex
                                >
                                > by the way anybody know the code for 1400x1050
                                > or do i have to start digging in the source?
                                >
                                > from /usr/src/linux/Documentation/fb/vesafb.txt
                                > ----+-------------------------------------
                                > | 640x480 800x600 1024x768 1280x102
                                > 256 | 0x301 0x303 0x305 0x307
                                > 32k | 0x310 0x313 0x316 0x319
                                > 64k | 0x311 0x314 0x317 0x31A
                                > 16M | 0x312 0x315 0x318 0x31B
                                >
                                > note the 0x31A
                                >
                                > i'm pretty sure that lilo just interprets it as hex
                                > but
                                > you should pass it right in case that changes.
                                >
                                > brad
                                >
                                > __________________________________________________
                                > Do You Yahoo!?
                                > Yahoo! Health - your guide to health and wellness
                                > http://health.yahoo.com
                                >


                                __________________________________________________
                                Do You Yahoo!?
                                Yahoo! Health - your guide to health and wellness
                                http://health.yahoo.com
                              • Rodney _meff_ Gordon II
                                vesafb works for me its a known bug for rivafb to not be able to coexist with NVdriver.. ... -- Rodney meff Gordon II - meff@pobox.com -- Love is never
                                Message 15 of 19 , Apr 30, 2002
                                • 0 Attachment
                                  vesafb works for me
                                  its a known bug for rivafb to not be able to coexist with NVdriver..

                                  Thomas Deselaers (thomas@...) wrote:
                                  > Hello,
                                  >
                                  > is here someone successful in using vesa framebuffer on i8k2?
                                  >
                                  > I tried this, but it is not working, and another pity is: It seems that
                                  > vesa-framebuffer is not capable of resolutions higher than 1280x1024 but
                                  > I would like 1600x1200.
                                  >
                                  > Greeting,
                                  > thomas
                                  > --
                                  > thomas@... ?<>? JabberID on request ?<>? GPG/PGP key on request
                                  > ?< Unless stated otherwise everything I write is just my opinion >?
                                  >
                                  >
                                  > --------------------------------------------------------------
                                  > Please post your X config files in the group links or database
                                  > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                                  > FAQ: http://www.whacked.net/ldl/faq
                                  >
                                  > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                                  >
                                  >

                                  --
                                  Rodney "meff" Gordon II - meff@...

                                  -->
                                  Love is never asking why?
                                • Domsalla, Thorsten
                                  ... Yes, still in 2.4.18 ... :-( TJ
                                  Message 16 of 19 , Apr 30, 2002
                                  • 0 Attachment
                                    > the problem is that if I close the screen (blank the
                                    > console) and reopen it, the screen coordinates are
                                    > [...]
                                    > did anyone else have this problem already?

                                    Yes, still in 2.4.18 ... :-(

                                    TJ
                                  • James H. Cloos Jr.
                                    ... Thomas I tried this, but it is not working, and another pity is: It Thomas seems that vesa-framebuffer is not capable of resolutions Thomas higher than
                                    Message 17 of 19 , May 1 12:39 AM
                                    • 0 Attachment
                                      >>>>> "Thomas" == Thomas Deselaers <thomas@...> writes:

                                      Thomas> I tried this, but it is not working, and another pity is: It
                                      Thomas> seems that vesa-framebuffer is not capable of resolutions
                                      Thomas> higher than 1280x1024 but I would like 1600x1200.

                                      The vesa mode number for resolutions above 1280x1024 is not
                                      standardized; every vga bios uses different numbers.

                                      On the radeon 7500 dell shiped in some of the 8100s, 1600x1200 is
                                      0x374 (aka 884 in decimal) for 16 bit colour, IIRC.

                                      Suse's yast2 can give a detailed hardware listing which mentions all
                                      of the vesa modes the vga bios on board supports. That is where I got
                                      the 0x374. I do not know how to get at that info on any of the other
                                      dists. I'm sure it is available, though.

                                      There is probably also a way to get that info in doze, before
                                      upgrading to linux.

                                      -JimC
                                    • Nils-Anders Duesund Nottseter
                                      ... Great that somebody found some facts. Can anybody with gf2go or gf4go and suse find out what the numbers are for nvidia? -- Nils-Anders
                                      Message 18 of 19 , May 1 3:07 PM
                                      • 0 Attachment
                                        On Wed, 2002-05-01 at 09:39, James H. Cloos Jr. wrote:
                                        > >>>>> "Thomas" == Thomas Deselaers <thomas@...> writes:
                                        >
                                        > Thomas> I tried this, but it is not working, and another pity is: It
                                        > Thomas> seems that vesa-framebuffer is not capable of resolutions
                                        > Thomas> higher than 1280x1024 but I would like 1600x1200.
                                        >
                                        > The vesa mode number for resolutions above 1280x1024 is not
                                        > standardized; every vga bios uses different numbers.
                                        >
                                        > On the radeon 7500 dell shiped in some of the 8100s, 1600x1200 is
                                        > 0x374 (aka 884 in decimal) for 16 bit colour, IIRC.
                                        >
                                        > Suse's yast2 can give a detailed hardware listing which mentions all
                                        > of the vesa modes the vga bios on board supports. That is where I got
                                        > the 0x374. I do not know how to get at that info on any of the other
                                        > dists. I'm sure it is available, though.
                                        >
                                        > There is probably also a way to get that info in doze, before
                                        > upgrading to linux.
                                        >
                                        > -JimC
                                        >
                                        >

                                        Great that somebody found some facts.
                                        Can anybody with gf2go or gf4go and suse find out what the numbers are
                                        for nvidia?

                                        --
                                        Nils-Anders
                                      • Swen Thuemmler
                                        ... Hi, on my i8k, the numbers are 837 and 838 (8bpp and 16bpp). Unfortunately it does not work for me: the resolution is set to 1600x1200, but there seems to
                                        Message 19 of 19 , May 2 12:12 AM
                                        • 0 Attachment
                                          On 2 May 2002, Nils-Anders Duesund Nottseter wrote:

                                          > Great that somebody found some facts.
                                          > Can anybody with gf2go or gf4go and suse find out what the numbers are
                                          > for nvidia?

                                          Hi,

                                          on my i8k, the numbers are 837 and 838 (8bpp and 16bpp). Unfortunately it
                                          does not work for me: the resolution is set to 1600x1200, but there seems
                                          to be a problem with font sizes: it seems as if the font would use only
                                          every second pixel, so that the font is 4 times as large. Additionally,
                                          there are a lot of extra pixels somewhere on the screen (like white
                                          noise), so it is unusable this way.

                                          Has anybody a solution for this?

                                          --Swen
                                        Your message has been successfully submitted and would be delivered to recipients shortly.