Loading ...
Sorry, an error occurred while loading the content.

Re: [linux-dell-laptops] Linux Laptop's In General, what's best?

Expand Messages
  • Adam Lowry
    ... I know it s not a trivial thing, in my opinion getting a lower resolution because fonts are too small isn t the best way to handle it. Maybe using larger
    Message 1 of 17 , Mar 1, 2002
    • 0 Attachment
      On Fri, 2002-03-01 at 22:31, Robert W. Current wrote:
      > My thinking is, I want to use it at home, late at night (after a few
      > beers when my eyes blur) and in my car (explain later) so probably
      > 1400x1050 would suck for me at 14", I want crystal clear 1024x768.
      > I'll play DVD's on the road sometimes, so DVD and good video is a must
      > (cause I hook into a TV at times).

      I know it's not a trivial thing, in my opinion getting a lower
      resolution because fonts are too small isn't the best way to handle it.
      Maybe using larger fonts? XPMs would still be smaller, but generally
      those don't put as much of a strain on the eyes. And larger fonts on a
      higher resolution screen are much easier to read. But then again, fonts
      in X use some strong voodoo...

      Adam
    • Dr. Robert W. Current
      = From: Adam Lowry [mailto:aclowry@umr.edu] = I know it s not a trivial thing, in my opinion getting a = lower resolution because fonts are too small isn t
      Message 2 of 17 , Mar 1, 2002
      • 0 Attachment
        => From: Adam Lowry [mailto:aclowry@...]
        => I know it's not a trivial thing, in my opinion getting a
        => lower resolution because fonts are too small isn't the best
        => way to handle it. Maybe using larger fonts?

        Ah... Well... No.

        Small fonts are the problem, but it's not that simple. There are a lot
        of things I use that don't have scalable fonts (icons, some apps have
        fixed fonts in the menus, and are all menu based, like VAG-COM and all
        the software my company makes, control software, stuff with JUST
        buttons, not like web browsers or word processors).

        So, the solution is to have the ABILITY to have high resolution
        displays, but just run at a lower resolution... Problem is, I tried
        that.

        My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
        it was run at max resolution. Everything was fuzzy. I called dell,
        emailed, and did all kinds of research. If you search through the dell
        support message forum, you will see a LOT of people complain about this.
        Dell has only 1 answer "our displays are only designed to be clear at
        the 'optimum' resolution, if it's within 30 days of your purchase, you
        may exchange it" which is their way of admitting it sucks at lower
        resolution.

        So...

        I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
        happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
        at home up to 1800 x 1440 without any complaints).

        Again, this is only MY opinion. And since it makes me happy, and
        getting the 1 down from max resolution displays on laptops is actually
        cheaper anyway, it's a win-win thing for me.

        Rob
      • Stephen Lau
        Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small size on a 14.1 1600x1200 UXGA i4100), but then once I started anti-aliasing them
        Message 3 of 17 , Mar 1, 2002
        • 0 Attachment
          Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
          size on a 14.1" 1600x1200 UXGA i4100), but then once I started
          anti-aliasing them with gdkxft, it looked sooooooooooooo much better.

          -steve

          On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W. Current wrote:
          > => From: Adam Lowry [mailto:aclowry@...]
          > => I know it's not a trivial thing, in my opinion getting a
          > => lower resolution because fonts are too small isn't the best
          > => way to handle it. Maybe using larger fonts?
          >
          > Ah... Well... No.
          >
          > Small fonts are the problem, but it's not that simple. There are a lot
          > of things I use that don't have scalable fonts (icons, some apps have
          > fixed fonts in the menus, and are all menu based, like VAG-COM and all
          > the software my company makes, control software, stuff with JUST
          > buttons, not like web browsers or word processors).
          >
          > So, the solution is to have the ABILITY to have high resolution
          > displays, but just run at a lower resolution... Problem is, I tried
          > that.
          >
          > My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
          > it was run at max resolution. Everything was fuzzy. I called dell,
          > emailed, and did all kinds of research. If you search through the dell
          > support message forum, you will see a LOT of people complain about this.
          > Dell has only 1 answer "our displays are only designed to be clear at
          > the 'optimum' resolution, if it's within 30 days of your purchase, you
          > may exchange it" which is their way of admitting it sucks at lower
          > resolution.
          >
          > So...
          >
          > I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
          > happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
          > at home up to 1800 x 1440 without any complaints).
          >
          > Again, this is only MY opinion. And since it makes me happy, and
          > getting the 1 down from max resolution displays on laptops is actually
          > cheaper anyway, it's a win-win thing for me.
          >
          > Rob
          >

          --
          stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
        • Steve Baldwin
          Can you please explain what you did, where you got gdkxft, and how you got it all set up. Thx
          Message 4 of 17 , Mar 2, 2002
          • 0 Attachment
            Can you please explain what you did, where you got gdkxft, and how you
            got it all set up.

            Thx

            On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:
            > Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
            > size on a 14.1" 1600x1200 UXGA i4100), but then once I started
            > anti-aliasing them with gdkxft, it looked sooooooooooooo much better.
            >
            > -steve
            >
            > On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W. Current wrote:
            > > => From: Adam Lowry [mailto:aclowry@...]
            > > => I know it's not a trivial thing, in my opinion getting a
            > > => lower resolution because fonts are too small isn't the best
            > > => way to handle it. Maybe using larger fonts?
            > >
            > > Ah... Well... No.
            > >
            > > Small fonts are the problem, but it's not that simple. There are a lot
            > > of things I use that don't have scalable fonts (icons, some apps have
            > > fixed fonts in the menus, and are all menu based, like VAG-COM and all
            > > the software my company makes, control software, stuff with JUST
            > > buttons, not like web browsers or word processors).
            > >
            > > So, the solution is to have the ABILITY to have high resolution
            > > displays, but just run at a lower resolution... Problem is, I tried
            > > that.
            > >
            > > My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
            > > it was run at max resolution. Everything was fuzzy. I called dell,
            > > emailed, and did all kinds of research. If you search through the dell
            > > support message forum, you will see a LOT of people complain about this.
            > > Dell has only 1 answer "our displays are only designed to be clear at
            > > the 'optimum' resolution, if it's within 30 days of your purchase, you
            > > may exchange it" which is their way of admitting it sucks at lower
            > > resolution.
            > >
            > > So...
            > >
            > > I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
            > > happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
            > > at home up to 1800 x 1440 without any complaints).
            > >
            > > Again, this is only MY opinion. And since it makes me happy, and
            > > getting the 1 down from max resolution displays on laptops is actually
            > > cheaper anyway, it's a win-win thing for me.
            > >
            > > Rob
            > >
            >
            > --
            > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
            >
            >
            > --------------------------------------------------------------
            > Please post your X config files in the group links or database
            > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
            > FAQ: http://www.whacked.net/ldl/faq
            >
            > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
            >
            >
          • Stephen Lau
            I m running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important later) go to http://gdkxft.sourceforge.net, click on the download link at the bottom
            Message 5 of 17 , Mar 2, 2002
            • 0 Attachment
              I'm running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important
              later)

              go to http://gdkxft.sourceforge.net, click on the download link at the
              bottom and download gdkxft-1.5.tar.gz

              ./configure --prefix=/usr
              make

              then become root
              make install
              gdkxft_sysinstall

              exit Xwindows
              edit either your .bashrc, .bash_profile, or the systemwide equivalents and
              add:
              export LD_PRELOAD="/usr/lib/libgdkxft.so.0"

              logout, log back in
              put all your truetype fonts in one dir
              run 'ttmkfdir' to generate the fonts.dir in that dir
              add the directory to your /etc/X11/fs/config (put it first, ahead of all
              other dirs)
              if you haven't changed the default-resolutions line to be 100,100,75,75
              instead of 75,75,100,100 - do it while you're here. :) it'll bump you up to
              100dpi fonts. also make sure the /usr/X11R6/lib/X11/fonts/100dpi line is
              ahead of the 75dpi path.

              edit /etc/X11/XftConfig and make sure it's sane, i.e.: map your font
              families properly. for instance, I like all of Microsoft's Core Fonts, so
              I use Arial as my sans font and map Helvetica to it. I use "Times New
              Roman" as my times font, "Courier New" as my courier font, and "Andale
              Mono" as my mono font.

              restart XFS by doing '/etc/init.d/xfs restart'
              generate your ~/.gdkxft file, if you want to anti-alias certain fonts, etc.
              it'll look like:

              # turn off anti-aliasing for all fonts
              !*
              # turn them on one at a time
              -arial-*
              -courier new-*
              -times new roman-*
              # bad applications - don't anti-alias them
              &gkrellm

              NOW, you can finally start up X. so go start it up and you should see
              anti-aliased fonts. one of the best parts of AA fonts is for web-browsing,
              so you want to make sure Mozilla supports it. If you're running Ximian,
              the mozilla packages are already compiled to support it - you just need to
              add another export line like we did earlier, except this time:
              export MOZILLA_USE_GDKXFT=1
              do the routine: log out of X, logout console/login, start x
              now Mozilla (and hence, galeon) should have AA fonts.
              if you're running your own version of Mozilla, you can apply the binary
              patch found here:
              http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-0.9.8.i386.tar.gz
              or apply the source patch to the source tree found here:
              http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-patch-0.9.8.diff

              there... it seems like a daunting process, and it took me about half an
              hour to get it working my first time, but it only took me about 5-10
              minutes for each machine i've done it on since then. I've only installed
              it on Red Hat 7.1 & 7.2 machines...but it's gorgeous. everyone i've
              installed it for agrees its awesome.

              i'd be happy to post my XftConfig, and .gdkxft files if people care to. if
              you want the Microsoft Truetype Core Fonts, go here:
              http://www.microsoft.com/typography/fontpack/default.htm

              cheers,
              steve



              On Sat, Mar 02, 2002 at 08:22:45PM +1100, Steve Baldwin wrote:
              > Can you please explain what you did, where you got gdkxft, and how you
              > got it all set up.
              >
              > Thx
              >
              > On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:
              > > Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
              > > size on a 14.1" 1600x1200 UXGA i4100), but then once I started
              > > anti-aliasing them with gdkxft, it looked sooooooooooooo much better.
              > >
              > > -steve
              > >
              > > On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W. Current wrote:
              > > > => From: Adam Lowry [mailto:aclowry@...]
              > > > => I know it's not a trivial thing, in my opinion getting a
              > > > => lower resolution because fonts are too small isn't the best
              > > > => way to handle it. Maybe using larger fonts?
              > > >
              > > > Ah... Well... No.
              > > >
              > > > Small fonts are the problem, but it's not that simple. There are a lot
              > > > of things I use that don't have scalable fonts (icons, some apps have
              > > > fixed fonts in the menus, and are all menu based, like VAG-COM and all
              > > > the software my company makes, control software, stuff with JUST
              > > > buttons, not like web browsers or word processors).
              > > >
              > > > So, the solution is to have the ABILITY to have high resolution
              > > > displays, but just run at a lower resolution... Problem is, I tried
              > > > that.
              > > >
              > > > My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
              > > > it was run at max resolution. Everything was fuzzy. I called dell,
              > > > emailed, and did all kinds of research. If you search through the dell
              > > > support message forum, you will see a LOT of people complain about this.
              > > > Dell has only 1 answer "our displays are only designed to be clear at
              > > > the 'optimum' resolution, if it's within 30 days of your purchase, you
              > > > may exchange it" which is their way of admitting it sucks at lower
              > > > resolution.
              > > >
              > > > So...
              > > >
              > > > I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
              > > > happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
              > > > at home up to 1800 x 1440 without any complaints).
              > > >
              > > > Again, this is only MY opinion. And since it makes me happy, and
              > > > getting the 1 down from max resolution displays on laptops is actually
              > > > cheaper anyway, it's a win-win thing for me.
              > > >
              > > > Rob
              > > >
              > >
              > > --
              > > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
              > >
              > >
              > > --------------------------------------------------------------
              > > Please post your X config files in the group links or database
              > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
              > > FAQ: http://www.whacked.net/ldl/faq
              > >
              > > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
              > >
              > >
              >
              >

              --
              stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
            • Victor Manuel Hernandez Maksimenko
              Could you please post them?, i m currently using gdkxft (+mozilla gdkxft) and im very happy with the results. But im using 75dpi fonts, when i modified the
              Message 6 of 17 , Mar 2, 2002
              • 0 Attachment
                Could you please post them?, i'm currently using gdkxft (+mozilla
                gdkxft) and im very happy with the results. But im using 75dpi fonts,
                when i modified the /etc/X11/fs/config to use 100dpi, im getting fonts
                too big.

                Also what dpi reports X that your LCD have?, when i run 'xdpyinfo | grep
                resolution' it reports 75x75 dots per inchs. And when i add the line
                'DisplaySize 305 230' to the XF86Config-4, then it reports 133x133 dots
                per inch, but im back with the BIG fonts.

                thanks!


                On Sat, 2002-03-02 at 05:54, Stephen Lau wrote:
                > I'm running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important
                > later)
                >
                > go to http://gdkxft.sourceforge.net, click on the download link at the
                > bottom and download gdkxft-1.5.tar.gz
                >
                > ./configure --prefix=/usr
                > make
                >
                > then become root
                > make install
                > gdkxft_sysinstall
                >
                > exit Xwindows
                > edit either your .bashrc, .bash_profile, or the systemwide equivalents and
                > add:
                > export LD_PRELOAD="/usr/lib/libgdkxft.so.0"
                >
                > logout, log back in
                > put all your truetype fonts in one dir
                > run 'ttmkfdir' to generate the fonts.dir in that dir
                > add the directory to your /etc/X11/fs/config (put it first, ahead of all
                > other dirs)
                > if you haven't changed the default-resolutions line to be 100,100,75,75
                > instead of 75,75,100,100 - do it while you're here. :) it'll bump you up to
                > 100dpi fonts. also make sure the /usr/X11R6/lib/X11/fonts/100dpi line is
                > ahead of the 75dpi path.
                >
                > edit /etc/X11/XftConfig and make sure it's sane, i.e.: map your font
                > families properly. for instance, I like all of Microsoft's Core Fonts, so
                > I use Arial as my sans font and map Helvetica to it. I use "Times New
                > Roman" as my times font, "Courier New" as my courier font, and "Andale
                > Mono" as my mono font.
                >
                > restart XFS by doing '/etc/init.d/xfs restart'
                > generate your ~/.gdkxft file, if you want to anti-alias certain fonts, etc.
                > it'll look like:
                >
                > # turn off anti-aliasing for all fonts
                > !*
                > # turn them on one at a time
                > -arial-*
                > -courier new-*
                > -times new roman-*
                > # bad applications - don't anti-alias them
                > &gkrellm
                >
                > NOW, you can finally start up X. so go start it up and you should see
                > anti-aliased fonts. one of the best parts of AA fonts is for web-browsing,
                > so you want to make sure Mozilla supports it. If you're running Ximian,
                > the mozilla packages are already compiled to support it - you just need to
                > add another export line like we did earlier, except this time:
                > export MOZILLA_USE_GDKXFT=1
                > do the routine: log out of X, logout console/login, start x
                > now Mozilla (and hence, galeon) should have AA fonts.
                > if you're running your own version of Mozilla, you can apply the binary
                > patch found here:
                > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-0.9.8.i386.tar.gz
                > or apply the source patch to the source tree found here:
                > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-patch-0.9.8.diff
                >
                > there... it seems like a daunting process, and it took me about half an
                > hour to get it working my first time, but it only took me about 5-10
                > minutes for each machine i've done it on since then. I've only installed
                > it on Red Hat 7.1 & 7.2 machines...but it's gorgeous. everyone i've
                > installed it for agrees its awesome.
                >
                > i'd be happy to post my XftConfig, and .gdkxft files if people care to. if
                > you want the Microsoft Truetype Core Fonts, go here:
                > http://www.microsoft.com/typography/fontpack/default.htm
                >
                > cheers,
                > steve
                >
                >
                >
                > On Sat, Mar 02, 2002 at 08:22:45PM +1100, Steve Baldwin wrote:
                > > Can you please explain what you did, where you got gdkxft, and how you
                > > got it all set up.
                > >
                > > Thx
                > >
                > > On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:
                > > > Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
                > > > size on a 14.1" 1600x1200 UXGA i4100), but then once I started
                > > > anti-aliasing them with gdkxft, it looked sooooooooooooo much better.
                > > >
                > > > -steve
                > > >
                > > > On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W. Current wrote:
                > > > > => From: Adam Lowry [mailto:aclowry@...]
                > > > > => I know it's not a trivial thing, in my opinion getting a
                > > > > => lower resolution because fonts are too small isn't the best
                > > > > => way to handle it. Maybe using larger fonts?
                > > > >
                > > > > Ah... Well... No.
                > > > >
                > > > > Small fonts are the problem, but it's not that simple. There are a lot
                > > > > of things I use that don't have scalable fonts (icons, some apps have
                > > > > fixed fonts in the menus, and are all menu based, like VAG-COM and all
                > > > > the software my company makes, control software, stuff with JUST
                > > > > buttons, not like web browsers or word processors).
                > > > >
                > > > > So, the solution is to have the ABILITY to have high resolution
                > > > > displays, but just run at a lower resolution... Problem is, I tried
                > > > > that.
                > > > >
                > > > > My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
                > > > > it was run at max resolution. Everything was fuzzy. I called dell,
                > > > > emailed, and did all kinds of research. If you search through the dell
                > > > > support message forum, you will see a LOT of people complain about this.
                > > > > Dell has only 1 answer "our displays are only designed to be clear at
                > > > > the 'optimum' resolution, if it's within 30 days of your purchase, you
                > > > > may exchange it" which is their way of admitting it sucks at lower
                > > > > resolution.
                > > > >
                > > > > So...
                > > > >
                > > > > I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
                > > > > happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
                > > > > at home up to 1800 x 1440 without any complaints).
                > > > >
                > > > > Again, this is only MY opinion. And since it makes me happy, and
                > > > > getting the 1 down from max resolution displays on laptops is actually
                > > > > cheaper anyway, it's a win-win thing for me.
                > > > >
                > > > > Rob
                > > > >
                > > >
                > > > --
                > > > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                > > >
                > > >
                > > > --------------------------------------------------------------
                > > > Please post your X config files in the group links or database
                > > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                > > > FAQ: http://www.whacked.net/ldl/faq
                > > >
                > > > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                > > >
                > > >
                > >
                > >
                >
                > --
                > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                >
                >
                > --------------------------------------------------------------
                > Please post your X config files in the group links or database
                > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                > FAQ: http://www.whacked.net/ldl/faq
                >
                > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                >
                >
              • Stephen Lau
                That s the whole point...you will have BIG fonts with the 100dpi fonts - you just need to go into your window manager preferences bring the font sizes back
                Message 7 of 17 , Mar 2, 2002
                • 0 Attachment
                  That's the whole point...you will have BIG fonts with the 100dpi fonts -
                  you just need to go into your window manager preferences bring the font
                  sizes back down to a smaller size... they will have more resolution than
                  the 75dpi fonts.

                  -steve

                  On Sat, Mar 02, 2002 at 01:34:17PM -0400, Victor Manuel Hernandez Maksimenko wrote:
                  > Could you please post them?, i'm currently using gdkxft (+mozilla
                  > gdkxft) and im very happy with the results. But im using 75dpi fonts,
                  > when i modified the /etc/X11/fs/config to use 100dpi, im getting fonts
                  > too big.
                  >
                  > Also what dpi reports X that your LCD have?, when i run 'xdpyinfo | grep
                  > resolution' it reports 75x75 dots per inchs. And when i add the line
                  > 'DisplaySize 305 230' to the XF86Config-4, then it reports 133x133 dots
                  > per inch, but im back with the BIG fonts.
                  >
                  > thanks!
                  >
                  >
                  > On Sat, 2002-03-02 at 05:54, Stephen Lau wrote:
                  > > I'm running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important
                  > > later)
                  > >
                  > > go to http://gdkxft.sourceforge.net, click on the download link at the
                  > > bottom and download gdkxft-1.5.tar.gz
                  > >
                  > > ./configure --prefix=/usr
                  > > make
                  > >
                  > > then become root
                  > > make install
                  > > gdkxft_sysinstall
                  > >
                  > > exit Xwindows
                  > > edit either your .bashrc, .bash_profile, or the systemwide equivalents and
                  > > add:
                  > > export LD_PRELOAD="/usr/lib/libgdkxft.so.0"
                  > >
                  > > logout, log back in
                  > > put all your truetype fonts in one dir
                  > > run 'ttmkfdir' to generate the fonts.dir in that dir
                  > > add the directory to your /etc/X11/fs/config (put it first, ahead of all
                  > > other dirs)
                  > > if you haven't changed the default-resolutions line to be 100,100,75,75
                  > > instead of 75,75,100,100 - do it while you're here. :) it'll bump you up to
                  > > 100dpi fonts. also make sure the /usr/X11R6/lib/X11/fonts/100dpi line is
                  > > ahead of the 75dpi path.
                  > >
                  > > edit /etc/X11/XftConfig and make sure it's sane, i.e.: map your font
                  > > families properly. for instance, I like all of Microsoft's Core Fonts, so
                  > > I use Arial as my sans font and map Helvetica to it. I use "Times New
                  > > Roman" as my times font, "Courier New" as my courier font, and "Andale
                  > > Mono" as my mono font.
                  > >
                  > > restart XFS by doing '/etc/init.d/xfs restart'
                  > > generate your ~/.gdkxft file, if you want to anti-alias certain fonts, etc.
                  > > it'll look like:
                  > >
                  > > # turn off anti-aliasing for all fonts
                  > > !*
                  > > # turn them on one at a time
                  > > -arial-*
                  > > -courier new-*
                  > > -times new roman-*
                  > > # bad applications - don't anti-alias them
                  > > &gkrellm
                  > >
                  > > NOW, you can finally start up X. so go start it up and you should see
                  > > anti-aliased fonts. one of the best parts of AA fonts is for web-browsing,
                  > > so you want to make sure Mozilla supports it. If you're running Ximian,
                  > > the mozilla packages are already compiled to support it - you just need to
                  > > add another export line like we did earlier, except this time:
                  > > export MOZILLA_USE_GDKXFT=1
                  > > do the routine: log out of X, logout console/login, start x
                  > > now Mozilla (and hence, galeon) should have AA fonts.
                  > > if you're running your own version of Mozilla, you can apply the binary
                  > > patch found here:
                  > > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-0.9.8.i386.tar.gz
                  > > or apply the source patch to the source tree found here:
                  > > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-patch-0.9.8.diff
                  > >
                  > > there... it seems like a daunting process, and it took me about half an
                  > > hour to get it working my first time, but it only took me about 5-10
                  > > minutes for each machine i've done it on since then. I've only installed
                  > > it on Red Hat 7.1 & 7.2 machines...but it's gorgeous. everyone i've
                  > > installed it for agrees its awesome.
                  > >
                  > > i'd be happy to post my XftConfig, and .gdkxft files if people care to. if
                  > > you want the Microsoft Truetype Core Fonts, go here:
                  > > http://www.microsoft.com/typography/fontpack/default.htm
                  > >
                  > > cheers,
                  > > steve
                  > >
                  > >
                  > >
                  > > On Sat, Mar 02, 2002 at 08:22:45PM +1100, Steve Baldwin wrote:
                  > > > Can you please explain what you did, where you got gdkxft, and how you
                  > > > got it all set up.
                  > > >
                  > > > Thx
                  > > >
                  > > > On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:
                  > > > > Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
                  > > > > size on a 14.1" 1600x1200 UXGA i4100), but then once I started
                  > > > > anti-aliasing them with gdkxft, it looked sooooooooooooo much better.
                  > > > >
                  > > > > -steve
                  > > > >
                  > > > > On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W. Current wrote:
                  > > > > > => From: Adam Lowry [mailto:aclowry@...]
                  > > > > > => I know it's not a trivial thing, in my opinion getting a
                  > > > > > => lower resolution because fonts are too small isn't the best
                  > > > > > => way to handle it. Maybe using larger fonts?
                  > > > > >
                  > > > > > Ah... Well... No.
                  > > > > >
                  > > > > > Small fonts are the problem, but it's not that simple. There are a lot
                  > > > > > of things I use that don't have scalable fonts (icons, some apps have
                  > > > > > fixed fonts in the menus, and are all menu based, like VAG-COM and all
                  > > > > > the software my company makes, control software, stuff with JUST
                  > > > > > buttons, not like web browsers or word processors).
                  > > > > >
                  > > > > > So, the solution is to have the ABILITY to have high resolution
                  > > > > > displays, but just run at a lower resolution... Problem is, I tried
                  > > > > > that.
                  > > > > >
                  > > > > > My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
                  > > > > > it was run at max resolution. Everything was fuzzy. I called dell,
                  > > > > > emailed, and did all kinds of research. If you search through the dell
                  > > > > > support message forum, you will see a LOT of people complain about this.
                  > > > > > Dell has only 1 answer "our displays are only designed to be clear at
                  > > > > > the 'optimum' resolution, if it's within 30 days of your purchase, you
                  > > > > > may exchange it" which is their way of admitting it sucks at lower
                  > > > > > resolution.
                  > > > > >
                  > > > > > So...
                  > > > > >
                  > > > > > I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
                  > > > > > happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
                  > > > > > at home up to 1800 x 1440 without any complaints).
                  > > > > >
                  > > > > > Again, this is only MY opinion. And since it makes me happy, and
                  > > > > > getting the 1 down from max resolution displays on laptops is actually
                  > > > > > cheaper anyway, it's a win-win thing for me.
                  > > > > >
                  > > > > > Rob
                  > > > > >
                  > > > >
                  > > > > --
                  > > > > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                  > > > >
                  > > > >
                  > > > > --------------------------------------------------------------
                  > > > > Please post your X config files in the group links or database
                  > > > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                  > > > > FAQ: http://www.whacked.net/ldl/faq
                  > > > >
                  > > > > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                  > > > >
                  > > > >
                  > > >
                  > > >
                  > >
                  > > --
                  > > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                  > >
                  > >
                  > > --------------------------------------------------------------
                  > > Please post your X config files in the group links or database
                  > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                  > > FAQ: http://www.whacked.net/ldl/faq
                  > >
                  > > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                  > >
                  > >
                  >
                  >



                  --
                  stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                • Steve Baldwin
                  Thanks for going to all this trouble. However, I have a couple of questions ... Did you get any errors when you did the make install . I had 2 problems - one
                  Message 8 of 17 , Mar 2, 2002
                  • 0 Attachment
                    Thanks for going to all this trouble.  However, I have a couple of questions ...

                    Did you get any errors when you did the 'make install'.  I had 2 problems - one I solved and one I havent yet.  The first was that it couldn't find capplet-widget.h when making gdkxft-capplet.  I created a symlink from the copy in /usr/include/libcapplet1 to /usr/include.  Now I get the following error ...

                    make[1]: Entering directory `/home/steve/Downloads/gdkxft-1.5/capplet'
                    /bin/sh ../libtool --mode=link gcc  -g -O2 -L/usr/lib -L/usr/X11R6/lib -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -o gdkxft-capplet  gdkxft-capplet.o gdkxftcfg.o -rdynamic -L/usr/lib -L/usr/X11R6/lib -rdynamic -lcapplet -lgnomeui -lart_lgpl
                    -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -ldb1 -lORBit -lIIOP -lORBitutil -lglib -lnsl -lm -lgnorba -L/usr/lib -lglade-gnome -lglade -L/usr/lib -lxml -lz -rdynamic -L/usr/lib -L/usr/X11R6/lib -rdynamic -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -lm -ldb1 -lglib -ldl -lXft
                    libtool: link: cannot find the library `/usr/lib/libaudiofile.la'
                    make[1]: *** [gdkxft-capplet] Error 1
                    make[1]: Leaving directory `/home/steve/Downloads/gdkxft-1.5/capplet'
                    make: *** [install-recursive] Error 1

                    I don't know where it's getting libaudiofile.la from.  In /usr/lib, there are the files libaudiofile.a, and libaudiofile.so.  I checked the makefile, and I can see '-laudiofile', but nothing about a '.la' suffix.  Any ideas ??

                    Anyway, then I thought I'd grab the M$ fonts.  They are all in self installing .exe format.  How did you extract the .ttfs out of them ?

                    I'd also appreciate you posting your XftConfig and .gdkxft files if you don't mind.

                    Thanks.

                    Stephen Lau wrote:
                    That's the whole point...you will have BIG fonts with the 100dpi fonts -
                    you just need to go into your window manager preferences bring the font
                    sizes back down to a smaller size... they will have more resolution than
                    the 75dpi fonts.

                    -steve

                    On Sat, Mar 02, 2002 at 01:34:17PM -0400, Victor Manuel Hernandez Maksimenko wrote:
                    Could you please post them?, i'm currently using gdkxft (+mozilla
                    gdkxft) and im very happy with the results. But im using 75dpi fonts,
                    when i modified the /etc/X11/fs/config to use 100dpi, im getting fonts
                    too big.

                    Also what dpi reports X that your LCD have?, when i run 'xdpyinfo | grep
                    resolution' it reports 75x75 dots per inchs. And when i add the line
                    'DisplaySize 305 230' to the XF86Config-4, then it reports 133x133 dots
                    per inch, but im back with the BIG fonts.

                    thanks!


                    On Sat, 2002-03-02 at 05:54, Stephen Lau wrote:
                    I'm running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important
                    later)

                    go to http://gdkxft.sourceforge.net, click on the download link at the
                    bottom and download gdkxft-1.5.tar.gz

                    ./configure --prefix=/usr
                    make

                    then become root
                    make install
                    gdkxft_sysinstall

                    exit Xwindows
                    edit either your .bashrc, .bash_profile, or the systemwide equivalents and
                    add:
                    export LD_PRELOAD="/usr/lib/libgdkxft.so.0"

                    logout, log back in
                    put all your truetype fonts in one dir
                    run 'ttmkfdir' to generate the fonts.dir in that dir
                    add the directory to your /etc/X11/fs/config (put it first, ahead of all
                    other dirs)
                    if you haven't changed the default-resolutions line to be 100,100,75,75
                    instead of 75,75,100,100 - do it while you're here. :) it'll bump you up to
                    100dpi fonts. also make sure the /usr/X11R6/lib/X11/fonts/100dpi l ine is
                    ahead of the 75dpi path.

                    edit /etc/X11/XftConfig and make sure it's sane, i.e.: map your font
                    families properly. for instance, I like all of Microsoft's Core Fonts, so
                    I use Arial as my sans font and map Helvetica to it. I use "Times New
                    Roman" as my times font, "Courier New" as my courier font, and "Andale
                    Mono" as my mono font.

                    restart XFS by doing '/etc/init.d/xfs restart'
                    generate your ~/.gdkxft file, if you want to anti-alias certain fonts, etc.
                    it'll look like:

                    # turn off anti-aliasing for all fonts
                    !*
                    # turn them on one at a time
                    -arial-*
                    -courier new-*
                    -times new roman-*
                    # bad applications - don't anti-alias them
                    &gkrellm

                    NOW, you can finally start up X. so go start it up and you should see
                    anti-aliased fonts. one of the best parts of AA fonts is for web-browsing,
                    so you want to make sure Mozilla supports it. If you're running Ximian,
                    the mozilla packages are already compiled to support it - you just need to
                    add another export line like we did earlier, except this time:
                    export MOZILLA_USE_GDKXFT=1
                    do the routine: log out of X, logout console/login, start x
                    now Mozilla (and hence, galeon) should have AA fonts.
                    if you're running your own version of Mozilla, you can apply the binary
                    patch found here:
                    http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-0.9.8.i386.tar.gz
                    or apply the source patch to the source tree found here:
                    http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-patch-0.9.8.diff

                    there... it seems like a daunting process, and it took me about half an
                    hour to get it working my first time, but it only took me about 5-10
                    minutes for each machine i've done it on since then. I've only installed
                    it on Red Hat 7.1 & 7.2 machines...but it's gorgeous. everyone i've
                    installed it for agrees its awesome.

                    i'd be happy to post my XftConfig, and .gdkxft files if people care to. if
                    you want the Microsoft Truetype Core Fonts, go here:
                    http://www.microsoft.com/typography/fontpack/default.htm

                    cheers,
                    steve



                    On Sat, Mar 02, 2002 at 08:22:45PM +1100, Steve Baldwin wrote:
                    Can you please explain what you did, where you got gdkxft, and how you
                    got it all set up.

                    Thx

                    On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:
                    Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
                    size on a 14.1" 1600x1200 UXGA i4100), but then once I started
                    anti-aliasing them with gdkxft, it looked sooooooooooooo much better.

                    -steve

                    On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W. Current wrote:
                    => From: Adam Lowry [mailto:aclowry@...] 
                    => I know it's not a trivial thing, in my opinion getting a
                    => lower resolution because fonts are too small isn't the best
                    => way to handle it. Maybe using larger fonts?

                    Ah... Well... No.

                    Small fonts are the problem, but it's not that simple. There are a lot
                    of things I use that don't have scalable fonts (icons, some apps have
                    fixed fonts in the menus, and are all menu based, like VAG-COM and all
                    the software my company makes, control software, stuff with JUST
                    buttons, not like web browsers or word processors).

                    So, the solution is to have the ABILITY to have high resolution
                    displays, but just run at a lower resolution... Problem is, I tried
                    that.

                    My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
                    it was run at max resolution. Everything was fuzzy. I called dell,
                    emailed, and did all kinds of research. If you search through the dell
                    support message forum, you will see a LOT of people complain about this.
                    Dell has only 1 answer "our displays are only designed to be clear at
                    the 'optimum' resolution, if it's within 30 days of your purchase, you
                    may exchange it" which is their way of admitting it sucks at lower
                    resolution.

                    So...

                    I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
                    happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
                    at home up to 1800 x 1440 without any complaints).

                    Again, this is only MY opinion. And since it makes me happy, and
                    getting the 1 down from max resolution displays on laptops is actually
                    cheaper anyway, it's a win-win thing for me.

                    Rob

                    -- 
                    stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21


                    --------------------------------------------------------------
                    Please post your X config files in the group links or database
                    To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                    FAQ: http://www.whacked.net/ldl/faq

                    Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/



                    -- 
                    stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21


                    --------------------------------------------------------------
                    Please post your X config files in the group links or database
                    To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                    FAQ: http://www.whacked.net/ldl/faq

                    Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/







                  • Stephen Lau
                    Hrm...I have a /usr/lib/libaudiofile.la, It s a text file - I ll post it here: =============snip # libaudiofile.la - a libtool library file # Generated by
                    Message 9 of 17 , Mar 2, 2002
                    • 0 Attachment
                      Hrm...I have a /usr/lib/libaudiofile.la, It's a text file - I'll post it
                      here:

                      =============snip
                      # libaudiofile.la - a libtool library file
                      # Generated by ltmain.sh - GNU libtool 1.3.4 (1.385.2.196 1999/12/07 21:47:57)
                      #
                      # Please DO NOT delete this file!
                      # It is necessary for linking the library.

                      # The name that we can dlopen(3).
                      dlname=''

                      # Names of this library.
                      library_names='libaudiofile.so.0.0.1 libaudiofile.so.0 libaudiofile.so'

                      # The name of the static archive.
                      old_library='libaudiofile.a'

                      # Libraries that this one depends upon.
                      dependency_libs=' -lm -lm'

                      # Version information for libaudiofile.
                      current=0
                      age=0
                      revision=1

                      # Is this an already installed library?
                      installed=yes

                      # Directory that this library needs to be installed in:
                      libdir='/usr/lib'
                      =================snip

                      yeah, I had to boot up my vmware windows 2000 machine and extract the
                      fonts and then bring them back into linux. :)

                      you can find my config stuff at http://www.whacked.net/ldl/aa-fonts.tar.gz
                      if you don't have windows, let me know and I'll tar up the fonts & the
                      fonts.dir file generated and put them on the web.

                      -steve

                      On Sun, Mar 03, 2002 at 12:17:46PM +1100, Steve Baldwin wrote:
                      >
                      > Thanks for going to all this trouble. However, I have a couple of
                      > questions ...
                      > Did you get any errors when you did the 'make install'. I had 2
                      > problems - one I solved and one I havent yet. The first was that it
                      > couldn't find capplet-widget.h when making gdkxft-capplet. I created
                      > a symlink from the copy in /usr/include/libcapplet1 to /usr/include.
                      > Now I get the following error ...
                      > make[1]: Entering directory `/home/steve/Downloads/gdkxft-1.5/capplet'
                      > /bin/sh ../libtool --mode=link gcc -g -O2 -L/usr/lib -L/usr/X11R6/lib
                      > -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -o
                      > gdkxft-capplet gdkxft-capplet.o gdkxftcfg.o -rdynamic -L/usr/lib
                      > -L/usr/X11R6/lib -rdynamic -lcapplet -lgnomeui -lart_lgpl
                      > -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl -lXi -lXext -lX11
                      > -lgnome -lgnomesupport -lesd -laudiofile -ldb1 -lORBit -lIIOP
                      > -lORBitutil -lglib -lnsl -lm -lgnorba -L/usr/lib -lglade-gnome -lglade
                      > -L/usr/lib -lxml -lz -rdynamic -L/usr/lib -L/usr/X11R6/lib -rdynamic
                      > -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl
                      > -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -lm -ldb1
                      > -lglib -ldl -lXft
                      > libtool: link: cannot find the library `/usr/lib/libaudiofile.la'
                      > make[1]: *** [gdkxft-capplet] Error 1
                      > make[1]: Leaving directory `/home/steve/Downloads/gdkxft-1.5/capplet'
                      > make: *** [install-recursive] Error 1
                      > I don't know where it's getting libaudiofile.la from. In /usr/lib,
                      > there are the files libaudiofile.a, and libaudiofile.so. I checked
                      > the makefile, and I can see '-laudiofile', but nothing about a '.la'
                      > suffix. Any ideas ??
                      > Anyway, then I thought I'd grab the M$ fonts. They are all in self
                      > installing .exe format. How did you extract the .ttfs out of them ?
                      > I'd also appreciate you posting your XftConfig and .gdkxft files if
                      > you don't mind.
                      > Thanks.
                      > Stephen Lau wrote:
                      >
                      > That's the whole point...you will have BIG fonts with the 100dpi fonts -
                      > you just need to go into your window manager preferences bring the font
                      > sizes back down to a smaller size... they will have more resolution than
                      > the 75dpi fonts.
                      > -steve
                      > On Sat, Mar 02, 2002 at 01:34:17PM -0400, Victor Manuel Hernandez Maksimenko wr
                      > ote:
                      >
                      > Could you please post them?, i'm currently using gdkxft (+mozilla
                      > gdkxft) and im very happy with the results. But im using 75dpi fonts,
                      > when i modified the /etc/X11/fs/config to use 100dpi, im getting fonts
                      > too big.
                      > Also what dpi reports X that your LCD have?, when i run 'xdpyinfo | grep
                      > resolution' it reports 75x75 dots per inchs. And when i add the line
                      > 'DisplaySize 305 230' to the XF86Config-4, then it reports 133x133 dots
                      > per inch, but im back with the BIG fonts.
                      > thanks!
                      > On Sat, 2002-03-02 at 05:54, Stephen Lau wrote:
                      >
                      > I'm running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important
                      > later)
                      > go to http://gdkxft.sourceforge.net, click on the download link at the
                      > bottom and download gdkxft-1.5.tar.gz
                      > ./configure --prefix=/usr
                      > make
                      > then become root
                      > make install
                      > gdkxft_sysinstall
                      > exit Xwindows
                      > edit either your .bashrc, .bash_profile, or the systemwide equivalents and
                      > add:
                      > export LD_PRELOAD="/usr/lib/libgdkxft.so.0"
                      > logout, log back in
                      > put all your truetype fonts in one dir
                      > run 'ttmkfdir' to generate the fonts.dir in that dir
                      > add the directory to your /etc/X11/fs/config (put it first, ahead of all
                      > other dirs)
                      > if you haven't changed the default-resolutions line to be 100,100,75,75
                      > instead of 75,75,100,100 - do it while you're here. :) it'll bump you up to
                      > 100dpi fonts. also make sure the /usr/X11R6/lib/X11/fonts/100dpi l
                      > ine is
                      > ahead of the 75dpi path.
                      > edit /etc/X11/XftConfig and make sure it's sane, i.e.: map your font
                      > families properly. for instance, I like all of Microsoft's Core Fonts, so
                      > I use Arial as my sans font and map Helvetica to it. I use "Times New
                      > Roman" as my times font, "Courier New" as my courier font, and "Andale
                      > Mono" as my mono font.
                      > restart XFS by doing '/etc/init.d/xfs restart'
                      > generate your ~/.gdkxft file, if you want to anti-alias certain fonts, etc.
                      > it'll look like:
                      > # turn off anti-aliasing for all fonts
                      > !*
                      > # turn them on one at a time
                      > -arial-*
                      > -courier new-*
                      > -times new roman-*
                      > # bad applications - don't anti-alias them
                      > &gkrellm
                      > NOW, you can finally start up X. so go start it up and you should see
                      > anti-aliased fonts. one of the best parts of AA fonts is for web-browsing,
                      > so you want to make sure Mozilla supports it. If you're running Ximian,
                      > the mozilla packages are already compiled
                      > to support it - you just need to
                      > add another export line like we did earlier, except this time:
                      > export MOZILLA_USE_GDKXFT=1
                      > do the routine: log out of X, logout console/login, start x
                      > now Mozilla (and hence, galeon) should have AA fonts.
                      > if you're running your own version of Mozilla, you can apply the binary
                      > patch found here:
                      > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-0.9.8.i386.tar.gz
                      > or apply the source patch to the source tree found here:
                      > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-patch-0.9.8.diff
                      > there... it seems like a daunting process, and it took me about half an
                      > hour to get it working my first time, but it only took me about 5-10
                      > minutes for each machine i've done it
                      > on since then. I've only installed
                      > it on Red Hat 7.1 & 7.2 machines...but it's gorgeous. everyone i've
                      > installed it for agrees its awesome.
                      > i'd be happy to post my XftConfig, and .gdkxft files if people care to. if
                      > you want the Microsoft Truetype Core Fonts, go here:
                      > http://www.microsoft.com/typography/fontpack/default.htm
                      > cheers,
                      > steve
                      > On Sat, Mar 02, 2002 at 08:22:45PM +1100, Steve Baldwin wrote:
                      >
                      > Can you please explain what you did, where you got gdkxft, and how you
                      > got it all set up.
                      > Thx
                      > On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:
                      >
                      > Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
                      > size on a 14.1" 1600x1200 UXGA i4100), but then once I started
                      > anti-aliasing them with gdkxft, it looked sooooooooooooo much better.
                      > -steve
                      > On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W. Current wrote:
                      >
                      > => From: Adam Lowry [mailto:aclowry@...]
                      > => I know it's not a trivial thing, in my opinion getting a
                      > => lower resolution because fonts are too small isn't the best
                      > => way to handle it. Maybe using larger fonts?
                      > Ah... Well... No.
                      > Small fonts are the problem, but it's not that simple. There are a lot
                      > of things I use that don't have scalable fonts (icons, some apps have
                      > fixed fonts in the menus, and are all menu based, like VAG-COM and all
                      > the software my company makes, control software, stuff with JUST
                      > buttons, not like web browsers or word processors).
                      > So, the solution is to have the ABILITY to have high resolution
                      > displays, but just run at a lower resolution... Problem is, I tried
                      > that.
                      > My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
                      > it was run at max resolution. Everything was fuzzy.
                      > I called dell,
                      > emailed, and did all kinds of research. If you search through the dell
                      > support message forum, you will see a LOT of people complain about this.
                      > Dell has only 1 answer "our displays are only designed to be clear at
                      > the 'optimum' resolution, if it's within 30 days of your purchase, you
                      > may exchange it" which is their way of admitting it sucks at lower
                      > resolution.
                      > So...
                      > I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
                      > happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
                      > at home up to 1800 x 1440 without any complaints).
                      > Again, this is only MY opinion. And since it makes me happy, and
                      > getting the 1 down from max resolution displays on laptops is actually
                      > cheaper anyway, it's a win-win thing for me.
                      > Rob
                      >
                      > --
                      > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                      > --------------------------------------------------------------
                      > Please post your X config files in the group links or database
                      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                      > FAQ: http://www.whacked.net/ldl/faq
                      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                      >
                      > --
                      > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                      > --------------------------------------------------------------
                      > Please post your X config files in the group links or database
                      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                      > FAQ: http://www.whacked.net/ldl/faq
                      > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                      >
                      > Yahoo! Groups Sponsor
                      > ADVERTISEMENT
                      >
                      > --------------------------------------------------------------
                      > Please post your X config files in the group links or database
                      > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                      > FAQ: http://www.whacked.net/ldl/faq
                      > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

                      --
                      stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                    • Victor Manuel Hernandez Maksimenko
                      Hi there, did u run ./configure --prefix=/usr before trying to make ? it seems weird that libtool is linking to a missing file... i have audiofile-0.2.3
                      Message 10 of 17 , Mar 2, 2002
                      • 0 Attachment
                        Hi there,

                        did u run './configure --prefix=/usr' before trying to 'make' ?
                        it seems weird that libtool is linking to a missing file...
                        i have audiofile-0.2.3 installed and had no problems.

                        for grabbing the m$ fonts try this utils it will grab the fonts, and
                        extract them
                        http://rhcontrib.bero.org/RPMS/i386/xf86ttfontool-0.1-6.i386.rpm




                        On Sat, 2002-03-02 at 21:17, Steve Baldwin wrote: Thanks for going to
                        all this trouble. However, I have a couple of questions ...

                        Did you get any errors when you did the 'make install'. I had 2
                        problems - one I solved and one I havent yet. The first was that it
                        couldn't find capplet-widget.h when making gdkxft-capplet. I created a
                        symlink from the copy in /usr/include/libcapplet1 to /usr/include. Now
                        I get the following error ...

                        make[1]: Entering directory `/home/steve/Downloads/gdkxft-1.5/capplet'
                        /bin/sh ../libtool --mode=link gcc -g -O2 -L/usr/lib -L/usr/X11R6/lib
                        -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -o
                        gdkxft-capplet gdkxft-capplet.o gdkxftcfg.o -rdynamic -L/usr/lib
                        -L/usr/X11R6/lib -rdynamic -lcapplet -lgnomeui -lart_lgpl
                        -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl -lXi -lXext -lX11
                        -lgnome -lgnomesupport -lesd -laudiofile -ldb1 -lORBit -lIIOP
                        -lORBitutil -lglib -lnsl -lm -lgnorba -L/usr/lib -lglade-gnome -lglade
                        -L/usr/lib -lxml -lz -rdynamic -L/usr/lib -L/usr/X11R6/lib -rdynamic
                        -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl
                        -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -lm -ldb1
                        -lglib -ldl -lXft
                        libtool: link: cannot find the library `/usr/lib/libaudiofile.la'
                        make[1]: *** [gdkxft-capplet] Error 1
                        make[1]: Leaving directory `/home/steve/Downloads/gdkxft-1.5/capplet'
                        make: *** [install-recursive] Error 1

                        I don't know where it's getting libaudiofile.la from. In /usr/lib,
                        there are the files libaudiofile.a, and libaudiofile.so. I checked the
                        makefile, and I can see '-laudiofile', but nothing about a '.la' suffix.
                        Any ideas ??

                        Anyway, then I thought I'd grab the M$ fonts. They are all in self
                        installing .exe format. How did you extract the .ttfs out of them ?

                        I'd also appreciate you posting your XftConfig and .gdkxft files if you
                        don't mind.

                        Thanks.

                        Stephen Lau wrote:

                        That's the whole point...you will have BIG fonts with the 100dpi fonts -
                        you just need to go into your window manager preferences bring the font
                        sizes back down to a smaller size... they will have more resolution than
                        the 75dpi fonts.

                        -steve

                        On Sat, Mar 02, 2002 at 01:34:17PM -0400, Victor Manuel Hernandez Maksimenko wrote:

                        Could you please post them?, i'm currently using gdkxft (+mozilla
                        gdkxft) and im very happy with the results. But im using 75dpi fonts,
                        when i modified the /etc/X11/fs/config to use 100dpi, im getting fonts
                        too big.

                        Also what dpi reports X that your LCD have?, when i run 'xdpyinfo | grep
                        resolution' it reports 75x75 dots per inchs. And when i add the line
                        'DisplaySize 305 230' to the XF86Config-4, then it reports 133x133 dots
                        per inch, but im back with the BIG fonts.

                        thanks!


                        On Sat, 2002-03-02 at 05:54, Stephen Lau wrote:

                        I'm running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important
                        later)

                        go to http://gdkxft.sourceforge.net, click on the download link at the
                        bottom and download gdkxft-1.5.tar.gz

                        ./configure --prefix=/usr
                        make

                        then become root
                        make install
                        gdkxft_sysinstall

                        exit Xwindows
                        edit either your .bashrc, .bash_profile, or the systemwide equivalents and
                        add:
                        export LD_PRELOAD="/usr/lib/libgdkxft.so.0"

                        logout, log back in
                        put all your truetype fonts in one dir
                        run 'ttmkfdir' to generate the fonts.dir in that dir
                        add the directory to your /etc/X11/fs/config (put it first, ahead of all
                        other dirs)
                        if you haven't changed the default-resolutions line to be 100,100,75,75
                        instead of 75,75,100,100 - do it while you're here. :) it'll bump you up to
                        100dpi fonts. also make sure the /usr/X11R6/lib/X11/fonts/100dpi l
                        ine is
                        ahead of the 75dpi path.

                        edit /etc/X11/XftConfig and make sure it's sane, i.e.: map your font
                        families properly. for instance, I like all of Microsoft's Core Fonts, so
                        I use Arial as my sans font and map Helvetica to it. I use "Times New
                        Roman" as my times font, "Courier New" as my courier font, and "Andale
                        Mono" as my mono font.

                        restart XFS by doing '/etc/init.d/xfs restart'
                        generate your ~/.gdkxft file, if you want to anti-alias certain fonts, etc.
                        it'll look like:

                        # turn off anti-aliasing for all fonts
                        !*
                        # turn them on one at a time
                        -arial-*
                        -courier new-*
                        -times new roman-*
                        # bad applications - don't anti-alias them
                        &gkrellm

                        NOW, you can finally start up X. so go start it up and you should see
                        anti-aliased fonts. one of the best parts of AA fonts is for web-browsing,
                        so you want to make sure Mozilla supports it. If you're running Ximian,
                        the mozilla packages are already compiled
                        to support it - you just need to
                        add another export line like we did earlier, except this time:
                        export MOZILLA_USE_GDKXFT=1
                        do the routine: log out of X, logout console/login, start x
                        now Mozilla (and hence, galeon) should have AA fonts.
                        if you're running your own version of Mozilla, you can apply the binary
                        patch found here:
                        http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-0.9.8.i386.tar.gz
                        or apply the source patch to the source tree found here:
                        http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-patch-0.9.8.diff

                        there... it seems like a daunting process, and it took me about half an
                        hour to get it working my first time, but it only took me about 5-10
                        minutes for each machine i've done it
                        on since then. I've only installed
                        it on Red Hat 7.1 & 7.2 machines...but it's gorgeous. everyone i've
                        installed it for agrees its awesome.

                        i'd be happy to post my XftConfig, and .gdkxft files if people care to. if
                        you want the Microsoft Truetype Core Fonts, go here:
                        http://www.microsoft.com/typography/fontpack/default.htm

                        cheers,
                        steve



                        On Sat, Mar 02, 2002 at 08:22:45PM +1100, Steve Baldwin wrote:

                        Can you please explain what you did, where you got gdkxft, and how you
                        got it all set up.

                        Thx

                        On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:

                        Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
                        size on a 14.1" 1600x1200 UXGA i4100), but then once I started
                        anti-aliasing them with gdkxft, it looked sooooooooooooo much better.

                        -steve

                        On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W. Current wrote:

                        => From: Adam Lowry [mailto:aclowry@...]
                        => I know it's not a trivial thing, in my opinion getting a
                        => lower resolution because fonts are too small isn't the best
                        => way to handle it. Maybe using larger fonts?

                        Ah... Well... No.

                        Small fonts are the problem, but it's not that simple. There are a lot
                        of things I use that don't have scalable fonts (icons, some apps have
                        fixed fonts in the menus, and are all menu based, like VAG-COM and all
                        the software my company makes, control software, stuff with JUST
                        buttons, not like web browsers or word processors).

                        So, the solution is to have the ABILITY to have high resolution
                        displays, but just run at a lower resolution... Problem is, I tried
                        that.

                        My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
                        it was run at max resolution. Everything was fuzzy.
                        I called dell,
                        emailed, and did all kinds of research. If you search through the dell
                        support message forum, you will see a LOT of people complain about this.
                        Dell has only 1 answer "our displays are only designed to be clear at
                        the 'optimum' resolution, if it's within 30 days of your purchase, you
                        may exchange it" which is their way of admitting it sucks at lower
                        resolution.

                        So...

                        I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
                        happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
                        at home up to 1800 x 1440 without any complaints).

                        Again, this is only MY opinion. And since it makes me happy, and
                        getting the 1 down from max resolution displays on laptops is actually
                        cheaper anyway, it's a win-win thing for me.

                        Rob


                        --
                        stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21


                        --------------------------------------------------------------
                        Please post your X config files in the group links or database
                        To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                        FAQ: http://www.whacked.net/ldl/faq

                        Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/




                        --
                        stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21


                        --------------------------------------------------------------
                        Please post your X config files in the group links or database
                        To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                        FAQ: http://www.whacked.net/ldl/faq

                        Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/









                        Yahoo! Groups Sponsor
                        ADVERTISEMENT


                        --------------------------------------------------------------
                        Please post your X config files in the group links or database
                        To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                        FAQ: http://www.whacked.net/ldl/faq

                        Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
                      • Victor Manuel Hernandez Maksimenko
                        well, now i setup lucidux sans - 7 points with 100dpi and its looking gorgeous :). the only problem that i m having is with gaim, that seems to override that
                        Message 11 of 17 , Mar 2, 2002
                        • 0 Attachment
                          well, now i setup 'lucidux sans - 7 points' with 100dpi and its looking
                          gorgeous :). the only problem that i'm having is with gaim, that seems
                          to override that setting and put the default font for the crux theme,
                          which seems huge :(... but after manually logging off and on on gaim
                          correct that problem.

                          where i could find info on configuring the XftConfig file?, i tried 'man
                          XftConfig', 'info XftConfig', but had no luck.

                          On Sat, 2002-03-02 at 15:34, Stephen Lau wrote:
                          > That's the whole point...you will have BIG fonts with the 100dpi fonts -
                          > you just need to go into your window manager preferences bring the font
                          > sizes back down to a smaller size... they will have more resolution than
                          > the 75dpi fonts.
                          >
                          > -steve
                          >
                          > On Sat, Mar 02, 2002 at 01:34:17PM -0400, Victor Manuel Hernandez Maksimenko wrote:
                          > > Could you please post them?, i'm currently using gdkxft (+mozilla
                          > > gdkxft) and im very happy with the results. But im using 75dpi fonts,
                          > > when i modified the /etc/X11/fs/config to use 100dpi, im getting fonts
                          > > too big.
                          > >
                          > > Also what dpi reports X that your LCD have?, when i run 'xdpyinfo | grep
                          > > resolution' it reports 75x75 dots per inchs. And when i add the line
                          > > 'DisplaySize 305 230' to the XF86Config-4, then it reports 133x133 dots
                          > > per inch, but im back with the BIG fonts.
                          > >
                          > > thanks!
                          > >
                          > >
                          > > On Sat, 2002-03-02 at 05:54, Stephen Lau wrote:
                          > > > I'm running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important
                          > > > later)
                          > > >
                          > > > go to http://gdkxft.sourceforge.net, click on the download link at the
                          > > > bottom and download gdkxft-1.5.tar.gz
                          > > >
                          > > > ./configure --prefix=/usr
                          > > > make
                          > > >
                          > > > then become root
                          > > > make install
                          > > > gdkxft_sysinstall
                          > > >
                          > > > exit Xwindows
                          > > > edit either your .bashrc, .bash_profile, or the systemwide equivalents and
                          > > > add:
                          > > > export LD_PRELOAD="/usr/lib/libgdkxft.so.0"
                          > > >
                          > > > logout, log back in
                          > > > put all your truetype fonts in one dir
                          > > > run 'ttmkfdir' to generate the fonts.dir in that dir
                          > > > add the directory to your /etc/X11/fs/config (put it first, ahead of all
                          > > > other dirs)
                          > > > if you haven't changed the default-resolutions line to be 100,100,75,75
                          > > > instead of 75,75,100,100 - do it while you're here. :) it'll bump you up to
                          > > > 100dpi fonts. also make sure the /usr/X11R6/lib/X11/fonts/100dpi line is
                          > > > ahead of the 75dpi path.
                          > > >
                          > > > edit /etc/X11/XftConfig and make sure it's sane, i.e.: map your font
                          > > > families properly. for instance, I like all of Microsoft's Core Fonts, so
                          > > > I use Arial as my sans font and map Helvetica to it. I use "Times New
                          > > > Roman" as my times font, "Courier New" as my courier font, and "Andale
                          > > > Mono" as my mono font.
                          > > >
                          > > > restart XFS by doing '/etc/init.d/xfs restart'
                          > > > generate your ~/.gdkxft file, if you want to anti-alias certain fonts, etc.
                          > > > it'll look like:
                          > > >
                          > > > # turn off anti-aliasing for all fonts
                          > > > !*
                          > > > # turn them on one at a time
                          > > > -arial-*
                          > > > -courier new-*
                          > > > -times new roman-*
                          > > > # bad applications - don't anti-alias them
                          > > > &gkrellm
                          > > >
                          > > > NOW, you can finally start up X. so go start it up and you should see
                          > > > anti-aliased fonts. one of the best parts of AA fonts is for web-browsing,
                          > > > so you want to make sure Mozilla supports it. If you're running Ximian,
                          > > > the mozilla packages are already compiled to support it - you just need to
                          > > > add another export line like we did earlier, except this time:
                          > > > export MOZILLA_USE_GDKXFT=1
                          > > > do the routine: log out of X, logout console/login, start x
                          > > > now Mozilla (and hence, galeon) should have AA fonts.
                          > > > if you're running your own version of Mozilla, you can apply the binary
                          > > > patch found here:
                          > > > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-0.9.8.i386.tar.gz
                          > > > or apply the source patch to the source tree found here:
                          > > > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-patch-0.9.8.diff
                          > > >
                          > > > there... it seems like a daunting process, and it took me about half an
                          > > > hour to get it working my first time, but it only took me about 5-10
                          > > > minutes for each machine i've done it on since then. I've only installed
                          > > > it on Red Hat 7.1 & 7.2 machines...but it's gorgeous. everyone i've
                          > > > installed it for agrees its awesome.
                          > > >
                          > > > i'd be happy to post my XftConfig, and .gdkxft files if people care to. if
                          > > > you want the Microsoft Truetype Core Fonts, go here:
                          > > > http://www.microsoft.com/typography/fontpack/default.htm
                          > > >
                          > > > cheers,
                          > > > steve
                          > > >
                          > > >
                          > > >
                          > > > On Sat, Mar 02, 2002 at 08:22:45PM +1100, Steve Baldwin wrote:
                          > > > > Can you please explain what you did, where you got gdkxft, and how you
                          > > > > got it all set up.
                          > > > >
                          > > > > Thx
                          > > > >
                          > > > > On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:
                          > > > > > Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
                          > > > > > size on a 14.1" 1600x1200 UXGA i4100), but then once I started
                          > > > > > anti-aliasing them with gdkxft, it looked sooooooooooooo much better.
                          > > > > >
                          > > > > > -steve
                          > > > > >
                          > > > > > On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W. Current wrote:
                          > > > > > > => From: Adam Lowry [mailto:aclowry@...]
                          > > > > > > => I know it's not a trivial thing, in my opinion getting a
                          > > > > > > => lower resolution because fonts are too small isn't the best
                          > > > > > > => way to handle it. Maybe using larger fonts?
                          > > > > > >
                          > > > > > > Ah... Well... No.
                          > > > > > >
                          > > > > > > Small fonts are the problem, but it's not that simple. There are a lot
                          > > > > > > of things I use that don't have scalable fonts (icons, some apps have
                          > > > > > > fixed fonts in the menus, and are all menu based, like VAG-COM and all
                          > > > > > > the software my company makes, control software, stuff with JUST
                          > > > > > > buttons, not like web browsers or word processors).
                          > > > > > >
                          > > > > > > So, the solution is to have the ABILITY to have high resolution
                          > > > > > > displays, but just run at a lower resolution... Problem is, I tried
                          > > > > > > that.
                          > > > > > >
                          > > > > > > My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
                          > > > > > > it was run at max resolution. Everything was fuzzy. I called dell,
                          > > > > > > emailed, and did all kinds of research. If you search through the dell
                          > > > > > > support message forum, you will see a LOT of people complain about this.
                          > > > > > > Dell has only 1 answer "our displays are only designed to be clear at
                          > > > > > > the 'optimum' resolution, if it's within 30 days of your purchase, you
                          > > > > > > may exchange it" which is their way of admitting it sucks at lower
                          > > > > > > resolution.
                          > > > > > >
                          > > > > > > So...
                          > > > > > >
                          > > > > > > I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
                          > > > > > > happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
                          > > > > > > at home up to 1800 x 1440 without any complaints).
                          > > > > > >
                          > > > > > > Again, this is only MY opinion. And since it makes me happy, and
                          > > > > > > getting the 1 down from max resolution displays on laptops is actually
                          > > > > > > cheaper anyway, it's a win-win thing for me.
                          > > > > > >
                          > > > > > > Rob
                          > > > > > >
                          > > > > >
                          > > > > > --
                          > > > > > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                          > > > > >
                          > > > > >
                          > > > > > --------------------------------------------------------------
                          > > > > > Please post your X config files in the group links or database
                          > > > > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                          > > > > > FAQ: http://www.whacked.net/ldl/faq
                          > > > > >
                          > > > > > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                          > > > > >
                          > > > > >
                          > > > >
                          > > > >
                          > > >
                          > > > --
                          > > > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                          > > >
                          > > >
                          > > > --------------------------------------------------------------
                          > > > Please post your X config files in the group links or database
                          > > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                          > > > FAQ: http://www.whacked.net/ldl/faq
                          > > >
                          > > > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                          > > >
                          > > >
                          > >
                          > >
                          >
                          >
                          >
                          > --
                          > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                          >
                          >
                          > --------------------------------------------------------------
                          > Please post your X config files in the group links or database
                          > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                          > FAQ: http://www.whacked.net/ldl/faq
                          >
                          > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                          >
                          >
                        • Steve Baldwin
                          Thanks mate, that fixed my linking problem. Wonder where that file was supposed to come from ??? I actually don t have windows, so I would very much appreciate
                          Message 12 of 17 , Mar 2, 2002
                          • 0 Attachment
                            Thanks mate, that fixed my linking problem.  Wonder where that file was supposed to come from ???

                            I actually don't have windows, so I would very much appreciate it if you could tar them up and put them up on the web.

                            Cheers,

                            Steve

                            Stephen Lau wrote:
                            Hrm...I have a /usr/lib/libaudiofile.la, It's a text file - I'll post it
                            here:

                            =============snip
                            # libaudiofile.la - a libtool library file
                            # Generated by ltmain.sh - GNU libtool 1.3.4 (1.385.2.196 1999/12/07 21:47:57)
                            #
                            # Please DO NOT delete this file!
                            # It is necessary for linking the library.

                            # The name that we can dlopen(3).
                            dlname=''

                            # Names of this library.
                            library_names='libaudiofile.so.0.0.1 libaudiofile.so.0 libaudiofile.so'

                            # The name of the static archive.
                            old_library='libaudiofile.a'

                            # Libraries that this one depends upon.
                            dependency_libs=' -lm -lm'

                            # Version information for libaudiofile.
                            current=0
                            age=0
                            revision=1

                            # Is this an already installed library?
                            installed=yes

                            # Directory that this library needs to be installed in:
                            libdir='/usr/lib'
                            =================snip

                            yeah, I had to boot up my vmware windows 2000 machine and extract the
                            font s and then bring them back into linux. :)

                            you can find my config stuff at http://www.whacked.net/ldl/aa-fonts.tar.gz
                            if you don't have windows, let me know and I'll tar up the fonts & the
                            fonts.dir file generated and put them on the web.

                            -steve

                            On Sun, Mar 03, 2002 at 12:17:46PM +1100, Steve Baldwin wrote:
                               Thanks  for  going  to  all this trouble.  However, I have a couple of
                            questions ...
                            Did you get any errors when you did the 'make install'. I had 2
                            problems - one I solved and one I havent yet. The first was that it
                            couldn't find capplet-widget.h when making gdkxft-capplet. I created
                            a symlink from the copy in /usr/include/libcapplet1 to /usr/include.
                            Now I get the following error ...
                            make[1]: Entering directory `/home/steve/Downloads/gdkxft-1.5/capplet'
                            /bin/sh ../libtool --mode=link gcc -g -O2 -L/usr/lib -L/usr/X11R6/lib
                            -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -o
                            gdkxft-capplet gdkxft-capplet.o gdkxftcfg.o -rdynamic -L/usr/lib
                            -L/usr/X11R6/lib -rdynamic -lcapplet -lgnomeui -lart_lgpl
                            -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl -lXi -lXext -lX11
                            -lgnome -lgnomesupport -lesd -laudiofile -ldb1 -lORBit -lIIOP
                            -lORBitutil -lglib -lnsl -lm -lgnorba -L/usr/lib -lglade-gnome -lglade
                            -L/usr/lib -lxml -lz -rdynamic -L/usr/lib -L/usr/X11R6/lib -rdynamic
                            -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl
                            -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -lm -ldb1
                            -lglib -ldl -lXft
                            libtool: link: cannot find the library `/usr/lib/libaudiofile.la'
                            make[1]: *** [gdkxft-capplet] Error 1
                            make[1]: Leaving directory `/home/steve/Downloads/gdkxft-1.5/capplet'
                            make: *** [install-recursive] Error 1
                            I don't know where it's getting libaudiofile.la from. In /usr/lib,
                            there are the files libaudiofile.a, and libaudiofile.so. I checked
                            the makefile, and I can see '-laudiofile', but nothing about a '.la'
                            suffix. Any ideas ??
                            Anyway, then I thought I'd grab the M$ fonts. They are all in self
                            installing .exe format. How did you extract the .ttfs out of them ?
                            I'd also appreciate you posting your XftConfig and .gdkxft files if
                            you don't mind.
                            Thanks.
                            Stephen Lau wrote:

                            That's the whole point...you will have BIG fonts with the 100dpi fonts -
                            you just need to go into your window manager preferences bring the font
                            sizes back down to a smaller size... they will have more resolution than
                            the 75dpi fonts.
                            -steve
                            On Sat, Mar 02, 2002 at 01:34:17PM -0400, Victor Manuel Hernandez Maksimenko wr
                            ote:

                            Could you please post them?, i'm currently using gdkxft (+mozilla
                            gdkxft) and im very happy with the results. But im using 75dpi fonts,
                            when i modified the /etc/X11/fs/config to use 100dpi, im getting fonts
                            too big.
                            Also what dpi reports X that your LCD have?, when i run 'xdpyinfo | grep
                            resolution' it reports 75x75 dots per inchs. And when i add the line
                            'DisplaySize 305 230' to the XF86Config-4, then it reports 133x133 dots
                            per inch, but im back with the BIG fonts.
                            thanks!
                            On Sat, 2002-03-02 at 05:54, Stephen Lau wrote:

                            I'm running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important
                            later)
                            go to http://gdkxft.sourceforge.net, click on the download link at the
                            bottom and download gdkxft-1.5.tar.gz
                            ./configure --prefix=/usr
                            make
                            then become root
                            make install
                            gdkxft_sysinstall
                            exit Xwindows
                            edit either your .bashrc, .bash_profile, or the systemwide equivalents and
                            add:
                            export LD_PRELOAD="/usr/lib/libgdkxft.so.0"
                            logout, log back in
                            put all your truetype fonts in one dir
                            run 'ttmkfdir' to generate the fonts.dir in that dir
                            add the directory to your /etc/X11/fs/config (put it first, ahead of all
                            other dirs)
                            if you haven't changed the default-resolutions line to be 100,100,75,75
                            instead of 75,75,100,100 - do it while you're here. :) it'll bump you up to
                            100dpi fonts. also make sure the /usr/X11R6/lib/X1 1/fonts/100dpi l
                            ine is
                            ahead of the 75dpi path.
                            edit /etc/X11/XftConfig and make sure it's sane, i.e.: map your font
                            families properly. for instance, I like all of Microsoft's Core Fonts, so
                            I use Arial as my sans font and map Helvetica to it. I use "Times New
                            Roman" as my times font, "Courier New" as my courier font, and "Andale
                            Mono" as my mono font.
                            restart XFS by doing '/etc/init.d/xfs restart'
                            generate your ~/.gdkxft file, if you want to anti-alias certain fonts, etc.
                            it'll look like:
                            # turn off anti-aliasing for all fonts
                            !*
                            # turn them on one at a time
                            -arial-*
                            -courier new-*
                            -times new roman-*
                            # bad applications - don't anti-alias them
                            &gkrellm
                            NOW, you can finally start up X. so go start it up and you should see
                            anti-aliased fonts. one of the best parts of AA fonts is for web-browsing,
                            so you want to make sure Mozilla supports it. If you're running Ximian,
                            the mozilla packages are already comp iled
                            to support it - you just need to
                            add another export line like we did earlier, except this time:
                            export MOZILLA_USE_GDKXFT=1
                            do the routine: log out of X, logout console/login, start x
                            now Mozilla (and hence, galeon) should have AA fonts.
                            if you're running your own version of Mozilla, you can apply the binary
                            patch found here:
                            http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-0.9.8.i386.tar.gz
                            or apply the source patch to the source tree found here:
                            http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-patch-0.9.8.diff
                            there... it seems like a daunting process, and it took me about half an
                            hour to get it working my first time, but it only took me about 5-10
                            minutes for each machine i've don e it
                            on since then. I've only installed
                            it on Red Hat 7.1 & 7.2 machines...but it's gorgeous. everyone i've
                            installed it for agrees its awesome.
                            i'd be happy to post my XftConfig, and .gdkxft files if people care to. if
                            you want the Microsoft Truetype Core Fonts, go here:
                            http://www.microsoft.com/typography/fontpack/default.htm
                            cheers,
                            steve
                            On Sat, Mar 02, 2002 at 08:22:45PM +1100, Steve Baldwin wrote:

                            Can you please explain what you did, where you got gdkxft, and how you
                            got it all set up.
                            Thx
                            On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:

                            Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
                            size on a 14.1" 1600x1200 UXGA i4100), but then once I started
                            anti-aliasing them with gdkxft, it looked sooooooooooooo much better.
                            -steve
                            On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W . Current wrote:

                            => From: Adam Lowry [mailto:aclowry@...]
                            => I know it's not a trivial thing, in my opinion getting a
                            => lower resolution because fonts are too small isn't the best
                            => way to handle it. Maybe using larger fonts?
                            Ah... Well... No.
                            Small fonts are the problem, but it's not that simple. There are a lot
                            of things I use that don't have scalable fonts (icons, some apps have
                            fixed fonts in the menus, and are all menu based, like VAG-COM and all
                            the software my company makes, control software, stuff with JUST
                            buttons, not like web browsers or word processors).
                            So, the solution is to have the ABILITY to have high resolution
                            displays, but just run at a lower resolution... Problem is, I tried
                            that.
                            My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
                            it was run at max resolution. Everything was fuzzy.
                            I called dell,< br>emailed, and did all kinds of research. If you search through the dell
                            support message forum, you will see a LOT of people complain about this.
                            Dell has only 1 answer "our displays are only designed to be clear at
                            the 'optimum' resolution, if it's within 30 days of your purchase, you
                            may exchange it" which is their way of admitting it sucks at lower
                            resolution.
                            So...
                            I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
                            happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
                            at home up to 1800 x 1440 without any complaints).
                            Again, this is only MY opinion. And since it makes me happy, and
                            getting the 1 down from max resolution displays on laptops is actually
                            cheaper anyway, it's a win-win thing for me.
                            Rob

                            --
                            stephen lau :: [ldl@...] :: www.grommi t.com :: gpg key id: 0x09E5CD21
                            --------------------------------------------------------------
                            Please post your X config files in the group links or database
                            To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                            FAQ: http://www.whacked.net/ldl/faq
                            Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/

                            --
                            stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                            --------------------------------------------------------------
                            Please post your X config files in the group links or database
                            To unsubscrib e, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                            FAQ: http://www.whacked.net/ldl/faq
                            Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/

                            Yahoo! Groups Sponsor
                            ADVERTISEMENT

                            --------------------------------------------------------------
                            Please post your X config files in the group links or database
                            To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                            FAQ: http://www.whacked.net/ldl/faq
                            Your use of Yahoo! Groups is subject to the Yahoo! Terms of Servic e.


                          • Stephen Lau
                            gorgeous isn t it? :) i can t use a workstation without having anti-aliased fonts now... it s made things so much easier on my eyes. this is about the only
                            Message 13 of 17 , Mar 2, 2002
                            • 0 Attachment
                              gorgeous isn't it? :) i can't use a workstation without having
                              anti-aliased fonts now... it's made things so much easier on my eyes.

                              this is about the only documentation i could find on the web for XftConfig:
                              http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-fonts.html

                              if you want, you can grab my XftConfig if it'd help.

                              -steve

                              On Sat, Mar 02, 2002 at 09:53:35PM -0400, Victor Manuel Hernandez Maksimenko wrote:
                              > well, now i setup 'lucidux sans - 7 points' with 100dpi and its looking
                              > gorgeous :). the only problem that i'm having is with gaim, that seems
                              > to override that setting and put the default font for the crux theme,
                              > which seems huge :(... but after manually logging off and on on gaim
                              > correct that problem.
                              >
                              > where i could find info on configuring the XftConfig file?, i tried 'man
                              > XftConfig', 'info XftConfig', but had no luck.
                              >
                              > On Sat, 2002-03-02 at 15:34, Stephen Lau wrote:
                              > > That's the whole point...you will have BIG fonts with the 100dpi fonts -
                              > > you just need to go into your window manager preferences bring the font
                              > > sizes back down to a smaller size... they will have more resolution than
                              > > the 75dpi fonts.
                              > >
                              > > -steve
                              > >
                              > > On Sat, Mar 02, 2002 at 01:34:17PM -0400, Victor Manuel Hernandez Maksimenko wrote:
                              > > > Could you please post them?, i'm currently using gdkxft (+mozilla
                              > > > gdkxft) and im very happy with the results. But im using 75dpi fonts,
                              > > > when i modified the /etc/X11/fs/config to use 100dpi, im getting fonts
                              > > > too big.
                              > > >
                              > > > Also what dpi reports X that your LCD have?, when i run 'xdpyinfo | grep
                              > > > resolution' it reports 75x75 dots per inchs. And when i add the line
                              > > > 'DisplaySize 305 230' to the XF86Config-4, then it reports 133x133 dots
                              > > > per inch, but im back with the BIG fonts.
                              > > >
                              > > > thanks!
                              > > >
                              > > >
                              > > > On Sat, 2002-03-02 at 05:54, Stephen Lau wrote:
                              > > > > I'm running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important
                              > > > > later)
                              > > > >
                              > > > > go to http://gdkxft.sourceforge.net, click on the download link at the
                              > > > > bottom and download gdkxft-1.5.tar.gz
                              > > > >
                              > > > > ./configure --prefix=/usr
                              > > > > make
                              > > > >
                              > > > > then become root
                              > > > > make install
                              > > > > gdkxft_sysinstall
                              > > > >
                              > > > > exit Xwindows
                              > > > > edit either your .bashrc, .bash_profile, or the systemwide equivalents and
                              > > > > add:
                              > > > > export LD_PRELOAD="/usr/lib/libgdkxft.so.0"
                              > > > >
                              > > > > logout, log back in
                              > > > > put all your truetype fonts in one dir
                              > > > > run 'ttmkfdir' to generate the fonts.dir in that dir
                              > > > > add the directory to your /etc/X11/fs/config (put it first, ahead of all
                              > > > > other dirs)
                              > > > > if you haven't changed the default-resolutions line to be 100,100,75,75
                              > > > > instead of 75,75,100,100 - do it while you're here. :) it'll bump you up to
                              > > > > 100dpi fonts. also make sure the /usr/X11R6/lib/X11/fonts/100dpi line is
                              > > > > ahead of the 75dpi path.
                              > > > >
                              > > > > edit /etc/X11/XftConfig and make sure it's sane, i.e.: map your font
                              > > > > families properly. for instance, I like all of Microsoft's Core Fonts, so
                              > > > > I use Arial as my sans font and map Helvetica to it. I use "Times New
                              > > > > Roman" as my times font, "Courier New" as my courier font, and "Andale
                              > > > > Mono" as my mono font.
                              > > > >
                              > > > > restart XFS by doing '/etc/init.d/xfs restart'
                              > > > > generate your ~/.gdkxft file, if you want to anti-alias certain fonts, etc.
                              > > > > it'll look like:
                              > > > >
                              > > > > # turn off anti-aliasing for all fonts
                              > > > > !*
                              > > > > # turn them on one at a time
                              > > > > -arial-*
                              > > > > -courier new-*
                              > > > > -times new roman-*
                              > > > > # bad applications - don't anti-alias them
                              > > > > &gkrellm
                              > > > >
                              > > > > NOW, you can finally start up X. so go start it up and you should see
                              > > > > anti-aliased fonts. one of the best parts of AA fonts is for web-browsing,
                              > > > > so you want to make sure Mozilla supports it. If you're running Ximian,
                              > > > > the mozilla packages are already compiled to support it - you just need to
                              > > > > add another export line like we did earlier, except this time:
                              > > > > export MOZILLA_USE_GDKXFT=1
                              > > > > do the routine: log out of X, logout console/login, start x
                              > > > > now Mozilla (and hence, galeon) should have AA fonts.
                              > > > > if you're running your own version of Mozilla, you can apply the binary
                              > > > > patch found here:
                              > > > > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-0.9.8.i386.tar.gz
                              > > > > or apply the source patch to the source tree found here:
                              > > > > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-patch-0.9.8.diff
                              > > > >
                              > > > > there... it seems like a daunting process, and it took me about half an
                              > > > > hour to get it working my first time, but it only took me about 5-10
                              > > > > minutes for each machine i've done it on since then. I've only installed
                              > > > > it on Red Hat 7.1 & 7.2 machines...but it's gorgeous. everyone i've
                              > > > > installed it for agrees its awesome.
                              > > > >
                              > > > > i'd be happy to post my XftConfig, and .gdkxft files if people care to. if
                              > > > > you want the Microsoft Truetype Core Fonts, go here:
                              > > > > http://www.microsoft.com/typography/fontpack/default.htm
                              > > > >
                              > > > > cheers,
                              > > > > steve
                              > > > >
                              > > > >
                              > > > >
                              > > > > On Sat, Mar 02, 2002 at 08:22:45PM +1100, Steve Baldwin wrote:
                              > > > > > Can you please explain what you did, where you got gdkxft, and how you
                              > > > > > got it all set up.
                              > > > > >
                              > > > > > Thx
                              > > > > >
                              > > > > > On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:
                              > > > > > > Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
                              > > > > > > size on a 14.1" 1600x1200 UXGA i4100), but then once I started
                              > > > > > > anti-aliasing them with gdkxft, it looked sooooooooooooo much better.
                              > > > > > >
                              > > > > > > -steve
                              > > > > > >
                              > > > > > > On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W. Current wrote:
                              > > > > > > > => From: Adam Lowry [mailto:aclowry@...]
                              > > > > > > > => I know it's not a trivial thing, in my opinion getting a
                              > > > > > > > => lower resolution because fonts are too small isn't the best
                              > > > > > > > => way to handle it. Maybe using larger fonts?
                              > > > > > > >
                              > > > > > > > Ah... Well... No.
                              > > > > > > >
                              > > > > > > > Small fonts are the problem, but it's not that simple. There are a lot
                              > > > > > > > of things I use that don't have scalable fonts (icons, some apps have
                              > > > > > > > fixed fonts in the menus, and are all menu based, like VAG-COM and all
                              > > > > > > > the software my company makes, control software, stuff with JUST
                              > > > > > > > buttons, not like web browsers or word processors).
                              > > > > > > >
                              > > > > > > > So, the solution is to have the ABILITY to have high resolution
                              > > > > > > > displays, but just run at a lower resolution... Problem is, I tried
                              > > > > > > > that.
                              > > > > > > >
                              > > > > > > > My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
                              > > > > > > > it was run at max resolution. Everything was fuzzy. I called dell,
                              > > > > > > > emailed, and did all kinds of research. If you search through the dell
                              > > > > > > > support message forum, you will see a LOT of people complain about this.
                              > > > > > > > Dell has only 1 answer "our displays are only designed to be clear at
                              > > > > > > > the 'optimum' resolution, if it's within 30 days of your purchase, you
                              > > > > > > > may exchange it" which is their way of admitting it sucks at lower
                              > > > > > > > resolution.
                              > > > > > > >
                              > > > > > > > So...
                              > > > > > > >
                              > > > > > > > I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
                              > > > > > > > happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
                              > > > > > > > at home up to 1800 x 1440 without any complaints).
                              > > > > > > >
                              > > > > > > > Again, this is only MY opinion. And since it makes me happy, and
                              > > > > > > > getting the 1 down from max resolution displays on laptops is actually
                              > > > > > > > cheaper anyway, it's a win-win thing for me.
                              > > > > > > >
                              > > > > > > > Rob
                              > > > > > > >
                              > > > > > >
                              > > > > > > --
                              > > > > > > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                              > > > > > >
                              > > > > > >
                              > > > > > > --------------------------------------------------------------
                              > > > > > > Please post your X config files in the group links or database
                              > > > > > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                              > > > > > > FAQ: http://www.whacked.net/ldl/faq
                              > > > > > >
                              > > > > > > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                              > > > > > >
                              > > > > > >
                              > > > > >
                              > > > > >
                              > > > >
                              > > > > --
                              > > > > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                              > > > >
                              > > > >
                              > > > > --------------------------------------------------------------
                              > > > > Please post your X config files in the group links or database
                              > > > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                              > > > > FAQ: http://www.whacked.net/ldl/faq
                              > > > >
                              > > > > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                              > > > >
                              > > > >
                              > > >
                              > > >
                              > >
                              > >
                              > >
                              > > --
                              > > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                              > >
                              > >
                              > > --------------------------------------------------------------
                              > > Please post your X config files in the group links or database
                              > > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                              > > FAQ: http://www.whacked.net/ldl/faq
                              > >
                              > > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                              > >
                              > >
                              >



                              --
                              stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                            • Stephen Lau
                              Hi Steve, If Victor s tool that he posted (which sounds great, btw) doesn t work - let me know and I ll tar up the fonts. Try his tool first to save me the
                              Message 14 of 17 , Mar 2, 2002
                              • 0 Attachment
                                Hi Steve,
                                If Victor's tool that he posted (which sounds great, btw) doesn't work
                                - let me know and I'll tar up the fonts. Try his tool first to save me the
                                bandwidth of having to post the fonts. :P

                                -steve

                                On Sun, Mar 03, 2002 at 12:59:07PM +1100, Steve Baldwin wrote:
                                >
                                > Thanks mate, that fixed my linking problem. Wonder where that file
                                > was supposed to come from ???
                                > I actually don't have windows, so I would very much appreciate it if
                                > you could tar them up and put them up on the web.
                                > Cheers,
                                > Steve
                                > Stephen Lau wrote:
                                >
                                > Hrm...I have a /usr/lib/libaudiofile.la, It's a text file - I'll post it
                                > here:
                                > =============snip
                                > # libaudiofile.la - a libtool library file
                                > # Generated by ltmain.sh - GNU libtool 1.3.4 (1.385.2.196 1999/12/07 21:47:57)
                                > #
                                > # Please DO NOT delete this file!
                                > # It is necessary for linking the library.
                                > # The name that we can dlopen(3).
                                > dlname=''
                                > # Names of this library.
                                > library_names='libaudiofile.so.0.0.1 libaudiofile.so.0 libaudiofile.so'
                                > # The name of the static archive.
                                > old_library='libaudiofile.a'
                                > # Libraries that this one depends upon.
                                > dependency_libs=' -lm -lm'
                                > # Version information for libaudiofile.
                                > current=0
                                > age=0
                                > revision=1
                                > # Is this an already installed library?
                                > installed=yes
                                > # Directory that this library needs to be installed in:
                                > libdir='/usr/lib'
                                > =================snip
                                > yeah, I had to boot up my vmware windows 2000 machine and extract the
                                > font
                                > s and then bring them back into linux. :)
                                > you can find my config stuff at http://www.whacked.net/ldl/aa-fonts.tar.gz
                                > if you don't have windows, let me know and I'll tar up the fonts & the
                                > fonts.dir file generated and put them on the web.
                                > -steve
                                > On Sun, Mar 03, 2002 at 12:17:46PM +1100, Steve Baldwin wrote:
                                >
                                > Thanks for going to all this trouble. However, I have a couple of
                                > questions ...
                                > Did you get any errors when you did the 'make install'. I had 2
                                > problems - one I solved and one I havent yet. The first was that it
                                > couldn't find capplet-widget.h when making gdkxft-capplet. I created
                                > a symlink from the copy in /usr/include/libcapplet1 to /usr/include.
                                > Now I get the following error ...
                                > make[1]: Entering directory `/home/steve/Downloads/gdkxft-1.5/capplet'
                                > /bin/sh ../libtool --mode=link gcc -g -O2 -L/usr/lib -L/usr/X11R6/lib
                                > -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm -o
                                > gdkxft-capplet gdkxft-capplet.o gdkxftcfg.o -rdynamic -L/usr/lib
                                > -L/usr/X11R6/lib -rdynamic -lcapplet -lgnomeui -lart_lgpl
                                > -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl -lXi -lXext -lX11
                                > -lgnome -lgnomesupport -lesd -laudiofile -ldb1 -lORBit -lIIOP
                                >
                                > -lORBitutil -lglib -lnsl -lm -lgnorba -L/usr/lib -lglade-gnome -lglade
                                > -L/usr/lib -lxml -lz -rdynamic -L/usr/lib -L/usr/X11R6/lib -rdynamic
                                > -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -ldl
                                > -lXi -lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -lm -ldb1
                                > -lglib -ldl -lXft
                                > libtool: link: cannot find the library `/usr/lib/libaudiofile.la'
                                > make[1]: *** [gdkxft-capplet] Error 1
                                > make[1]: Leaving directory `/home/steve/Downloads/gdkxft-1.5/capplet'
                                > make: *** [install-recursive] Error 1
                                > I don't know where it's getting libaudiofile.la from. In /usr/lib,
                                > there are the files libaudiofile.a, and libaudiofile.so. I checked
                                > the makefile, and I can see '-laudiofile', but nothing about a '.la'
                                > suffix. Any ideas ??
                                > Anyway, then I thought I'd grab the M$ fonts. They are all in self
                                > installing .exe format. How did you extract the .ttfs out of them ?
                                > I'd also
                                > appreciate you posting your XftConfig and .gdkxft files if
                                > you don't mind.
                                > Thanks.
                                > Stephen Lau wrote:
                                > That's the whole point...you will have BIG fonts with the 100dpi fonts -
                                > you just need to go into your window manager preferences bring the font
                                > sizes back down to a smaller size... they will have more resolution than
                                > the 75dpi fonts.
                                > -steve
                                > On Sat, Mar 02, 2002 at 01:34:17PM -0400, Victor Manuel Hernandez Maksimenko wr
                                > ote:
                                > Could you please post them?, i'm currently using gdkxft (+mozilla
                                > gdkxft) and im very happy with the results. But im using 75dpi fonts,
                                > when i modified the /etc/X11/fs/config to use 100dpi, im getting fonts
                                > too big.
                                > Also what dpi reports X that your LCD have?, when i run 'xdpyinfo | grep
                                > resolution' it reports 75x75 dots per inchs. And when i add the line
                                > 'DisplaySize 305 230' to the XF86Config-4, then it reports 133x133 dots
                                > per inch, but im back with the BIG fonts.
                                > thanks!
                                >
                                > On Sat, 2002-03-02 at 05:54, Stephen Lau wrote:
                                > I'm running Red Hat 7.1 with Ximian Gnome 1.4 (this is mildly important
                                > later)
                                > go to http://gdkxft.sourceforge.net, click on the download link at the
                                > bottom and download gdkxft-1.5.tar.gz
                                > ./configure --prefix=/usr
                                > make
                                > then become root
                                > make install
                                > gdkxft_sysinstall
                                > exit Xwindows
                                > edit either your .bashrc, .bash_profile, or the systemwide equivalents and
                                > add:
                                > export LD_PRELOAD="/usr/lib/libgdkxft.so.0"
                                > logout, log back in
                                > put all your truetype fonts in one dir
                                > run 'ttmkfdir' to generate the fonts.dir in that dir
                                > add the directory to your /etc/X11/fs/config (put it first, ahead of all
                                > other dirs)
                                > if you haven't changed the default-resolutions line to be 100,100,75,75
                                > instead of 75,75,100,100 - do it while you're here. :) it'll bump you up to
                                > 100dpi fonts. also make sure the /usr/X11R6/lib/X1
                                > 1/fonts/100dpi l
                                > ine is
                                > ahead of the 75dpi path.
                                > edit /etc/X11/XftConfig and make sure it's sane, i.e.: map your font
                                > families properly. for instance, I like all of Microsoft's Core Fonts, so
                                > I use Arial as my sans font and map Helvetica to it. I use "Times New
                                > Roman" as my times font, "Courier New" as my courier font, and "Andale
                                > Mono" as my mono font.
                                > restart XFS by doing '/etc/init.d/xfs restart'
                                > generate your ~/.gdkxft file, if you want to anti-alias certain fonts, etc.
                                > it'll look like:
                                > # turn off anti-aliasing for all fonts
                                > !*
                                > # turn them on one at a time
                                > -arial-*
                                > -courier new-*
                                > -times new roman-*
                                > # bad applications - don't anti-alias them
                                > &gkrellm
                                > NOW, you can finally start up X. so go start it up and you should see
                                > anti-aliased fonts. one of the best parts of AA fonts is for web-browsing,
                                > so you want to make sure Mozilla supports it. If you're running Ximian,
                                > the mozilla packages are already comp
                                > iled
                                > to support it - you just need to
                                > add another export line like we did earlier, except this time:
                                > export MOZILLA_USE_GDKXFT=1
                                > do the routine: log out of X, logout console/login, start x
                                > now Mozilla (and hence, galeon) should have AA fonts.
                                > if you're running your own version of Mozilla, you can apply the binary
                                > patch found here:
                                > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-0.9.8.i386.tar.gz
                                > or apply the source patch to the source tree found here:
                                > http://prdownloads.sourceforge.net/gdkxft/gdkxft-mozilla-patch-0.9.8.diff
                                > there... it seems like a daunting process, and it took me about half an
                                > hour to get it working my first time, but it only took me about 5-10
                                > minutes for each machine i've don
                                > e it
                                > on since then. I've only installed
                                > it on Red Hat 7.1 & 7.2 machines...but it's gorgeous. everyone i've
                                > installed it for agrees its awesome.
                                > i'd be happy to post my XftConfig, and .gdkxft files if people care to. if
                                > you want the Microsoft Truetype Core Fonts, go here:
                                > http://www.microsoft.com/typography/fontpack/default.htm
                                > cheers,
                                > steve
                                > On Sat, Mar 02, 2002 at 08:22:45PM +1100, Steve Baldwin wrote:
                                > Can you please explain what you did, where you got gdkxft, and how you
                                > got it all set up.
                                > Thx
                                > On Sat, 2002-03-02 at 17:21, Stephen Lau wrote:
                                > Just a note... my fonts were hard to read (i run 100dpi fonts, pretty small
                                > size on a 14.1" 1600x1200 UXGA i4100), but then once I started
                                > anti-aliasing them with gdkxft, it looked sooooooooooooo much better.
                                > -steve
                                > On Sat, Mar 02, 2002 at 12:31:10AM -0500, Dr. Robert W
                                > . Current wrote:
                                > => From: Adam Lowry [mailto:aclowry@...]
                                > => I know it's not a trivial thing, in my opinion getting a
                                > => lower resolution because fonts are too small isn't the best
                                > => way to handle it. Maybe using larger fonts?
                                > Ah... Well... No.
                                > Small fonts are the problem, but it's not that simple. There are a lot
                                > of things I use that don't have scalable fonts (icons, some apps have
                                > fixed fonts in the menus, and are all menu based, like VAG-COM and all
                                > the software my company makes, control software, stuff with JUST
                                > buttons, not like web browsers or word processors).
                                > So, the solution is to have the ABILITY to have high resolution
                                > displays, but just run at a lower resolution... Problem is, I tried
                                > that.
                                > My last laptop was a Inspiron 8000 w/ UXGA. And it SUCKED IMHO unless
                                > it was run at max resolution. Everything was fuzzy.
                                > I called dell,<
                                > br>emailed, and did all kinds of research. If you search through the dell
                                > support message forum, you will see a LOT of people complain about this.
                                > Dell has only 1 answer "our displays are only designed to be clear at
                                > the 'optimum' resolution, if it's within 30 days of your purchase, you
                                > may exchange it" which is their way of admitting it sucks at lower
                                > resolution.
                                > So...
                                > I'm very happy with Inspiron 8100's at 1400x1050, usually, and extremely
                                > happy with 14.1" at 1024x768 (this coming from me when I run my 19" CRT
                                > at home up to 1800 x 1440 without any complaints).
                                > Again, this is only MY opinion. And since it makes me happy, and
                                > getting the 1 down from max resolution displays on laptops is actually
                                > cheaper anyway, it's a win-win thing for me.
                                > Rob
                                > --
                                > stephen lau :: [ldl@...] :: www.grommi
                                > t.com :: gpg key id: 0x09E5CD21
                                > --------------------------------------------------------------
                                > Please post your X config files in the group links or database
                                > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                                > FAQ: http://www.whacked.net/ldl/faq
                                > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                                > --
                                > stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                                > --------------------------------------------------------------
                                > Please post your X config files in the group links or database
                                > To unsubscrib
                                > e, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                                > FAQ: http://www.whacked.net/ldl/faq
                                > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                                > Yahoo! Groups Sponsor
                                > ADVERTISEMENT
                                >
                                > --------------------------------------------------------------
                                > Please post your X config files in the group links or database
                                > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                                > FAQ: http://www.whacked.net/ldl/faq
                                > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Servic
                                > e.
                                >
                                > Yahoo! Groups Sponsor
                                > ADVERTISEMENT
                                >
                                > --------------------------------------------------------------
                                > Please post your X config files in the group links or database
                                > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                                > FAQ: http://www.whacked.net/ldl/faq
                                > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

                                --
                                stephen lau :: [ldl@...] :: www.grommit.com :: gpg key id: 0x09E5CD21
                              Your message has been successfully submitted and would be delivered to recipients shortly.