Loading ...
Sorry, an error occurred while loading the content.

[linux-dell-laptops] shutdown

Expand Messages
  • torifile@mciworld.com
    how do i get my dell inspiron 3200 to power off after linux completes it s shutdown procedure? -sammy
    Message 1 of 12 , Oct 3, 1999
    • 0 Attachment
      how do i get my dell inspiron 3200 to power off after linux completes
      it's shutdown procedure?

      -sammy
    • Leon Wood
      ... From: torifile@mciworld.com To: linux-dell-laptops@eGroups.com Date: October 4, 1999 12:28 AM
      Message 2 of 12 , Oct 4, 1999
      • 0 Attachment
        -----Original Message-----
        From: torifile@... <torifile@...>
        To: linux-dell-laptops@... <linux-dell-laptops@...>
        Date: October 4, 1999 12:28 AM
        Subject: [linux-dell-laptops] shutdown


        > how do i get my dell inspiron 3200 to power off after linux completes
        >it's shutdown procedure?


        I haven't done this myself, but I believe you must configure the kernel for
        support for APM and recompile.

        Leon Wood
      • Terrence O'Connor
        RedHat 6.0 should support the APM daemon out of the box. At least it did on my Inspiron 3K. --tj ... From: torifile@mciworld.com [SMTP:torifile@mciworld.com]
        Message 3 of 12 , Oct 5, 1999
        • 0 Attachment
          RedHat 6.0 should support the APM daemon out of the box. At least it did on my Inspiron 3K. --tj

          -----Original Message-----
          From: torifile@... [SMTP:torifile@...]
          Sent: Monday, October 04, 1999 12:30 AM
          To: linux-dell-laptops@egroups.com
          Subject: [linux-dell-laptops] shutdown

          how do i get my dell inspiron 3200 to power off after linux completes
          it's shutdown procedure?

          -sammy


          ------------------------------------------------------------------------

          eGroups.com home: http://www.egroups.com/group/linux-dell-laptops
          http://www.egroups.com - Simplifying group communications
        • d99ma
          Hi I have a strange problem. When i shutdown my 8200 it doesn t turn itself of. It does all the usual stuff and then informs me that runlevel 0 has been
          Message 4 of 12 , Sep 4, 2002
          • 0 Attachment
            Hi

            I have a strange problem.
            When i shutdown my 8200 it doesn't turn itself of.
            It does all the usual stuff and then informs me that runlevel 0 has been reached, but it doesn't shutdown. Any ideas what is wrong?
            I've in windows xp and it turns itself off, so it shouldn't be a hardware failure.

            /Martin
          • David Carlton
            ... You need to recompile the kernel and select some not very unintuitively named option. (Something about power management, I think.) David Carlton
            Message 5 of 12 , Sep 4, 2002
            • 0 Attachment
              On Wed, 04 Sep 2002 14:48:23 -0000, "d99ma" <d99ma@...> said:

              > I have a strange problem. When i shutdown my 8200 it doesn't turn
              > itself of. It does all the usual stuff and then informs me that
              > runlevel 0 has been reached, but it doesn't shutdown. Any ideas what
              > is wrong?

              You need to recompile the kernel and select some not very
              unintuitively named option. (Something about power management, I
              think.)

              David Carlton | <http://math.stanford.edu/~carlton/>
              carlton@... | I8200: <http://math.stanford.edu/~carlton/i8200/>
            • Mike Hicks
              ... Yeah, it should be possible to get it to work. Windows probably uses the ACPI interface to power down, while Linux generaly uses APM, but whatever. There
              Message 6 of 12 , Sep 4, 2002
              • 0 Attachment
                On Wed, 2002-09-04 at 09:48, d99ma wrote:
                > Hi
                >
                > I have a strange problem.
                > When i shutdown my 8200 it doesn't turn itself of.
                > It does all the usual stuff and then informs me that runlevel 0 has been reached, but it doesn't shutdown. Any ideas what is wrong?
                > I've in windows xp and it turns itself off, so it shouldn't be a hardware failure

                Yeah, it should be possible to get it to work. Windows probably uses
                the ACPI interface to power down, while Linux generaly uses APM, but
                whatever.

                There are a few options you can pass to the kernel at boot-time to tweak
                the APM settings

                From linux/arch/i386/kernel/apm.c:

                * Various options can be changed at boot time as follows:
                * (We allow underscores for compatibility with the modules code)
                * apm=on/off enable/disable APM
                * [no-]allow[-_]ints allow interrupts during BIOS calls
                * [no-]broken[-_]psr BIOS has a broken GetPowerStatus call
                * [no-]realmode[-_]power[-_]off switch to real mode before
                * powering off
                * [no-]debug log some debugging messages
                * [no-]power[-_]off power off on shutdown
                * bounce[-_]interval=<n> number of ticks to ignore suspend
                * bounces
                * idle[-_]threshold=<n> System idle percentage above which to
                * make APM BIOS idle calls. Set it to
                * 100 to disable.
                * idle[-_]period=<n> Period (in 1/100s of a second) over
                * which the idle percentage is
                * calculated.

                I know my Inspiron 4100's kernel is compiled with the realmode-power-off
                option turned on by default. You'd probably want to try passing the
                parameter

                apm=realmode-power-off

                when the system boots. For a more permanent change, edit /etc/lilo.conf
                and put that in the append="..." line, then run /sbin/lilo. (well, if
                your computer uses LILO).

                --
                _ _ _ _ _ ___ _ _ _ ___ _ _ __ When does summertime come
                / \/ \(_)| ' // ._\ / - \(_)/ ./| ' /(__ to Minnesota? Last year, I
                \_||_/|_||_|_\\___/ \_-_/|_|\__\|_|_\ __) think it was a Tuesday.
                [ Mike Hicks | http://umn.edu/~hick0088/ | mailto:hick0088@... ]
              • d99ma
                ... 0 has been reached, but it doesn t shutdown. Any ideas what is wrong? ... be a hardware failure ... probably uses ... APM, but ... to tweak ... code) ...
                Message 7 of 12 , Sep 5, 2002
                • 0 Attachment
                  --- In linux-dell-laptops@y..., Mike Hicks <hick0088@t...> wrote:
                  > On Wed, 2002-09-04 at 09:48, d99ma wrote:
                  > > Hi
                  > >
                  > > I have a strange problem.
                  > > When i shutdown my 8200 it doesn't turn itself of.
                  > > It does all the usual stuff and then informs me that runlevel
                  0 has been reached, but it doesn't shutdown. Any ideas what is
                  wrong?
                  > > I've in windows xp and it turns itself off, so it shouldn't
                  be a hardware failure
                  >
                  > Yeah, it should be possible to get it to work. Windows
                  probably uses
                  > the ACPI interface to power down, while Linux generaly uses
                  APM, but
                  > whatever.
                  >
                  > There are a few options you can pass to the kernel at boot-time
                  to tweak
                  > the APM settings
                  >
                  > From linux/arch/i386/kernel/apm.c:
                  >
                  > * Various options can be changed at boot time as follows:
                  > * (We allow underscores for compatibility with the modules
                  code)
                  > * apm=on/off enable/disable APM
                  > * [no-]allow[-_]ints allow interrupts during
                  BIOS calls
                  > * [no-]broken[-_]psr BIOS has a broken
                  GetPowerStatus call
                  > * [no-]realmode[-_]power[-_]off switch to real
                  mode before
                  > * powering off
                  > * [no-]debug log some debugging
                  messages
                  > * [no-]power[-_]off power off on shutdown
                  > * bounce[-_]interval=<n> number of ticks to
                  ignore suspend
                  > * bounces
                  > * idle[-_]threshold=<n> System idle percentage
                  above which to
                  > * make APM BIOS idle
                  calls. Set it to
                  > * 100 to disable.
                  > * idle[-_]period=<n> Period (in 1/100s of a
                  second) over
                  > * which the idle
                  percentage is
                  > * calculated.
                  >
                  > I know my Inspiron 4100's kernel is compiled with the
                  realmode-power-off
                  > option turned on by default. You'd probably want to try
                  passing the
                  > parameter
                  >
                  > apm=realmode-power-off
                  >
                  > when the system boots. For a more permanent change, edit
                  /etc/lilo.conf
                  > and put that in the append="..." line, then run /sbin/lilo.
                  (well, if
                  > your computer uses LILO).
                  >
                  > --
                  > _ _ _ _ _ ___ _ _ _ ___ _ _ __ When does
                  summertime come
                  > / \/ \(_)| ' // ._\ / - \(_)/ ./| ' /(__ to Minnesota? Last
                  year, I
                  > \_||_/|_||_|_\\___/ \_-_/|_|\__\|_|_\ __) think it was a
                  Tuesday.
                  > [ Mike Hicks | http://umn.edu/~hick0088/ | mailto:hick0088@t...
                  ]

                  That didn't seem to help. Could I try the apm=power-off?
                  That sounds like what I'm after.
                • James D Strandboge
                  ... I haven t read the whole thread, so pardon me if some if this has already been said. How are you trying to shutdown? If not shutdown -h now (or
                  Message 8 of 12 , Sep 5, 2002
                  • 0 Attachment
                    On Thu, 2002-09-05 at 03:51, d99ma wrote:
                    > --- In linux-dell-laptops@y..., Mike Hicks <hick0088@t...> wrote:
                    > > On Wed, 2002-09-04 at 09:48, d99ma wrote:
                    > > > Hi
                    > > >
                    > > > I have a strange problem.
                    > > > When i shutdown my 8200 it doesn't turn itself of.
                    > > > It does all the usual stuff and then informs me that runlevel
                    > 0 has been reached, but it doesn't shutdown. Any ideas what is
                    > wrong?
                    > > > I've in windows xp and it turns itself off, so it shouldn't
                    > be a hardware failure
                    > >

                    I haven't read the whole thread, so pardon me if some if this has
                    already been said. How are you trying to shutdown? If not 'shutdown -h
                    now' (or whatever time) then it may not poweroff automatically. You
                    might also try the 'poweroff' command.

                    If you think the kernel isn't compiled right, check out my .config at
                    http://jpstrand.homeip.net/user/delli8200/delli8200.html. I have an
                    8200 and it powers off fine with this configuration-- with no grub/lilo
                    boot options.

                    Jamie Strandboge
                  • d99ma
                    ... runlevel ... is ... shouldn t ... has ... shutdown -h ... You ... .config at ... have an ... grub/lilo ... If I send apm=power-off to the kernel it works
                    Message 9 of 12 , Sep 7, 2002
                    • 0 Attachment
                      --- In linux-dell-laptops@y..., James D Strandboge
                      <jstrand1@r...> wrote:
                      > On Thu, 2002-09-05 at 03:51, d99ma wrote:
                      > > --- In linux-dell-laptops@y..., Mike Hicks <hick0088@t...>
                      wrote:
                      > > > On Wed, 2002-09-04 at 09:48, d99ma wrote:
                      > > > > Hi
                      > > > >
                      > > > > I have a strange problem.
                      > > > > When i shutdown my 8200 it doesn't turn itself of.
                      > > > > It does all the usual stuff and then informs me that
                      runlevel
                      > > 0 has been reached, but it doesn't shutdown. Any ideas what
                      is
                      > > wrong?
                      > > > > I've in windows xp and it turns itself off, so it
                      shouldn't
                      > > be a hardware failure
                      > > >
                      >
                      > I haven't read the whole thread, so pardon me if some if this
                      has
                      > already been said. How are you trying to shutdown? If not
                      'shutdown -h
                      > now' (or whatever time) then it may not poweroff automatically.
                      You
                      > might also try the 'poweroff' command.
                      >
                      > If you think the kernel isn't compiled right, check out my
                      .config at
                      > http://jpstrand.homeip.net/user/delli8200/delli8200.html. I
                      have an
                      > 8200 and it powers off fine with this configuration-- with no
                      grub/lilo
                      > boot options.
                      >
                      > Jamie Strandboge

                      If I send apm=power-off to the kernel it works fine, so I think I
                      will stick with that for a while. At least until I have time to
                      do something else.

                      /Martin
                    • sergiodegrass <sergiodegrass@yahoo.com>
                      Hi, I have a problem while trying to shutdown my laptop. When I type: shutdown -h now , instead of shutting down, it reboots. I have a partition for Dell
                      Message 10 of 12 , Feb 23, 2003
                      • 0 Attachment
                        Hi,

                        I have a problem while trying to shutdown my laptop. When I type:
                        "shutdown -h now", instead of shutting down, it reboots. I have a
                        partition for Dell utils, another for WinXP and then Swap and Linux
                        ones. Any solutions?

                        Thanks!


                        Debian in a Dell inspiron 8200 (notebook). P4M 1.6GHz, nVidia
                        GeForce2 32MB, 256M RAM.
                      • John Britton
                        Try halt -p , John. ... -- Centre for Bioengineering, Trinity College, University of Dublin, Ireland www.biomechanics.ie
                        Message 11 of 12 , Feb 24, 2003
                        • 0 Attachment
                          Try "halt -p", John.

                          On Mon February 24 2003 03:35, sergiodegrass <sergiodegrass@...> wrote:
                          > Hi,
                          >
                          > I have a problem while trying to shutdown my laptop. When I type:
                          > "shutdown -h now", instead of shutting down, it reboots. I have a
                          > partition for Dell utils, another for WinXP and then Swap and Linux
                          > ones. Any solutions?
                          >
                          > Thanks!
                          >
                          >
                          > Debian in a Dell inspiron 8200 (notebook). P4M 1.6GHz, nVidia
                          > GeForce2 32MB, 256M RAM.
                          >
                          >
                          >
                          > --------------------------------------------------------------
                          > Please post your X config files in the group links or database
                          > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                          > FAQ: http://www.whacked.net/ldl/faq
                          >
                          > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/

                          --
                          Centre for Bioengineering,
                          Trinity College,
                          University of Dublin,
                          Ireland
                          www.biomechanics.ie
                        • Dado Feigenblatt
                          or poweroff ... -- Dado Feigenblatt Wild Brain, Inc. Technical Director (415) 553-8000
                          Message 12 of 12 , Feb 24, 2003
                          • 0 Attachment
                            or poweroff

                            On Mon, 2003-02-24 at 00:36, John Britton wrote:
                            > Try "halt -p", John.
                            >
                            > On Mon February 24 2003 03:35, sergiodegrass <sergiodegrass@...>
                            > wrote:
                            > > Hi,
                            > >
                            > > I have a problem while trying to shutdown my laptop. When I type:
                            > > "shutdown -h now", instead of shutting down, it reboots. I have a
                            > > partition for Dell utils, another for WinXP and then Swap and Linux
                            > > ones. Any solutions?
                            > >
                            > > Thanks!
                            > >
                            > >
                            > > Debian in a Dell inspiron 8200 (notebook). P4M 1.6GHz, nVidia
                            > > GeForce2 32MB, 256M RAM.
                            > >
                            > >
                            > >
                            > > --------------------------------------------------------------
                            > > Please post your X config files in the group links or database
                            > > To unsubscribe, email:
                            > linux-dell-laptops-unsubscribe@yahoogroups.com
                            > > FAQ: http://www.whacked.net/ldl/faq
                            > >
                            > > Your use of Yahoo! Groups is subject to
                            > http://docs.yahoo.com/info/terms/
                            >
                            > --
                            > Centre for Bioengineering,
                            > Trinity College,
                            > University of Dublin,
                            > Ireland
                            > www.biomechanics.ie
                            >
                            > Yahoo! Groups Sponsor
                            > ADVERTISEMENT
                            >
                            >
                            > --------------------------------------------------------------
                            > Please post your X config files in the group links or database
                            > To unsubscribe, email: linux-dell-laptops-unsubscribe@yahoogroups.com
                            > FAQ: http://www.whacked.net/ldl/faq
                            >
                            > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
                            --
                            Dado Feigenblatt Wild Brain, Inc.
                            Technical Director (415) 553-8000
                            dado@... San Francisco, CA.
                          Your message has been successfully submitted and would be delivered to recipients shortly.