Loading ...
Sorry, an error occurred while loading the content.

2592Re: 3D acceleration on I5Ke

Expand Messages
  • dell-linux@aaman.net
    Feb 3 2:39 AM
    • 0 Attachment
      --- In linux-dell-laptops@y..., Mark Dorset <markd@i...> wrote:
      > Hmm, since it's the topic at the moment....
      >
      > > > > DRI was one of the harder things for me to get working just
      fine.
      > > > >
      > > > > The glxinfo line should actually read:
      > > > >
      > > > > OpenGL renderer string: Mesa DRI Rage128 20001215 M3 AGP 2x
      x86
      >
      > $ glxinfo | grep DRI
      > OpenGL renderer string: Mesa DRI Rage128 20001215 M3 AGP 2x x86
      >
      > > You should see something like this in dmesg:
      > >
      > > Linux agpgart interface v0.99 (c) Jeff Hartmann
      > > agpgart: Maximum main memory to use for agp memory: 203M
      > > agpgart: Detected Intel 440BX chipset
      > > agpgart: AGP aperture is 64M @ 0xe0000000
      > > [drm] AGP 0.99 on Intel 440BX @ 0xe0000000 64MB
      > > [drm] Initialized r128 2.1.2 20001215 on minor 63
      >
      > $ dmesg | grep agp
      > Linux agpgart interface v0.99 (c) Jeff Hartmann
      > agpgart: Maximum main memory to use for agp memory: 94M
      > agpgart: Detected Intel 440BX chipset
      > agpgart: AGP aperture is 64M @ 0xe0000000
      >
      > $ dmesg | grep drm
      > [drm] AGP 0.99 on Intel 440BX @ 0xe0000000 64MB
      > [drm] Initialized r128 2.1.2 20001215 on minor 63
      >
      > $ uname -a
      > Linux markd 2.4.0 #1 Thu Jan 11 15:14:11 EST 2001 i686 unknown
      >
      > from my /var/log/XFree86.0.log;
      >
      > (II) R128(0): [drm] Added 128 16384 byte vertex/indirect buffers
      > (II) R128(0): [drm] Mapped 128 vertex/indirect buffers
      > (II) R128(0): Direct rendering enabled
      >
      > When I try and run anything involved 3d type stuff the machine hangs
      > totally. No keyboard input (not even ctrl-alt-del or ctrl-alt-f1),
      no
      > screen movement (including pointer)...
      >
      > Any suggestions?
      >

      The same thing happens to me, except I am running an I8K. The first
      problem is that the agpgart reports 2x instead of 4x. Everything looks
      great but when you run something that utilizes openGL everything
      hangs. This bug has been reported to the DRI project (at sourceforge),
      but I have not seen any comments to it! The problem is probably in the
      kernel module r128 (may have something todo with it beeing M4 and not
      M3 perhaps?)

      / Daniel
    • Show all 10 messages in this topic