Loading ...
Sorry, an error occurred while loading the content.

24722Re: [linux-dell-laptops] Touchpad

Expand Messages
  • Marvin R. Pierce
    Jul 31, 2004
    • 0 Attachment
      On Sun, 1 Aug 2004 06:51 am, Jason Morganson wrote:
      > I have a Dell Inspiron 8200, I recently installed Slackware and have
      > been trying to get my touchpad working with no luck. I read every
      > HOW-TO i could find and read anything I could find. The ALP's pad
      > seems to be a little tricky though and doesn't work out of the box
      > for most people, but then other people have no problems with it. So
      > the help files i could find a very diverse. I was hoping maybe
      > someone here could help me out.
      >  
      > My system is a Dell Inspiron 8200, I am running Slackware 10.0,
      > kernel 2.6.7, the x.org window server, and KDE aKademy.
      >  
      > I read that gpm doesn't work well with the 8200, I tried with it on
      > and off and it didn't make a difference, it is disabled right now.

      Get the synaptic touchpad driver and follow the instructions as this
      works perfectly. I would also suggest that you get the latest kernel and
      compile in the options for dell as well as acpi as everything works on
      my I8.1K notebook.

      Section "InputDevice"
      Identifier "mouse.usb"
      Driver "mouse"
      Option "SendCoreEvents" "YES"
      Option "Device" "/dev/input/mice"
      Option "Protocol" "IMPS/2"
      Option "Emulate3Buttons" "YES"
      Option "ZAxisMapping" "4 5"
      EndSection

      Section "InputDevice"
      Identifier "touchpad"
      Driver "synaptics"
      Option "Device" "/dev/psaux"
      Option "Protocol" "auto-dev"
      Option "LeftEdge" "1700"
      Option "RightEdge" "5300"
      Option "TopEdge" "1700"
      Option "BottomEdge" "4200"
      Option "FingerLow" "25"
      Option "FingerHigh" "30"
      Option "MaxTapTime" "180"
      Option "MaxTapMove" "220"
      Option "VertScrollDelta" "100"
      Option "MinSpeed" "0.06"
      Option "MaxSpeed" "0.12"
      Option "AccelFactor" "0.0010"
      Option "SHMConfig" "on"
      # Option "Repeater" "/dev/ps2mouse"
      EndSection

      Section "ServerLayout"
      Identifier "Default Layout"
      Screen "Default Screen"
      InputDevice "Default Keyboard"
      InputDevice "mouse.usb"
      InputDevice "touchpad" "CorePointer"
      EndSection

      Let us know if this solves your problem.

      Marvin
    • Show all 4 messages in this topic