Loading ...
Sorry, an error occurred while loading the content.

2330Re: [linux-dell-laptops] Re: Maestro 3 works with latest ALSA drivers

Expand Messages
  • Jan Marius Evang
    Jan 20, 2001
    • 0 Attachment
      I had the same problem.

      After rebooting, the problem was gone

      MArius
      ----- Original Message -----
      From: <wolf_michael@...>
      To: <linux-dell-laptops@egroups.com>
      Sent: Saturday, January 20, 2001 5:14 AM
      Subject: [linux-dell-laptops] Re: Maestro 3 works with latest ALSA drivers


      > I believe I did exactly these. All was well until
      >
      > # /etc/rc.d/init.d/alsasound restart
      > Shutting down sound driver: alsactl: No soundcards found...
      > done
      > Starting sound driver: snd-card-maestro3 done
      > No mixer config in /etc/asound.conf, you have to unmute your card!
      > #
      >
      > Then I try to run 'alsamixer' but fail with
      > alsamixer: failed to open mixer #0/#0: No such file or directory
      >
      > And running gmix is hardly better -- I just get a diagnostic message
      > saying no mixers found, make sure you have sound support compiled into
      > the kernel. I'm running RedHat7.0 fresh out of the box, basically.
      >
      > Thoughts? Help?
      >
      > Thanks,
      >
      > Michael
      >
      > --- In linux-dell-laptops@egroups.com, brianhef-egroups@h... wrote:
      > > The latest ALSA drivers (vesion 5.10) work well with the Maestro3
      > > sound chip in my i8000 running Redhat 7.
      > > Here is what I did to make it work.
      > >
      > > First, downloaded all three of theses file from alsa-project.org:
      > > ftp://ftp.alsa-project.org/pub/driver/alsa-driver-0.5.10.tar.bz2
      > > ftp://ftp.alsa-project.org/pub/lib/alsa-lib-0.5.10.tar.bz2
      > > ftp://ftp.alsa-project.org/pub/utils/alsa-utils-0.5.10.tar.bz2
      > >
      > > #untarred the files:
      > > tar -Ixvf alsa-driver-0.5.10.tar.bz2
      > > tar -Ixvf alsa-libs-0.5.10.tar.bz2
      > > tar -Ixvf alsa-utils-0.5.10.tar.bz2
      > >
      > > #configure,make, and install:
      > > cd alsa-driver-0.5.10; ./configure; make; su -c 'make install'
      > > cd alsa-libs-0.5.10; ./configure; make; su -c 'make install'
      > > cd alsa-utils-0.5.10; ./configure; make; su -c 'make install'
      > >
      > > added these lines to /etc/modules.conf (as root user):
      > > #lines for alsa sound drivers
      > > alias char-major-116 snd
      > > alias char-major-14 soundcore
      > > alias snd-minor-oss-0 snd-mixer
      > > alias snd-minor-oss-3 snd-pcm1-oss
      > > alias snd-minor-oss-4 snd-pcm1-oss
      > > alias snd-minor-oss-5 snd-pcm1-oss
      > > alias snd-minor-oss-12 snd-pcm1-oss
      > > alias snd-card-0 snd-card-maestro3
      > > alias sound-service-1-12 snd-pcm-oss
      > >
      > > In order to make the sound card work after resuming from suspend I
      > > created (as root user) a file /etc/sysconfig/apm-scripts/apmcontinue
      > > with these lines :
      > > /etc/rc.d/init.d/alsasound restart
      > > /sbin/modprobe snd-mixer-oss
      > > /sbin/modprobe snd-pcm-oss
      > >
      > > To start the sound modules, run (as root):
      > > /etc/rc.d/init.d/alsasound restart
      > >
      > > I think the /etc/rc.d/init.d/alsasound script (and maybe the
      > > apmcontinue script) is Redhat-specific. I'm not sure how best to load
      > > and unload the modules in other linux distrubtions, but it's probably
      > > in the the alsa documentation.
      > >
      > > Most sound application I've tried work fine. I can record with a
      > > microphone, play cd's, play soundfiles with mpg123 and xmms and mix
      > > with the mixer. The gnome sound monitor applet and Extrace waveform
      > > display aren't working for me, and the built-in physical
      > > volume-control buttons on the Inspiron 8000 don't work either. Overall
      > > the system is very usable, though.
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
    • Show all 21 messages in this topic