Loading ...
Sorry, an error occurred while loading the content.

2037Re: [linux-dell-laptops] Re: Maestro 3 works with latest ALSA drivers

Expand Messages
  • T. Daniel Crawford
    Jan 3, 2001
    • 0 Attachment
      Brian,

      You were correct: the card was muted and I had to adjust it using a mixer
      program. Everything works great now, those some test MPEGs with audio just
      give static when played with either plaympeg or gtv.

      I am maintaining an I8000/RH7.0 web page and I have added your steps for
      getting the alsa drivers working. Do you mind if I add your name to the
      page to give you proper credit?

      http://orion.chem.vt.edu/i8000

      Thanks for your help!

      -Daniel


      On Wed, 3 Jan 2001, Brian Hefferan wrote:

      > The alsa drivers are still working for me on my i8000, in fact I'm on
      > an mp3 bing right now ;>.
      >
      > Here are couple more things to try:
      >
      > 1. try manually running the contents of the
      > /etc/sysconfig/apm-scripts/apmcontinue file I mentioned. That is, do
      > this as root (the first command assumes Redhat linux):
      >
      > etc/rc.d/init.d/alsasound restart
      > /sbin/modprobe snd-mixer-oss
      > /sbin/modprobe snd-pcm-oss
      >
      > 2. The alsa drivers start with the mixer muted by default, so it need
      > to be unmuted before you get any sound. I started /usr/bin/alsamixer,
      > used the arrow keys to navigate and adjust volume levels, and used the
      > "m" key to toggle off the muting. Quit with the escape key. Once it's
      > unmuted it should stay unmuted even after a reboot.
      >
      > I'm using the stock redhat 7 kernel (2.2.16-22) with no modification,
      > although I am running the latest pcmcia drivers from Sourcforge as you
      > suggested.
      >
      > I did not make any changes to /etc/asound.conf, but here is what's in
      > mine:
      > # ALSA driver configuration
      > # This configuration is generated with the alsactl program.
      >
      > soundcard("card1") {
      > mixer("ESS Maestro3") {
      > ; The type is 'bool'.
      > switch("AC97 Mono Output Select", false)
      > ; The type is 'bool'.
      > switch("AC97 Second MIC", false)
      > ; The type is 'bool'.
      > switch("ADC/DAC Loopback", false)
      > element("Input Gain Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 15
      > ; Voice 1 : Min 0 Max 15
      > element("Input Gain Volume",0,200,Volume1(11,11))
      > element("Master Mono Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 31
      > element("Master Mono Volume",0,200,Volume1(27))
      > element("Surround Switch",0,100,Switch1(on,on))
      > ; Voice 0 : Min 0 Max 31
      > ; Voice 1 : Min 0 Max 31
      > element("Surround Volume",0,200,Volume1(25,25))
      > element("Master Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 31
      > ; Voice 1 : Min 0 Max 31
      > element("Master Volume",0,200,Volume1(27,27))
      > ; The 3D effect has an on/off switch.
      > ; Wide : Min 0 Max 3
      > element("Effect",0,600,_3D_Effect1(sw=off,wide=0))
      > element("Aux Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 31
      > ; Voice 1 : Min 0 Max 31
      > element("Aux Volume",0,200,Volume1(26,26))
      > element("Video Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 31
      > ; Voice 1 : Min 0 Max 31
      > element("Video Volume",0,200,Volume1(19,19))
      > element("CD Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 31
      > ; Voice 1 : Min 0 Max 31
      > element("CD Volume",0,200,Volume1(26,26))
      > element("Line Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 31
      > ; Voice 1 : Min 0 Max 31
      > element("Line Volume",0,200,Volume1(23,23))
      > element("MIC Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 31
      > element("MIC Volume",0,200,Volume1(25))
      > ; Voice 0 : Min 0 Max 1
      > element("MIC Boost",0,200,Volume1(0))
      > element("Phone Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 31
      > element("Phone Volume",0,200,Volume1(22))
      > element("PC Speaker Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 15
      > element("PC Speaker Volume",0,200,Volume1(12))
      > element("PCM Switch",0,101,Switch2(on))
      > ; Voice 0 : Min 0 Max 31
      > ; Voice 1 : Min 0 Max 31
      > element("PCM Volume",0,200,Volume1(13,13))
      > element("Mono Output MUX",0,401,Mux2(element("Mono-Out
      > Accumulator",0,301))) element("Input
      > MUX",0,400,Mux1(element("Line",0,0),element("Line",0,0)))
      > }
      > }
      >
      >
      > Here are the results I get from /sbin/lsmod:
      > Module Size Used by
      > snd-pcm-oss 16460 0
      > snd-pcm-plugin 14248 0 [snd-pcm-oss]
      > snd-mixer-oss 3924 0 [snd-pcm-oss]
      > snd-card-maestro3 11604 0
      > snd-pcm 29464 0 [snd-pcm-oss snd-pcm-plugin
      > snd-card-maestro3]
      > snd-timer 8064 0 [snd-pcm]
      > snd-ac97-codec 23680 0 [snd-card-maestro3]
      > snd-mixer 23356 0 [snd-mixer-oss snd-ac97-codec]
      > snd 35820 1 [snd-pcm-oss snd-pcm-plugin
      > snd-mixer-oss snd-card-maestro3 snd-pcm snd-timer snd-ac97-codec
      > snd-mixer]
      > soundcore 2596 2 [snd]
      > binfmt_misc 3280 0
      > ltmodem 453200 0 (unused)
      > ds 6248 2
      > i82365 21552 2
      > pcmcia_core 43776 0 [ds i82365]
      > lockd 31176 1 (autoclean)
      > sunrpc 52964 1 (autoclean) [lockd]
      > eepro100 16180 1 (autoclean)
      > usb-uhci 19052 0 (unused)
      >
      > (the eepro100 line is for the intel-based modem/network card that
      > shipped with my machine. I think other i8000s use a 3com card instead)
      >
      > Let me know if you still have trouble.
      > ---Brian
      >
      > ----In linux-dell-laptops@egroups.com, "T. Daniel Crawford"
      > <crawdad@v...> wrote:
      > > Would it be possible to get a copy of your /etc/asound.conf file and
      > the
      > > output from the "lsmod" command on your I8000?
      >
      >
      >
      >
      > --------------------------------------------------------------
      > Please post your X config files in the group links or database
      >
    • Show all 21 messages in this topic