Loading ...
Sorry, an error occurred while loading the content.
 

AW: [libertybasic] LB on 3.11

Expand Messages
  • Stefan Pendl
    ... As Carl pointed out there is a 16-bit LB version available to download at his site. Here is a litle table about the relationship between LB and Windows.
    Message 1 of 18 , May 2, 2007
      >
      > think the latest one, I only bought the full version recently.
      >

      As Carl pointed out there is a 16-bit LB version available to download at
      his site.

      Here is a litle table about the relationship between LB and Windows.

      16-bit Windows 3.x and earlier ....... LB 2.x and earlier
      32-bit Windows 4.x (95) and newer .... LB 3.x and newer
      64-bit Windows 5.2 (x64) and newer ... LB 4.x and newer

      LB 3.x and 4.x will not work at all on any 16-bit Windows, this is a
      limitation of Windows.

      ---
      Stefan Pendl
    • Chergarj@cs.com
      What was Windows 5.2 ? When did that become released? G C In a message dated 05/02/2007 11:03:08 AM Pacific Daylight Time, ... [Non-text portions of
      Message 2 of 18 , May 2, 2007
        What was Windows 5.2 ? When did that become released?

        G C

        In a message dated 05/02/2007 11:03:08 AM Pacific Daylight Time,
        pendl2megabit@... writes:
        > <Here is a litle table about the relationship between LB and Windows.
        >
        > 16-bit Windows 3.x and earlier ....... LB 2.x and earlier
        > 32-bit Windows 4.x (95) and newer .... LB 3.x and newer
        > 64-bit Windows 5.2 (x64) and newer ... LB 4.x and newer
        >


        [Non-text portions of this message have been removed]
      • Stefan Pendl
        ... Windows NT 5.2 is Windows XP x64 Edition and Windows Server 2003 x64 Edition . These are the 64-bit Windows Editions. ... Stefan Pendl
        Message 3 of 18 , May 2, 2007
          >
          > What was Windows 5.2 ? When did that become released?
          >

          Windows NT 5.2 is "Windows XP x64 Edition" and "Windows Server 2003 x64
          Edition".
          These are the 64-bit Windows Editions.

          ---
          Stefan Pendl
        • beachkidken
          I believed I downloaded the LB 2.X version Carl mentioned the other day. While it may run on Windows 3.01 and/or 3.11, I wonder if it would run on M/S DOS
          Message 4 of 18 , May 3, 2007
            I believed I downloaded the LB 2.X version Carl mentioned the other
            day. While it may run on Windows 3.01 and/or 3.11, I wonder if it
            would run on M/S DOS v6.22?

            Ken

            --- In libertybasic@yahoogroups.com, "Stefan Pendl"
            <pendl2megabit@...> wrote:
            >
            >
            > As Carl pointed out there is a 16-bit LB version available to
            download at
            > his site.
            >
            > Here is a litle table about the relationship between LB and Windows.
            >
            > 16-bit Windows 3.x and earlier ....... LB 2.x and earlier
            > 32-bit Windows 4.x (95) and newer .... LB 3.x and newer
            > 64-bit Windows 5.2 (x64) and newer ... LB 4.x and newer
            >
            > LB 3.x and 4.x will not work at all on any 16-bit Windows, this is a
            > limitation of Windows.
            >
            > ---
            > Stefan Pendl
          • mst_crow5429
            ... download at ... Does LB 4.x actually run in x86-64 mode, or run in 32-bit mode on 64-bit Windows? Also, just out of curiosity, would it be possible to get
            Message 5 of 18 , May 3, 2007
              --- In libertybasic@yahoogroups.com, "Stefan Pendl"
              <pendl2megabit@...> wrote:
              >
              > >
              > > think the latest one, I only bought the full version recently.
              > >
              >
              > As Carl pointed out there is a 16-bit LB version available to
              download at
              > his site.
              >
              > Here is a litle table about the relationship between LB and Windows.
              >
              > 16-bit Windows 3.x and earlier ....... LB 2.x and earlier
              > 32-bit Windows 4.x (95) and newer .... LB 3.x and newer
              > 64-bit Windows 5.2 (x64) and newer ... LB 4.x and newer
              >
              > LB 3.x and 4.x will not work at all on any 16-bit Windows, this is a
              > limitation of Windows.
              >
              > ---
              > Stefan Pendl
              >
              Does LB 4.x actually run in x86-64 mode, or run in 32-bit mode on
              64-bit Windows? Also, just out of curiosity, would it be possible to
              get 32-bit LB working on Windows 3.x with Win32S? Or maybe as Win32S
              hasn't been updated in so many years (last update 1996?), it would be
              impossible.
            • Carl Gundel
              Hi, It is not a DOS programming language, sorry. -Carl ...... Original Message ....... On Thu, 03 May 2007 15:27:15 -0000 beachkidken
              Message 6 of 18 , May 3, 2007
                Hi,

                It is not a DOS programming language, sorry.

                -Carl

                ...... Original Message .......
                On Thu, 03 May 2007 15:27:15 -0000 "beachkidken" <ken.g@...>
                wrote:
                >I believed I downloaded the LB 2.X version Carl mentioned the other
                >day. While it may run on Windows 3.01 and/or 3.11, I wonder if it
                >would run on M/S DOS v6.22?
                >
                >Ken
                >
                >--- In libertybasic@yahoogroups.com, "Stefan Pendl"
                ><pendl2megabit@...> wrote:
                >>
                >>
                >> As Carl pointed out there is a 16-bit LB version available to
                >download at
                >> his site.
                >>
                >> Here is a litle table about the relationship between LB and Windows.
                >>
                >> 16-bit Windows 3.x and earlier ....... LB 2.x and earlier
                >> 32-bit Windows 4.x (95) and newer .... LB 3.x and newer
                >> 64-bit Windows 5.2 (x64) and newer ... LB 4.x and newer
                >>
                >> LB 3.x and 4.x will not work at all on any 16-bit Windows, this is a
                >> limitation of Windows.
                >>
                >> ---
                >> Stefan Pendl
                >
                >
                >
                >
                >
                >
                >Yahoo! Groups Links
                >
                >
                >
                >
                >
              • rwstradewinds
                If you re looking for a DOS BASIC, try Application BASIC (AP BASIC). It s a free shareware product. It s a fairly good compiled BASIC that was derived from
                Message 7 of 18 , May 3, 2007
                  If you're looking for a DOS BASIC, try Application BASIC (AP BASIC).
                  It's a free shareware product. It's a fairly good compiled BASIC that
                  was derived from MS-DOS based Microsoft BASIC. If you can't find it
                  posted anywhere, let me know. I'll dig out my floppy.

                  Regards,

                  Bob Starinsky


                  --- In libertybasic@yahoogroups.com, Carl Gundel <carlg@...> wrote:
                  >
                  > Hi,
                  >
                  > It is not a DOS programming language, sorry.
                  >
                  > -Carl
                  >
                  > ...... Original Message .......
                  > On Thu, 03 May 2007 15:27:15 -0000 "beachkidken" <ken.g@...>
                  > wrote:
                  > >I believed I downloaded the LB 2.X version Carl mentioned the other
                  > >day. While it may run on Windows 3.01 and/or 3.11, I wonder if it
                  > >would run on M/S DOS v6.22?
                  > >
                  > >Ken
                  > >
                  > >--- In libertybasic@yahoogroups.com, "Stefan Pendl"
                  > ><pendl2megabit@> wrote:
                  > >>
                  > >>
                  > >> As Carl pointed out there is a 16-bit LB version available to
                  > >download at
                  > >> his site.
                  > >>
                  > >> Here is a litle table about the relationship between LB and
                  Windows.
                  > >>
                  > >> 16-bit Windows 3.x and earlier ....... LB 2.x and earlier
                  > >> 32-bit Windows 4.x (95) and newer .... LB 3.x and newer
                  > >> 64-bit Windows 5.2 (x64) and newer ... LB 4.x and newer
                  > >>
                  > >> LB 3.x and 4.x will not work at all on any 16-bit Windows, this
                  is a
                  > >> limitation of Windows.
                  > >>
                  > >> ---
                  > >> Stefan Pendl
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >Yahoo! Groups Links
                  > >
                  > >
                  > >
                  > >
                  > >
                  >
                • Mike
                  ... download at ... Windows. ... a ... Stefan (& Sarah) I may be wrong, but I believe there was a 32bit extension to win3.1, called something like win32s? It
                  Message 8 of 18 , May 3, 2007
                    --- In libertybasic@yahoogroups.com, "Stefan Pendl"
                    <pendl2megabit@...> wrote:
                    >
                    > >
                    > > think the latest one, I only bought the full version recently.
                    > >
                    >
                    > As Carl pointed out there is a 16-bit LB version available to
                    download at
                    > his site.
                    >
                    > Here is a litle table about the relationship between LB and
                    Windows.
                    >
                    > 16-bit Windows 3.x and earlier ....... LB 2.x and earlier
                    > 32-bit Windows 4.x (95) and newer .... LB 3.x and newer
                    > 64-bit Windows 5.2 (x64) and newer ... LB 4.x and newer
                    >
                    > LB 3.x and 4.x will not work at all on any 16-bit Windows, this is
                    a
                    > limitation of Windows.
                    >
                    > ---
                    > Stefan Pendl
                    >

                    Stefan (& Sarah)

                    I may be wrong, but I believe there was a 32bit extension to win3.1,
                    called something like win32s? It is a long time since I used win3.1
                    but believe that my machine had this 32bit extension.

                    Just found http://web.mit.edu/cascon/microsoft/win32sfaq.htm which
                    may help but still don't know if LB3 or LB4 would run under win32s.

                    HTH
                    Mike.
                  • Carl Gundel
                    ...... Original Message .......
                    Message 9 of 18 , May 3, 2007
                      ...... Original Message .......
                      On Thu, 03 May 2007 20:03:46 -0000 "Mike" <karemi@...> wrote:
                      >--- In libertybasic@yahoogroups.com, "Stefan Pendl"
                      ><pendl2megabit@...> wrote:
                      >>
                      >> >
                      >> > think the latest one, I only bought the full version recently.
                      >> >
                      >>
                      >> As Carl pointed out there is a 16-bit LB version available to
                      >download at
                      >> his site.
                      >>
                      >> Here is a litle table about the relationship between LB and
                      >Windows.
                      >>
                      >> 16-bit Windows 3.x and earlier ....... LB 2.x and earlier
                      >> 32-bit Windows 4.x (95) and newer .... LB 3.x and newer
                      >> 64-bit Windows 5.2 (x64) and newer ... LB 4.x and newer
                      >>
                      >> LB 3.x and 4.x will not work at all on any 16-bit Windows, this is
                      >a
                      >> limitation of Windows.
                      >>
                      >> ---
                      >> Stefan Pendl
                      >>
                      >
                      >Stefan (& Sarah)
                      >I may be wrong, but I believe there was a 32bit extension to win3.1,
                      >called something like win32s? It is a long time since I used win3.1
                      >but believe that my machine had this 32bit extension.
                      >
                      >Just found http://web.mit.edu/cascon/microsoft/win32sfaq.htm which
                      >may help but still don't know if LB4 or LB4 would run under win32s.
                      >
                      >HTH
                      >Mike.
                      >
                      >
                      >
                      >
                      >
                      >
                      >Yahoo! Groups Links
                      >
                      >
                      >
                      >
                      >
                    • laurie camion
                      Sorry, but I can no longer resist asking the question. Why would anyone in 2007 buy and use windows 3.11 ? Carl Gundel wrote: ......
                      Message 10 of 18 , May 4, 2007
                        Sorry, but I can no longer resist asking the question. Why would anyone in 2007 buy and use windows 3.11 ?

                        Carl Gundel <carlg@...> wrote:

                        ...... Original Message .......
                        On Thu, 03 May 2007 20:03:46 -0000 "Mike" <karemi@...> wrote:
                        >--- In libertybasic@yahoogroups.com, "Stefan Pendl"
                        ><pendl2megabit@...> wrote:
                        >>
                        >> >
                        >> > think the latest one, I only bought the full version recently.
                        >> >
                        >>
                        >> As Carl pointed out there is a 16-bit LB version available to
                        >download at
                        >> his site.
                        >>
                        >> Here is a litle table about the relationship between LB and
                        >Windows.
                        >>
                        >> 16-bit Windows 3.x and earlier ....... LB 2.x and earlier
                        >> 32-bit Windows 4.x (95) and newer .... LB 3.x and newer
                        >> 64-bit Windows 5.2 (x64) and newer ... LB 4.x and newer
                        >>
                        >> LB 3.x and 4.x will not work at all on any 16-bit Windows, this is
                        >a
                        >> limitation of Windows.
                        >>
                        >> ---
                        >> Stefan Pendl
                        >>
                        >
                        >Stefan (& Sarah)
                        >I may be wrong, but I believe there was a 32bit extension to win3.1,
                        >called something like win32s? It is a long time since I used win3.1
                        >but believe that my machine had this 32bit extension.
                        >
                        >Just found http://web.mit.edu/cascon/microsoft/win32sfaq.htm which
                        >may help but still don't know if LB4 or LB4 would run under win32s.
                        >
                        >HTH
                        >Mike.
                        >
                        >
                        >
                        >
                        >
                        >
                        >Yahoo! Groups Links
                        >
                        >
                        >
                        >
                        >






                        ---------------------------------
                        Ahhh...imagining that irresistible "new car" smell?
                        Check outnew cars at Yahoo! Autos.

                        [Non-text portions of this message have been removed]
                      • beachkidken
                        Just fooling around with getting an old computer, an HP 4535 from a neighbor which has no setup/recovery/restore floppy disks available anywhere after
                        Message 11 of 18 , May 4, 2007
                          Just fooling around with getting an old computer, an HP 4535 from a
                          neighbor which has no setup/recovery/restore floppy disks available
                          anywhere after searching for 10 days. It has 96 MB for RAM and 6 GB
                          for hard drive. An antique machine if I can say so myself. LOL. I
                          just happen to have a set of M/S DOS 6.22 and Windows 3.11 floppy
                          disks collecting dust.

                          Ken

                          --- In libertybasic@yahoogroups.com, laurie camion <lauriecam2006@...>
                          wrote:
                          >
                          > Sorry, but I can no longer resist asking the question. Why would
                          anyone in 2007 buy and use windows 3.11 ?
                          >
                          > Carl Gundel <carlg@...> wrote:
                          >
                          > ...... Original Message .......
                          > On Thu, 03 May 2007 20:03:46 -0000 "Mike" <karemi@...> wrote:
                          > >--- In libertybasic@yahoogroups.com, "Stefan Pendl"
                          > ><pendl2megabit@> wrote:
                          > >>
                        • Chergarj@cs.com
                          ... Maybe because someone wants to use DOS for important purposes and also wants a version of Windows available on the same computer, and older versions of
                          Message 12 of 18 , May 4, 2007
                            laurie camion <lauriecam2006@...> wrote:

                            >Sorry, but I can no longer resist asking the question. Why would anyone in 2007 buy and use windows 3.11 ?
                            >
                            >Carl Gundel <carlg@...> wrote:          
                            >
                            >...... Original Message .......
                            >On Thu, 03 May 2007 20:03:46 -0000 "Mike" <karemi@...> wrote:
                            >>--- In libertybasic@yahoogroups.com, "Stefan Pendl"
                            >><pendl2megabit@...> wrote:
                            >

                            Maybe because someone wants to use DOS for important purposes and also wants a version of Windows available on the same computer, and older versions of Windows programs would be more than sufficient for the user's purposes. I know no specific programs for reference.

                            G C
                          • laurie camion
                            There are plenty of DOS s around, I use em myself, but the OP wrote that they had just purchased W 3.11 and that was what I found surprising. ... Maybe
                            Message 13 of 18 , May 4, 2007
                              There are plenty of DOS's around, I use 'em myself, but the OP wrote that they had just purchased W 3.11 and that was what I found surprising.

                              Chergarj@... wrote: laurie camion <lauriecam2006@...> wrote:

                              >Sorry, but I can no longer resist asking the question. Why would anyone in 2007 buy and use windows 3.11 ?
                              >
                              >Carl Gundel <carlg@...> wrote:
                              >
                              >...... Original Message .......
                              >On Thu, 03 May 2007 20:03:46 -0000 "Mike" <karemi@...> wrote:
                              >>--- In libertybasic@yahoogroups.com, "Stefan Pendl"
                              >><pendl2megabit@...> wrote:
                              >

                              Maybe because someone wants to use DOS for important purposes and also wants a version of Windows available on the same computer, and older versions of Windows programs would be more than sufficient for the user's purposes. I know no specific programs for reference.

                              G C





                              ---------------------------------
                              Ahhh...imagining that irresistible "new car" smell?
                              Check outnew cars at Yahoo! Autos.

                              [Non-text portions of this message have been removed]
                            • Stefan Pendl
                              ... LB is a 32-bit applicaton and will therefore only run in 32-bit mode. You will have to read the Platform SDK or MSDN about redirection carefully to get
                              Message 14 of 18 , May 15, 2007
                                > Does LB 4.x actually run in x86-64 mode, or run in 32-bit
                                > mode on 64-bit Windows? Also, just out of curiosity, would
                                > it be possible to get 32-bit LB working on Windows 3.x with
                                > Win32S? Or maybe as Win32S hasn't been updated in so many
                                > years (last update 1996?), it would be impossible.
                                >

                                LB is a 32-bit applicaton and will therefore only run in 32-bit mode.
                                You will have to read the Platform SDK or MSDN about redirection carefully
                                to get some things working.

                                For example, some Windows programs come only as 64-bit version, so you need
                                to turn off file system redirection before you can call them with RUN.
                                You need to turn file system redirection on directly after RUN to avoid any
                                problems.

                                ---
                                Stefan Pendl
                              Your message has been successfully submitted and would be delivered to recipients shortly.