Loading ...
Sorry, an error occurred while loading the content.

Re: [libertybasic] Re: Shaped windows:Problem running

Expand Messages
  • William Roggow
    Janet/Stefan Maybe it is just my setup, but I couldn t get anything to run. After going through the program line by line, I discovered my caveman sprites to
    Message 1 of 3 , Aug 1, 2006
    • 0 Attachment
      Janet/Stefan

      Maybe it is just my setup, but I couldn't get anything to run. After going
      through the program line by line, I discovered my caveman sprites to be in a
      different location. "C:\Program Files\Liberty Basic v4.03" If someone else
      can't get the program to run, this might be one place to check.

      Bill
    • JanetTerra
      You re right, of course, Bill. What I did was change this line in the beginning of the program LBFolder$ = DefaultDir$ The program must be run from the LB
      Message 2 of 3 , Aug 1, 2006
      • 0 Attachment
        You're right, of course, Bill. What I did was change this line in
        the beginning of the program

        LBFolder$ = DefaultDir$

        The program must be run from the LB Root Directory in order for the
        sprites to be found. Of course, you can always modify the program
        to show your own sprites in whatever directory you choose. ;-)

        Don't forget to add the WAIT statement in the sub called by the
        timer to prevent a possible bug crash.

        sub drawFrame
        #m.g "drawsprites"
        wait
        end sub

        Janet

        --- In libertybasic@yahoogroups.com, "William Roggow" <roggowb@...>
        wrote:
        >
        > Janet/Stefan
        >
        > Maybe it is just my setup, but I couldn't get anything to run.
        After going
        > through the program line by line, I discovered my caveman sprites
        to be in a
        > different location. "C:\Program Files\Liberty Basic v4.03" If
        someone else
        > can't get the program to run, this might be one place to check.
        >
        > Bill
        >
      • pendl2megabit
        Message 3 of 3 , Aug 1, 2006
        • 0 Attachment
          >
          > You're right, of course, Bill. What I did was change this line in
          > the beginning of the program
          >
          > LBFolder$ = DefaultDir$
          >

          The reason I included the LBFolder$ variable was, because it would be easy
          to change for different localizations and setups.
          I usualy do not run LB through the desktop icon or any other icon where the
          working folder would be set to the LB install dir (DefaltDir$ would not work
          in this case), so I can run it from everywhere.

          ---
          Stefan Pendl



          ___________________________________________________________
          Telefonate ohne weitere Kosten vom PC zum PC: http://messenger.yahoo.de
        Your message has been successfully submitted and would be delivered to recipients shortly.