Loading ...
Sorry, an error occurred while loading the content.
 

tooltips in win2k and win xp

Expand Messages
  • Bruno Schaefer
    Tooltips don t appear in win2000 and winXP, they appear only in win98. What is the reason? What can I do? Thanks, Bruno
    Message 1 of 8 , Jun 23, 2004
      Tooltips don't appear in win2000 and winXP, they appear only in win98.

      What is the reason? What can I do?

      Thanks, Bruno
    • Alyce
      ... win98. ... Sorry, I ve been away. Do you mean tooltips associated with a real API toolbar? In XP, the first button shows the tip, the others don t. If the
      Message 2 of 8 , Jun 23, 2004
        --- In libertybasic@yahoogroups.com, "Bruno Schaefer"
        <bup.schaefer@f...> wrote:
        >
        > Tooltips don't appear in win2000 and winXP, they appear only in
        win98.
        >
        > What is the reason? What can I do?
        >
        > Thanks, Bruno

        Sorry, I've been away. Do you mean tooltips associated with a real
        API toolbar? In XP, the first button shows the tip, the others don't.
        If the XP manifest is not used, all tooltips show. I developed a
        workaround method to add tooltips to toolbars by using the coords of
        the buttons, rather than the usual way. It worked just fine for me
        until Carl automatically included the manifest for XP, but after that
        only the first button had a tip.

        What can you do? You can study the docs and do some trial and error
        as I did, hoping to come up with a fix. Perhaps Dennis or Brent knows
        a way around this. When I have a chance, I'll try to find a fix. I'd
        be more inclined to use a fake toolbar with LB bmpbuttons, since
        tooltips work fine with them. I usually look for the simplest
        solutions, if they'll suit the need.

        -Alyce
      • Brent Thorn
        ... knows ... I d ... For the ViviFire IDE I m currently developing, I use a different technique to show tooltips in an API-created toolbar. Since this is a
        Message 3 of 8 , Jun 23, 2004
          --- In libertybasic@yahoogroups.com, "Alyce" <alycewatson@c...> wrote:
          > --- In libertybasic@yahoogroups.com, "Bruno Schaefer"
          > <bup.schaefer@f...> wrote:
          > > Tooltips don't appear in win2000 and winXP, they appear only in
          > win98.
          > > What is the reason? What can I do?
          >
          >
          > What can you do? You can study the docs and do some trial and error
          > as I did, hoping to come up with a fix. Perhaps Dennis or Brent
          knows
          > a way around this. When I have a chance, I'll try to find a fix.
          I'd
          > be more inclined to use a fake toolbar with LB bmpbuttons, since
          > tooltips work fine with them. I usually look for the simplest
          > solutions, if they'll suit the need.
          >
          For the ViviFire IDE I'm currently developing, I use a different
          technique to show tooltips in an API-created toolbar. Since this is a
          project to demonstrate the usefullness of my WMLiberty DLL, I use it
          to trap the TBN_GETINFOTIP notification.

          Since I have no real access to a 2k/XP machine, it might be useful to
          know how well this works on these platforms. If a handful of people
          want to test a pre-alpha of ViviFire, please send me a private e-mail.

          -Brent
        • dennis_mckinney
          ... don t. ... of ... that ... error ... knows ... I d ... I don t seem to have any problems with tooltips in XP. The toolbar tooltips in JaLBe display
          Message 4 of 8 , Jun 28, 2004
            --- In libertybasic@yahoogroups.com, "Alyce" <alycewatson@c...>
            wrote:
            > --- In libertybasic@yahoogroups.com, "Bruno Schaefer"
            > <bup.schaefer@f...> wrote:
            > >
            > > Tooltips don't appear in win2000 and winXP, they appear only in
            > win98.
            > >
            > > What is the reason? What can I do?
            > >
            > > Thanks, Bruno
            >
            > Sorry, I've been away. Do you mean tooltips associated with a real
            > API toolbar? In XP, the first button shows the tip, the others
            don't.
            > If the XP manifest is not used, all tooltips show. I developed a
            > workaround method to add tooltips to toolbars by using the coords
            of
            > the buttons, rather than the usual way. It worked just fine for me
            > until Carl automatically included the manifest for XP, but after
            that
            > only the first button had a tip.
            >
            > What can you do? You can study the docs and do some trial and
            error
            > as I did, hoping to come up with a fix. Perhaps Dennis or Brent
            knows
            > a way around this. When I have a chance, I'll try to find a fix.
            I'd
            > be more inclined to use a fake toolbar with LB bmpbuttons, since
            > tooltips work fine with them. I usually look for the simplest
            > solutions, if they'll suit the need.
            >
            > -Alyce

            I don't seem to have any problems with tooltips in XP. The toolbar
            tooltips in JaLBe display correctly as do the button tooltips in
            Easy Tooltips. Both are available at the Liberty Belle.
            http://www.syberden.net/libertybelle/jalbe.html
            http://www.syberden.net/libertybelle/lb3code.htm

            What gives? Have I missed something?
            -Dennis
          • dirtbottom@starband.net
            Dennis, Just downloaded your tooltips. WORKS GREAT. Thanks a lot. Gary ... Outgoing mail is certified Virus Free. Checked by AVG anti-virus system
            Message 5 of 8 , Jun 28, 2004
              Dennis,
              Just downloaded your tooltips. WORKS GREAT. Thanks a lot.
              Gary





              >I don't seem to have any problems with tooltips in XP. The toolbar
              >tooltips in JaLBe display correctly as do the button tooltips in
              >Easy Tooltips. Both are available at the Liberty Belle.
              >http://www.syberden.net/libertybelle/jalbe.html
              >http://www.syberden.net/libertybelle/lb3code.htm
              >
              >What gives? Have I missed something?
              >-Dennis

              ----------


              ---
              Outgoing mail is certified Virus Free.
              Checked by AVG anti-virus system (http://www.grisoft.com).
              Version: 6.0.710 / Virus Database: 466 - Release Date: 6/23/2004


              [Non-text portions of this message have been removed]
            • Alyce
              ... Yes, Dennis, you missed something! Your method uses callbacks (I think) to handle the tooltips. My method was simpler and used the coords of the buttons to
              Message 6 of 8 , Jun 29, 2004
                --- In libertybasic@yahoogroups.com, "dennis_mckinney" <dennis@s...>
                wrote:
                >
                > I don't seem to have any problems with tooltips in XP. The toolbar
                > tooltips in JaLBe display correctly as do the button tooltips in
                > Easy Tooltips. Both are available at the Liberty Belle.
                > http://www.syberden.net/libertybelle/jalbe.html
                > http://www.syberden.net/libertybelle/lb3code.htm
                >
                > What gives? Have I missed something?
                > -Dennis

                Yes, Dennis, you missed something! Your method uses callbacks (I
                think) to handle the tooltips. My method was simpler and used the
                coords of the buttons to set the tooltips. That is an alternate way
                that is quite acceptable, although it doesn't work right if the
                toolbar wraps when the window is made smaller. The problem we are
                discussing is that the method works in XP without the manifest, but
                not with it. Your method works all the time.

                To all: visit Dennis's webpage for a way cool data grid control
                written by Dennis himself!

                -Alyce
              • Dennis
                ... ... toolbar ... way ... but ... Nope, no callbacks. I create the toolbar without buttons, tooltips, or bitmap then add add them to the
                Message 7 of 8 , Jun 29, 2004
                  --- In libertybasic@yahoogroups.com, "Alyce" <alycewatson@c...>
                  wrote:
                  > --- In libertybasic@yahoogroups.com, "dennis_mckinney"
                  <dennis@s...>
                  > wrote:
                  > >
                  > > I don't seem to have any problems with tooltips in XP. The
                  toolbar
                  > > tooltips in JaLBe display correctly as do the button tooltips in
                  > > Easy Tooltips. Both are available at the Liberty Belle.
                  > > http://www.syberden.net/libertybelle/jalbe.html
                  > > http://www.syberden.net/libertybelle/lb3code.htm
                  > >
                  > > What gives? Have I missed something?
                  > > -Dennis
                  >
                  > Yes, Dennis, you missed something! Your method uses callbacks (I
                  > think) to handle the tooltips. My method was simpler and used the
                  > coords of the buttons to set the tooltips. That is an alternate
                  way
                  > that is quite acceptable, although it doesn't work right if the
                  > toolbar wraps when the window is made smaller. The problem we are
                  > discussing is that the method works in XP without the manifest,
                  but
                  > not with it. Your method works all the time.
                  >
                  > To all: visit Dennis's webpage for a way cool data grid control
                  > written by Dennis himself!
                  >
                  > -Alyce

                  Nope, no callbacks. I create the toolbar without buttons, tooltips,
                  or bitmap then add add them to the toolbar. When it wraps during a
                  resize the tooltip window is destroyed, then recreated with the new
                  coords of the buttons.

                  -Dennis
                • Alyce
                  ... Dennis, With your gracious and generous help, I was able to fix the problem with tooltips on an API toolbar with the XP manifest in the toolbar maker in
                  Message 8 of 8 , Jun 30, 2004
                    --- In libertybasic@yahoogroups.com, "Dennis" <dennis@s...> wrote:
                    > Nope, no callbacks. I create the toolbar without buttons, tooltips,
                    > or bitmap then add add them to the toolbar. When it wraps during a
                    > resize the tooltip window is destroyed, then recreated with the new
                    > coords of the buttons.
                    >
                    > -Dennis

                    Dennis,

                    With your gracious and generous help, I was able to fix the problem
                    with tooltips on an API toolbar with the XP manifest in the toolbar
                    maker in LBW. It will be in the next update. You're the best!

                    -Alyce
                  Your message has been successfully submitted and would be delivered to recipients shortly.