Loading ...
Sorry, an error occurred while loading the content.

47492Re: [LIBERTYBASIC] Re:

Expand Messages
  • Marc Rossi
    May 3, 2014
      Hi, Rod.  I looked at your code and I was only getting the bmp using the memory commands  GetDC etc..
      Do I have to draw the bmp or use getbmp to make it work?
      Thanks,
      Marc
      On Saturday, May 3, 2014 6:05 AM, "rodbird@..." <rodbird@...> wrote:
       
      Flush does make the difference, remove the flush in this code and your error is replicated. So do you have the flush command in the correct place? Is it bypassed or never called?

       WindowWidth = 650
          WindowHeight = 650
          open "temp" for graphics as #1
          #1 "down"
          for x= 0 to 540 step 60
          for y= 0 to 540 step 60
              if toggle then
                  #1 "backcolor red"
                  #1 "place ";x;" ";y;" ; boxfilled ";x+60;" ";y+60
                  toggle=0
              else
                  #1 "backcolor yellow"
                  #1 "place ";x;" ";y;" ; boxfilled ";x+60;" ";y+60
                  toggle=1
              end if
          next
          next
          #1 "getbmp bmp 0 0 600 600"
          close #1

          WindowWidth = 300
          WindowHeight = 300
          graphicbox #1.gb, 0, 0, 200, 200
          open "test" for window as #1
          #1 "trapclose [quit]"
          #1.gb "horizscrollbar on 0 400"
          #1.gb "vertscrollbar on 0 400"
          #1.gb "down ; drawbmp bmp 0 0 ; flush"
          wait

          [quit]
          close #1
          end



    • Show all 7 messages in this topic