Loading ...
Sorry, an error occurred while loading the content.

Re: It rises from the grave (Part 4)

Expand Messages
  • ktony1313
    This was a fascinating and informative series. I m not really up on the internal details of the MP4, but I know enough basic audio electronics to follow the
    Message 1 of 9 , Jan 28, 2011
    • 0 Attachment
      This was a fascinating and informative series. I'm not really up on the internal details of the MP4, but I know enough basic audio electronics to follow the descriptions. Thanks for sharing!

      --- In korg_mono-poly@yahoogroups.com, Steve Carter <synth@...> wrote:
      >
      > This is the last part of my tale of woe. I can already hear shouts of "who is this guy, where did he crawl out from and why does he think we're interested in his trainwreck of a Mono/Poly" Anyway I promise you this is the last!
      >
      > The final job was to look at the board (KLM-398) that controls the offset voltage to the VCOs and the board (KLM-357) that controls the heating current in the SSM2033s. The two TL072 ICs had blown on the offset board and the two 4558 ICs had bitten the dust but the four 2SD794 power transistors were OK on the heater control board. After changing the ICs I connected the plug to the board and checked that the SSM2033s were getting warm. They certainly were. It was at this stage I thought that I'd better look into the architecture of the Solid State Micro SSM2033 - I wasn't familiar with the chip having cut my teeth on discrete VCOs and then Curtis chips. Looking at the datasheet showed that the negative supply on pin 2 had to be fed via a series resistor of 620R to reduce the current thus allowing the on board 8v zener to maintain a steady 8v. Was this one of the reasons that the ICs hadn't blown? Any series resistance and zener combination has to increase the odds of chip survival in a fry-up. OK so that explains the negative rail but the datasheet shows that pin1 goes straight to the positive rail which is +15v. So maybe the +15v rail didn't go into a massive overvolts situation and only the -15v and +5 volts rail did. All conjecture and maybe faster ICs took the brunt of the surge and shorted out more quickly than the 2033s could respond; either way it was still looking promising for the 2033s.
      >
      > It was now time for the calibration as per Korg's service manual. Mmm. Getting the power rails correct was easy enough - they have to be within plus or minus 0.01v for the -15v and +5v rails and within 0.5v for the +15v rail. Next up, the key assigner adjustment. This needs an accurate DVM that can resolve to 3 decimal places. With the 'Tune Point' jumper in place on the KLM-356 board, set VR1 to give 10.583 volts at pin 1 on connector 27 (CV1 Out). This is done with the transpose switch set to 'Up'. Next, set VR2 to give 0.000 volts this time with the transpose switch in the 'Down' position. Finally, adjust VR3 to give 5.250 volts with the transpose switch set to 'Normal'. OK, this went smoothly but I noticed something whilst making the adjustments - all three trim pots were fully clockwise before I adjusted them - a pattern to be repeated later on.
      >
      > Next the offset voltages for the four VCOs needed setting - this is done on the piggy back board to the VCO board. The manual doesn't make it clear where this is measured and gives 4 colours for each VCO which I presumed referred to the wires coming from the little board. This wasn't the case, or wasn't with mine anyway.Just measure the voltage on connector 39 on pins 1,3,5 and 7 accordingly and set the respective trimpot for the lowest to zero reading you can.
      >
      > OK, with that done it was time to calibrate the VCOs. There have been postings regarding this recently and there's little to add except that I didn't adopt stretch tuning. This is procedure I used: Set VR103 to give 55Hz on bottom A at 16', set VR102 to give 440Hz on top A at 16', set VR101 to give 440Hz on bottom A at 2' and set VR104 to give 3520Hz on top A at 2'. This is repeated with the respective trimpots for all 4 oscillators. Now here is where my earlier comments come into play again - every trimpot for the VCO pitch and tracking had been turned fully clockwise - which shows that you should never take anything on face value or trust the previous owner's story that "it worked perfectly OK until.... " The fact that the trimpots had been set fully clockwise actually causes a headache when trying to calibrate because if you start from that point you can't bring in the top A at 2' - it is always sharp. The four trimpots are relative to each other to some degree and the only way to calibrate successfully is to start with each of the trimpots in the centre position to start with. I wish I'd discovered that earlier - it would have saved a lot of time and having to listen to those tones over and over again drives you crazy! Anyway the really good news is that everything calibrated perfectly and the VCO chips are fine. A testament to the Solid State Micro design of these ICs. A very clever and versatile chip indeed.
      >
      > The very last problem only came to light upon reassembly of the Mono/Poly. I screwed everything back together and started to play it and there was significant mains hum present but only when the VCA was 'open' - no notes played everything was fine, play a note and you get a mains hum. It wasn't nasty hum, just an induced kind of hum. Cutting a long story short, it turned out to be the new 240v mains transformer inducing hum into VCA/VCF board simply through proximity. I put the original 110V mains transformer back in its place and used an external stepdown transformer and everything is now fine. The 240v transformer although oriented the same way as the original and in the same place must have a stronger magnetic radiation than the original. As a final precaution I found an American mains lead which I wired in so it's impossible to plug it into a UK supply and only into the adaptor.
      >
      > Well there you have it - a marathon affair but a great sounding synth at the end of all that and definitely worth the effort. I hope some this is useful to list members and I'll shove the whole document together as a pdf and stick it in the Misc Files folder.
      >
      >
      > Steve
      >
    • Florian Anwander
      Hello ... As first: welcome back to the MP comunity. And thanks for the hint. I can only recommend to the new members of the last weeks to poke around (right
      Message 2 of 9 , Jan 28, 2011
      • 0 Attachment
        Hello

        ktony1313 schrieb:
        > This was a fascinating and informative series. I'm not really up on the internal details of the MP4, but I know enough basic audio electronics to follow the descriptions. Thanks for sharing!
        As first: welcome back to the MP comunity.
        And thanks for the hint. I can only recommend to the new members of the
        last weeks to "poke around" (right word?) in the archives.

        And yes: Steves articles contain great information!

        Florian
      Your message has been successfully submitted and would be delivered to recipients shortly.