Loading ...
Sorry, an error occurred while loading the content.

Re: [kicad-users] Overlapping zones on same layer

Expand Messages
  • Krisztina Harsÿffffe1nyi
    Hi all, any ideas about this? (sorry for the up) peter ________________________________ From: tengerkek To: kicad-users@yahoogroups.com
    Message 1 of 5 , Apr 24 2:39 AM
    View Source
    • 0 Attachment
      Hi all,

      any ideas about this? (sorry for the up)

      peter


      From: tengerkek <tengerkek@...>
      To: kicad-users@yahoogroups.com
      Sent: Saturday, April 14, 2012 10:23 AM
      Subject: [kicad-users] Overlapping zones on same layer

       
      Hi,

      I ran into the following issue:
      I have several minor zones on top layer connected to individual nets. Finally i tried to pour a power plane over the unused areas of the layer, it nicely avoids contact with tracks, but does not avoid the already existing zones, producing a continuous fill with them.

      Any way to correct this?

      thx,
      peter



    • Ivica Kvasina
      did you turn off DRC? don t do that. zones on same layer cannot overlap, you have to exclude one from another. if you do big zone, add exclusions to places
      Message 2 of 5 , Apr 24 2:52 AM
      View Source
      • 0 Attachment
        did you turn off DRC? don't do that.
        zones on same layer cannot overlap, you have to exclude one from another.
        if you do big zone, add exclusions to places where small zones will be, then add small zones.



        From: Krisztina Harsÿffffe1nyi <tengerkek@...>
        To: "kicad-users@yahoogroups.com" <kicad-users@yahoogroups.com>
        Sent: Tuesday, April 24, 2012 5:39:36 AM
        Subject: Re: [kicad-users] Overlapping zones on same layer

         
        Hi all,

        any ideas about this? (sorry for the up)

        peter


        From: tengerkek <tengerkek@...>
        To: kicad-users@yahoogroups.com
        Sent: Saturday, April 14, 2012 10:23 AM
        Subject: [kicad-users] Overlapping zones on same layer

         
        Hi,

        I ran into the following issue:
        I have several minor zones on top layer connected to individual nets. Finally i tried to pour a power plane over the unused areas of the layer, it nicely avoids contact with tracks, but does not avoid the already existing zones, producing a continuous fill with them.

        Any way to correct this?

        thx,
        peter





      • Krisztina Harsÿffffe1nyi
        Hi, No, i did not turn DRC off. But it would make sense that zones connected to different net do not get overlapped even if on the same layer. In fact i first
        Message 3 of 5 , May 4, 2012
        View Source
        • 0 Attachment
          Hi,
          No, i did not turn DRC off. But it would make sense that zones connected to different net do not get overlapped even if on the same layer. In fact i first added the smaller zones, and when i  was done with all the routing i poured a gnd plane over the layer to fill the unused space.
          It would be nonsense to me if i should manually avoid the small zones... Tracks are nicely avoided automatically, but zones not?
          thx,
          peter


          From: Ivica Kvasina <kvasina@...>
          To: "kicad-users@yahoogroups.com" <kicad-users@yahoogroups.com>
          Sent: Tuesday, April 24, 2012 11:52 AM
          Subject: Re: [kicad-users] Overlapping zones on same layer

           
          did you turn off DRC? don't do that.
          zones on same layer cannot overlap, you have to exclude one from another.
          if you do big zone, add exclusions to places where small zones will be, then add small zones.



          From: Krisztina Harsÿffffe1nyi <tengerkek@...>
          To: "kicad-users@yahoogroups.com" <kicad-users@yahoogroups.com>
          Sent: Tuesday, April 24, 2012 5:39:36 AM
          Subject: Re: [kicad-users] Overlapping zones on same layer

           
          Hi all,

          any ideas about this? (sorry for the up)

          peter


          From: tengerkek <tengerkek@...>
          To: kicad-users@yahoogroups.com
          Sent: Saturday, April 14, 2012 10:23 AM
          Subject: [kicad-users] Overlapping zones on same layer

           
          Hi,

          I ran into the following issue:
          I have several minor zones on top layer connected to individual nets. Finally i tried to pour a power plane over the unused areas of the layer, it nicely avoids contact with tracks, but does not avoid the already existing zones, producing a continuous fill with them.

          Any way to correct this?

          thx,
          peter







        • Ivica Kvasina
          that is my understanding, when you have zone and tracks in close proximity, tracks have priority and zone expands as far as it can without interfering with
          Message 4 of 5 , May 4, 2012
          View Source
          • 0 Attachment
            that is my understanding, when you have zone and tracks in close proximity, tracks have priority and zone expands as far as it can without interfering with tracks.
            when zones are overlapping, KiCad is not smart enough to deduce which zone has priority and should be drawn first. at least there should be parameter assigned by user.
            for example ground planes to have low priority, zones for power traces higher etc. then overlapping zones would not be such pain and in case of densely packed board, user would not have to painstakingly stich zone outline with tight tolerances.

            i'd post it as bug or wishlist on launchpad.

            Ivica Kvasina


            From: Krisztina Harsÿffffe1nyi <tengerkek@...>
            To: "kicad-users@yahoogroups.com" <kicad-users@yahoogroups.com>
            Sent: Friday, May 4, 2012 1:20:20 PM
            Subject: Re: [kicad-users] Overlapping zones on same layer

             
            Hi,
            No, i did not turn DRC off. But it would make sense that zones connected to different net do not get overlapped even if on the same layer. In fact i first added the smaller zones, and when i  was done with all the routing i poured a gnd plane over the layer to fill the unused space.
            It would be nonsense to me if i should manually avoid the small zones... Tracks are nicely avoided automatically, but zones not?
            thx,
            peter


            From: Ivica Kvasina <kvasina@...>
            To: "kicad-users@yahoogroups.com" <kicad-users@yahoogroups.com>
            Sent: Tuesday, April 24, 2012 11:52 AM
            Subject: Re: [kicad-users] Overlapping zones on same layer

             
            did you turn off DRC? don't do that.
            zones on same layer cannot overlap, you have to exclude one from another.
            if you do big zone, add exclusions to places where small zones will be, then add small zones.



            From: Krisztina Harsÿffffe1nyi <tengerkek@...>
            To: "kicad-users@yahoogroups.com" <kicad-users@yahoogroups.com>
            Sent: Tuesday, April 24, 2012 5:39:36 AM
            Subject: Re: [kicad-users] Overlapping zones on same layer

             
            Hi all,

            any ideas about this? (sorry for the up)

            peter


            From: tengerkek <tengerkek@...>
            To: kicad-users@yahoogroups.com
            Sent: Saturday, April 14, 2012 10:23 AM
            Subject: [kicad-users] Overlapping zones on same layer

             
            Hi,

            I ran into the following issue:
            I have several minor zones on top layer connected to individual nets. Finally i tried to pour a power plane over the unused areas of the layer, it nicely avoids contact with tracks, but does not avoid the already existing zones, producing a continuous fill with them.

            Any way to correct this?

            thx,
            peter









          Your message has been successfully submitted and would be delivered to recipients shortly.