Loading ...
Sorry, an error occurred while loading the content.
 

Solution for NoSuchMethodError describeMismatch using Hamcrest...

Expand Messages
  • jimbarritt
    Hi, When I try using CoreMatchers.hasItems, I get this error (NoSuchMethodError describeMismatch) I ve seen a post here indicating to downgrade to Hamcrest 1.1
    Message 1 of 1 , Dec 14, 2010
      Hi,

      When I try using CoreMatchers.hasItems, I get this error (NoSuchMethodError describeMismatch)

      I've seen a post here indicating to downgrade to Hamcrest 1.1 but Ive tried that and it didn't work.

      I know that this problem occurs because of an old Matcher class in the JUnit jar file and so, what I thought I might be able to do is just use the junit-4.8.2-dep.jar file in my JUnitMax plugins folder.

      What I saw was that everything showed up as warnings in the problems pane.

      So I doctored the original Jar file and manually removed the hamcrest classes. This worked fine!

      It seems that there is something hard coded to load the junit-4.8.4.jar file up. If I replace it with the dep jar and rename, it also works fine.

      I thought it might be the MANIFEST.MF, but no amount of changing the classpath in that seems to have any effect. Is there somehwere else that the name of the Jar file is listed?

      Anyway the monkey patch is to just replace the Jar with the dep one and rename.
    Your message has been successfully submitted and would be delivered to recipients shortly.